Subject: [Roll] RPL visualization tools

From: Ken Bannister <[email-masked]>
Date: Sun, 20 Aug 2017 23:05:27 -0400

Can anyone point me to tools that allow visualization of an RPL-based 
network? I'm particularly interested in open source solutions that 
accept live network data. I'd like to see the relationships between 
nodes, with rank values and objective function parameters.

I'm aware of Foren6 and OpenVisualizer's web UI. Is there anything else?

Thanks,
Ken

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 21 Aug 2017 03:59:10 +0000

Ken,
I don't know of any else, but would be interested in learning.
Thomas

On Sun, 20 Aug 2017 at 20:05 Ken Bannister <[email-masked]> wrote:

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>
-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: Michael Richardson <[email-masked]>
Date: Mon, 21 Aug 2017 14:49:09 -0400

Thomas Watteyne <[email-masked]> wrote:
    > Ken, I don't know of any else, but would be interested in learning.

    Ken>     Can anyone point me to tools that allow visualization of an
    ken> RPL-based network?

What we need is a standard form for the data to be in!

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Randy Turner <[email-masked]>
Date: Mon, 21 Aug 2017 19:40:36 -0400

+1 - a standard format for exporting RPL topology info would be a good start.

R.

> On Aug 21, 2017, at 2:49 PM, Michael Richardson <[email-masked]> wrote:
> 
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 28 Aug 2017 09:37:25 +0000

Agreed, Randy.

Please note that in non storing the root has all the information to build an internal representation of the usable DODAG, but
- that is not true for storing
- a child may not expose all its parents to the root though it may use them to send traffic up
- the siblings are not exposed

There appears to be a need to provide more information to the root so it can use it for its own purposes, e.g. route projection.
There could also be a need for the root to export its topological knowledge to an external PCE/NME.
Finally, there is work at TEAS that may be leveraged to expose this, but TEAS will not be aware of wireless specifics such as the value or the duration of the coherence of a metric.

cheers,

Pascal

-----Original Message-----
From: Roll [mailto:[email-masked]] On Behalf Of Randy Turner
Sent: mardi 22 août 2017 01:41
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] RPL visualization tools

R.