Subject: Re: [Roll] rplinfo

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 4 Aug 2017 13:00:24 +0000

Dear all:

Very soon, when 6lo ships rfc6775-update, we will have the tools we need from the outside to enable interconnecting non-RPL-aware hosts as RPL leaves. Leaves will need a certain level of 6lo but no knowledge of RPL. And RPL will be able to register leaves with upgraded 6lo with a certain upgrade of RPL as well.

We'll need a new draft to specify the building of DAOs by the firs RPL router on behalf of the leaves in both storing and non-storing (there's a E bit to signal that already in RPL). The 6LR will have to be the first RPL router, and the 6lo spec will give us the TID which maps to the path-sequence, and the router will turn the periodic NS/NA into a periodic DAO.

We may specify that similarly, the DAO reaching the RPL root can be used to refresh the 6LBR in order to save the periodic DAR/DAC, but in order to do that, the 6LBR will also have to be the RPL root. Separating them will require additional signaling between the split functions, hopefully more a local exchange than the DAR/DAC.

Take care,

Pascal

-----Original Message-----
From: Roll [mailto:[email-masked]] On Behalf Of peter van der Stok
Sent: mardi 18 juillet 2017 13:49
To: Ines Robles <[email-masked]>
Cc: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] rplinfo

Hi Ines,

my suggestion:
There is a LLN of connected nodes with IPv6 addresses and paths between them A subset of these nodes is RPL aware.
These RPL aware nodes form a DODAG.
The non RPL aware nodes are not part of the DODAG and cannot be leaves of the DODAG However, communication is possible between a rpl-aware node and a non-rpl-aware node via link-local addresses at least.

Peter

Ines  Robles schreef op 2017-07-18 13:32:
> Yes, agree.
> 
> So, could we have a case where the leaf nodes do not accept DIO 
> Messages like in the use cases?
> 
> Maybe we should define the features with more detail of a 
> not-RPL-aware-leaf in the document.
> 
> 2017-07-18 13:23 GMT+02:00 peter van der Stok <[email-masked]>:
> 
>> section 2, rpl-not-capable; how can this node be a leaf of a DODAG.
>> It can be a neighbour of a DODAG node but not a leaf in my 
>> understanding
>> 
>> I understand that we can have it. Please someone correct me if I am 
>> wrong.
>> 
>> RFC 6550 (pag. 110) mentions that a RPL-Leaf-Node-only:
>> 
>> - A leaf node (only) does not ever participate as a RPL router.
>> 
>> - Support of a particular MOP encoding is not required
>> 
>> - Support of a particular OF is not required.
>> 
>> -  A leaf node does not generally issue DIO messages,
>> 
>> - it may issue DAO and DIS messages.  A leaf node accepts DIO 
>> messages though it generally ignores DAO and DIS messages  (not 
>> applied in our case)
> 
>  A leaf node accepts DIO messages and is thus RPL-aware in my 
> understanding;
> 
> Peter

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Rahul Jadhav <[email-masked]>
Date: Fri, 4 Aug 2017 14:50:27 +0000 (UTC)

Hello Pascal,

Please find my resp inline..

Regards,
Rahul

> We'll need a new draft to specify the building of DAOs by the firs RPL router on behalf of the leaves in both storing and non-storing (there's a E bit to signal that already in RPL). The 6LR will h…

[RJ]: Yes this draft is needed and it will optimize the non-RPL-aware leaf 
node joining (as compared to using proxy NS/NA DAR/DAC). One of the thing 
that is missing is the DAO-ACK signalling to the non-RPL-aware leaf node 
i.e. if DAO-ACK is received with negative status then what should the 
first-6LR node send to the non-RPL-aware node? Should the first-6LR delay 
the NA response till the time DAO-ACK is returned? This has its own 
complexities. Note that DAO-ACK might be sent from the Root/parent-6LR 
regardless of 'K' bit in the DAO message. Thus this has to be 
handled.

> We may specify that similarly, the DAO reaching the RPL root can be used to refresh the 6LBR in order to save the periodic DAR/DAC, but in order to do that, the 6LBR will also have to be the RPL ro…

[RJ]: Are you suggesting splitting it up in a way that there is different 
RPL signalling between 6LBR and multiple RPL roots? Or is it that 6LBR 
will initiate the DIO and RPL roots simply become 6LRs? The later approach 
has multiple issues.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 4 Aug 2017 16:06:39 +0000

I'm not suggesting to split, Rahul, but pointing the consequences if we did.

If we did, the 6LBR would do DAR/DAC, and the RPL root DAO/DIO. And the root would need to signal to the 6LBR upon a DAO, e.g. a proxy DAR/DAC exchange.
Note also that RPL does not have the OID. 

Take care,

Pascal
-----Original Message-----
From: Roll [mailto:[email-masked]] On Behalf Of Rahul Jadhav
Sent: vendredi 4 août 2017 16:50
To: Routing Over Low power and Lossy networks <[email-masked]>
Cc: Ines Robles <[email-masked]>
Subject: Re: [Roll] rplinfo

Hello Pascal,

Regards,
Rahul

> We'll need a new draft to specify the building of DAOs by the firs RPL router on behalf of the leaves in both storing and non-storing (there's a E bit to signal that already in RPL). The 6LR will h…

[RJ]: Yes this draft is needed and it will optimize the non-RPL-aware leaf node joining (as compared to using proxy NS/NA DAR/DAC). One of the thing that is missing is the DAO-ACK signalling to the non-RPL-aware leaf node i.e. if DAO-ACK is received with negative status then what should the first-6LR node send to the non-RPL-aware node? Should the first-6LR delay the NA response till the time DAO-ACK is returned? This has its own complexities. Note that DAO-ACK might be sent from the Root/parent-6LR regardless of 'K' bit in the DAO message. Thus this has to be handled.

> We may specify that similarly, the DAO reaching the RPL root can be used to refresh the 6LBR in order to save the periodic DAR/DAC, but in order to do that, the 6LBR will also have to be the RPL ro…

[RJ]: Are you suggesting splitting it up in a way that there is different RPL signalling between 6LBR and multiple RPL roots? Or is it that 6LBR will initiate the DIO and RPL roots simply become 6LRs? The later approach has multiple issues.