Subject: [Roll] DAG Metric Container option in RPL control messages

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Mon, 16 Oct 2017 11:37:44 +0200 (CEST)

Hello,

while looking into how to use the DAG Metric Container option, I noticed an
inconsistency regarding which RPL control messages it may appear in. More
specifically, in Section "6.4.3.  DAO Options" it does not appear in the
supported options list:

6.4.3.  DAO Options

   The DAO message MAY carry valid options.

   This specification allows for the DAO message to carry the following
   options:

      0x00 Pad1
      0x01 PadN
      0x05 RPL Target
      0x06 Transit Information
      0x09 RPL Target Descriptor

but in Section "6.7.4.  DAG Metric Container" it is stated that a DAO can
contain the option:

6.7.4.  DAG Metric Container

   The DAG Metric Container option MAY be present in DIO or DAO
   messages, and its format is as follows:
   ...

Furthermore, RFC6551, which specifies the metrics, has no reference to DAOs
while it does have a few DIO references.

Based on these hints, it looks to me like the DAO message is not supposed
to have the ability to carry the DAG Metric Container option, so the text
in the Section "6.7.4.  DAG Metric Container" might need to be changed to
reflect this.

I can report this to the errata database, but I thought that asking here
first would be a better start.

Best,
Aris

---

From: Rahul Jadhav <[email-masked]>
Date: Mon, 16 Oct 2017 15:38:33 +0530

+1
I don't see a reason for DAO to contain DAG metric container.

Regards, 
Rahul

> On 16-Oct-2017, at 3:07 PM, Remous-Aris Koutsiamanis <[email-masked]> wrote:
> 
> Hello,
> 
> while looking into how to use the DAG Metric Container option, I noticed an inconsistency regarding which RPL control messages it may appear in. More specifically, in Section "6.4.3.  DAO Options" it does not appear in the supported options list:
> 
> 6.4.3.  DAO Options
> 
> but in Section "6.7.4.  DAG Metric Container" it is stated that a DAO can contain the option:
> 
> Furthermore, RFC6551, which specifies the metrics, has no reference to DAOs while it does have a few DIO references.
> 
> Based on these hints, it looks to me like the DAO message is not supposed to have the ability to carry the DAG Metric Container option, so the text in the Section "6.7.4.  DAG Metric Container" might need to be changed to reflect this.
> 
> I can report this to the errata database, but I thought that asking here first would be a better start.
> 
> Best,
> Aris
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 16 Oct 2017 12:03:17 +0000

I agree that in the original series, the metrics container was not expected in DAO messages.

-----Original Message-----
From: Roll [mailto:[email-masked]] On Behalf Of Rahul Jadhav
Sent: lundi 16 octobre 2017 12:09
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] DAG Metric Container option in RPL control messages

+1

Regards, 
Rahul

---

From: Mamoun Qasem <[email-masked]>
Date: Mon, 16 Oct 2017 13:55:45 +0100

+1,
Agree with Rahul.
Best
Mamoun

On Mon, Oct 16, 2017 at 1:03 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> > while looking into how to use the DAG Metric Container option, I noticed
> an inconsistency regarding which RPL control messages it may appear in.
> More specifically, in Section "6.4.3.  DAO Options" it does not appear in
> the supported options list:
> >
> > 6.4.3.  DAO Options
> >
> > Furthermore, RFC6551, which specifies the metrics, has no reference to
> DAOs while it does have a few DIO references.
> >
> > Based on these hints, it looks to me like the DAO message is not
> supposed to have the ability to carry the DAG Metric Container option, so
> the text in the Section "6.7.4.  DAG Metric Container" might need to be
> changed to reflect this.
> >

---

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Mon, 16 Oct 2017 16:20:40 +0200 (CEST)

Hi again,

I have also just checked the latest source code for Contiki (DAG Metric
Container option only generated/checked for in DIO messages), OpenWSN (no
mention of DAG Metric Container option, as far as I can tell) and RIOT OS
(only defines the type code, no option handling present, as far as I can
tell).
So changing the documentation should not have any real world impact.

Best,
Aris

On Mon, Oct 16, 2017 at 11:37 AM, Remous-Aris Koutsiamanis <[email-masked]
> wrote: