Subject: [Roll] Fwd: New Version Notification for draft-pkm-roll-nsa-extension-00.txt

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Fri, 27 Oct 2017 18:06:19 +0200 (CEST)

Hello all,

We have just submitted a new draft describing the format and functionality
of an optional TLV carried within the RPL DIO Control Message in the Metric
Container option, as part of the NSA object (RFC6551),
for broadcasting parent node set address information in order to support
Alternative Parent selection for Packet Replication and Elimination.

Aris

---------- Forwarded message ----------
From: <[email-masked]>
Date: Fri, Oct 27, 2017 at 5:38 PM
Subject: New Version Notification for draft-pkm-roll-nsa-extension-00.txt
To: Nicolas Montavont <[email-masked]>, Pascal Thubert
<[email-masked]>, Georgios Papadopoulos <georgios.papadopoulos@imt-
atlantique.fr>, Remous-Aris Koutsiamanis <[email-masked]>

A new version of I-D, draft-pkm-roll-nsa-extension-00.txt
has been successfully submitted by Remous-Aris Koutsiamanis and posted to
the
IETF repository.

Name:           draft-pkm-roll-nsa-extension
Revision:       00
Title:          RPL DAG Metric Container (MC) Node State and Attribute
(NSA) object type extension
Document date:  2017-10-26
Group:          Individual Submission
Pages:          9
URL:            https://www.ietf.org/internet-drafts/draft-pkm-roll-nsa-
extension-00.txt
Status:         https://datatracker.ietf.org/doc/draft-pkm-roll-nsa-
extension/
Htmlized:       https://tools.ietf.org/html/draft-pkm-roll-nsa-extension-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-pkm-roll-nsa-
extension-00

Abstract:
   Implementing 6TiSCH Packet Replication and Elimination from / to the
   RPL root requires the ability to forward copies of packets over
   different paths via different RPL parents.  Selecting the appropriate
   parents to achieve ultra-low latency and jitter requires information
   about a node's parents.  This document details what information needs
   to be transmitted and how it is encoded within a packet to enable
   this functionality.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Georgios Z. Papadopoulos" <[email-masked]>
Date: Mon, 30 Oct 2017 16:48:07 +0100

Hello again,

To initiate the discussion over the ML before the IETF100, we would like to further motivate the use of our submitted draft (draft-pkm-roll-nsa-extension-00 "RPL DAG Metric Container (MC) Node State and Attribute (NSA) object type extension").

In an attempt to provide ultra-high reliability and ultra-low jitter performance in RPL-based networks, Packet Replication and Elimination (PRE) is a highly recommended scheme to employ.
Under PRE, each node forwards copies of a single data packet over different and congruent paths via different RPL parents.
In order to constrain the pool of alternative paths, an alternative parent among the list of possible parents need to be chosen. 
To this aim, a potential parent's parent set needs to be known. 
This draft defines how this information can be included and transmitted via DIO control messages.

Best,
Aris, Georgios, Nicolas and Pascal

> On Oct 27, 2017, at 6:06 PM, Remous-Aris Koutsiamanis <[email-masked]> wrote:
> 
> Hello all,
> 
> We have just submitted a new draft describing the format and functionality of an optional TLV carried within the RPL DIO Control Message in the Metric Container option, as part of the NSA object (RFC6551),
> for broadcasting parent node set address information in order to support Alternative Parent selection for Packet Replication and Elimination.
> 
> Aris
> 
> 
> 
> To: Nicolas Montavont <[email-masked]>, Pascal Thubert <[email-masked]>, Georgios Papadopoulos <[email-masked]>, Remous-Aris Koutsiamanis <[email-masked]>
> 
> 
> 
> has been successfully submitted by Remous-Aris Koutsiamanis and posted to the
> IETF repository.
> 
> Title:          RPL DAG Metric Container (MC) Node State and Attribute (NSA) object type extension
> URL:            https://www.ietf.org/internet-drafts/draft-pkm-roll-nsa-extension-00.txt <https://www.ietf.org/internet-drafts/draft-pkm-roll-nsa-extension-00.txt>
> Status:         https://datatracker.ietf.org/doc/draft-pkm-roll-nsa-extension/ <https://datatracker.ietf.org/doc/draft-pkm-roll-nsa-extension/>
> Htmlized:       https://tools.ietf.org/html/draft-pkm-roll-nsa-extension-00 <https://tools.ietf.org/html/draft-pkm-roll-nsa-extension-00>
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-pkm-roll-nsa-extension-00 <https://datatracker.ietf.org/doc/html/draft-pkm-roll-nsa-extension-00>
> 
> 
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> The IETF Secretariat
> 
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll