Subject: [Roll] Child count in parent selection

From: Chenyang JI <[email-masked]>
Date: Mon, 30 Oct 2017 08:40:02 +0100 (CET)

Hello,

I have some questions about draft-hou-roll-rpl-parent-selection-00 and draft-qasem-roll-rpl-load-balancing-01.
In the draft,it describes a new type of metric which has this format:

CNC: 8 bits. The Child Node Count is encoded in 8 bits in unsigned
integer format, expressed in number count, representing the number of
child nodes.

MAX_CNC: 8 bits. The Maximum Child Node Count is encoded in 8 bits
in unsigned integer format, expressed in number count, representing
the maximum number of child nodes allowed in the neighbor cache.

but it does not clarify if this number of child nodes refers to the number of direct child or the subtree size.

In draft-qasem-roll-rpl-load-balancing-01:

In LB-OF algorithm, the received DIO from the child node
is counted by the preferred parent node. Each DIO contains the IP
address of the chosen preferred parent as detailed in section 4.3. Thus,
for each received DIO, the node matches its own IP address with the
preferred parent IP address which is inserted in the DIO message, then
increments the number of children by ONE for this node if there is a
matching.

My question is if that mean it will store the children's address and if yes,how will the node stores its children.

The first draft
https://tools.ietf.org/html/draft-hou-roll-rpl-parent-selection-00

The second draft
https://datatracker.ietf.org/doc/html/draft-qasem-roll-rpl-load-balancing

Best regards,
Chenyang Ji

---

From: "Houjianqiang (Derek)" <[email-masked]>
Date: Tue, 31 Oct 2017 01:42:19 +0000

Hi Chenyang

Many thanks for your interest in our draft. I am happy to answer your questions. Please see my response in line.

Best regards,

Jianqiang Hou (Derek)

Date: Mon, 30 Oct 2017 08:40:02 +0100 (CET)

From: Chenyang JI <[email-masked]<mailto:[email-masked]>>

To: [email-masked]<mailto:[email-masked]>

Cc: jichenyang920 <[email-masked]<mailto:[email-masked]>>

Subject: [Roll] Child count in parent selection

Message-ID:

                <[email-masked]<mailto:[email-masked]>>

Content-Type: text/plain; charset=utf-8

Hello,

CNC: 8 bits. The Child Node Count is encoded in 8 bits in unsigned integer format, expressed in number count, representing the number of child nodes.

MAX_CNC: 8 bits. The Maximum Child Node Count is encoded in 8 bits in unsigned integer format, expressed in number count, representing the maximum number of child nodes allowed in the neighbor cache.

[Jianqiang] My mistake... This number of child nodes refers to the number of direct child.

In LB-OF algorithm, the received DIO from the child node is counted by the preferred parent node. Each DIO contains the IP address of the chosen preferred parent as detailed in section 4.3. Thus, for each received DIO, the node matches its own IP address with the preferred parent IP address which is inserted in the DIO message, then increments the number of children by ONE for this node if there is a matching.

[Jianqiang] There are two possible ways of storing its children. One is to store the children's address in a new table with extra cache, the other way is to manage the neighbor cache entry (after all the direct children set is a subset of the neighbor set).

The first draft

The second draft

Best regards,

Chenyang Ji