Subject: Re: [Roll] Child count in parent selection

From: Chenyang JI <[email-masked]>
Date: Fri, 3 Nov 2017 18:21:43 +0100 (CET)

Hello,

Thank you for the answer and I apologize for my late response.
Today I realized that you had a new version of draft draft-qasem-roll-rpl-load-balancing-02 and I also have some questions on this.
The description about LB-OF is:

 In LB-OF algorithm, the received DIO from the child node is counted by the preferred parent node. Each DIO contains the IP
 address of the chosen preferred parent as detailed in section 4.3. Thus,for each received DIO, the node matches its own IP 
 address with the preferred parent IP address which is inserted in the DIO message, thenincrements the number of children by 
 ONE for this node if there is a matching.

And the format of DIO metric container object is:

        0                   1                   2                   3
        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |   Flags     |P|     CNC       |    CNC_MAX    |               |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+               +
       |                                                               |
       +                                                               +
       |                                                               |
       +                        Parent Address                         +
       |                                                               |
       +                                               +-+-+-+-+-+-+-+-+
       |                                               |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

which Parent Address field is optional and is set if 'p'flag is set.
Also,it says that:

Thus, to minimize traffic load, the Parent Address field in the CNC object should not be present in the storing mode.

That means the 'p'flag is set for every DIO message sent in Non-storing mode?

Thank you,
Chenyang ji

https://www.ietf.org/id/draft-qasem-roll-rpl-load-balancing-02.txt

----- Original Message -----
From: "Houjianqiang (Derek)" <[email-masked]>
To: "chenyang ji" <[email-masked]>
Cc: "roll" <[email-masked]>, "jichenyang920" <[email-masked]>, "Qasem, Mamoun" <[email-masked]>
Sent: Tuesday, October 31, 2017 2:42:19 AM
Subject: Re: [Roll] Child count in parent selection

Hi Chenyang

Many thanks for your interest in our draft. I am happy to answer your questions. Please see my response in line.

Best regards,

Jianqiang Hou (Derek)

Date: Mon, 30 Oct 2017 08:40:02 +0100 (CET)

From: Chenyang JI <[email-masked]<mailto:[email-masked]>>

To: [email-masked]<mailto:[email-masked]>

Cc: jichenyang920 <[email-masked]<mailto:[email-masked]>>

Subject: [Roll] Child count in parent selection

Message-ID:

                <[email-masked]<mailto:[email-masked]>>

Content-Type: text/plain; charset=utf-8

Hello,

I have some questions about draft-hou-roll-rpl-parent-selection-00 and draft-qasem-roll-rpl-load-balancing-01.

In the draft,it describes a new type of metric which has this format:

CNC: 8 bits. The Child Node Count is encoded in 8 bits in unsigned integer format, expressed in number count, representing the number of child nodes.

MAX_CNC: 8 bits. The Maximum Child Node Count is encoded in 8 bits in unsigned integer format, expressed in number count, representing the maximum number of child nodes allowed in the neighbor cache.

but it does not clarify if this number of child nodes refers to the number of direct child or the subtree size.

[Jianqiang] My mistake... This number of child nodes refers to the number of direct child.

In draft-qasem-roll-rpl-load-balancing-01:

In LB-OF algorithm, the received DIO from the child node is counted by the preferred parent node. Each DIO contains the IP address of the chosen preferred parent as detailed in section 4.3. Thus, for each received DIO, the node matches its own IP address with the preferred parent IP address which is inserted in the DIO message, then increments the number of children by ONE for this node if there is a matching.

My question is if that mean it will store the children's address and if yes,how will the node stores its children.

[Jianqiang] There are two possible ways of storing its children. One is to store the children's address in a new table with extra cache, the other way is to manage the neighbor cache entry (after all the direct children set is a subset of the neighbor set).

The first draft

https://tools.ietf.org/html/draft-hou-roll-rpl-parent-selection-00

The second draft

https://datatracker.ietf.org/doc/html/draft-qasem-roll-rpl-load-balancing

Best regards,

Chenyang Ji

---

From: "Houjianqiang (Derek)" <[email-masked]>
Date: Mon, 6 Nov 2017 09:29:35 +0000

Hi Chenyang,

Yes, we want the 'P' flag of the CNC metric to be set in every DIO in non-storing mode.

In storing mode, DAO/NP-DAO can be used for child registration and de-registration, thus there is no need of a parent address in DIO. But in non-storing mode, DAO cannot be used for counting the number of children, so we use DIO(+ parent address) instead.

Regards,
Jianqiang Hou (Derek) 

-----Original Message-----
From: Chenyang JI [mailto:[email-masked]] 
Sent: Saturday, November 04, 2017 1:22 AM
To: Houjianqiang (Derek) <[email-masked]>; roll <[email-masked]>
Subject: Re: [Roll] Child count in parent selection

Hello,

 In LB-OF algorithm, the received DIO from the child node is counted by the preferred parent node. Each DIO contains the IP  address of the chosen preferred parent as detailed in section 4.3. Thus,for each received DIO, the node matches its own IP  address with the preferred parent IP address which is inserted in the DIO message, thenincrements the number of children by  ONE for this node if there is a matching.

        0                   1                   2                   3

Thank you,
Chenyang ji

----- Original Message -----
From: "Houjianqiang (Derek)" <[email-masked]>
To: "chenyang ji" <[email-masked]>
Cc: "roll" <[email-masked]>, "jichenyang920" <[email-masked]>, "Qasem, Mamoun" <[email-masked]>
Sent: Tuesday, October 31, 2017 2:42:19 AM
Subject: Re: [Roll] Child count in parent selection

Hi Chenyang

Best regards,

Jianqiang Hou (Derek)

Message-ID:

Hello,

The first draft

The second draft

Best regards,

Chenyang Ji

---

From: Chenyang JI <[email-masked]>
Date: Mon, 6 Nov 2017 10:50:43 +0100 (CET)

Hello,

Thank you for the answer.

Best regards,
Chenyang Ji

----- Original Message -----
From: "Houjianqiang" <[email-masked]>
To: "Chenyang JI" <[email-masked]>, "roll" <[email-masked]>
Sent: Monday, November 6, 2017 10:29:35 AM
Subject: RE: [Roll] Child count in parent selection

Hi Chenyang,

Regards,
Jianqiang Hou (Derek) 

-----Original Message-----
From: Chenyang JI [mailto:[email-masked]] 
Sent: Saturday, November 04, 2017 1:22 AM
To: Houjianqiang (Derek) <[email-masked]>; roll <[email-masked]>
Subject: Re: [Roll] Child count in parent selection

Hello,

        0                   1                   2                   3

Thank you,
Chenyang ji

----- Original Message -----
From: "Houjianqiang (Derek)" <[email-masked]>
To: "chenyang ji" <[email-masked]>
Cc: "roll" <[email-masked]>, "jichenyang920" <[email-masked]>, "Qasem, Mamoun" <[email-masked]>
Sent: Tuesday, October 31, 2017 2:42:19 AM
Subject: Re: [Roll] Child count in parent selection

Hi Chenyang

Best regards,

Jianqiang Hou (Derek)

Message-ID:

Hello,

The first draft

The second draft

Best regards,

Chenyang Ji