Subject: Re: [Roll] Fwd: Review of useofrplinfo-19

From: Rahul Arvind Jadhav <[email-masked]>
Date: Mon, 4 Dec 2017 09:56:33 +0000

Rahul> [RJ]: Lingering EDNOTE... I like using IP-in-IP destined to root
    Rahul> (because its relatively less processing overhead!), but hop-by-hop has
    Rahul> its own advantage. The advantage is, If there is RPL aware node with a
    Rahul> DAO-advertised IPv6 address not using the DIO-advertised network
    Rahul> prefix in PIO, then the routing would be faster/more efficient (since
    Rahul> 6LR_i would be able to remove IP-in-IP and check the routing table for
    Rahul> the dst in underlying IP hdr).

Mcr> yes, you are right.
Mcr> Can you tell us why such a node would exist?  What's the use case?

I do not have the use-case now. But by this change we disallow something which RFC6550 did allow. 
Now I tried understanding the impact if the dst node is incorrectly identified as ~Raf and following are my observations:
1. Storing MOP: (Raf to Raf)  and (Raf to ~Raf) 
	Handling is exactly same. Thus no impact if identification goes wrong.
2. Storing MOP: (~Raf to Raf)  and (~Raf to ~Raf) 
	Handling is Almost same. There is slight difference about what dst is put in IP-in-IP header, but overall this has no impact i.e. IP-in-IP-hop (hop as dst) will be used but things should still work equally well.
3. Storing MOP: (Int to Raf) and (Root to Raf) is not a problem since BR knows Raf is a Raf without depending on matching network prefix.
4. Non-storing MOP: This MOP does not have an impact because all the packets go to the 6LBR and 6LBR definitely knows whether node is Raf.

Point is, there seems no (very less in one case) impact even if identification for Raf goes wrong. Or am I missing something very basic here?

---

From: Michael Richardson <[email-masked]>
Date: Mon, 04 Dec 2017 08:53:10 -0500

Rahul Arvind Jadhav <[email-masked]> wrote:
    > Point is, there seems no (very less in one case) impact even if
    > identification for Raf goes wrong. Or am I missing something very basic
    > here?

I think that I agree, there is little that breaks. Some extra encapsulation
may occur, as the heuristic breaks for some senders.

The DODAG root will know the correct information by DAOs in non-storing mode,
and additionally any 6LRs above the node with the non-PIO address will know
that it's in the DODAG.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-