Subject: [Roll] Comments on storing mode of AODV-RPL

From: "Liubing (Remy)" <[email-masked]>
Date: Tue, 9 Jan 2018 07:14:38 +0000

Hello AODV-RPL authors,

I find that the terminology "storing mode" used in the draft is not accurate. 

The storing/non-storing mode is for downward route only, i.e. the route from the DODAG root to leaf nodes. In AODV-RPL, the "downward route" from the OrigNode to the TargNode is actually built by discovering an "upward route" in a second DODAG rooted at the TargNode. Therefore, the OrigNode-to-TargNode route and the TargNode-to-OrigNode route are both upward routes. Thus they are not storing mode or non-storing mode.

I suggest to use "hop-by-hop route" to replace "storing mode" in the draft. If you plan to develop a mechanism, in which the intermediate routers don't build route entries, you can use the terminology ''source routing". 

Best regards,
Remy

---

From: Michael Richardson <[email-masked]>
Date: Tue, 09 Jan 2018 09:12:54 -0500

> The storing/non-storing mode is for downward route only, i.e. the route
    > from the DODAG root to leaf nodes. In AODV-RPL, the "downward route"
    > from the OrigNode to the TargNode is actually built by discovering an
    > "upward route" in a second DODAG rooted at the TargNode. Therefore, the
    > OrigNode-to-TargNode route and the TargNode-to-OrigNode route are both
    > upward routes. Thus they are not storing mode or non-storing mode.

    > I suggest to use "hop-by-hop route" to replace "storing mode" in the
    > draft. If you plan to develop a mechanism, in which the intermediate
    > routers don't build route entries, you can use the terminology ''source
    > routing".

As a new MODP is assigned by the document, it seems like the document should
perhaps create a more descriptive/interesting name for the MODP and to use
that term throughout the document.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-