Subject: [Roll] Obtaining ranks at the DAGroot

From: Esteban Municio <[email-masked]>
Date: Fri, 16 Feb 2018 20:27:45 +0100

Hi all,

I think this has been already discussed, but I don't think I totally
understand it.

Is there any way to obtain the rank of the nodes at the DAGroot? (e.g.
in order to monitor the network)

One possible idea is obtain it through the ETX of the links.

Apparently, some metrics can be sent in the in DAG Metric Container,
but I'm not sure if this option can be included in DIOs and DAOs, or
only in DIOs. According to errata 5160 of RFC6560 is only in DIOs.

Is there any important reason to not send them in the DAOs as well (at
least in the non-storing mode)?

If this is not possible, is there any other way within RPL to deliver
this information to the DAGroot?

Otherwise, I only only possibilities:
- Send the rank values from the application layer (which is not very 
convenient since that would require access to the RPL sublayer)
- Through sniffer nodes that would get DIO packets in the network.
(however this would require distributing additional nodes all over the
network)

Am I missing something? Any idea?

Thank you and kind regards,
Esteban 

-- 
Esteban Municio

IDLab - Dept. Mathematics and Computer Science 

University of Antwerp - imec

Middelheimlaan 1 , 2020 Antwerp, Belgium 

Office M.G.322

---

From: Rahul Jadhav <[email-masked]>
Date: Mon, 19 Feb 2018 08:59:25 +0530

Hello Esteban,

We had a similar requirement i.e. the root should be able to monitor the
connectivity of the entire DODAG.

We achieved it by using the target-parent information which is sent in the
DAO. From this information you can form the complete DAG at the root.

Is there any specific thing that is achieved by sending ETX/Rank ? i.e. if
all you want is to monitor the DAG formation at the root then this
information should work.
Also even though parent-info is not 'usually' sent in the DAO in case of
storing mode, we still ended up sending it in order to achieve this
monitoring in storing mode as well. I dont think 6550 restricts sending
parent info in DAO in storing mode.

Regards,
Rahul

On 17 February 2018 at 00:57, Esteban Municio <[email-masked]
> wrote:

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>
>

---

From: "Georgios Z. Papadopoulos" <[email-masked]>
Date: Mon, 19 Feb 2018 10:03:45 +0100

Rahul,

A minor question:
You do this once the RPL DODAG is constructed?
I assume the DAOs that are transmitted are in unicast, from child to parent?

Please correct me, if I misunderstood.

Cheers,
Georgios

> On Feb 19, 2018, at 04:29, Rahul Jadhav <[email-masked]> wrote:
> 
> Hello Esteban,
> 
> We had a similar requirement i.e. the root should be able to monitor the connectivity of the entire DODAG.
> 
> We achieved it by using the target-parent information which is sent in the DAO. From this information you can form the complete DAG at the root. 
> 
> Is there any specific thing that is achieved by sending ETX/Rank ? i.e. if all you want is to monitor the DAG formation at the root then this information should work.
> Also even though parent-info is not 'usually' sent in the DAO in case of storing mode, we still ended up sending it in order to achieve this monitoring in storing mode as well. I dont think 6550 restricts sending parent info in DAO in storing mode.
> 
> Regards,
> Rahul
> 
> 
> 
> On 17 February 2018 at 00:57, Esteban Municio <[email-masked] <mailto:[email-masked]>> wrote:
> Hi all,
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/roll <https://www.ietf.org/mailman/listinfo/roll>
> 
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 19 Feb 2018 09:14:38 +0000

Hello Esteban

RPL does not transport the Rank to the root. We actually designed to save the cost of doing that (and maintaining it afterwards).

RPL assumes that the links are symmetrical enough so routing downwards can follow the target’s subdag. That subdag is within the root’s DODAG but directed to the target so there is no need of a Rank to build it.

Regards,

Pascal

> Le 16 févr. 2018 à 20:28, Esteban Municio <[email-masked]> a écrit :
> 
> Hi all,
>

---

From: Rahul Jadhav <[email-masked]>
Date: Mon, 19 Feb 2018 15:07:26 +0530

Please find resp inline [RJ].

Regards,
Rahul

> You do this once the RPL DODAG is constructed?

[RJ] This can be done while the DODAG formation is in progress ... so
essentially you get a view of nodes gradually connecting in the network.

> I assume the DAOs that are transmitted are in unicast, from child to

[RJ] Yes the DAOs are unicast.

> On 17 February 2018 at 00:57, Esteban Municio <
> [email-masked]> wrote:
>
>> Hi all,
>>

---

From: Michael Richardson <[email-masked]>
Date: Mon, 19 Feb 2018 13:52:48 -0500

Rahul Jadhav <[email-masked]> wrote:
    > Is there any specific thing that is achieved by sending ETX/Rank ?

It's awefully good for diagnostics.

We really need a mgmt interface that either lets the DAGroot query directly,
or lets' the leaves send the information.  But if we send it from leaf->root,
then we need to decide how often to do that, and this means appling trickle
to it.

So I prefer to have the root query this information; it's just another P2MP
control flow.  It would be nice to have some bit that tells the root if the
new leaf is capable of the new interface.

This would fit into our SMI (now YANG/NETCONF) requirements, btw.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: peter van der Stok <[email-masked]>
Date: Tue, 20 Feb 2018 09:37:14 +0100

When it is diagnostics or management, using DIO or DAO is stresfull for 
the network.
Reserving DIO and DAO for DODAG control only seems a good practice to 
me.
There are other tools for diagnostic like: YANG.

It would be good to put a bit more effort in a YANG model for RPL.

Peter

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 20 Feb 2018 09:20:38 +0000

+1

-----Original Message-----
From: Roll [mailto:[email-masked]] On Behalf Of peter van der Stok
Sent: mardi 20 février 2018 09:37
To: Routing Over Low power and Lossy networks <[email-masked]>
Cc: Michael Richardson <[email-masked]>
Subject: Re: [Roll] Obtaining ranks at the DAGroot

When it is diagnostics or management, using DIO or DAO is stresfull for the network.
Reserving DIO and DAO for DODAG control only seems a good practice to me.
There are other tools for diagnostic like: YANG.

Peter

Michael Richardson schreef op 2018-02-19 19:52:
> We really need a mgmt interface that either lets the DAGroot query 
> directly, or lets' the leaves send the information.  But if we send it 
> from
> leaf->root,
> then we need to decide how often to do that, and this means appling 
> trickle to it.
> 
> So I prefer to have the root query this information; it's just another 
> P2MP control flow.  It would be nice to have some bit that tells the 
> root if the new leaf is capable of the new interface.
>