Subject: Re: [Roll] Obtaining ranks at the DAGroot

From: Esteban Municio <[email-masked]>
Date: Mon, 19 Feb 2018 19:15:54 +0100

Hi Pascal, Rahul,

Yes, that was actually one of my doubts: if a node can send uplink
through one path and receive downlink through a different path using
the same DODAG instance.

If links are assumed symmetric that means that is not possible.

@Rahul, yes, the idea was to monitor the rank in the nodes (e.g. for
visualize it in a graph), and maybe play a bit with it. For only the
DAG, indeed the target-parent option in the DAOs is enough.

Thanks and kind regards,
Esteban

> Hello Esteban
> 
> RPL does not transport the Rank to the root. We actually designed to
> save the cost of doing that (and maintaining it afterwards).
> 
> RPL assumes that the links are symmetrical enough so routing
> downwards can follow the target’s subdag. That subdag is within the
> root’s DODAG but directed to the target so there is no need of a Rank
> to build it.
> 
> Regards,
> 
> Pascal
> 
> > Le 16 févr. 2018 à 20:28, Esteban Municio <esteban.municio@uantwerp
> en.be>; a écrit :
> > 
> > Hi all,
> > 
> > I think this has been already discussed, but I don't think I
> totally
> > understand it.
> > 
> > Is there any way to obtain the rank of the nodes at the DAGroot?
> (e.g.
> > in order to monitor the network)
> > 
> > One possible idea is obtain it through the ETX of the links.
> > 
> > Apparently, some metrics can be sent in the in DAG Metric
> Container,
> > but I'm not sure if this option can be included in DIOs and DAOs,
> or
> > only in DIOs. According to errata 5160 of RFC6560 is only in DIOs.
> > 
> > Is there any important reason to not send them in the DAOs as well
> (at
> > least in the non-storing mode)?
> > 
> > If this is not possible, is there any other way within RPL to
> deliver
> > this information to the DAGroot?
> > 
> > Otherwise, I only only possibilities:
> > - Send the rank values from the application layer (which is not
> very 
> > convenient since that would require access to the RPL sublayer)
> > - Through sniffer nodes that would get DIO packets in the network.
> > (however this would require distributing additional nodes all over
> the
> > network)
> > 
> > Am I missing something? Any idea?
> > 
> > Thank you and kind regards,
> > Esteban 
> > 
> > 
> > 
> > -- 
> > Esteban Municio
> > 
> > IDLab - Dept. Mathematics and Computer Science 
> > 
> > University of Antwerp - imec
> > 
> > Middelheimlaan 1 , 2020 Antwerp, Belgium 
> > 
> > Office M.G.322 
> > 
> > _______________________________________________
> > Roll mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/roll

-- 
Esteban Municio

IDLab - Dept. Mathematics and Computer Science 

University of Antwerp - imec

Middelheimlaan 1 , 2020 Antwerp, Belgium 

Office M.G.322

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 19 Feb 2018 18:57:35 +0000

Hello Esteban

For asymmetric link one can build 2 DODAGs. There is a draft I published several years ago about that...

Regards,

Pascal

> Le 19 févr. 2018 à 19:16, Esteban Municio <[email-masked]> a écrit :
> 
> Hi Pascal, Rahul,
>

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Mon, 19 Feb 2018 17:34:50 -0300

Pascal,
             I'm interested in that draft. Do you have a pointer to it?
Thanks,

          Diego

Le lundi 19 février 2018, Pascal Thubert (pthubert) <[email-masked]> a

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 20 Feb 2018 06:25:10 +0000

Hello Diego

That is

https://tools.ietf.org/html/draft-thubert-roll-asymlink-02

Take care,

Pascal

Le 19 févr. 2018 à 21:35, Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> a écrit :

Pascal,

          Diego

Le lundi 19 février 2018, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> a écrit :
Hello Esteban

Regards,

Pascal

> Le 19 févr. 2018 à 19:16, Esteban Municio <[email-masked]<mailto:[email-masked]>> a écrit :
>
> Hi Pascal, Rahul,
>
>> en.be<http://en.be>>; a écrit :
>>>
>>> Hi all,
>>>
>>> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

--
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Tue, 20 Feb 2018 05:16:58 -0300

Pascal,
             Thanks!
Regards,

               Diego

Le mardi 20 février 2018, Pascal Thubert (pthubert) <[email-masked]> a
écrit :

> Le 19 févr. 2018 à 21:35, Prof. Diego Dujovne <[email-masked]>
> a écrit :
>
> Pascal,
> Le lundi 19 février 2018, Pascal Thubert (pthubert) <[email-masked]>
> a écrit :
>
>> Hello Esteban
>>