Subject: [Roll] rpl routing and linux-kernel

From: Rahul Jadhav <[email-masked]>
Date: Tue, 17 Jul 2018 12:40:11 -0400

Hello ROLL,

While trying to integrate RPL with linux kernel and we had certain
design choices. In that context I have some specific questions,
especially towards linux-kernel integration and not towards RPL
protocol implementation itself. Assuming RPL implementation will be in
userspace, questions are:

1. We can add/del routes using rtnetlink interfaces ... this can be
used for the routes learnt by RPL as well ... But RPL needs to
maintain some additional per-route information on the 6LBR ... To be
very specific, we need to store parent information in context to every
route. Is it possible to do it with rtnetlink? I didn't find an option
to do that. If it ain't possible then what could be an alt approach?

2. RPL requires that certain extended ipv6 options be added in data
flows .. What is the best way to do this? It is possible to do this
with netfilter+libnfq but i m not sure whether this is the best
approach.

If there is anyone who tried this before, it would be great to have a
discussion in person while we are in IETF102. Please let know if you
are available for discussion.

Thanks,
Rahul

---

From: Michael Richardson <[email-masked]>
Date: Wed, 18 Jul 2018 22:16:00 -0400

Hi, I'm not sure that the ROLL list is a good place for Linux-specific
implementation questions.  In particular, it seems that most implementers are
on monolithic embedded kernels (contiki, openwsn, etc.)

There are discussions on [email-masked] about Linux
kernel integration (none recently through).

Discussions also occur on [email-masked].
It would be a good place to start a new thread.

    > _______________________________________________
    > Roll mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/roll

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 19 Jul 2018 09:35:44 -0400

Thanks Michael for the pointers. Will followup on [email-masked]

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 23 Jul 2018 14:29:17 +0200

> on monolithic embedded kernels (contiki, openwsn, etc.)

Why? I don't care about most implementers, I care about our RFCs
implemented and discussed in IETF lists, not outside, if we follow
implementers some day we will leave the ROLL list as they did !!!!

IMHO  ROLL list is a good place for implementing RFCs into Linux, I don't
agree that the questions are Linux specific, but implement specific.

> It would be a good place to start a new thread.

but also IMHO we need to have some summary with discuss in this list about
implementations of WG RFCs.

---

From: João Pedro Taveira <[email-masked]>
Date: Tue, 31 Jul 2018 00:58:09 +0100

Hi,

Rahul, I watch the youtube video of ROLL session (thanks to Michael last mail to list) and I notice you ask about RPL implementations in linux kernel. About my kernel implementation attempt history, roadmap and status, please check https://github.com/joaopedrotaveira/linux-rpl/issues/1 <https://github.com/joaopedrotaveira/linux-rpl/issues/1>. There’s a link with my initial plan and my failures.

If we could try to make it happen, it would great. Send me your questions to my email or make presure on github repo. I just would like to move this subject to any other channel.

Abdussalam, I agree with Michael, there are discussions about this subject were they should be. And IMHO, I never leaved, I’m still here.

Best Regards,
João Pedro Taveira

> On 23 Jul 2018, at 13:29, Abdussalam Baryun <[email-masked]> wrote:
> 
> 
> 
> On Thu, Jul 19, 2018 at 4:16 AM, Michael Richardson <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Why? I don't care about most implementers, I care about our RFCs implemented and discussed in IETF lists, not outside, if we follow implementers some day we will leave the ROLL list as they did !!!! 
> 
> IMHO  ROLL list is a good place for implementing RFCs into Linux, I don't agree that the questions are Linux specific, but implement specific.
> 
> 
> 
> There are discussions on [email-masked] <mailto:[email-masked]..ca> about Linux
> Discussions also occur on [email-masked] <mailto:[email-masked]>.
> but also IMHO we need to have some summary with discuss in this list about implementations of WG RFCs.
>  
> 
> Rahul Jadhav <[email-masked] <mailto:[email-masked]>> wrote:
>     > Hello ROLL,
> 
>     > [email-masked] <mailto:[email-masked]>
>     > https://www.ietf.org/mailman/listinfo/roll <https://www.ietf.org/mailman/listinfo/roll>
> 
> -- 
> Michael Richardson <[email-masked] <mailto:[email-masked]>>, Sandelman Software Works
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/roll <https://www.ietf.org/mailman/listinfo/roll>
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/roll <https://www.ietf.org/mailman/listinfo/roll>
________________________________________
João Pedro Taveira Pinto Silva
e-mail: [email-masked] <mailto:[email-masked]>
github: joaopedrotaveira <https://github.com/joaopedrotaveira>
linkedin: joaopedrotaveira <https://www.linkedin.com/in/joaopedrotaveira>