Subject: Re: [Roll] WGLC for draft-ietf-roll-efficient-npdao-03

From: "Liubing (Remy)" <[email-masked]>
Date: Tue, 7 Aug 2018 03:28:44 +0000

Hello Roll, Rahul and co-authors,

After reading the draft-ietf-roll-efficient-04, I found this draft useful. The problems, motivation and solutions are described quite clearly.

I have some minor comments:

1.       Does this draft require a new MOP to distinguish the original storing mode MOP?

2.       In the second paragraph of section 4.1, “In this case, Node A which is the common ancestor node for node D along the two paths (previous and new), may generate a DCO which traverses downwards in the network.” “traverses downwards in the network” should be clarified as “traverses downwards along the previous route”.

3.       The title of section 4.2 might be misleading. It proposes an update of transit information option instead of the DAO body itself. When reading the second paragraph of this section, I thought there was update to the DAO message body. The term “transit container option” should be “transit information option”?

4.       In section 4.4.1, how do dependent nodes know that the route is changed, so that the ‘I’ bit is set correctly?

Best regards,
Remy

From: Roll [mailto:[email-masked]] On Behalf Of Ines Robles
Sent: Wednesday, July 04, 2018 5:41 PM
To: roll <[email-masked]>; [email-masked]
Subject: [Roll] WGLC for draft-ietf-roll-efficient-npdao-03

Dear all,

A Working Group Last call (WGLC) starts today (04/07) until 20/07 for draft-ietf-roll-efficient-npdao-03

The draft is available here:
https://datatracker.ietf.org/doc/draft-ietf-roll-efficient-npdao/

Please review this draft to see if you think that it is ready for publication and send comments to the list stating your view.

Thank you very much in advance,

Ines and Peter

---

From: Rahul Arvind Jadhav <[email-masked]>
Date: Tue, 7 Aug 2018 15:04:01 +0000

Thanks Remy for the review. Please find my comments inline [RJ].

Best,
Rahul

From: Roll [mailto:[email-masked]] On Behalf Of Liubing (Remy)
Sent: 07 August 2018 11:29
To: Routing Over Low power and Lossy networks <[email-masked]>; [email-masked]
Subject: Re: [Roll] WGLC for draft-ietf-roll-efficient-npdao-03

[RJ]: The draft provides an improvised invalidation primitive in existing storing MOP. New MOP is not relevant for this work and the draft does not require signaling of new MOP. Any context where storing route entries are made can use this technique (including storing MOP or storing entries made using DAO projection).

[RJ]: The DCO does not traverse the previous route. The DCO traverses the current route from the common ancestor to the target’s previous parent. I get what you are trying to suggest here but calling it as previous route may add to the confusion imo. Will try to rephrase the statement.

[RJ]: Yes this should be reworded. Thanks.

[RJ]: I-bit allows the target node to have control over its own route invalidation. This was required because current NPDAO follows that semantic. I-bit helps DCO remain inline with this principle of NPDAO. With this rationale, the dependent node essentially can mark I-bit always in the transit option whenever regular DAO is set if it desires route-invalidation for any previous path.

From: Roll [mailto:[email-masked]] On Behalf Of Ines Robles
Sent: Wednesday, July 04, 2018 5:41 PM
To: roll <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [Roll] WGLC for draft-ietf-roll-efficient-npdao-03

Dear all,

Ines and Peter

---

From: "Liubing (Remy)" <[email-masked]>
Date: Fri, 10 Aug 2018 01:37:19 +0000

Hello Rahul,

Regarding to the last question, as each node is in charge of its own route invalidation, I‘m curious that how the dependent nodes know that the downward route is changed so the nodes can send out a DAO with the I bit set to invalid the previous route.

Thank you,
Remy
From: Roll [mailto:[email-masked]] On Behalf Of Rahul Arvind Jadhav
Sent: Tuesday, August 07, 2018 11:04 PM
To: Routing Over Low power and Lossy networks <[email-masked]>; [email-masked]
Subject: Re: [Roll] WGLC for draft-ietf-roll-efficient-npdao-03

Best,
Rahul

From: Roll [mailto:[email-masked]] On Behalf Of Liubing (Remy)
Sent: 07 August 2018 11:29
To: Routing Over Low power and Lossy networks <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Roll] WGLC for draft-ietf-roll-efficient-npdao-03

Dear all,

Ines and Peter

---

From: Rahul Arvind Jadhav <[email-masked]>
Date: Fri, 10 Aug 2018 02:10:09 +0000

Dependent nodes have no way of telling whether upward routes have changed. They send DAO in response to updated DTSN from their preferred parent. All this is as per 6550.

Dependent nodes always set the I-bit in regular DAO if they desire route invalidation to happen for them. Your question is, how do they know route invalidation needs to happen. My point is, they do not need to know. If there is no previous route installed in the system for the node, then there is no DCO getting generated even though I-bit is set.

From implementation point of view, a node takes a decision to set I-bit based on one-time configuration and not based on input from DIO/any other control messages.

Best,
Rahul

From: Roll [mailto:[email-masked]] On Behalf Of Liubing (Remy)
Sent: 10 August 2018 09:37
To: Routing Over Low power and Lossy networks <[email-masked]>; [email-masked]
Subject: Re: [Roll] WGLC for draft-ietf-roll-efficient-npdao-03

Hello Rahul,

Thank you,
Remy

Best,
Rahul

Dear all,

Ines and Peter