Subject: [Roll] Review of draft-koutsiamanis-roll-nsa-extension-02

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Wed, 17 Oct 2018 23:38:08 -0300

Dear all,
        This is the review of draft-koutsiamanis-roll-nsa-extension-02.
Regards,

                    Diego Dujovne

Review
1. First, I woud say that sections 3, 4 and 5 are mostly concentrated on
the packet replication process. this text can be mostly removed
by referring to the pre-requisites draft on 6tisch.
2. "no TLV have been" should be "no TLV has been"
3. "option is included is shown" should be "option is included, is shown"
4. "is shown further expanded" should be "is shown expanded"
5. The idea "It does not make sense for this information to be
   aggregated due to the scalability issue created
   by the space required for many IPv6 addresses.
   Therefore, the PS MUST NOT be aggregated." is not
   clear. can you rephrase this expression? Why should
   aggregation be considered first?
6. "For reasons of clarity," -> "For clarity reasons,"

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Mon, 22 Oct 2018 15:20:17 +0200 (CEST)

Hello Diego,
thank you very much for the review!
I will respond to each comment inline..

Best,
Aris

> by referring to the pre-requisites draft on 6tisch.
This is true. Since draft-papadopoulos-6tisch-pre-reqs has matured I think
I will more carefully review it and keep the minimal amount of contextual
information required for this draft to be somewhat individually readable,
and will refer to draft-papadopoulos-6tisch-pre-reqs for the rest.

> 2. "no TLV have been" should be "no TLV has been"
Thanks, fixed.

> 3. "option is included is shown" should be "option is included, is shown"
Thanks, fixed.

> 4. "is shown further expanded" should be "is shown expanded"
Thanks, fixed.

>    aggregation be considered first?
Thanks, when we changed from using a metric to using a constraint I missed
this. I have removed it, it makes no sense for constraints.

> 6. "For reasons of clarity," -> "For clarity reasons,"
Thanks, fixed.

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>