Subject: [Roll] nsa-extension and traffic-aware-objective-function

From: Peter van der Stok <[email-masked]>
Date: Mon, 15 Oct 2018 15:20:17 +0200

Hi all,

During ietf102 the adoption of these two documents was discussed.
We asked for reviews and comments.
Prof Diego Dujovne promised a review and e are looking forward to that.

However these documents need more support for adoption by this WG.
One of the arguments was that 6tisch needed the documents.
Some remarks on the ML about the necessity of these by documents by
6tisch would be welcome.
Indications that implementations are on their way would certainly help.

looking forward to your reactions,

Ines and Peter 
-- 
Peter van der Stok
vanderstok consultancy
mailto: [email-masked], [email-masked]
www: www.vanderstok.org [1]
tel NL: +31(0)492474673     F: +33(0)966015248 

Links:
------
[1] http://www.vanderstok.org

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 15 Oct 2018 15:12:16 +0000

Hello Peter :

I think the observation was that 6TiSCH as a ROLL user/customer sees a need for information that can help select a RPL DODAG.
That can include load at the root (in terms of free bandwidth or free space to get more nodes in the network), capability of a node to be joined as a join proxy or as a RPL parent
I’m concerned that we adopt a document that is too focused on just one aspect (traffic-aware) before the full problem is even on the table is very, very premature.
As for NSA-extensions I understand a lot better and support the work, but as a background activity for ROLL since it is a next gen thing.

All the best,

Pascal

From: Roll <[email-masked]> On Behalf Of Peter van der Stok
Sent: lundi 15 octobre 2018 15:20
To: Roll <[email-masked]>
Subject: [Roll] nsa-extension and traffic-aware-objective-function

Hi all,

However these documents need more support for adoption by this WG.
One of the arguments was that 6tisch needed the documents.
Some remarks on the ML about the necessity of these by documents by 6tisch would be welcome.
Indications that implementations are on their way would certainly help.

Ines and Peter
--
Peter van der Stok
vanderstok consultancy
mailto: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
www: www.vanderstok.org<http://www.vanderstok.org>
tel NL: +31(0)492474673     F: +33(0)966015248

---

From: Rahul Arvind Jadhav <[email-masked]>
Date: Tue, 16 Oct 2018 00:38:14 +0000

Hello all,

Regarding traffic-aware-objective-function, we already have a variant of the drafts implementation (but it is not open sourced as of now). Our primary motivation for the work then was to improve network lifetime by ensuring traffic is distributed among all possible peers. We considered packets processed per time unit (PPU) as the primary metric and defined an OF around combination of PPU, ETX and #hops.

Best,
Rahul

From: Roll [mailto:[email-masked]] On Behalf Of Peter van der Stok
Sent: 15 October 2018 21:20
To: Roll <[email-masked]>
Subject: [Roll] nsa-extension and traffic-aware-objective-function

Hi all,

Ines and Peter

---

From: Bob Old <[email-masked]>
Date: Mon, 15 Oct 2018 21:20:40 -0500

On Mon, Oct 15, 2018, 7:38 PM Rahul Arvind Jadhav <[email-masked]>
wrote:

> Hello all,
>
>
>
> Regarding traffic-aware-objective-function, we already have a variant of
> the drafts implementation (but it is not open sourced as of now). Our
> primary motivation for the work then was to improve network lifetime by
> ensuring traffic is distributed among all possible peers. We considered
> packets processed per time unit (PPU) as the primary metric and defined an
> OF around combination of PPU, ETX and #hops.
>
>
>
> Best,
>
> Rahul
>
>
>
> *From:* Roll [mailto:[email-masked]] *On Behalf Of *Peter van der
> Stok
> *Sent:* 15 October 2018 21:20
> *To:* Roll <[email-masked]>
> *Subject:* [Roll] nsa-extension and traffic-aware-objective-function
>
>
>
> Hi all,
>
> www: www.vanderstok.org
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: "Timothy L. Hirou" <[email-masked]>
Date: Tue, 16 Oct 2018 03:37:54 +0000

Hello Bob,

How have you been? Are you still with Siemens Building Automation?

Best Regards,

Timothy L. Hirou
Founder
Convergence Wireless, Inc.
23 Corporate Plaza Drive, Suite 100
Newport Beach, CA 92660
(800) 519-9820 Office
(949) 258-5592 Fax
[email-masked]
www.convergencewireless.com‎

Privileged And Confidential Communication This electronic transmission, and any documents attached hereto, (a) are protected by the Electronic Communications privacy Act (18 USC §§ 2510- 2521),(b) may contain confidential and or legally privileged information , and (c) are for the sole use of the intended recipient(s) named above.  If you have received this electronic message in error, please notify the sender and delete the electronic message and destroy any physical copies of the information that may have been generated. Any disclosure, copying, distribution, or use of the contents of the information received in error is strictly prohibited.
From: Bob Old
Sent: Monday, October 15, 2018 7:20 PM
To: Routing Over Low power and Lossy networks
Reply To: Routing Over Low power and Lossy networks
Subject: Re: [Roll] nsa-extension and traffic-aware-objective-function

On Mon, Oct 15, 2018, 7:38 PM Rahul Arvind Jadhav <[email-masked]<mailto:[email-masked]>> wrote:
Hello all,

Best,
Rahul

From: Roll [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Peter van der Stok
Sent: 15 October 2018 21:20
To: Roll <[email-masked]<mailto:[email-masked]>>
Subject: [Roll] nsa-extension and traffic-aware-objective-function

Hi all,

Ines and Peter
[email-masked]<mailto:[email-masked]>

---

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Tue, 16 Oct 2018 16:16:08 +0200 (CEST)

Dear all,

for the traffic-aware-objective-function, firstly we are happy that Rahul
is also working on a similar concept and we think this shows that the idea
has merit.
Furthermore, during the summer there was interest for reviews (Rahul) and
we are still looking forward to the review.

We are currently preparing improvements for integration into the draft
before the 2018-10-22 (Monday) Internet Draft submission cut-off deadline.

In these improvements we are firstly orienting our work not only for
load-balancing but also to form a part of the solution to the join process
in Michael Richardson's work
(draft-ietf-6tisch-enrollment-enhanced-beacon-00,
draft-richardson-6tisch-roll-enrollment-priority-01)
as Pascal also mentioned, by extending the metric container object so that
it can be used to select DODAGs (using the minimum-based aggregation
function).

>From what I can gather, we also have some differences to Rahul's work. We
will be updating the draft to change the information reported: now the
current traffic is reported but we will change to reporting the current
*remaining* traffic capacity.

Finally, we are planning to show some first simulation results from our
ongoing work. We are currently implementing this in the Contiki OS.

Best,
Aris