Subject: [Roll] Implementation of draft-ietf-roll-nsa-extension-00 with 6LoRH-style address compression

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Thu, 17 Jan 2019 12:19:48 +0100 (CET)

Hi all,

as a follow-up to the adoption of draft-ietf-roll-nsa-extension, we have
updated the Contiki-based implementation to also perform compression of the
addresses stored in the Parent Set (PS) extension proposed.
As per Michael's suggestion, we implemented 6LoRH-style address
compression. As in RFC 8138, we need a reference address and the one we
chose is the DODAG ID, i.e. the address of the DODAG root.
We also added an example of the use of the draft extension in examples/ipv6/
rpl-tsch-draft-ietf-nsa-extension.

The code has been updated and it is available at:
https://github.com/ariskou/contiki/tree/draft-ietf-roll-nsa-extension

Kind regards,
Aris

---

From: Michael Richardson <[email-masked]>
Date: Thu, 17 Jan 2019 12:25:03 -0500

Very cool, thank you for letting the WG know.

So you have suggested updates to the document?
Clarificiations?   Typos you observed?

Remous-Aris Koutsiamanis <[email-masked]> wrote:
    > As per Michael's suggestion, we implemented 6LoRH-style address compression.
    > As in RFC 8138, we need a reference address and the one we chose is the DODAG
    > ID, i.e. the address of the DODAG root.
    > We also added an example of the use of the draft extension in
    > examples/ipv6/rpl-tsch-draft-ietf-nsa-extension.

    > ----------------------------------------------------
    > Alternatives:

    > ----------------------------------------------------
    > _______________________________________________
    > Roll mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/roll

---

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Fri, 18 Jan 2019 15:07:52 +0100 (CET)

Hi and thanks!

We continue to work on this topic. This code update brings the
implementation in line with the draft.
For the draft, indeed we are also looking for reviewers for some help.
Any suggestions, updates or requests for clarifications are *very* welcome.

Kind regards,
Aris

On Thu, Jan 17, 2019 at 6:25 PM Michael Richardson <[email-masked]> wrote:

> compression.