Subject: Re: [Roll] [6tisch] I-D Action: draft-richardson-6tisch-roll-enrollment-priority-02.txt

From: Michael Richardson <[email-masked]>
Date: Thu, 07 Feb 2019 12:10:40 -0500

[email-masked] wrote:
    > A New Internet-Draft is available from the on-line Internet-Drafts directories.
    > This draft is a work item of the IPv6 over the TSCH mode of IEEE 802.15.4e WG of the IETF.

    > Title           : Enabling secure network enrollment in RPL networks
    > Author          : Michael Richardson
    > Filename        : draft-richardson-6tisch-roll-enrollment-priority-02.txt
    > Pages           : 6
    > Date            : 2019-02-06

    > Abstract:
    > [I-D.richardson-6tisch-enrollment-enhanced-beacon] defines a method
    > by which a potential [I-D.ietf-6tisch-minimal-security] can announce
    > itself as a available for new Pledges to Join a network.  The
    > announcement includes a priority for join.  This document provides a
    > mechanism by which a RPL DODAG root can disable join announcements,
    > or adjust the base priority for join operation.

I have refreshed this document: no changes.

We discussed this a year and a half, I think, and again at the London IETF101
meeting.  There was general support in the room for providing something like
this, and is it generally non-invasive.

But, there has been very little discussion on the mailing list.
The IANA considerations make it easier to do as a WG document.
6tisch has a document that needs to reference this.

Would the WG care to consider adopting it?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Rahul Arvind Jadhav <[email-masked]>
Date: Fri, 8 Feb 2019 05:20:34 +0000

<CCing LWIG>>

Hello Michael,

The min-priority information from 6LRs/6LBRs is an important field.
In our experiments, we found that without such a mechanism it won't be possible to even form a stable network with limited memory in dense deployments.
We have a draft in LWIG (https://datatracker.ietf.org/doc/draft-ietf-lwig-nbr-mgmt-policy/) which talks about managing neighbor cache entries effectively with dense deployments and limited memory. Section 2.5.2. in the draft explains the need for such a field in the DIO message.
In the last LWIG session I had explained the need for this field in DIO messages (and quoted your draft) in my presentation.
This time we will be providing performance data in LWIG for this draft and the implementation already has min-priority (-like) field in the DIO.

Regards,
Rahul

> -----Original Message-----
> From: Roll [mailto:[email-masked]] On Behalf Of Michael Richardson
> Sent: 07 February 2019 22:41
> To: [email-masked]
> Subject: Re: [Roll] [6tisch] I-D Action: draft-richardson-6tisch-roll-enrollment-
> priority-02.txt
> 
> 
> meeting.  There was general support in the room for providing something
> like this, and is it generally non-invasive.
>