Subject: [Roll] Unassigned bits of the ... are reserved

From: Rahul Arvind Jadhav <[email-masked]>
Date: Tue, 30 Apr 2019 10:00:43 +0000

Hello ROLL,

RPL (RFC6550) base objects and options have a couple of sentences in the context saying,
"Unassigned bits of the [MSG] are reserved. They MUST be set to zero on transmission and MUST be ignored on reception."

This text is present for all base objects including, DIO/DAO/DAO-ACK/CC.
Also it is present for following options, RIO/PIO/Transit Information Option/Solicited Information
But it is not present for following options, DODAG Configuration/DAG Metric Container/Pad1/PadN/RPL Target.

Want to understand which bits are referenced by this statement and why for certain options it is not mentioned?

<This point was commented upon by Alvaro during review of draft-ietf-roll-efficient-npdao-09>

Regards,
Rahul

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 30 Apr 2019 10:10:33 +0000

Hello Rahul

I guess we forgot. Reserved is always zero as a general practice but it is good to say it to make sure  : )

All the best,

Pascal

From: Roll <[email-masked]> On Behalf Of Rahul Arvind Jadhav
Sent: mardi 30 avril 2019 12:01
To: roll <[email-masked]>
Subject: [Roll] Unassigned bits of the ... are reserved

Hello ROLL,

Regards,
Rahul

---

From: Michael Richardson <[email-masked]>
Date: Tue, 30 Apr 2019 19:07:53 -0400

> “Unassigned bits of the [MSG] are reserved. They MUST be set to zero on
    > transmission and MUST be ignored on reception.”

    > certain options it is not mentioned?

I think that it's an omission, that all reserved bits should be set to zero
and ignored.  I don't think we have good IANA text on how to allocate them,
so I would assume it takes an IETF Standards Action, which your document is.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-