Subject: [Roll] Route projection

From: "Turner, Randy" <[email-masked]>
Date: Thu, 2 May 2019 10:16:27 +0000

HI All,

Apologies if this has already been discussed, but in reading the draft on route projection, it seems like the PCE is always making decisions when routes are projected and I understand why this is the focus.  Has there been a discussion on the possibility of an arbitrary router in the DODAG "asking" the root or PCE for an optimal source route (P2P) to a particular destination ?  Or in the language of the draft, an arbitrary router requesting a P-DAO to a particular destination (assuming the "request" for a P-DAO contains the intended destination).  I guess I'm more interested in the "non-storing" scenario for route projection.

Thanks!
R.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 2 May 2019 10:47:33 +0000

Hello Randy:

We could add a method for that I guess; but we do not have a concept of route request in RFC 6550, so I'm wondering how that could be done. Do you have a suggestion?

All the best,

Pascal

From: Roll <[email-masked]> On Behalf Of Turner, Randy
Sent: jeudi 2 mai 2019 12:16
To: [email-masked]' <[email-masked]>
Subject: [Roll] Route projection

HI All,

Thanks!
R.