Subject: [Roll] clarification on rfc6206

From: francisco javier sanchez-roselly <[email-masked]>
Date: Fri, 17 May 2019 13:56:21 +0200

hi All, a minor question on section 4.2.

rule 6 states that to reset Trickle, I must be greater than Imin, but this condition always verifies because of rules 1 and 5.

is this redundant or I should be t in rule 6?

thanks, regards.

francisco javier sanchez-roselly

---

From: Rahul Arvind Jadhav <[email-masked]>
Date: Mon, 20 May 2019 00:43:25 +0000

Hi Francisco,

I must be greater than Imin based on rule 1 and 5. But note that in step6, I could be set to Imin on resetting the timer and then a node, in this state, could hear an inconsistent transmission yet again. In such case, step 6 will hit the condition after seeing (inconsistent transmission && I == Imin) and at this stage, there is no point in resetting the timer again.

Regards,
Rahul

> -----Original Message-----
> From: Roll [mailto:[email-masked]] On Behalf Of francisco javier
> sanchez-roselly
> Sent: 17 May 2019 19:56
> To: [email-masked]
> Subject: [Roll] clarification on rfc6206
> 
> rule 6 states that to reset Trickle, I must be greater than Imin, but this
> condition always verifies because of rules 1 and 5.
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll