Subject: [Roll] WG call for adoption of draft-thubert-roll-unaware-leaves

From: Ines Robles <[email-masked]>
Date: Mon, 13 May 2019 18:01:38 +0300

Dear all,

This is a call for adoption of the draft-thubert-roll-unaware-leaves
document.

The call starts today (13-05) and finalize on 27-05.

Please send your support/opposition with comments before deadline.

Thank you very much,

Ines and Peter

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 16 May 2019 06:10:13 +0000

Dear chairs,

I author I support the adoption (quite obviously!).

This draft is simple but it is still quite important as the ROLL complement to all the Wireless ND work done at 6lo.
With this draft, a 6LN that only supports RFC 8505 can be connected to a RPL network and obtain reachability back.
We have field use cases where the 6LN is a leaf and a very constrained device. Even supporting RPL in that device is overkill both in terms of code and bandwidth.
The draft avoids the double messaging that exists between ND and RPL, DAD to the 6LBR in the one hand and DAO to the Root in the other.

All the best,

Pascal

From: Roll <[email-masked]> On Behalf Of Ines Robles
Sent: lundi 13 mai 2019 17:02
To: roll <[email-masked]>
Subject: [Roll] WG call for adoption of draft-thubert-roll-unaware-leaves

Dear all,

This is a call for adoption of the draft-thubert-roll-unaware-leaves document.

Thank you very much,

Ines and Peter

---

From: Rahul Arvind Jadhav <[email-masked]>
Date: Thu, 16 May 2019 06:23:50 +0000

I support the adoption of this draft.

This draft is natural progression for the work done in RFC 8505. It does not have much impact on the semantics of RPL and still extends it to new scenarios.

Regards,
Rahul

From: Roll [mailto:[email-masked]] On Behalf Of Ines Robles
Sent: 13 May 2019 20:32
To: roll <[email-masked]>
Subject: [Roll] WG call for adoption of draft-thubert-roll-unaware-leaves

Dear all,

Thank you very much,

Ines and Peter

---

From: "Georgios Z. Papadopoulos" <[email-masked]>
Date: Fri, 17 May 2019 13:40:14 +0200

Dear Roll,

Best,
Georgios

> On May 16, 2019, at 08:23, Rahul Arvind Jadhav <[email-masked]> wrote:
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Fri, 17 May 2019 08:43:14 -0300

I support the adoption of this draft

El vie., 17 de may. de 2019 08:40, Georgios Z. Papadopoulos <
[email-masked]> escribió:

> This draft is natural progression for the work done in RFC 8505. It does
> not have much impact on the semantics of RPL and still extends it to new
> scenarios.
>
> Regards,
> Rahul
>
> *From:* Roll [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Ines Robles
> *Sent:* 13 May 2019 20:32
> *To:* roll <[email-masked]>
> *Subject:* [Roll] WG call for adoption of
> draft-thubert-roll-unaware-leaves
>
> Dear all,
>

---

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Fri, 17 May 2019 14:05:19 +0000

I support the adoption of the draft. It may be pretty useful in the smart grid environment.

Thanks,

Patrick

From: Roll <[email-masked]> on behalf of "Prof. Diego Dujovne" <[email-masked]>
Reply-To: Routing Over Low power and Lossy networks <[email-masked]>
Date: Friday 17 May 2019 at 13:43
To: roll <[email-masked]>
Subject: Re: [Roll] WG call for adoption of draft-thubert-roll-unaware-leaves

El vie., 17 de may. de 2019 08:40, Georgios Z. Papadopoulos <[email-masked]<mailto:[email-masked]>> escribió:
Dear Roll,

Best,
Georgios

On May 16, 2019, at 08:23, Rahul Arvind Jadhav <[email-masked]<mailto:[email-masked]>> wrote:

Regards,
Rahul

From: Roll [mailto:[email-masked]] On Behalf Of Ines Robles
Sent: 13 May 2019 20:32
To: roll <[email-masked]<mailto:[email-masked]>>
Subject: [Roll] WG call for adoption of draft-thubert-roll-unaware-leaves

Dear all,

Thank you very much,

Ines and Peter
_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 17 May 2019 14:47:28 +0000

True, Patrick, I’m hearing that too.

The RPL mesh in a Smartgrid has historically been powered. But there’s a new need for low power leaf devices, that would not be powered with mains.

For those, the support of RPL is:

  *   Double messaging in the constrained hop (NS/NA from RFC 8505 + DAO/ACK from RFC 6550)
  *   Double messaging inside the mesh (DAO + DAR/DAC)
  *   More Code in the constrained leaf device (All the RPL stack)

The device makers would prefer to ship devices that are agnostic of which routing protocol happens in the Smartgrid.
RFC 8505 provides the required abstraction but there’s a need for a spec that turns the abstraction into RPL and that is this draft.

All the best,

Pascal

From: Roll <[email-masked]> On Behalf Of Patrick Wetterwald (pwetterw)
Sent: vendredi 17 mai 2019 16:05
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] WG call for adoption of draft-thubert-roll-unaware-leaves

Thanks,

Patrick

From: Roll <[email-masked]<mailto:[email-masked]>> on behalf of "Prof. Diego Dujovne" <[email-masked]<mailto:[email-masked]>>
Reply-To: Routing Over Low power and Lossy networks <[email-masked]<mailto:[email-masked]>>
Date: Friday 17 May 2019 at 13:43
To: roll <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Roll] WG call for adoption of draft-thubert-roll-unaware-leaves

Best,
Georgios

Regards,
Rahul

Dear all,

Thank you very much,

Ines and Peter

---

From: Michael Richardson <[email-masked]>
Date: Fri, 17 May 2019 15:49:09 -0400

I have read unaware-leaves.
I think that is addresses an important gap in the ROLL specification, and I
think we should adopt it.

I have some concerns about how much time a leaf has to stay alive (figure 2).

The document only addresses control traffic.  I think that the document
should repeat some of the data plane advice, and I think that we should
have advice for RULs about insertion and ignoring RPI and RH3 headers.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 17 May 2019 20:18:17 +0000

Well noted Michael.

All the best,

Pascal

> Le 17 mai 2019 à 21:49, Michael Richardson <[email-masked]> a écrit :
> 
>

---

From: Peter van der Stok <[email-masked]>
Date: Tue, 28 May 2019 09:02:35 +0200

Hi Roll,

The WGLC on draft-thubert-roll-unaware-leaves has come to an end to-day.
Support has been expressed and the subject is relevant.

The document is accepted as WG document.

@pascal: can you submit a new ietf version?

Cheerio, thanks,

Ines andPeter