Subject: Re: [Roll] Route projection

From: "Turner, Randy" <[email-masked]>
Date: Thu, 2 May 2019 10:54:47 +0000

Hi Pascal,
It’s true most things come “down” the DODAG….without creating yet another type of RPL message, maybe we could do something with a DAO, since that targets the root – maybe indicate that this is a “reverse DAO” or something like that, defining an option for DAOs (using extension bits?) that indicates the destination address we’re interested in for a source route?

That’s just off the top of my head, I was just curious if anyone else had mentioned something like this, either on the list or a hallway conversation at a plenary.

R.

From: Roll <[email-masked]> on behalf of "Pascal Thubert (pthubert)" <[email-masked]>
Reply-To: Routing Over Low power and Lossy networks <[email-masked]>
Date: Thursday, May 2, 2019 at 6:47 AM
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] Route projection

Hello Randy:

We could add a method for that I guess; but we do not have a concept of route request in RFC 6550, so I’m wondering how that could be done. Do you have a suggestion?

All the best,

Pascal

From: Roll <[email-masked]> On Behalf Of Turner, Randy
Sent: jeudi 2 mai 2019 12:16
To: [email-masked]' <[email-masked]>
Subject: [Roll] Route projection

HI All,

Apologies if this has already been discussed, but in reading the draft on route projection, it seems like the PCE is always making decisions when routes are projected and I understand why this is the focus.  Has there been a discussion on the possibility of an arbitrary router in the DODAG “asking” the root or PCE for an optimal source route (P2P) to a particular destination ?  Or in the language of the draft, an arbitrary router requesting a P-DAO to a particular destination (assuming the “request” for a P-DAO contains the intended destination).  I guess I’m more interested in the “non-storing” scenario for route projection.

Thanks!
R.

---

From: "Turner, Randy" <[email-masked]>
Date: Thu, 2 May 2019 10:58:23 +0000

I was thinking sometimes a node may only want routes to a couple of P2P destinations, like CoAP resource directories or one or two CoAP service nodes, and the nodes would like a good route to get to these particular nodes (assuming they’re multiple hops away) – like storing mode, but I don’t need routes to everything that routes through me – just maybe 2 or 3 destinations.

R.

From: Roll <[email-masked]> on behalf of "Turner, Randy" <[email-masked]>
Reply-To: Routing Over Low power and Lossy networks <[email-masked]>
Date: Thursday, May 2, 2019 at 6:55 AM
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] Route projection

Hi Pascal,

R.

Hello Randy:

All the best,

Pascal

HI All,

Thanks!
R.