Subject: [Roll] Projected routes and RFC 8138

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 23 May 2019 06:11:43 +0000

Dear all

I'm willing to add text on the DAO projection draft to discuss RFC 8138. RFC 8138 was designed for RPL as it stands and optimizes P in IP compression for the case where either the source or destination of IP in IP is the root.

IP in IP
--------
An implementation is used to 1) IP in IP with SRH from the root to the last node indicated in the SRH or 2) IP in IP with no SRH from the node indicated as encapsulator to (implicitely) the root.
For DAO projection we will use an SRH from the node indicated as encapsulator to the last node indicated in the SRH, which is a mix of the above. It is compatible with RFC8138 but possibly untried with existing code.
My suggestion is to represent an example packet that has IP in IP and SRH and none of the outer IPs is the root

RPI
----
RPI flags and Rank are useless along the projected route. On the other hand, we could use a new flag in the RPI to indicated that the route is a projected route in the non-storing case.
Seems to me that we could propose an additional RPI encoding that :

  *   Is inspired from the existing RPI compression but is elective
  *   Does not contain a Rank information nor the flags
  *   May Indicate projected route, another thread on that

What to others think?

Pascal

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 23 May 2019 13:25:12 +0200

I think adding new flag is a good idea.

AB

On Thu, May 23, 2019 at 8:12 AM Pascal Thubert (pthubert) <
[email-masked]> wrote:

> Dear all
>
>
>
> *   I’m willing to add text on the DAO projection draft to discuss RFC
> 8138. RFC 8138 was designed for RPL as it stands and optimizes P in IP
> compression for the case where either the source or destination of IP in IP
> is the root.   IP in IP -------- An implementation is used to 1) IP in IP
> with SRH from the root to the last node indicated in the SRH or 2) IP in IP
> with no SRH from the node indicated as encapsulator to (implicitely) the
> root. For DAO projection we will use an SRH from the node indicated as
> encapsulator to the last node indicated in the SRH, which is a mix of the
> above. It is compatible with RFC8138 but possibly untried with existing
> code. My suggestion is to represent an example packet that has IP in IP and
> SRH and none of the outer IPs is the root   RPI ---- RPI flags and Rank are
> useless along the projected route. On the other hand, we could use a new
> flag in the RPI to indicated that the route is a projected route in the
> non-storing case. Seems to me that we could propose an additional RPI
> encoding that : - Is inspired from the existing RPI compression but is
> elective- Does not contain a Rank information nor the flags- May Indicate
> projected route, another thread on that   What to others think?   Pascal *
>
>
>
>
> * _______________________________________________ Roll mailing list
> [email-masked] <[email-masked]> https://www.ietf.org/mailman/listinfo/roll
> <https://www.ietf.org/mailman/listinfo/roll> *