Subject: Re: [Roll] Adam Roach's No Objection on draft-ietf-roll-useofrplinfo-25: (with COMMENT)

From: Ines Robles <[email-masked]>
Date: Fri, 17 May 2019 12:13:38 +0300

Hi Adam,

Thank you for your review. We have submitted a new version with
corrections. Please find answer in-line.

On Wed, May 1, 2019 at 7:27 AM Adam Roach via Datatracker <[email-masked]>
wrote:

> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> Thanks to everyone who worked on this document. I have only one minor
> comment.
>
> I'm a bit perplexed by the interplay between sections 3.1 and 3.3.
>
> Section 3.1 says:
>
> >  This change creates a flag day for existing networks which are
> >  currently using 0x63 as the RPI value.
>
> And then section 3.3 says:
>
> >  In order to avoid a Flag Day caused by lack of interoperation between
> >  new RPI (0x23) and old RPI (0x63) nodes, this section defines a flag
> >  in the DIO Configuration Option...
>
> Which leaves me wondering whether the net effect of this document does or
> does
> not create a flag day for networks. Please consider updating these
> sections to
> be consistent with each other.
>

Old text:  This change would otherwise create a flag day for existing
networks which are...

New Text: Without the signaling described below, this change would
otherwise create a flag day for existing networks which are currently using
0x63 as the RPI value.

Additionally, new text was added in Section 3.1.

Thanks,

The authors.

---

From: Adam Roach <[email-masked]>
Date: Fri, 17 May 2019 15:36:35 -0500

Thanks! This looks good.

/a

On 5/17/19 4:13 AM, Ines Robles wrote:
> On Wed, May 1, 2019 at 7:27 AM Adam Roach via Datatracker 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Thanks to everyone who worked on this document. I have only one
>     minor comment.
>
>     Which leaves me wondering whether the net effect of this document
>     does or does
> otherwise create a flag day for existing networks which are currently 
> using 0x63 as the RPI value.
>