Subject: [Roll] Last Call Review of draft-ietf-roll-efficient-npdao

From: Eric Gray <[email-masked]>
Date: Thu, 27 Jun 2019 04:40:30 +0000

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-roll-efficient-npdao
Reviewer: Andy Malis
Review Date: 26 June 2019
IETF LC End Date: 26 June 2019
Intended Status: Standards Track

Summary:
Perhaps I am missing some subtleties, but this document looks like it may need a little more work before it is published.

Overall comments:
The document is mostly well written.

Issues:

In the introduction, I have some trouble parsing "an optional messaging" - perhaps it was meant to just be "optional messaging?"

There are difference between the abstract (which claims the document describes issues with NPDAO) and the Introduction (which goes further to say that the document also discusses requirements and specifies a new message intended to meet the requirements and solve the problems.

So, it's a problem statement, requirements document and solution specification all rolled into one.  I guess this is not a problem for anyone in the WG?

The title for section 1.3 should probably be "Why is NPDAO Important."

In that section, I have to wonder if saving memory is the most important factor in removing route information that is no longer valid.  What about issues with forwarding packets toward destinations that can no longer be reached along that path?

Perhaps I misunderstand the approach, but it seems to me that the problems mentioned in section 2.1 should self-resolve.  The fact that one node cannot send messages to another node to inform that node that it has no DAO information seems kind of irrelevant if the node, or the link connecting it, is no longer there.

Perhaps the issue you're really trying to describe is with unreliable links and nodes, as opposed to missing links and nodes?  That would make sense in a low-power and lossy network.

If the behavior described in section 2.2 is common, and a more reasonable behavior is not anticipated by the original NPDAO specification, than I agree that is a problem.

If the problems described in 2.1 and 2.3 do exist, it seems likely that the underlying issue is really about an assumption of reliable delivery where that might not be the reality.

All of this said, the 3 requirements seem reasonable at least as far as they go.  There seems to be an implied requirement to introduce at least some level of reliability (as I seems intended by providing the DCO-ACK). And there probably should be a requirement to support compatibility with deployed implementations.

AFAICT, this document does not describe how nodes using the newly specified messaging and behavior would be compatible with deployed nodes.  Minimally the document should be clear if the intention is not to provide for compatibility.  There are at least a couple of indications that there is deployment.

---

From: Eric Gray <[email-masked]>
Date: Thu, 27 Jun 2019 04:41:52 +0000

Sorry, this review was done by Eric Gray, not Andy Malis.  ☹

From: Eric Gray
Sent: Thursday, June 27, 2019 12:41 AM
To: [email-masked]
Cc: Alvaro Retana (aretana) <[email-masked]>; [email-masked]
Subject: Last Call Review of draft-ietf-roll-efficient-npdao

Summary:

Overall comments:

Issues:

In the introduction, I have some trouble parsing “an optional messaging” – perhaps it was meant to just be “optional messaging?”

So, it’s a problem statement, requirements document and solution specification all rolled into one.  I guess this is not a problem for anyone in the WG?

The title for section 1.3 should probably be “Why is NPDAO Important.”

Perhaps the issue you’re really trying to describe is with unreliable links and nodes, as opposed to missing links and nodes?  That would make sense in a low-power and lossy network.

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 27 Jun 2019 07:35:17 -0400

On June 27, 2019 at 12:42:03 AM, Eric Gray ([email-masked]) wrote:

Eric:

Hi!

So, it’s a problem statement, requirements document and solution
specification all rolled into one.  I guess this is not a problem for
anyone in the WG?

Nope.  In fact, I think that for problems like this one where the result is
an enhancement to the protocol, this type of all-in-one document is ideal
and more efficient.

Thanks!

Alvaro.

---

From: Eric Gray <[email-masked]>
Date: Thu, 27 Jun 2019 13:12:30 +0000

That’s why I did not state this as an issue, exactly, but more as an query.

From: Alvaro Retana <[email-masked]>
Sent: Thursday, June 27, 2019 7:35 AM
To: Eric Gray <[email-masked]>; [email-masked]
Cc: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] Last Call Review of draft-ietf-roll-efficient-npdao
Importance: High

On June 27, 2019 at 12:42:03 AM, Eric Gray ([email-masked]<mailto:[email-masked]>) wrote:

Eric:

Hi!

Nope.  In fact, I think that for problems like this one where the result is an enhancement to the protocol, this type of all-in-one document is ideal and more efficient.

Thanks!

Alvaro.

---

From: Rahul Arvind Jadhav <[email-masked]>
Date: Fri, 28 Jun 2019 08:37:22 +0000

Thanks Eric for the review and feedback.
Regarding compatibility with old deployed nodes, we have received similar feedback (from Shwetha Bhandari) before. May be it is better to make this explicit in the document. Please check if the statement below makes sense.

NEW
                This document assumes that all the 6LRs in the network support this document. If there are 6LRs en-route DCO messaging which do not support this document, then the route invalidation for corresponding targets may not work or may work partially i.e., only part of the path supporting DCO may be invalidated.
Alternatively, a node could generate an NPDAO if it does not receive a DCO with itself as target within a specified time limit. The specified time limit is deployment specific and depends upon the maximum depth of the network and per hop latency. Note that sending NPDAO and DCO for the same operation would not result in unwanted side-effects as detailed in Section 4.6.2.
END

For other comments, find my responses inline.

Thanks,
Rahul

Issues:

[RJ] Yes this has to be fixed. Will remove “an”. This has been brought to notice by others also!

The title for section 1.3 should probably be “Why is NPDAO Important.”
[RJ] I am not sure if question mark here is incorrect. This section title is supposed to indeed read as a question.

In that section, I have to wonder if saving memory is the most important factor in removing route information that is no longer valid.  What about issues with forwarding packets toward destinations that can no longer be reached along that path?
[RJ] Our initial motivation to work on this problem was memory issue. But yes, I agree that in P2P traffic scenario the forwarding will be a problem. This has been described in Section 3.3

[RJ] That's true. Unlike NPDAO, DCO depends on “more” reliable links thus alleviating (but may not completely eliminate) the problem of route invalidation.

[RJ] Yes. Have specified the corresponding text above. Kindly check if it makes sense.