Subject: [Roll] Retrying DCO/DAO, retry parameters

From: Rahul Arvind Jadhav <[email-masked]>
Date: Thu, 27 Jun 2019 01:02:53 +0000

Hello All,

During IESG evaluation of (draft-ietf-roll-efficient-npdao-12) we received a comment from Mirja regarding specifying the DCO retry operation in detail if DCO-ACK is not received. Quoting her verbatim, "Please specify a maximum number of retries and also a minimum retry interval (of e.g. 3 sec best with exponential back-off)!"

Currently the draft says that this is "implementation and deployment dependent".
RFC 6550 also has DAO retries if DAO-ACK is not received but it also does not specify this operation in detail.

Do you think we can put this explicitly  and does anyone have an opinion on the right way of putting this considering different physical layers with very different characteristics operating in dense/sparse (wireless) deployments?

Thanks,
Rahul

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 27 Jun 2019 05:53:36 +0000

Hello Rahul

RPL is designed to operate in very different environment, and some LLNs can be very slow, very lossy or even both. This is why RFC 6550 refrains from being too specific.
Maybe it is good enough to add text indicating that the values used for DCO are expected to be similar/consistent with those used in DAO?

All the best,

Pascal

From: Roll <[email-masked]> On Behalf Of Rahul Arvind Jadhav
Sent: jeudi 27 juin 2019 03:03
To: Routing Over Low power and Lossy networks <[email-masked]>
Cc: Mirja Kühlewind <[email-masked]>
Subject: [Roll] Retrying DCO/DAO, retry parameters

Hello All,

Thanks,
Rahul