Subject: [Roll] stitching PDAO segments

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 24 Jul 2019 22:09:48 +0000

Dear all

Following up on stitching PDAO paths at the meeting today:

As you know, a 6TiSCH Track can be a lot more complex than a sequence of nodes (see https://tools.ietf.org/html/draft-ietf-6tisch-architecture-24#section-4.5.3)
It results that deploying a Track requires stitching segments into a DODAG from source to destination.
What makes the most sense for a 6TISCH Track is probably that each track is defined as a DODAG local instance for the source. All the PDAO segments would be stitched together into that DODAG to form a Track.
The current draft allows for this but a section that explains it all would certainly be useful.

Are we all OK that I propose some text about that?

All the best

Pascal

---

From: <[email-masked]>
Date: Thu, 25 Jul 2019 02:09:16 +0000

Hi Pascal,

I thought 6TiSCH Track forwarding is a completely different forwarding scheme
from RPL/IPv6 forwarding, as implied in https://tools.ietf.org/html/draft-ietf-6tisch-architecture-24#section-3.6

In that case, we don't have to relate DAO projection and Track, I think.
Or, maybe DAO projection is one implementation of Track forwarding, with RPL root playing
the role of PCE?

From: Roll <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, July 25, 2019 7:10 AM
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: [Roll] stitching PDAO segments

Dear all

All the best

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 25 Jul 2019 02:52:11 +0000

Hello Toshio

6TiSCH provided a generic Architecture in which RPL and qrAW have different role to play.

A 6TiSCH tract is computed by a pce but with RPL the nodes do not care where that logical function is located and simply talk to the root. Either the root hosts a pce or it talks to a pce to get the computation done.

A projected track can be deep in a RPL DODAG.  When deep, a node cannot ask the root to change the path at each hiccup of the radio . This is why a simple serial track can be too limiting and the root may prefer to provide a complex track with redundancy that always works even if some segments fail randomly for split seconds.

RAW if formed would work on optimizing the use of a complex track to limit the waste of energy when the track lots of redundancy. RAW operates at the forwarding level over a track on a short time scale whereas RPL routing decisions are made on statistical time scales orders of magnitude longer.

Do I make sense?

Pascal

Le 24 juil. 2019 à 22:10, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> a écrit :

Hi Pascal,

From: Roll <[email-masked]<mailto:[email-masked]>> On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, July 25, 2019 7:10 AM
To: Routing Over Low power and Lossy networks <[email-masked]<mailto:[email-masked]>>
Subject: [Roll] stitching PDAO segments

Dear all

All the best

Pascal
_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: <[email-masked]>
Date: Thu, 25 Jul 2019 11:49:20 +0000

Thanks for explanation, Pascal.

> A 6TiSCH tract is computed by a pce but with RPL the nodes do not care where that logical function is located and simply talk to the root.

That makes sense.

So, if we use Track forwarding, forwarding table for each node is computed by PCE. Then, those forwarding tables are deployed to nodes using RPL, i.e. sending PDAO messages.

From: Roll <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, July 25, 2019 11:52 AM
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] stitching PDAO segments

Hello Toshio

Do I make sense?

Pascal

Dear all

All the best

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 25 Jul 2019 12:23:18 +0000

Yes Toshio:

The forwarding behavior is the subject of RAW the new WG that I’m trying to form.

Regards,

Pascal

Le 25 juil. 2019 à 07:50, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> a écrit :

That makes sense.

Hello Toshio

Do I make sense?

Pascal

Dear all

All the best

Pascal

---

From: Michael Baddeley <[email-masked]>
Date: Fri, 26 Jul 2019 07:41:20 +0100

>
>
> A 6TiSCH tract is computed by a pce but with RPL the nodes do not care
> where that logical function is located and simply talk to the root. Either
> the root hosts a pce or it talks to a pce to get the computation done.
>
>
>
> Pascal,

Just to be clear for my own understanding: is a 6TiSCH track defined as
centrally computed by a PCE? I thought tracks could also be allocated with
soft cells in a distributed hop-by-hop manner? (for example, along the RPL
route).

Regards,

Michael

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 26 Jul 2019 10:27:07 +0000

Hello Michael

Sorry for misleading text. I should have said that in this case the track is computed by the PCE. It does not have to be the case.

The Track is a topology like a TE path. How it is set up is orthogonal. I guess you could use an RSVP like extension to AODV RPL to build one.

The 6TiSCH Architecture allows both centralized and distributed. The DetNet Architecture also recognizes both models but also that the centralized approach seems easier to tackle, e.g., when you have to optimize N independent tracks over common resources.

Regards,

Pascal

Le 26 juil. 2019 à 02:42, Michael Baddeley <[email-masked]<mailto:[email-masked]>> a écrit :

Pascal,

Just to be clear for my own understanding: is a 6TiSCH track defined as centrally computed by a PCE? I thought tracks could also be allocated with soft cells in a distributed hop-by-hop manner? (for example, along the RPL route).

Regards,

Michael