Subject: [Roll] WGAdoption for draft-rahul-roll-mop-ext

From: Ines Robles <[email-masked]>
Date: Wed, 24 Jul 2019 22:06:05 +0300

Dear all,

This is a WG adoption call for draft-rahul-roll-mop-ext from 24-07-2019 to
07-08-2019.

Please let us know your comments,

Thanks,

Ines and Peter

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 24 Jul 2019 19:59:21 +0000

Support 

This is an infrastructure document. We need it yesterday so we can use it in the other drafts.

Regards,

Pascal

> Le 24 juil. 2019 à 15:06, Ines Robles <mariainesrobles=[email-masked]> a écrit :
> 
> Dear all,
> 
> This is a WG adoption call for draft-rahul-roll-mop-ext from 24-07-2019 to 07-08-2019.
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Yasuyuki Tanaka <[email-masked]>
Date: Wed, 24 Jul 2019 16:16:26 -0400

I support this work.

Best,
Yatch

---

From: Michael Richardson <[email-masked]>
Date: Wed, 24 Jul 2019 17:31:16 -0400

> Please let us know your comments,

I have read the document, and I think it should be adopted.
I think that the mop==7 calculation should be changed, but we can do that
after adoption.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 24 Jul 2019 21:47:35 +0000

Agree with Michael here;

The suggestion I made at the mike in addition to this was that 7 in the MOP means that the MOP is in the ext. If there is no ext then the MOP is elided in this DIO, need to wait for the next one.

All the best,

Pascal

> -----Original Message-----
> From: Roll <[email-masked]> On Behalf Of Michael Richardson
> Sent: mercredi 24 juillet 2019 14:31
> To: Routing Over Low power and Lossy networks <[email-masked]>
> Subject: Re: [Roll] WGAdoption for draft-rahul-roll-mop-ext
> 
> 
> Michael Richardson <[email-masked]>, Sandelman Software Works  -
> = IPv6 IoT consulting =-
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 24 Jul 2019 17:52:04 -0400

Pascal Thubert (pthubert) <[email-masked]> wrote:
    > The suggestion I made at the mike in addition to this was that 7 in the
    > MOP means that the MOP is in the ext. If there is no ext then the MOP
    > is elided in this DIO, need to wait for the next one.

the mop is in every DIO.
You are suggesting that the mopext might not need to be sent in every DIO?

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 24 Jul 2019 21:57:46 +0000

Yes, that was actually Rahul's suggestion. 

We already elide the DODAG configuration option in some DIOs. This may be elided as well in some DIO messages if room is needed for something else.
Hopefully it would be elided only if there is a good reason.

All the best,

Pascal

> Sent: mercredi 24 juillet 2019 14:52
> Subject: [Roll] eliding mop ext
> 
>

---

From: "Georgios Z. Papadopoulos" <[email-masked]>
Date: Thu, 25 Jul 2019 10:31:30 -0400

I have read the draft and gave my review.
I support this document.

Georgios

> On Jul 24, 2019, at 15:06, Ines Robles <mariainesrobles=[email-masked]> wrote:
> 
> Dear all,
>

---

From: "Li Zhao (liz3)" <[email-masked]>
Date: Thu, 25 Jul 2019 19:35:57 +0000

Support.

Capability should be a significant character for RPL.

Best regards,
Li

From: Roll <[email-masked]> on behalf of Ines Robles <mariainesrobles=[email-masked]>
Reply-To: Routing Over Low power and Lossy networks <[email-masked]>
Date: Thursday, July 25, 2019 at 3:06 AM
To: roll <[email-masked]>
Subject: [Roll] WGAdoption for draft-rahul-roll-mop-ext

Dear all,

Thanks,

Ines and Peter