Subject: [Roll] Querying PDAO

From: "Li Zhao (liz3)" <[email-masked]>
Date: Wed, 24 Jul 2019 23:41:49 +0000

Dear all,

Following up on querying PDAO from root at the meeting today:

It makes sense to provide a querying mechanism for node which can get PDAO from root. Then node can query special PDAO route entry according to its special requirement. For example, route hop, latency, route algorithm, remaining lifetime.

We can enhance DIS to query PDAO if adding a flag in DIO Base Object to identify it is a PDAO query DIS.
And this DIS need to carry a new Control Message Options because existing Control Message can’t identify the requirement.
A possible Control message is as following:

        0                   1                   2                   3

        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

       |   Type = TBD | Option Length | Prefix Length | alg    | Resvd |

       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

       |                                                               |

       .                   Target Prefix (Variable Length)             .

       .                                                               .

       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

       |                        route parameter                        |

       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

alg: route algorithm such as latency/hop limited/common ancestor.
hops/latency/remaining lifetime are some route parameter.

Is it possible to add some text about it?

Best regards,
Li

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 24 Jul 2019 23:52:16 +0000

Looks good Li.

I’m confused that you see the target as a prefix; would you like to create a path to the nearest router that serves a subnet?
I guess that the route parameters should be a place for suboptions.
Suboptions I can fathom would be a max sum of steps of Rank, a max latency, and a reliability level. Should be extensible though.
Which means that the sibling and transit information in the DAO should provide enough metrics to build this.

Assessing the list here, do we have a consensus to add a PDAO query DIS to the PDAO draft?

All the best,

Pascal

From: Roll <[email-masked]> On Behalf Of Li Zhao (liz3)
Sent: mercredi 24 juillet 2019 16:42
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: [Roll] Querying PDAO

Dear all,

        0                   1                   2                   3

       |                                                               |

       .                                                               .

       |                        route parameter                        |

Best regards,
Li

---

From: Michael Richardson <[email-masked]>
Date: Wed, 24 Jul 2019 20:22:39 -0400

> It makes sense to provide a querying mechanism for node which can get PDAO
    > from root. Then node can query special PDAO route entry according to its
    > special requirement. For example, route hop, latency, route algorithm,
    > remaining lifetime.

So, if I understand, you are asking that a given node X, having traffic to
node Y, should be able to ask the root to project a DAO towards Y?

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: "Li Zhao (liz3)" <[email-masked]>
Date: Thu, 25 Jul 2019 13:02:46 +0000

Correct. If the application on node X wants to ask a nearest path to node Y, PDAO draft doesn't provide any mechanism.
I think PDAO draft need to cover this case. Maybe how and when to use PDAO is out of scope of this draft.
But at least we need to reserve the asking capability and define the protocol.

Best regards,
Li

On 2019/7/25, 8:22 AM, "Roll on behalf of Michael Richardson" <[email-masked] on behalf of [email-masked]> wrote:

---

From: Michael Richardson <[email-masked]>
Date: Thu, 25 Jul 2019 11:37:32 -0400

Li Zhao (liz3) <[email-masked]> wrote:
    > Correct. If the application on node X wants to ask a nearest path to
    > node Y, PDAO draft doesn't provide any mechanism.

P2PRPL tries to do this, but you are suggesting that instead of learing it,
the root should just know it.  This goes to some of the PCE cases, I think.

Is there PCE technology we can use?

DAO-projection does not create a route that is remembered, rather it prefixes
it to a particular packet.  So you'd want node X to be able to ask the root
for such a source route?

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 25 Jul 2019 17:25:46 +0000

Hello Michael:

I'd reward saying that DAO is the centralized way of doing what P2P RPL achieves in a distributed reactive fashion: a local DODAG that implements the concept of a 6TiSCH Track.
With the current spec the packets flow down the DODAG only, against the DODAG orientation. The root the DODAG is the source of the packets, and the RPL classical forwarding apply for storing and non-storing.  
The difference is in the control: there is no DIO messaging on the local DODAG, and the DAO messaging is initiated by the main root as opposed to the distributed nodes.
If we need a return channel well need to introduce a DIO that would be flooded the other way, or a DODAG in the other direction like AODV does.

So yes, P DAO installs routes, normally as different DODAGs typically as source-local RPL instances. The PCE may be hidden within or separated behind the main root, in which case the main root acts as proxy.
The expectation so far was that the request o establish a path would come from the application but the general DetNet model also enables the host to make that request.
With P DAO that means a message from the node to the root with a TSPEC that allows the root to compute a constrained DODAG. Can be a DIS.

The DODAG is decomposed in linear segments that are installed separately using the PDAO messaging in a same local instance owned by the local root. We probably need to explain all that a lot better. 
RAW would be how we optimize the runtime of the projected DODAG.

All the best,

Pascal

> -----Original Message-----
> From: Roll <[email-masked]> On Behalf Of Michael Richardson
> Sent: jeudi 25 juillet 2019 11:38
> Subject: Re: [Roll] Querying PDAO
> 
> 
> P2PRPL tries to do this, but you are suggesting that instead of learing it, the
> root should just know it.  This goes to some of the PCE cases, I think.
> 
> it to a particular packet.  So you'd want node X to be able to ask the root for
> such a source route?
>