Subject: [Roll] Sibling information

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 24 Jul 2019 22:12:29 +0000

Dear all

Following up on the WG meeting today:

It makes sense to make the draft complete by adding a sibling information in the Non storing mode DAO to the root. This was the root can compute more optimized P DAO.

Are we OK that I include some text and a proposed format about that in the next revision?

All the best

Pascal

---

From: Rahul Arvind Jadhav <[email-masked]>
Date: Thu, 25 Jul 2019 00:33:31 +0000

Hi Pascal,

Isn't it already possible to send multiple Transit Information Option in DAO in non-storing MOP for a node to inform root of node's multiple parents?
I understand you mentioned sibling information but I am wondering how root makes use of sibling information to optimize P-DAO. I can clearly relate how root can use multiple parent's info to optimize P-DAO but not sure how sibling info will help.

Regards,
Rahul

From: Roll [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: 25 July 2019 06:12
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: [Roll] Sibling information

Dear all

All the best

Pascal

---

From: <[email-masked]>
Date: Thu, 25 Jul 2019 02:16:30 +0000

Hi Pascal,

I'm interested in this feature.

Having a standardized way to collect (both DIO- and DAO-based) topology information sounds useful for
management and monitoring purposes, too.

From: Roll <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, July 25, 2019 7:12 AM
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: [Roll] Sibling information

Dear all

All the best

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 25 Jul 2019 02:39:58 +0000

Hello Rahul

Siblings are peers at a Rank similar to this node.
RPL will not tell the root about them. We want to give similar information about parents and siblings but we do not want the root to use siblings for source routing.
So a sibling information option would be just like a transit but not for use as a parent in normal RPL and then the metrics could be added for both kinds.

Regards,

Pascal

Le 24 juil. 2019 à 20:34, Rahul Arvind Jadhav <[email-masked]<mailto:[email-masked]>> a écrit :

Hi Pascal,

Isn’t it already possible to send multiple Transit Information Option in DAO in non-storing MOP for a node to inform root of node’s multiple parents?
I understand you mentioned sibling information but I am wondering how root makes use of sibling information to optimize P-DAO. I can clearly relate how root can use multiple parent’s info to optimize P-DAO but not sure how sibling info will help.

Regards,
Rahul

From: Roll [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: 25 July 2019 06:12
To: Routing Over Low power and Lossy networks <[email-masked]<mailto:[email-masked]>>
Subject: [Roll] Sibling information

Dear all

All the best

Pascal
_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll