Subject: [Roll] AODV-RPL should be Standard or Experimental?

From: Ines Robles <[email-masked]>
Date: Wed, 14 Aug 2019 20:19:15 +0300

Dear all,

We would like to know your opinion whether AODV-RPL should be Standard or
Experimental Track. Source Ticket:
https://trac.ietf.org/trac/roll/ticket/195

- Experimental draft description
https://tools.ietf.org/html/rfc2026#section-4.2.1, Standard Track
description https://tools.ietf.org/html/rfc2026#section-4.1

- The Experimental RFC 6997 describes an approach for Reactive Discovery of
P2P Routes. AODV-RPL specifies an approach for reactive P2P route discovery
mechanism for hop-by-hop  and source routing. Should these two drafts be
aligned as Experimental ones?

RFC 6997 was made experimental because its deployment future was uncertain.
The same may apply to AODV-RPL. When  there are sure commitments for
deployment of AODV-RPL, we should like to be informed.

Thank you very much in advance,

Ines and Peter.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 19 Aug 2019 09:48:33 +0000

Hello Ines:

Relaunching in this call since you did not get an answer.
For my part I’m not aware of any return from implementation and thus of commitments for deployment of AODV-RPL.
I’d like to hear something different from another party?

All the best,

Pascal

From: Roll <[email-masked]> On Behalf Of Ines Robles
Sent: mercredi 14 août 2019 19:19
To: roll <[email-masked]>
Subject: [Roll] AODV-RPL should be Standard or Experimental?

Dear all,

We would like to know your opinion whether AODV-RPL should be Standard or Experimental Track. Source Ticket: https://trac.ietf.org/trac/roll/ticket/195

- Experimental draft description https://tools.ietf.org/html/rfc2026#section-4.2.1, Standard Track description https://tools.ietf.org/html/rfc2026#section-4.1

- The Experimental RFC 6997 describes an approach for Reactive Discovery of P2P Routes. AODV-RPL specifies an approach for reactive P2P route discovery mechanism for hop-by-hop  and source routing. Should these two drafts be aligned as Experimental ones?

RFC 6997 was made experimental because its deployment future was uncertain. The same may apply to AODV-RPL. When  there are sure commitments for deployment of AODV-RPL, we should like to be informed.

Ines and Peter.