Subject: Re: [Roll] Eliding mechanism in 6550

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 1 Oct 2019 16:51:11 +0000

Typo by autocorrection: Before my phone knew better I meant  DIO... So:
I would not compress the identification of the message otherwise a DIO for another DODAG may be confused.
The DODAGID indicates which DODAG this DIO is about, it should not be elided...

Pascal

-----Original Message-----
From: Roll <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: dimanche 29 septembre 2019 20:47
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] Eliding mechanism in 6550

I would not compress the identification of the message otherwise a FIO for another DODAG me be confused ...

Regards,

Pascal

> Le 30 sept. 2019 à 00:31, Michael Richardson <[email-masked]> a écrit :
> 
> 
> Rahul Jadhav <[email-masked]> wrote:
>> During the interim Pascal/Michael suggested the use of counter to 
>> track the freshness of the Config Option. This could further extend 
>> to track MOPex and CAP options freshness.
> 
>> The suggestion was to use the reserved bits in the base DIO message for such a counter.
> 
> Yup.
> 
>> I was wondering if the DODAGID in the DIO could also be elided under 
>> the same guise? Basically the point is to elide all the "static"
>> information which rarely changes.
> 
>> Clearly this has issues in multi-DODAG networks but it is possible to 
>> handle such issues. Considering that this directly results in 16 
>> bytes savings per DIO multicast message, do you think it is worth the 
>> effort or if there are other issues?
> 
> My question is what are the sizes of the DIOs, and how close are we to 
> fragmentation already?
> 
> --
> Michael Richardson <[email-masked]>, Sandelman Software Works 
> -= IPv6 IoT consulting =-
> 
> 
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Rahul Jadhav <[email-masked]>
Date: Mon, 7 Oct 2019 06:19:22 +0000

Maybe DODAGID is not a good example but how about other static information such as Prefix Information Option carried in DIO. Can it be a candidate for eliding?
________________________________
From: Roll <[email-masked]> on behalf of Pascal Thubert (pthubert) <[email-masked]>
Sent: Tuesday, October 1, 2019 4:51 PM
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] Eliding mechanism in 6550

Pascal

-----Original Message-----
From: Roll <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: dimanche 29 septembre 2019 20:47
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] Eliding mechanism in 6550

Regards,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 7 Oct 2019 10:17:14 +0000

Yes it could certainly. We might also consider SCHC as an alternative to GHC for extremely constrained networks...

Regards,

Pascal

Le 7 oct. 2019 à 08:19, Rahul Jadhav <[email-masked]> a écrit :

Pascal

-----Original Message-----
From: Roll <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: dimanche 29 septembre 2019 20:47
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] Eliding mechanism in 6550

Regards,

Pascal