Subject: [rtcweb] FW: New Version Notification for draft-holmberg-mmusic-sdp-multiplex-negotiation-00.txt

From: Christer Holmberg <[email-masked]>
Date: Wed, 14 Sep 2011 12:47:25 +0200

Hi,

I've submitted a draft in MMUSIC, which defines a mechanism and grouping framework extension in order to negotiate multiplexing of media associated with multiple m= lines.

The main difference from Harald's previous proposal is that it defines the usage of the same port number value for multiple m= lines, and every m= line is used to describe media even in the case of multiplex.

Comments are welcome :)

Regards,

Christer

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: 14. syyskuuta 2011 13:32
> To: Christer Holmberg
> Cc: Christer Holmberg
> Subject: New Version Notification for 
> draft-holmberg-mmusic-sdp-multiplex-negotiation-00.txt
> 
> A new version of I-D, 
> draft-holmberg-mmusic-sdp-multiplex-negotiation-00.txt has 
> been successfully submitted by Christer Holmberg and posted 
> to the IETF repository.
> 
> Filename:	 draft-holmberg-mmusic-sdp-multiplex-negotiation
> Revision:	 00
> Title:		 Multiplexing Negotiation Using Session 
> Description Protocol (SDP) Port Numbers
> Creation date:	 2011-09-14
> WG ID:		 Individual Submission
> Number of pages: 9
> 
> Abstract:
>    This document defines how to use the Session Description Protocol
>    (SDP) in order to negotiate the usage of multiplexed media.
> 
>                                                               
>                     
> 
> 
> The IETF Secretariat
>

---

From: "Muthu Arul Mozhi Perumal (mperumal)" <[email-masked]>
Date: Fri, 16 Sep 2011 16:55:58 +0530

The approach looks good overall. A quick comment on section 5. SDP
Offer/Answer Procedures:

|When an SDP offerer wants to offer multiplexed media, it inserts the
|same port number value for each "m=" line that is part of the offered
|multiplex.  In addition, the SDP offerer inserts an SDP session-level
|"a=group" attribute, with a "MULTIPLEX" value, and assigns an SDP
|media-level "a=mid" attribute value for each "m=" line that is part
|of the offered multiplex.

Suggestion:

An entity generating an SDP offer or answer describing multiplexed 
media does the following:
1. Inserts the same port number for each "m=" line that is part of 
   the multiplex.
2. Uses the same connection data ("c=" line) values for each media 
   stream that is part of the multiplex.
3. Inserts the same RTCP port number in the "a=rtcp" attribute for
   each media stream that is part of the multiplex, when the RTCP 
   port is not the next higher (odd) port number following the RTP 
   port described in the "m=" line.
4. Inserts an "a=rtcp-mux" attribute for each media stream that is
   part of the multiplex, when RTCP is multiplexed with RTP on the 
   same port.
5. Inserts an SDP session-level "a=group" attribute, with a "MULTIPLEX" 
   value, and assigns an SDP media-level "a=mid" attribute value for 
   each "m=" line that is part of the multiplex.

Muthu

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On
Behalf Of Christer Holmberg
|Sent: Wednesday, September 14, 2011 4:17 PM
|To: [email-masked]
|Subject: [rtcweb] FW: New Version Notification for
draft-holmberg-mmusic-sdp-multiplex-negotiation-
|00.txt
|
|
|
|Hi,
|
|I've submitted a draft in MMUSIC, which defines a mechanism and
grouping framework extension in order
|to negotiate multiplexing of media associated with multiple m= lines.
|
|The main difference from Harald's previous proposal is that it defines
the usage of the same port
|number value for multiple m= lines, and every m= line is used to
describe media even in the case of
|multiplex.
|
|Comments are welcome :)
|
|Regards,
|
|Christer
|
|
|
|
|> -----Original Message-----
|> From: [email-masked] [mailto:[email-masked]]
|> Sent: 14. syyskuuta 2011 13:32
|> To: Christer Holmberg
|> Cc: Christer Holmberg
|> Subject: New Version Notification for
|> draft-holmberg-mmusic-sdp-multiplex-negotiation-00.txt
|>
|> A new version of I-D,
|> draft-holmberg-mmusic-sdp-multiplex-negotiation-00.txt has
|> been successfully submitted by Christer Holmberg and posted
|> to the IETF repository.
|>
|> Filename:	 draft-holmberg-mmusic-sdp-multiplex-negotiation
|> Revision:	 00
|> Title:		 Multiplexing Negotiation Using Session
|> Description Protocol (SDP) Port Numbers
|> Creation date:	 2011-09-14
|> WG ID:		 Individual Submission
|> Number of pages: 9
|>
|> Abstract:
|>    This document defines how to use the Session Description Protocol
|>    (SDP) in order to negotiate the usage of multiplexed media.
|>
|>
|>
|>
|>
|> The IETF Secretariat
|>
|_______________________________________________
|rtcweb mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 16 Sep 2011 13:35:34 +0200

Hi Muthu,

You suggestion looks good, and I'll implement it in the next version of the draft.

Thanks!

Regards,

Christer 

> From: Muthu Arul Mozhi Perumal (mperumal) [mailto:[email-masked]] 
> Sent: 16. syyskuuta 2011 14:26
> To: Christer Holmberg; [email-masked]; IETF - MMUSIC
> Subject: RE: [rtcweb] FW: New Version Notification for 
> The approach looks good overall. A quick comment on section 
> 5. SDP Offer/Answer Procedures:
> 
> |media-level "a=mid" attribute value for each "m=" line that 
> is part of 
> |the offered multiplex.
> 
> Suggestion:
> 
> An entity generating an SDP offer or answer describing 
> multiplexed media does the following:
> |> draft-holmberg-mmusic-sdp-multiplex-negotiation-00.txt has been 
> |> successfully submitted by Christer Holmberg and posted to the IETF 
> |> repository.
> |>

---

From: "Roni Even" <[email-masked]>
Date: Fri, 16 Sep 2011 15:53:15 +0300

Hi,
I think that you MUST have unique payload type numbers in all m-lines.
As for parameters I am not sure what will be the outcome of the bandwidth if
they appear in both m-lines. Or for encryption parameters if you offer
SAVP/SAVPF.

BTW: This solution is not limited to RTCWEB, at least it does not say it is.

Regards
Roni Even 

> From: [email-masked] [mailto:[email-masked]] On
> Sent: Friday, September 16, 2011 2:36 PM
> To: Muthu Arul Mozhi Perumal (mperumal); [email-masked]; IETF - MMUSIC
> Subject: Re: [MMUSIC] [rtcweb] FW: New Version Notification for draft-
> holmberg-mmusic-sdp-multiplex-negotiation-00.txt
> 
> 
> Hi Muthu,
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 16 Sep 2011 14:56:29 +0200

Hi, 

>As for parameters I am not sure what will be the outcome of 
>the bandwidth if they appear in both m-lines. Or for 
>encryption parameters if you offer SAVP/SAVPF.
> 

That is why I submitted it to MMUSIC :)

Regards,

Christer

> > You suggestion looks good, and I'll implement it in the 
> next version 
> > of the draft.
> > 
> > Thanks!
> > 
> > Regards,
> > 
> > Christer
> > 
> > 
> > > |When an SDP offerer wants to offer multiplexed media, it inserts 
> > > |the same port number value for each "m=" line that is part of
> > > the offered
> has been 
> > > |> successfully submitted by Christer Holmberg and posted to the 
> > > |> IETF repository.
> > > |>