Subject: [rtcweb] Symmetric RTP and uni-directional media streams

From: Christer Holmberg <[email-masked]>
Date: Thu, 1 Sep 2011 13:23:06 +0200

Hi,

There has been much talk about the usage of symmetric RTP. Also, draft-perkins-rtcweb-rtp-usage suggests that symmetric RTP is required.

However, the PeerConnection API currently only supports the establishment of uni-directional streams, so for a single two way communication one needs to create two separate uni-directional streams.

So, I assume that one requirement from RTCWEB to W3C will be to add support of the establishment of bi-directional streams to the PeerConnection API.

Regards,

Christer

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 01 Sep 2011 13:30:55 +0200

On 09/01/11 13:23, Christer Holmberg wrote:
> Hi,
> There has been much talk about the usage of symmetric RTP. Also, 
> draft-perkins-rtcweb-rtp-usage suggests that symmetric RTP is required.
> However, the PeerConnection API currently only supports the 
> establishment of uni-directional streams, so for a single two way 
> communication one needs to create two separate uni-directional streams.
> So, I assume that one requirement from RTCWEB to W3C will be to add 
> support of the establishment of bi-directional streams to the 
> PeerConnection API.
To be precise:

I think (and we're implementing) that between two PeerConnections, there 
will be a small number of *RTP sessions*  (ideally one). These will be 
bidirectional.

These will be used for transporting any number of *MediaStreams* (a 
WEBRTC API concept), each of which corresponds to a CNAME (RTP protocol 
concept). These are unidirectional.

So the right answer is "yes" and "no", as far as I can see.
> Regards,
> Christer
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 1 Sep 2011 07:35:30 -0700

I think Christer's question related to the following text from the W3C WEBRTC editor's draft (http://dev.w3.org/2011/webrtc/editor/webrtc.html) Section 4:

All streams represented by MediaStream objects must be
  marked as "sendonly" by the peer that initially adds the stream to
  the session. The PeerConnection API does not support
  bidirectional ("sendrecv") audio or video media streams. [SDPOFFERANSWER]

Date: Thu, 1 Sep 2011 13:30:55 +0200
From: [email-masked]
To: [email-masked]
CC: [email-masked]
Subject: Re: [rtcweb] Symmetric RTP and uni-directional media streams

    

      

         
        Hi,
         
        There has been
            much talk about the usage of symmetric RTP. Also,
            draft-perkins-rtcweb-rtp-usage suggests that symmetric RTP
            is required.
         
        However, the
            PeerConnection API currently only supports the establishment
            of uni-directional streams, so for a single two way
            communication one needs to create two separate
            uni-directional streams.
         
        So, I assume
            that one requirement from RTCWEB to W3C will be to add
            support of the establishment of bi-directional streams to
            the PeerConnection API.
      
    To be precise:

    I think (and we're implementing) that between two PeerConnections,
    there will be a small number of *RTP sessions*  (ideally one). These
    will be bidirectional.

    These will be used for transporting any number of *MediaStreams* (a
    WEBRTC API concept), each of which corresponds to a CNAME (RTP
    protocol concept). These are unidirectional.

         
        Regards,
         
        Christer

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 01 Sep 2011 17:51:31 +0200

On 09/01/11 16:35, Bernard Aboba wrote:
> I think Christer's question related to the following text from the W3C 
> WEBRTC editor's draft 
> (http://dev.w3.org/2011/webrtc/editor/webrtc.html) Section 4:
>
> All streams represented by |MediaStream 
> <http://dev.w3.org/2011/webrtc/editor/webrtc.html#mediastream>| 
> objects must be marked as "sendonly" by the peer that initially adds 
> the stream to the session. The |PeerConnection 
> <http://dev.w3.org/2011/webrtc/editor/webrtc.html#peerconnection>| API 
> does not support bidirectional ("sendrecv") audio or video media 
> streams. [SDPOFFERANSWER] 
> <http://dev.w3.org/2011/webrtc/editor/webrtc.html#refsSDPOFFERANSWER>
Yes, as Christer knows, I think that's a broken design, have argued 
against it, and we're not implementing to it.
It's a bit strange of me of all people to flash the interoperability 
card, but this is not interoperable with other RTP usages either.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 1 Sep 2011 18:12:02 +0200

Hi,

I can't of course speak on behalf of others, but at least in IETF I assume one reason why people haven't said anything is simply because they haven't read the API :)

Regards,

Christer

________________________________
From: Harald Alvestrand [mailto:[email-masked]]
Sent: 1. syyskuuta 2011 18:52
To: Bernard Aboba
Cc: Christer Holmberg; [email-masked]
Subject: Re: [rtcweb] Symmetric RTP and uni-directional media streams

All streams represented by MediaStream<http://dev.w3.org/2011/webrtc/editor/webrtc.html#mediastream> objects must be marked as "sendonly" by the peer that initially adds the stream to the session. The PeerConnection<http://dev.w3.org/2011/webrtc/editor/webrtc.html#peerconnection> API does not support bidirectional ("sendrecv") audio or video media streams. [SDPOFFERANSWER]<http://dev.w3.org/2011/webrtc/editor/webrtc.html#refsSDPOFFERANSWER>
Yes, as Christer knows, I think that's a broken design, have argued against it, and we're not implementing to it.
It's a bit strange of me of all people to flash the interoperability card, but this is not interoperable with other RTP usages either.