Subject: [rtcweb] DRAFT Agenda for RTCWEB

From: Ted Hardie <[email-masked]>
Date: Wed, 27 Feb 2013 09:49:42 -0800

The agenda below has been uploaded as an initial, draft agenda for the
group.  Comments on the timing and balance are encouraged.

thanks,

Ted Hardie

RTCWEB Draft Agenda
March 12, 2013 9:00 to 11:30

Administrivia (5 min)

AD Message (5 min)

Data Channel
 - draft-jesup-rtcweb-data-protocol (20 min)
 - draft-thomson-rtcweb-data (15 min)
 - draft-marcon-rtcweb-data-channel-management (15 min)
 - Discussion (30 min)
 - Consensus call(s) (5 min)

WGLC Issue resolution (30 min)
- draft-ietf-rtcweb-security
- draft-ietf-rtcweb-security-arch
- draft-ietf-rtcweb-overview
- draft-ietf-rtcweb-use-cases-and-requirements

RTCP-XR (15 min )
- draft-ietf-rtcweb-rtp-usage-06

FEC in RTCWEB  (Call for interest)
- draft-mandyam-rtcweb-fecframe-00 (5 min)

Mobile issues for RTCWEB (Call for review)
- http://tools.ietf.org/html/draft-reddy-rtcweb-mobile-00 (5 min)

March 14, 2013 9:00 to 11:30

JSEP
- draft-rtcweb-jsep (40 min)
- Discussion (30 min)
- Consensus call(s) (5)

Video Codec                       10:15 to 11:30
1. draft-alvestrand-rtcweb-vp8-01 (15 mins)
2. draft-burman-rtcweb-h264-proposal-01+draft-dbenham-webrtcvideomti-01+draft-marjou-rtcweb-video-codec-00
(25 mins)
      Discussion (30 minutes)
      Call the question (5 minutes)

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 27 Feb 2013 20:29:49 +0000

Hi,

Does the Data Channel part (or some other part) of the agenda include making a decision on whether it shall be possible to bundle the Data Channel with the RTP media?

Or, do we already have consensus that it shall be possible?

Just to clarify, because I think it is important input for the MMUSIC discussions on the actual mechanism.

Regards,

Christer

________________________________________
From: [email-masked] [[email-masked]] on behalf of Ted Hardie [[email-masked]]
Sent: Wednesday, 27 February 2013 7:49 PM
To: [email-masked]
Cc: Richard Barnes; [email-masked]
Subject: [rtcweb] DRAFT Agenda for RTCWEB

thanks,

Ted Hardie

RTCWEB Draft Agenda

Administrivia (5 min)

AD Message (5 min)

Data Channel

RTCP-XR (15 min )

JSEP

Video Codec                       10:15 to 11:30
1. draft-alvestrand-rtcweb-vp8-01 (15 mins)
2. draft-burman-rtcweb-h264-proposal-01+draft-dbenham-webrtcvideomti-01+draft-marjou-rtcweb-video-codec-00
(25 mins)
      Discussion (30 minutes)
      Call the question (5 minutes)
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Ejzak, Richard P (Richard)" <[email-masked]>
Date: Thu, 28 Feb 2013 23:10:07 +0000

Since multiplexing of the data channel with RTP media has been shown as a desirable feature of BUNDLE (and most of its variants), I would suggest that this be treated as a significant advantage for BUNDLE (and similarly capable variants) over any proposal without it.  Cullen's "Plan A" is preferred over Plan B precisely because it has an incremental muxing advantage.

BR, Richard

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Christer Holmberg
> Sent: Wednesday, February 27, 2013 2:30 PM
> To: Ted Hardie; [email-masked]
> Subject: Re: [rtcweb] DRAFT Agenda for RTCWEB
> 
> 
> Hi,
> 
> Does the Data Channel part (or some other part) of the agenda include
> making a decision on whether it shall be possible to bundle the Data
> Channel with the RTP media?
> 
> 1. draft-alvestrand-rtcweb-vp8-01 (15 mins) 2. draft-burman-rtcweb-
> h264-proposal-01+draft-dbenham-webrtcvideomti-01+draft-marjou-rtcweb-
> video-codec-00
> (25 mins)
>       Discussion (30 minutes)

---

From: Justin Uberti <[email-masked]>
Date: Thu, 28 Feb 2013 23:30:15 -0800

BUNDLE and data muxing works for both "Plan A" and "Plan B".

Recall that "Plan B" is muxing multiple media sources of the same type over
a single m= line, and BUNDLE then provides muxing of the audio, video, and
data m= lines.

On Thu, Feb 28, 2013 at 3:10 PM, Ejzak, Richard P (Richard) <
[email-masked]> wrote:

> Since multiplexing of the data channel with RTP media has been shown as a
> desirable feature of BUNDLE (and most of its variants), I would suggest
> that this be treated as a significant advantage for BUNDLE (and similarly
> capable variants) over any proposal without it.  Cullen's "Plan A" is
> preferred over Plan B precisely because it has an incremental muxing
> advantage.
>
> BR, Richard
>