Subject: [rtcweb] BUNDLE: RTP only?

From: Christer Holmberg <[email-masked]>
Date: Wed, 13 Feb 2013 19:48:23 +0000

(Sorry for sending this to both RTCWEB and MMUSIC, but it is related to both the need of RTCWEB, and the solution produced by MMUSIC)

Hi,

At the interim, during my BUNDLE presentation, I indicated that we need to make a decision whether the solution (whatever it will be...) shall support bundling of non-RTP media. Not saying it can't be changed, but as currently documented all alternatives only support bundling of RTP media.

There might have been some comments from the mic, but as far as I know there was no decision (if there was, please point me to it).

So, my question is: do we keep the scope to RTP media?

Regards,

Christer

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 13 Feb 2013 20:37:42 +0000

I think EKR expressed that he felt it was important for data channel to be included in the multiplexing. 

On Feb 13, 2013, at 12:48 PM, Christer Holmberg <[email-masked]> wrote:

> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Randell Jesup <[email-masked]>
Date: Wed, 13 Feb 2013 15:42:31 -0500

> I think EKR expressed that he felt it was important for data channel to be included in the multiplexing.

And I agree(d), strongly.  We want 1 port to minimize NAT issues and 
startup times.

-- 
Randell Jesup
[email-masked]

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 13 Feb 2013 13:48:30 -0800

I would phrase this somewhat less strongly: less ports is better than more
ports,
so all things being equal, a multiplexing mechanism that keeps you down to
one port is better than not. That said, if we decide that plan A is dead and
we are going to plan B, I can live with having data on a separate port.

-Ekr

On Wed, Feb 13, 2013 at 12:42 PM, Randell Jesup <[email-masked]>wrote:

>> At the interim, during my BUNDLE presentation, I indicated that we need
>> to make a decision whether the solution (whatever it will be...) shall
>> support bundling of non-RTP media. Not saying it can't be changed, but as
>> currently documented all alternatives only support bundling of RTP media.
>>
>> There might have been some comments from the mic, but as far as I know
>> there was no decision (if there was, please point me to it).
>>
> ______________________________**_________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/rtcweb<https://www.ietf.org/mailman/listinfo/rtcweb>
>

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 13 Feb 2013 14:24:00 -0800

A question: 

Since we have a clear way of de-multiplexing RTP and DTLS, is it necessary to entangle that (solved) problem with the A/V mux issue? I realize that SDP has the tendency to "deeply intermingle" just about everything, but at the RTP/DTLS level, we're in much better shape.

Bernard "Do we need to boil the entire ocean, or just a lake or two?" Aboba

On Feb 13, 2013, at 13:49, "Eric Rescorla" <[email-masked]> wrote:

> I would phrase this somewhat less strongly: less ports is better than more ports,
> On Wed, Feb 13, 2013 at 12:42 PM, Randell Jesup <[email-masked]> wrote:
>> And I agree(d), strongly.  We want 1 port to minimize NAT issues and startup times.
>> 
>> 
>>> 
>> https://www.ietf.org/mailman/listinfo/rtcweb
> 
> https://www.ietf.org/mailman/listinfo/rtcweb
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb