Subject: [rtcweb] Video Codec MTI & User Experience == 1

From: Suhas Nandakumar <[email-masked]>
Date: Thu, 14 Mar 2013 10:59:00 -0700

I feel a good user experience is as important as MTI being successfully
negotiated. Users will turn off their video and de-escalate to audio only
interaction if they look terribly bad in any kind of use-cases dealt within
RTCWeb.

We should be avoiding this at any cause since it defeats the purpose of
RTCWeb to enable rich interactions via audio, video.

This is my personal opinion.

Thanks
./Suhas
 [ one of the end-users]

---

From: Hadriel Kaplan <[email-masked]>
Date: Thu, 14 Mar 2013 19:23:33 +0000

On Mar 14, 2013, at 1:59 PM, Suhas Nandakumar <[email-masked]> wrote:

>  I feel a good user experience is as important as MTI being successfully negotiated. Users will turn off their video and de-escalate to audio only interaction if they look terribly bad in any kind of use-cases dealt within RTCWeb. 

Yes, but that's the point - a *user* can choose to do it.  And a user can choose to instead live with whatever crappy video they can get.  The great thing is it would be the user's choice.  But if we don't pick at least one MTI, no matter how good or bad it is, then the user won't have that choice... because there will be no video if the two ends don't happen to implement the same one.

And I'm not saying that with respect to either VP8 or H.264 - as far as I can tell neither of them can be an MTI codec right now, since we've been told each group of vendors can't live with the other's codec.

> We should be avoiding this at any cause since it defeats the purpose of RTCWeb to enable rich interactions via audio, video.

Define "rich interactions".  Obviously choosing an MTI codec that provides 4-pixel video would be a waste of our time.  But is H.261 sufficient to 'richly' communicate?  If I communicate with my wife/kids/siblings while I'm traveling, of course I'd prefer it be great quality video, but I can live with H.261.  What I won't put up with is having my browser decide the video's "not good enough for me", or having to make us all use the same browser vendor. (we don't)

Just my 2 cents.

-hadriel