Subject: [rtcweb] some thoguhts on draft draft-hutton-rtcweb-nat-firewall-considerations-00

From: "Chenxin (Xin)" <[email-masked]>
Date: Tue, 19 Mar 2013 07:36:17 +0000

Hi Andrew,

   I have read the draft-hutton-rtcweb-nat-firewall-considerations-00, and have some more considerations about nat-fw-traversal: Is it possible to consider to allow the webrtc client connect to the turn server using websocket connection. The websocket is upgraded from http and supports subprotocol field and multiplexing extension, which will be convenient to deal with the multiplexing usecase.

2.3 Firewall open only for TCP-based HTTP(s) traffic

   If upgrade the http to websocket and send the Turn data directly on the websocket connection, it works too.
   The Turn server should be configured to accept the websocket connection and listen to the HTTP(S) ports as well.
   The webrtc client need to be configured to contact the TURN server over the HTTP(s) ports.

3.3.1 TURN server connection via TCP
   Websocket works fine in the scenario of explicit proxy traversal using Http Connect method. If there are intermediate transparent proxy server, ecncrypted websocket connection will be successful.

  In this scenario, The Turn server should be configured to accept the websocket connection and listen to the HTTP(S) ports as well.
  In addition, the proxy server may need to be upgraded to support Websocket if the uncrypted websocket need be supported.

Best Regards,
     Xin

---

From: "Stach, Thomas" <[email-masked]>
Date: Tue, 19 Mar 2013 16:24:03 +0000

Hi Xin,

with the HTTP Connect we already have a TCP connection to the TURN server and could a TURN channel for media transport.
With your proposal the TURN server would have to additional protocols.
What would be the benefit of using websockets to transport media?
I rather prefer to have less options than more.

Regards
Thomas

________________________________
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Chenxin (Xin)
Gesendet: Dienstag, 19. März 2013 08:36
An: [email-masked]; Hutton, Andrew
Betreff: [rtcweb] some thoguhts on draft draft-hutton-rtcweb-nat-firewall-considerations-00

Hi Andrew,

Best Regards,
     Xin