Subject: [rtcweb] VP8 IPR agreement announced.

From: Serge Lachapelle <[email-masked]>
Date: Thu, 7 Mar 2013 20:18:45 +0100

Hello,

Today, Google Inc. and MPEG LA, LLC have announced that they have entered
into an agreement granting Google a license to techniques, if any, that may
be essential to VP8. Furthermore, MPEG LA has agreed to discontinue efforts
to form a patent pool around VP8.

The official press release can be found here: http://goo.gl/F7xUu

The licensors are part of the group that responded to MPEG LA’s call for
patents. They are a group of well-known video IP holders and participants
in standards-based video patent pools.

This agreement allows for Google to sublicense the techniques to any user
of VP8, whether the VP8 implementation is by Google or another entity; this
means that users can develop independent implementations of VP8 and still
enjoy coverage under the sublicenses.

Google intends to license the techniques under terms that are in line with
the W3C’s definition of a Royalty Free License. This definition can be
found here: http://www.w3.org/2001/07/SVG10-IPR-statements  We anticipate
having the sublicense ready in the next few weeks. The terms will appear on
the WebM Project website at http://webmproject.org

This agreement is not an acknowledgment that the licensed techniques read
on VP8. The purpose of this agreement is meant to provide further and
stronger reassurance to implementors of VP8.

On a personal note, I think you will all agree that the RTCWeb MTI video
codec discussion included many whispered doubts but little evidence. In
contrast, we have taken clear steps to demonstrate the viability of VP8:

1. Made VP8 available with a strong, simple software license and patent
grant.
2. Continued to innovate and improve VP8 in the open.
3. Licensed a royalty free VP8 enabled RTL (aka hardware source code) to
more than 50 SOCs.
4. Built, iterated and launched VP8 powered WebRTC in the Chrome browser to
hundreds of millions of users.
5. Worked to ensure WebRTC interop using the VP8 and Opus formats by
working closely with Firefox.
6. Introduced a preview of VP8 and Opus based WebRTC in Chrome for Android
beta.

And now, we have taken taken two significant steps that we hope will make
the situation clear to all:

7. Submitted VP8 to ISO SC29/WG11 (MPEG) in January of this year for
standardization.
8. Invested a significant amount of time and resources into reaching an
agreement with the MPEG LA, to provide further reassurances.

VP8 is a royalty free, open sourced codec that offers several advantages
and innovations for real time and other uses.  It has a publicly-available
specification that is getting broadly adopted in hardware; it has been
submitted for standardization to a leading standards body, and is the
subject of a royalty-free RAND license which will now include a license
covering any essential VP8 techniques that may be relevant to major IP
holders who responded to the MPEG LA's call for VP8 patents.

It is the most suitable codec for MTI.

I understand the timing is very close to the Orlando IETF meeting.  While
we tried to do this as quickly as possible, I am sure you will appreciate
the sensitivities and enormous effort involved in reaching such an
agreement.

I will be in Orlando, arriving monday evening and will be available to
answer questions.

/Serge

---

From: Matthew Kaufman <[email-masked]>
Date: Thu, 07 Mar 2013 11:32:50 -0800

The below announcement, while an interesting development, comes weeks 
after the traditional deadlines for providing new information to the 
working group prior to an upcoming meeting and certainly does not give 
me enough time to adequately review the development. In fact, the 
sublicense terms referenced below will not be available to review until 
*after* the upcoming meeting and might very well contain language that 
is incompatible with my requirements or those of other implementers of 
RTCWEB specifications.

Therefore I believe the most sensible action is to once again delay the 
MTI video codec discussion, remove it from the agenda from the upcoming 
meeting, and have the call for an MTI codec at a later time... no sooner 
than several weeks after the relevant license terms are even available 
to review. I hope the chairs concur.

Alternatively, we can have the discussion at the upcoming meeting, but 
it will not be able to incorporate this development at all, and without 
any change in the IPR situation it was clear that H.264 was the only 
suitable alternative (and may still be the best choice, given the strong 
arguments for the technical merits and implementation advantages of 
H.264, irrespective of the IPR issues).

Matthew Kaufman

On 3/7/2013 11:18 AM, Serge Lachapelle wrote:
> Hello,
>
> Today, Google Inc. and MPEG LA, LLC have announced that they have 
> entered into an agreement granting Google a license to techniques, if 
> any, that may be essential to VP8. Furthermore, MPEG LA has agreed to 
> discontinue efforts to form a patent pool around VP8.
>
> The licensors are part of the group that responded to MPEG LA's call 
> for patents. They are a group of well-known video IP holders and 
> participants in standards-based video patent pools.
>
> This agreement allows for Google to sublicense the techniques to any 
> user of VP8, whether the VP8 implementation is by Google or another 
> entity; this means that users can develop independent implementations 
> of VP8 and still enjoy coverage under the sublicenses.
>
> Google intends to license the techniques under terms that are in line 
> with the W3C's definition of a Royalty Free License. This definition 
> can be found here: http://www.w3.org/2001/07/SVG10-IPR-statements We 
> anticipate having the sublicense ready in the next few weeks. The 
> terms will appear on the WebM Project website at http://webmproject.org
>
> This agreement is not an acknowledgment that the licensed techniques 
> read on VP8. The purpose of this agreement is meant to provide further 
> and stronger reassurance to implementors of VP8.
>
> On a personal note, I think you will all agree that the RTCWeb MTI 
> video codec discussion included many whispered doubts but little 
> evidence. In contrast, we have taken clear steps to demonstrate the 
> viability of VP8:
>
> 1. Made VP8 available with a strong, simple software license and 
> patent grant.
> 3. Licensed a royalty free VP8 enabled RTL (aka hardware source code) 
> to more than 50 SOCs.
> 4. Built, iterated and launched VP8 powered WebRTC in the Chrome 
> browser to hundreds of millions of users.
> 6. Introduced a preview of VP8 and Opus based WebRTC in Chrome for 
> Android beta.
>
> And now, we have taken taken two significant steps that we hope will 
> make the situation clear to all:
>
> 8. Invested a significant amount of time and resources into reaching 
> an agreement with the MPEG LA, to provide further reassurances.
>
> VP8 is a royalty free, open sourced codec that offers several 
> advantages and innovations for real time and other uses.  It has a 
> publicly-available specification that is getting broadly adopted in 
> hardware; it has been submitted for standardization to a leading 
> standards body, and is the subject of a royalty-free RAND license 
> which will now include a license covering any essential VP8 techniques 
> that may be relevant to major IP holders who responded to the MPEG 
> LA's call for VP8 patents.
>
> I understand the timing is very close to the Orlando IETF meeting. 
>  While we tried to do this as quickly as possible, I am sure you will 
> appreciate the sensitivities and enormous effort involved in reaching 
> such an agreement.
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Jean-Marc Valin <[email-masked]>
Date: Thu, 07 Mar 2013 15:55:19 -0500

I would propose that we actually have the discussion in Orlando, while
assuming that the Google license will make it possible for everyone to
implement VP8 with no additional restriction (and in compliance with
the W3C's licensing policies). If it turns out that the license has
unacceptable terms (with Google not willing to fix the issue), then we
can always revisit any decision. Sounds reasonable?

	Jean-Marc

On 03/07/2013 02:32 PM, Matthew Kaufman wrote:
> The below announcement, while an interesting development, comes
> weeks after the traditional deadlines for providing new information
> to the working group prior to an upcoming meeting and certainly
> does not give me enough time to adequately review the development.
> In fact, the sublicense terms referenced below will not be
> available to review until *after* the upcoming meeting and might
> very well contain language that is incompatible with my
> requirements or those of other implementers of RTCWEB
> specifications.
> 
> Therefore I believe the most sensible action is to once again delay
> the MTI video codec discussion, remove it from the agenda from the
> upcoming meeting, and have the call for an MTI codec at a later
> time? no sooner than several weeks after the relevant license terms
> are even available to review. I hope the chairs concur.
> 
> Alternatively, we can have the discussion at the upcoming meeting,
> but it will not be able to incorporate this development at all, and
> without any change in the IPR situation it was clear that H.264 was
> the only suitable alternative (and may still be the best choice,
> given the strong arguments for the technical merits and
> implementation advantages of H.264, irrespective of the IPR
> issues).
> 
> Matthew Kaufman
> 
>> Today, Google Inc. and MPEG LA, LLC have announced that they
>> have entered into an agreement granting Google a license to
>> techniques, if any, that may be essential to VP8. Furthermore,
>> MPEG LA has agreed to discontinue efforts to form a patent pool
>> around VP8.
>> 
>> The licensors are part of the group that responded to MPEG LA?s
>> call for patents. They are a group of well-known video IP holders
>> and participants in standards-based video patent pools.
>> 
>> This agreement allows for Google to sublicense the techniques to
>> any user of VP8, whether the VP8 implementation is by Google or
>> another entity; this means that users can develop independent
>> implementations of VP8 and still enjoy coverage under the
>> sublicenses.
>> 
>> Google intends to license the techniques under terms that are in
>> line with the W3C?s definition of a Royalty Free License. This
>> definition can be found here:
>> http://www.w3.org/2001/07/SVG10-IPR-statements  We anticipate
>> having the sublicense ready in the next few weeks. The terms will
>> appear on the WebM Project website at http://webmproject.org
>> 
>> This agreement is not an acknowledgment that the licensed
>> techniques read on VP8. The purpose of this agreement is meant to
>> provide further and stronger reassurance to implementors of VP8.
>> 
>> 
>> On a personal note, I think you will all agree that the RTCWeb
>> MTI video codec discussion included many whispered doubts but
>> little evidence. In contrast, we have taken clear steps to
>> demonstrate the viability of VP8:
>> 
>> patent grant. 2. Continued to innovate and improve VP8 in the
>> open. 3. Licensed a royalty free VP8 enabled RTL (aka hardware
>> source code) to more than 50 SOCs. 4. Built, iterated and
>> launched VP8 powered WebRTC in the Chrome browser to hundreds of
>> millions of users. 5. Worked to ensure WebRTC interop using the
>> VP8 and Opus formats by working closely with Firefox. 6.
>> Introduced a preview of VP8 and Opus based WebRTC in Chrome for 
>> Android beta.
>> 
>> And now, we have taken taken two significant steps that we hope
>> will make the situation clear to all:
>> 
>> 7. Submitted VP8 to ISO SC29/WG11 (MPEG) in January of this year
>> for standardization. 8. Invested a significant amount of time and
>> resources into reaching an agreement with the MPEG LA, to provide
>> further reassurances.
>> 
>> advantages and innovations for real time and other uses.  It has
>> a publicly-available specification that is getting broadly
>> adopted in hardware; it has been submitted for standardization to
>> a leading standards body, and is the subject of a royalty-free
>> RAND license which will now include a license covering any
>> essential VP8 techniques that may be relevant to major IP holders
>> who responded to the MPEG LA's call for VP8 patents.
>> 
>> I understand the timing is very close to the Orlando IETF
>> meeting. While we tried to do this as quickly as possible, I am
>> sure you will appreciate the sensitivities and enormous effort
>> involved in reaching such an agreement.
>> 
>> I will be in Orlando, arriving monday evening and will be
>> available to answer questions.
>> 
>> /Serge
>> 
>> 
>> _______________________________________________ rtcweb mailing
>> list [email-masked] 
> _______________________________________________ rtcweb mailing
> list [email-masked] https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Silvia Pfeiffer <[email-masked]>
Date: Fri, 8 Mar 2013 08:56:55 +1100

Seriously? Google and MPEG just announced that VP8 is essentially the first
widely agreed non-patent-encumbered codec and your reaction is "an
interesting development" and "process disallows discussion"? It's almost a
week until the meeting, just start preparing for it now.

For everyone else: it is a day of great joy and overwhelming relief that
MPEG and Google have found an arrangement to allow the world to publish and
share video without risk of getting sued over codec patents. I say: rejoice!

Silvia.
(speaking for myself and dare I say: most of humanity who doesn't even
realize what just happened ;-)

On Fri, Mar 8, 2013 at 6:32 AM, Matthew Kaufman <[email-masked]> wrote:

> working group prior to an upcoming meeting and certainly does not give me
> enough time to adequately review the development. In fact, the sublicense
> terms referenced below will not be available to review until *after* the
> upcoming meeting and might very well contain language that is incompatible
> with my requirements or those of other implementers of RTCWEB
> specifications.
>
> meeting, and have the call for an MTI codec at a later time… no sooner than
> several weeks after the relevant license terms are even available to
> review. I hope the chairs concur.
>
> Alternatively, we can have the discussion at the upcoming meeting, but it
> will not be able to incorporate this development at all, and without any
> change in the IPR situation it was clear that H.264 was the only suitable
> alternative (and may still be the best choice, given the strong arguments
> for the technical merits and implementation advantages of H.264,
> irrespective of the IPR issues).
>
> Matthew Kaufman
>
>
> entered into an agreement granting Google a license to techniques, if any,
> that may be essential to VP8. Furthermore, MPEG LA has agreed to
> user of VP8, whether the VP8 implementation is by Google or another entity;
> this means that users can develop independent implementations of VP8 and
> still enjoy coverage under the sublicenses.
>
> with the W3C’s definition of a Royalty Free License. This definition can be
> read on VP8. The purpose of this agreement is meant to provide further and
> 4. Built, iterated and launched VP8 powered WebRTC in the Chrome browser
> to hundreds of millions of users.
> appreciate the sensitivities and enormous effort involved in reaching such
> an agreement.
>
> rtcweb mailing [email-masked]://www.ietf.org/mailman/listinfo/rtcweb
>
>
>

---

From: Ted Hardie <[email-masked]>
Date: Thu, 7 Mar 2013 15:03:46 -0800

On Thu, Mar 7, 2013 at 1:56 PM, Silvia Pfeiffer
<[email-masked]> wrote:
> Seriously? Google and MPEG

Just as a point of clarification, the announcement was made by
MPEG-LA, which is distinct from MPEG.

regards,

Ted Hardie

---

From: Silvia Pfeiffer <[email-masked]>
Date: Fri, 8 Mar 2013 10:04:41 +1100

Oops! Point taken. Thanks for noticing - it's what I meant to say.
Silvia.

---

From: Ross Finlayson <[email-masked]>
Date: Fri, 8 Mar 2013 12:25:22 +1300

This is indeed excellent news (though one has to wonder: What did "MPEG LA" get out of the deal?)

Ross Finlayson
Live Networks, Inc.
http://www.live555.com/

---

From: Stephan Wenger <[email-masked]>
Date: Fri, 8 Mar 2013 20:14:08 +0000

Hi Serge,

This is a great development for VP8.  Congratulations.  I'm sure it took a few cycles and dollars to get something like this arranged.  I wish your PR would have come out a bit earlier, but licensing discussions do take time…  So better now than never.

I want to ask two more pieces of information that would allow me to put this announcement into context.

First, who are those 11 rightholders?  I'm sure you agree that, in order to make a meaningful risk assessment, that information is needed.

Second, the link provided to "preview" the possible sublicensing terms (http://www.w3.org/2001/07/SVG10-IPR-statements) lists a bunch of company statements that vary widely among the rightholders listed there, which do not include google.  It would be great if you could provide more specific information as early as possible, especially with respect to the essential claims definition and the reciprocity conditions.  That does not have to be final legal text, but should be a clear indication of your business intentions.  To me, term-sheet level is OK.

Please understand that without that information (especially the first item—on the second I at least would be willing to trust your good intentions in combination with written statements already one file), it will be very hard to take a position based on an informed position.

Thanks,
Stephan

From: Serge Lachapelle <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 7 March, 2013 11:18
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [rtcweb] VP8 IPR agreement announced.

Hello,

Today, Google Inc. and MPEG LA, LLC have announced that they have entered into an agreement granting Google a license to techniques, if any, that may be essential to VP8. Furthermore, MPEG LA has agreed to discontinue efforts to form a patent pool around VP8.

The licensors are part of the group that responded to MPEG LA’s call for patents. They are a group of well-known video IP holders and participants in standards-based video patent pools.

This agreement allows for Google to sublicense the techniques to any user of VP8, whether the VP8 implementation is by Google or another entity; this means that users can develop independent implementations of VP8 and still enjoy coverage under the sublicenses.

Google intends to license the techniques under terms that are in line with the W3C’s definition of a Royalty Free License. This definition can be found here: http://www.w3.org/2001/07/SVG10-IPR-statements  We anticipate having the sublicense ready in the next few weeks. The terms will appear on the WebM Project website at http://webmproject.org

This agreement is not an acknowledgment that the licensed techniques read on VP8. The purpose of this agreement is meant to provide further and stronger reassurance to implementors of VP8.

On a personal note, I think you will all agree that the RTCWeb MTI video codec discussion included many whispered doubts but little evidence. In contrast, we have taken clear steps to demonstrate the viability of VP8:

1. Made VP8 available with a strong, simple software license and patent grant.
2. Continued to innovate and improve VP8 in the open.
3. Licensed a royalty free VP8 enabled RTL (aka hardware source code) to more than 50 SOCs.
4. Built, iterated and launched VP8 powered WebRTC in the Chrome browser to hundreds of millions of users.
5. Worked to ensure WebRTC interop using the VP8 and Opus formats by working closely with Firefox.
6. Introduced a preview of VP8 and Opus based WebRTC in Chrome for Android beta.

And now, we have taken taken two significant steps that we hope will make the situation clear to all:

7. Submitted VP8 to ISO SC29/WG11 (MPEG) in January of this year for standardization.
8. Invested a significant amount of time and resources into reaching an agreement with the MPEG LA, to provide further reassurances.

VP8 is a royalty free, open sourced codec that offers several advantages and innovations for real time and other uses.  It has a publicly-available specification that is getting broadly adopted in hardware; it has been submitted for standardization to a leading standards body, and is the subject of a royalty-free RAND license which will now include a license covering any essential VP8 techniques that may be relevant to major IP holders who responded to the MPEG LA's call for VP8 patents.

I understand the timing is very close to the Orlando IETF meeting.  While we tried to do this as quickly as possible, I am sure you will appreciate the sensitivities and enormous effort involved in reaching such an agreement.

I will be in Orlando, arriving monday evening and will be available to answer questions.

/Serge

---

From: Bo Burman <[email-masked]>
Date: Fri, 8 Mar 2013 23:03:26 +0000

Hi Serge,

This is indeed interesting, but I anyway have a couple of follow up questions, in addition to the ones listed by Stephan below:

  *   Who among the ones in the group that responded to the MPEG-LA call are not part of the deal? Why? What will the implications be for implementing or shipping?
  *   How will Google act if (when) other IPR holders approach people implementing/shipping VP8 devices, or approaches MPEG-LA? Will Google extend the deal to cover these IPRs as well, and sub-license on the same terms as outlined below?

/Bo

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephan Wenger
Sent: Friday, March 08, 2013 9:14 PM
To: Serge Lachapelle; [email-masked]
Subject: Re: [rtcweb] VP8 IPR agreement announced.

Hi Serge,

This is a great development for VP8.  Congratulations.  I'm sure it took a few cycles and dollars to get something like this arranged.  I wish your PR would have come out a bit earlier, but licensing discussions do take time...  So better now than never.

Please understand that without that information (especially the first item-on the second I at least would be willing to trust your good intentions in combination with written statements already one file), it will be very hard to take a position based on an informed position.

Thanks,
Stephan

Hello,

The licensors are part of the group that responded to MPEG LA's call for patents. They are a group of well-known video IP holders and participants in standards-based video patent pools.

Google intends to license the techniques under terms that are in line with the W3C's definition of a Royalty Free License. This definition can be found here: http://www.w3.org/2001/07/SVG10-IPR-statements  We anticipate having the sublicense ready in the next few weeks. The terms will appear on the WebM Project website at http://webmproject.org

/Serge

---

From: Harald Alvestrand <[email-masked]>
Date: Sat, 09 Mar 2013 11:08:29 +0100

On 03/08/2013 09:14 PM, Stephan Wenger wrote:
> Hi Serge,
>
> This is a great development for VP8.  Congratulations.  I'm sure it 
> took a few cycles and dollars to get something like this arranged.  I 
> wish your PR would have come out a bit earlier, but licensing 
> discussions do take time...  So better now than never.
>
> First, who are those 11 rightholders?  I'm sure you agree that, in 
> order to make a meaningful risk assessment, that information is needed.

Stephan, at the moment, we have no agreement with the rightsholders that 
permits us to disclose their names. We're discussing that topic with 
them, but we will not name them without an agreement to do so.

Of course, the rightsholders are free to disclose themselves.
>
> Second, the link provided to "preview" the possible sublicensing terms 
> (http://www.w3.org/2001/07/SVG10-IPR-statements) lists a bunch of 
> company statements that vary widely among the rightholders listed 
> there, which do not include google.  It would be great if you could 
> provide more specific information as early as possible, especially 
> with respect to the essential claims definition and the reciprocity 
> conditions.  That does not have to be final legal text, but should be 
> a clear indication of your business intentions.  To me, term-sheet 
> level is OK.

That link was a bit weird - the real W3C definition of "royalty-free" is 
http://www.w3.org/Consortium/Patent-Policy-20040205/#sec-Requirements - 
I think the intent of the link was that if you don't find any of the RF 
terms listed on that page objectionable, you'll not find the Google RF 
terms objectionable either.

---

From: Rob Glidden <[email-masked]>
Date: Sat, 09 Mar 2013 12:21:46 -0800

Interesting.  Potential licensees will be aided by the provision of a 
clear list of the portfolio patents, said the 1997 US Department of 
Justice review letter of MPEG LA.

ISO/MPEG IPR rules are clear that proposers must ask for, and rights 
holders must provide, patent statements for a proposal to proceed.

Rob

On 3/9/2013 2:08 AM, Harald Alvestrand wrote:
> Stephan, at the moment, we have no agreement with the rightsholders 
> that permits us to disclose their names. We're discussing that topic 
> with them, but we will not name them without an agreement to do so.
>
>> Second, the link provided to "preview" the possible sublicensing 
>> terms (http://www.w3.org/2001/07/SVG10-IPR-statements) lists a bunch 
>> of company statements that vary widely among the rightholders listed 
> http://www.w3.org/Consortium/Patent-Policy-20040205/#sec-Requirements 
> - I think the intent of the link was that if you don't find any of the 
> RF terms listed on that page objectionable, you'll not find the Google 
> RF terms objectionable either.
>
>

---

From: "Timothy B. Terriberry" <[email-masked]>
Date: Sat, 09 Mar 2013 13:53:49 -0800

> holders must provide, patent statements for a proposal to proceed.

My understanding is that the MPEG LA pool license for AVC requires 
licensees to provide a reciprocal license to any essential patents they 
might own. Does someone have a list of all of those patent numbers?

---

From: Stephan Wenger <[email-masked]>
Date: Sat, 9 Mar 2013 22:39:38 +0000

For AVC, the patent list is public; see here:
http://www.mpegla.com/main/programs/AVC/Pages/PatentList.aspx.  However,
what parties have agreed to with respect to AVC has little or nothing to
do with what they have to do with respect to VP8.
Stephan

---

From: "Timothy B. Terriberry" <[email-masked]>
Date: Sat, 09 Mar 2013 14:50:42 -0800

> http://www.mpegla.com/main/programs/AVC/Pages/PatentList.aspx.  However,

I think you missed my point. That is the list for patents owned by the 
_licensors_. It does not appear to include any patents held by 
licensees, which are supposedly available via those licensees' 
reciprocal licenses.

> do with what they have to do with respect to VP8.

Well, Rob was the one who brought up the MPEG LA. But I won't argue with 
you on this point.

---

From: Stephan Wenger <[email-masked]>
Date: Sat, 9 Mar 2013 23:07:52 +0000

Hi Rob,
Please see inline.
Stephan

From: Rob Glidden <[email-masked]<mailto:[email-masked]>>
Date: Saturday, 9 March, 2013 12:21
To: Harald Alvestrand <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rtcweb] VP8 IPR agreement announced.

Interesting.  Potential licensees will be aided by the provision of a clear list of the portfolio patents, said the 1997 US Department of Justice review letter of MPEG LA.

AFAIK, neither a patent list nor a list of potential pool licensors were ever published.  What is known is that there were originally 12 parties which each submitted at least one patent (which was found essential) into a possible future pool, and 11 parties (which may or may not be related to the original 12 parties) decided, apparently with MPEG-LA's help, to furnish a sublicenseable license to google (but not to the world).  So we have a closed group of 11 licensors, and a single licensee, who came to an agreement using a facilitator which also happens to administers pools.  To what extent that transaction qualifies as a pooling arrangement from an antitrust law viewpoint surely has been looked at carefully by the parties in question.  Apparently, they came to the conclusion that they do not need to name the licensors, nor the patents in question.  Otherwise, I guess we would know by now.

ISO/MPEG IPR rules are clear that proposers must ask for, and rights holders must provide, patent statements for a proposal to proceed.

Huh?  Is that something special for this MPEG subgroup?  If yes, would there be a doc you can share explaining such procedures?

My understanding is that ISO/IEC patent matters are generally dealt with under the joint ITU/ISO/IEC patent policy, which requires in practice declarations with RAND terms towards the end of the process (before final approval of the standard, but after it is clear that the patent claim reads on the future standard).  Chairs are also under the obligation to request disclosure during each meeting, but (AFAIK) there are almost never replies to these calls.  When participating in a meeting, I usually to not reply, because I'm not quite sure that a patent claim reads on the final standard before that standard is reasonable frozen.

I know that the video coding joint teams (JVT, JCT-VC, JCT-3V) have additionally adopted a policy requiring in practice some form of RAND language in each contribution.

As some here know, I do not participate in this MPEG effort, so I really don't know.

Rob

Stephan, at the moment, we have no agreement with the rightsholders that permits us to disclose their names. We're discussing that topic with them, but we will not name them without an agreement to do so.

That link was a bit weird - the real W3C definition of "royalty-free" is http://www.w3.org/Consortium/Patent-Policy-20040205/#sec-Requirements - I think the intent of the link was that if you don't find any of the RF terms listed on that page objectionable, you'll not find the Google RF terms objectionable either.

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Stephan Wenger <[email-masked]>
Date: Sat, 9 Mar 2013 23:11:47 +0000

Hi Tim,

>licensees, which are supposedly available via those licensees'

Yes, I missed your point.
No, I don't believe that such a list has ever been published.  Nor that it
ever will.  Why does it matter?

Stephan

---

From: "Timothy B. Terriberry" <[email-masked]>
Date: Sat, 09 Mar 2013 15:26:47 -0800

> ever will.  Why does it matter?

I thought we just agreed that it did not.

---

From: Ron <[email-masked]>
Date: Sun, 10 Mar 2013 11:19:19 +1030

> with them, but we will not name them without an agreement to do so.

I'm a bit mystified by why Stephan thinks this is somehow essential
for anything more than curiosity sake.  Didn't he previously reassure
us that we could trust MPEG-LA to negotiate needed licences for us,
without any of the sort of additional guarantees and indemnities that
were being insisted of Google?

Why can we not trust them to have done so now, when they clearly
released a formal statement saying they have?

If anything really does remain in order to make a meaningful assessment
I would think it would be a careful examination of why this apparent
double-standard still persists.

> Of course, the rightsholders are free to disclose themselves.

Since it seems like a pretty good bet that most if not all of them
are represented here and have participated passionately in this
discussion, I assume they are actually under an obligation to under
the IETF IPR rules, should their IPR actually be relevant ...

So if they don't, then we can only assume that is yet another data
point solidly indicating that they also don't believe that anything
they have actually does read on this technology.  And that the
'agreement' may be as simple as not pressing a case with the DOJ
to tear their whole crooked circus down, and not embarrassing them
in public for being the simple grifters that they are.

So long as we're all perfectly clear on the actual status of what
is now even more obviously the preferred MTI technology to choose,
I guess I can live with that compromise.

 Good outcome is good,
 Ron

---

From: Stephan Wenger <[email-masked]>
Date: Sun, 10 Mar 2013 02:15:22 +0000

Hi Ron,
Please see inline.
Stephan

>were being insisted of Google?

I don't think I have ever said anything like this.  I may have previously
said something along the following lines:

A pooling arrangement (in the traditional sense), combined with a RAND
commitment by a large percentage of potential rightholders (i.e. through
their participation in a RAND SDO) can, IMO, indeed create a licensing
ecosystem that would reduce (though never eliminate) the risk of using a
technology and be hit by business-damaging royalties or injunctions.  In
the deal currently under discussion, we don't seem have to have either
factor in play.  At least not in a way verifiable by me.

If I knew the rightholders, I could correlate their names and portfolios
with a landscape study I may have performed, and then could decide a) the
rightholder group under whose rights which I would be licensed if I pick a
google sublicense is all I worry about, b) there are a few rightholders
where I don't have a license through google, but that's a risk I'm willing
to take given the benefits get, or c) I continue to stay away from VP8.
Given the nature of the google deal, I could also take a shortcut--as the
license google has appears to encompass all VP8-essential patent claims of
these 11 rightholders, I could just make a per company risk/benefit
assessment.

Further, one nice thing about pools is that they set a market price for
patent licenses for the standard in question, which, in combination with a
RAND commitment, MAY limit the damages and royalties and MAY also rule out
injunctions.  Both aspects are currently being litigated and hotly debated
in the academic and standards/patents communities, which is why I wrote
"MAY".  We will know better in a few years.

>released a formal statement saying they have?

It's not clear to me to what you refer here.

>the IETF IPR rules, should their IPR actually be relevant ...

Your understanding of the IETF IPR policy has, umm, a few holes.  Suggest
you read BCP79.  To summarize, only individuals have an obligations for
disclosure, and only if they a) have reasonable and personal knowledge of
IPR reading on the standard, b) have contributed, and c) the IPR is owned
by their employer.  Given the rather limited overlap between the video
coding community and IETF participants, it's rather unlikely that you find
people with a disclosure obligation under all three factors.  Of course,
people are also encouraged to disclose if only factor a) above is correct,
but there is no obligation, and given the risk of disclosures, such
voluntary disclosures are not particularly common and typically come from
academics (though others are by no means unheard of.)

>in public for being the simple grifters that they are.

I leave it to others to comment on this rant.

>I guess I can live with that compromise.

On that, we agree.

---

From: Rob Glidden <[email-masked]>
Date: Sun, 10 Mar 2013 13:11:40 -0700

Stephan:

I'm sure you are aware this is straight from the official ISO web site 
where you are listed as the liaison from IETF.

Perhaps I confused you by paraphrasing the term "shall" as "must".  I 
think they mean the same thing here, the former just seems oddly formal 
to use in an email.

Rob

On 3/9/2013 3:07 PM, Stephan Wenger wrote:
> Hi Rob,
> Please see inline.
> Stephan
>
> From: Rob Glidden <[email-masked] <mailto:[email-masked]>>
> To: Harald Alvestrand <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
>     Interesting.  Potential licensees will be aided by the provision
>     of a clear list of the portfolio patents, said the 1997 US
>     Department of Justice review letter of MPEG LA.
>
>
> AFAIK, neither a patent list nor a list of potential pool licensors 
> were ever published.  What is known is that there were originally 12 
> parties which each submitted at least one patent (which was found 
> essential) into a possible future pool, and 11 parties (which may or 
> may not be related to the original 12 parties) decided, apparently 
> with MPEG-LA's help, to furnish a sublicenseable license to google 
> (but not to the world).  So we have a closed group of 11 licensors, 
> and a single licensee, who came to an agreement using a facilitator 
> which also happens to administers pools.  To what extent that 
> transaction qualifies as a pooling arrangement from an antitrust law 
> viewpoint surely has been looked at carefully by the parties in 
> question.  Apparently, they came to the conclusion that they do not 
> need to name the licensors, nor the patents in question. 
>  Otherwise, I guess we would know by now.
>
>
>     ISO/MPEG IPR rules are clear that proposers must ask for, and
>     rights holders must provide, patent statements for a proposal to
>     proceed.
>
>
> Huh?  Is that something special for this MPEG subgroup?  If yes, would 
> there be a doc you can share explaining such procedures?
> My understanding is that ISO/IEC patent matters are generally dealt 
> with under the joint ITU/ISO/IEC patent policy, which requires in 
> practice declarations with RAND terms towards the end of the process 
> (before final approval of the standard, but after it is clear that the 
> patent claim reads on the future standard).  Chairs are also under the 
> obligation to request disclosure during each meeting, but (AFAIK) 
> there are almost never replies to these calls.  When participating in 
> a meeting, I usually to not reply, because I'm not quite sure that a 
> patent claim reads on the final standard before that standard is 
> reasonable frozen.
>
> I know that the video coding joint teams (JVT, JCT-VC, JCT-3V) have 
> additionally adopted a policy requiring in practice some form of RAND 
> language in each contribution.
>
>>>     This is a great development for VP8.  Congratulations.  I'm sure
>>>     it took a few cycles and dollars to get something like this
>>>     arranged.  I wish your PR would have come out a bit earlier, but
>>>     licensing discussions do take time…  So better now than never.
>>>
>>>     First, who are those 11 rightholders?  I'm sure you agree that,
>>>     in order to make a meaningful risk assessment, that information
>>>     is needed.
>>
>>     Stephan, at the moment, we have no agreement with the
>>     rightsholders that permits us to disclose their names. We're
>>     discussing that topic with them, but we will not name them
>>     without an agreement to do so.
>>
>>>     terms (http://www.w3.org/2001/07/SVG10-IPR-statements) lists a
>>>     bunch of company statements that vary widely among the
>>>     rightholders listed there, which do not include google.  It
>>>     would be great if you could provide more specific information as
>>>     early as possible, especially with respect to the essential
>>>     claims definition and the reciprocity conditions.  That does not
>>>     have to be final legal text, but should be a clear indication of
>>>     your business intentions.  To me, term-sheet level is OK.
>>
>>     - I think the intent of the link was that if you don't find any
>>     of the RF terms listed on that page objectionable, you'll not
>>     find the Google RF terms objectionable either.
>>
>>
>>     [email-masked]://www.ietf.org/mailman/listinfo/rtcweb
>