Subject: Re: [rtcweb] DRAFT Agenda for RTCWEB

From: Bernard Aboba <[email-masked]>
Date: Fri, 1 Mar 2013 23:06:04 -0800

Why would we want unsecured SCTP either for the WebRTC data channel or CLUE signaling? Let's not invent problems when we have enough real ones.
________________________________
From: Dale R. Worley<mailto:[email-masked]>
Sent: ‎3/‎1/‎2013 11:58 AM
To: Michael Tuexen<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] DRAFT Agenda for RTCWEB

> From: Michael Tuexen <[email-masked]>

> As far as I understand it is easy (based on the first byte) to demux
> DTLS from STUN and SRTP. SCTP is the only payload for DTLS, so there
> is no need for demuxing. So no need to control SCTP ports. Or am I
> missing something?

Controlling port numbers is needed if SCTP is *not* encapsulated in
DTLS and yet has to be distinguished from RTP et al.  (That would
become significant if encryption was applied to the bundle's packet
stream as a whole, rather than to the constituent streams
individually.)

Dale
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 1 Mar 2013 23:11:33 -0800

Plan B doesn't provide A/V mux so it may be desirable to add Plan A BUNDLE as well (e.g., later), assuming that the mux issues can be worked out (PT muxing breaks the stats API).
________________________________
From: Christer Holmberg<mailto:[email-masked]>
Sent: ‎3/‎1/‎2013 2:12 AM
To: Justin Uberti<mailto:[email-masked]>; Ejzak, Richard P (Richard)<mailto:[email-masked]>
Cc: Richard Barnes<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] DRAFT Agenda for RTCWEB

Hi,

>BUNDLE and data muxing works for both "Plan A" and "Plan B".
>
>Recall that "Plan B" is muxing multiple media sources of the same type over a single m= line, and BUNDLE then provides muxing of the audio, video, and data m= lines.

My understanding (based on the Boston slides, because I haven't read Cullen's plan draft yet) of "Plan B" is that it didn't include BUNDLE - or any other multi-mediatype multiplexing negotiation mechanism - but only multiple SSRCs per m- line.

Regards,

Christer

On Thu, Feb 28, 2013 at 3:10 PM, Ejzak, Richard P (Richard) <[email-masked]> wrote:
Since multiplexing of the data channel with RTP media has been shown as a desirable feature of BUNDLE (and most of its variants), I would suggest that this be treated as a significant advantage for BUNDLE (and similarly capable variants) over any proposal without it.  Cullen's "Plan A" is preferred over Plan B precisely because it has an incremental muxing advantage.

BR, Richard

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Christer Holmberg
> Sent: Wednesday, February 27, 2013 2:30 PM
> To: Ted Hardie; [email-masked]
> Cc: Richard Barnes; [email-masked]
> Hi,
> Does the Data Channel part (or some other part) of the agenda include
> making a decision on whether it shall be possible to bundle the Data
> Channel with the RTP media?
>
> Or, do we already have consensus that it shall be possible?
>
> Just to clarify, because I think it is important input for the MMUSIC
> discussions on the actual mechanism.
>
> Regards,
>
> Christer
>
>
> ________________________________________
> From: [email-masked] [[email-masked]] on behalf of
> Ted Hardie [[email-masked]]
> Sent: Wednesday, 27 February 2013 7:49 PM
> To: [email-masked]
> Cc: Richard Barnes; [email-masked]
> Subject: [rtcweb] DRAFT Agenda for RTCWEB
>
> The agenda below has been uploaded as an initial, draft agenda for the
> group.  Comments on the timing and balance are encouraged.
>
> thanks,
>
> Ted Hardie
>
> RTCWEB Draft Agenda
> March 12, 2013 9:00 to 11:30
>
> Administrivia (5 min)
>
> AD Message (5 min)
>
> Data Channel
>  - draft-jesup-rtcweb-data-protocol (20 min)
>  - draft-thomson-rtcweb-data (15 min)
>  - draft-marcon-rtcweb-data-channel-management (15 min)
>  - Discussion (30 min)
>  - Consensus call(s) (5 min)
>
> WGLC Issue resolution (30 min)
> - draft-ietf-rtcweb-security
> - draft-ietf-rtcweb-security-arch
> - draft-ietf-rtcweb-overview
> - draft-ietf-rtcweb-use-cases-and-requirements
>
> RTCP-XR (15 min )
> - draft-ietf-rtcweb-rtp-usage-06
>
> FEC in RTCWEB  (Call for interest)
> - draft-mandyam-rtcweb-fecframe-00 (5 min)
>
> Mobile issues for RTCWEB (Call for review)
> - http://tools.ietf.org/html/draft-reddy-rtcweb-mobile-00 (5 min)
>
>
> March 14, 2013 9:00 to 11:30
>
> JSEP
> - draft-rtcweb-jsep (40 min)
> - Discussion (30 min)
> - Consensus call(s) (5)
>
> Video Codec                       10:15 to 11:30
> 1. draft-alvestrand-rtcweb-vp8-01 (15 mins) 2. draft-burman-rtcweb-
> h264-proposal-01+draft-dbenham-webrtcvideomti-01+draft-marjou-rtcweb-
> video-codec-00
> (25 mins)
>       Discussion (30 minutes)
>       Call the question (5 minutes)