Subject: [rtcweb] Request to postpone the question on VP8 as MTI

From: Gaelle Martin-Cocher <[email-masked]>
Date: Sun, 10 Mar 2013 14:45:00 +0000

Dear All,

In light of the recent announcements (both MPEG-LA and the VP8 litigation), I believe that more time is needed to make a proper risk assessment on VP8 and an informed decision. On one side the MPEG-LA announcement provides some relief but also confirms that VP8 does not come for free and that concerns were/are justified. This is further confirmed by the second announcement.
It will take more efforts for VP8 supporters (and Google does not need to be alone in that process) to reach the goal of an RF video codec (or a codec with a suitable licensing terms). I think it is understood by now, that this would likely be more prone to success in a standardization body than anywhere else . (speaking here as a WebVC proponent that went through that process too).
It is also apparent that the MPEG-LA/Google agreement raises additional questions.

Here are the reasons I believe we need more time and should postpone the question on VP8 (I am not saying that this should not be asked at a later time):
-The license is not yet published (and the meeting starts tomorrow)
-Some negotiations are still ongoing (e.g. names of the licensors).
-Some questions were/are raised and not answered yet, below are the one that matters to me:
- Will the patent list be provided?
- Who are the licensors  and how that group of licensors relates to the initial 12 patent holders identified by MPEG-LA?
- Will there be alignment of licenses across WebM, RFC, MPEG, and is that even feasible with the possible new license terms?
- Questions related to clarifications of the different grants inside/outside the RFC and their applicability to the RFC itself still need to be answered (aka: how  section 20: 27 apply to the RFC code itself or to the code provided in MPEG)
- Questions related to the status of VP8 as a standard as it was mentioned that the RFC will not progress to the standard track still remain
- In light of the litigation announcement, was due diligence done by VP8 proponents toward patent holders that are not MPEG-LA members?  (e.g. possibly on a model similar to what was done in WebVC)
- More questions will likely be raised once the license is published.
-We need to give enough time to Google to finalize its license and provide answers on those above points.
-VP8 is not (yet) a standard in IETF nor in MPEG (MPEG only saw an input contribution for the first time in January). It would be desirable that RTCWeb points to a standard or that VP8 reaches a certain stage in MPEG so that it can be considered as an MPEG deliverable. VP8 may reach that status at a next MPEG meeting in April or July, I don't see how that can be accelerated further. We need to give MPEG the time to proceed properly.
-legal entities will need time to review both the new license and the answers to the various questions that were asked. This cannot be achieved in 3 days.

Further, I just came across an informational RFC for VP9:
-Is VP9 going to "deprecate" VP8?
- What is the timeframe for VP9 in IETF?
-if VP9 going to be proposed for a next generation of RTCWeb Client? Which timeframe?
I don't think it would be desirable to mandate VP8 today if VP9 is around the corner and will be proposed for RTCWeb as well.
Requesting two codecs to be implemented instead of one in a short timeframe is obviously an issue for implementers that cannot do a simple software upgrade of their products.

I hope all of you will find that request reasonable.
Sincerely,

Gaëlle Martin-Cocher

Standards Manager

Office: (905) 629-4746 x14591

BlackBerry: (647) 267-0569

PIN: 2835485E

[Description: C:\Documents and Settings\gmartincocher\Application Data\Microsoft\Signatures\bblogo.gif]

www.rim.com

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 10 Mar 2013 10:52:31 -0500

Gaelle, 

I think these are good points and other have erased similar points. I need to discuss it with my co-chairs but I suspect that for the points you raised, we will need delay this to IETF 86. Again, I need to talk to my co-chairs before we can make a decision on this but I would guess that is the direction things will need to go.

Cullen (One of the co-chairs)

On Mar 10, 2013, at 9:45 AM, Gaelle Martin-Cocher <[email-masked]> wrote:

> -VP8 is not (yet) a standard in IETF nor in MPEG (MPEG only saw an input contribution for the first time in January). It would be desirable that RTCWeb points to a standard or that VP8 reaches a certain stage in MPEG so that it can be considered as an MPEG deliverable. VP8 may reach that status at a next MPEG meeting in April or July, I don’t see how that can be accelerated further. We need to give MPEG the time to proceed properly.
> -Is VP9 going to “deprecate” VP8?
> I don’t think it would be desirable to mandate VP8 today if VP9 is around the corner and will be proposed for RTCWeb as well.
> This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful. _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Cameron Byrne <[email-masked]>
Date: Sun, 10 Mar 2013 11:57:35 -0700

After seeing this play out over the last few months,  i believe we
need to strongly consider no MTI for video.

It's unfortunate, but i believe the various stakeholder have
irreconcilable difference.  IPR is a dark art and the IETF has no
method for dealing with it beyond running away.  That said, run away.

CB

On Sun, Mar 10, 2013 at 8:52 AM, Cullen Jennings <[email-masked]> wrote:
> _______________________________________________
> rtcweb mailing list
> [email-masked]

---

From: David Singer <[email-masked]>
Date: Mon, 11 Mar 2013 15:51:40 -0700

> I think these are good points and other have erased similar points. I need to discuss it with my co-chairs but I suspect that for the points you raised, we will need delay this to IETF 86. Again, I…

I also think it would be prudent to defer the codec decision.

>> BlackBerry: (647) 267-0569

David Singer
Multimedia and Software Standards, Apple Inc.

---

From: Gaelle Martin-Cocher <[email-masked]>
Date: Tue, 12 Mar 2013 16:09:10 +0000

Dear All,

I am following up on my request to postpone the discussion.
It appears that the new license for VP8 and the Nokia declaration in IETF on VP8 are not available yet.
Questions were not answered either.
The meeting has started, and that particular discussion is planned for Thursday.

In light of the recent email exchanges, it is clear that the discussion is not technical at all anymore; this is about risk assessments and legal matters. 
It seems that it would be necessary that legal counsels from IETF and from the various companies are involved in the discussion. I am not sure if this topic will be better dealt with in the RTCWeb group of if there is another group in IETF that would be more suitable. 
One (as a technical expert) can try to bring his/her legal counsel up to speed quickly; but within that time frame and without tangible information that is very improbable  that our respective legal counsel will be able to have an informed position and that each one of us would be in a position to reach a consensus on Thursday.

I am hence re-iterating my request to postpone that discussion. Cullen (or chairs) , would you mind giving an update on this?

Sincerely,
Gaëlle

-----Original Message-----
From: David Singer [mailto:[email-masked]] 
Sent: Monday, March 11, 2013 6:52 PM
To: Cullen Jennings
Cc: Gaelle Martin-Cocher; [email-masked]
Subject: Re: [rtcweb] Request to postpone the question on VP8 as MTI

>> - Questions related to clarifications of the different grants 
>> inside/outside the RFC and their applicability to the RFC itself 
>> still need to be answered (aka: how  section 20: 27 apply to the RFC 
>> code itself or to the code provided in MPEG)
>> - Questions related to the status of VP8 as a standard as it was 
>> mentioned that the RFC will not progress to the standard track still 
>> remain
>> - In light of the litigation announcement, was due diligence done by 
>> VP8 proponents toward patent holders that are not MPEG-LA members?  
>> (e.g. possibly on a model similar to what was done in WebVC)
>> This transmission (including any attachments) may contain 
>> confidential information, privileged material (including material 
>> protected by the solicitor-client or other applicable privileges), or 
>> constitute non-public information. Any use of this information by 
>> anyone other than the intended recipient is prohibited. If you have 
>> received this transmission in error, please immediately reply to the 
>> sender and delete this information from your system. Use, 
>> dissemination, distribution, or reproduction of this transmission by 
>> unintended recipients is not authorized and may be unlawful. 

David Singer