Subject: [rtcweb] TURN, NAT and Proxies

From: Binod <[email-masked]>
Date: Mon, 11 Mar 2013 21:31:06 +0530

I was scanning the webrtc drafts to figure out what is
specified regarding NAT traversal, firewall and proxies.

draft-ietf-rtcweb-use-cases-and-requirements 
<http://tools.ietf.org/wg/rtcweb/draft-ietf-rtcweb-use-cases-and-requirements/> 
mentions
1)  NAT/FW that blocks UDP :

Ok, This is achieved by supporting ICE-TCP

2) FW that only allows http:

How is this supported?

What about enterprises that only support proxies?

In the google group discussion, Justin was mentioning
that browser could connect with a proxy (http connect)
even for TURN traffic and also mentioned supporting
an enterprise TURN server.

Will this make into one of the webrtc rfcs?

thanks,
Binod.

---

From: Lorenzo Miniero <[email-masked]>
Date: Mon, 11 Mar 2013 17:21:56 +0100

Il giorno Mon, 11 Mar 2013 21:31:06 +0530

> Will this make into one of the webrtc rfcs?

I submitted an individual draft (now expired) a few months ago that
tried to address this exact issue. From the discussion that came out,
which you can find in the archives, the consensus was basically to rely
on TURN (e.g. on port 443 to look like HTTPS) or on nothing at all, as
using some kind of HTTP fallback could have been seen as "overkill".
Besides, trying to pass through more restrictive firewalls by, well,
fooling them was seen as trying to bypass policies configured by
network administrators, so not acceptable for some.

Lorenzo

-- 
Lorenzo Miniero, COB

Meetecho s.r.l.
Web Conferencing and Collaboration Tools
http://www.meetecho.com

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 11 Mar 2013 17:00:23 +0000

Hi,

By coincidence we submitted a draft on this subject just this morning it can be found at: http://tools.ietf.org/html/draft-hutton-rtcweb-nat-firewall-considerations-00.

Regards
Andy 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Lorenzo Miniero
> Sent: 11 March 2013 12:22
> To: Binod
> Cc: [email-masked]
> Subject: Re: [rtcweb] TURN, NAT and Proxies
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb