Subject: Re: [rtcweb] My SDP doesn't interoperate

From: Justin Uberti <[email-masked]>
Date: Wed, 1 May 2013 08:43:44 -0700

The one SDP issue mentioned in that document has been fixed; that document
is now outdated by events.

Regarding the "100 lines", that code promoted Opus to be the preferred
codec, as well as disabling CN. This munging is also no longer needed; we
have now added support for the VoiceActivityDetection constraint to control
use of CN.

On Fri, Apr 26, 2013 at 12:00 PM, Martin Thomson
<[email-masked]>wrote:

> (was Re: [rtcweb] SDP Security Descriptions (RFC 4568) and RTCWeb)
>
> On 26 April 2013 11:07, Cullen Jennings (fluffy) <[email-masked]> wrote:
> >
> > On Apr 26, 2013, at 7:47 AM, Tim Panton <[email-masked]> wrote:
> >
> >> If anyone still thinks that SDP is just a blob not an API surface, take
> a look at the 'reference implementation' of browser to browser interop.
> >>
> https://code.google.com/p/webrtc-samples/source/browse/trunk/apprtc/index.html
> >>
> >> I count around 100 lines of javascript munging the SDP.
> >
> > Could you just summarize what the 100 lines do and which theses would be
> needed for browsers that implemented the drat standards? I'm trying to dig
> into what we need to fix.
>
> http://www.webrtc.org/interop
>
> That's probably out of date, but you get the idea.
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 1 May 2013 10:46:00 -0700

>From what I could tell, most of the interop issues addressed in the most recent sample app were not SDP-related, but dealt with differences in API implementations, quite a few of which should be expected to disappear when the API spec is finalized.  

Of course, the sample app is not attempting to address legacy interop, which is where I am expecting the narliest interop issues to arise (particularly video).  And as we get more WebRTC browser implementations, the amount of interop code will undoubtedly grow.  

From: [email-masked]
Date: Wed, 1 May 2013 08:43:44 -0700
To: [email-masked]
CC: [email-masked]; [email-masked]
Subject: Re: [rtcweb] My SDP doesn't interoperate

The one SDP issue mentioned in that document has been fixed; that document is now outdated by events.
Regarding the "100 lines", that code promoted Opus to be the preferred codec, as well as disabling CN. This munging is also no longer needed; we have now added support for the VoiceActivityDetection constraint to control use of CN.

On Fri, Apr 26, 2013 at 12:00 PM, Martin Thomson <[email-masked]> wrote:

On 26 April 2013 11:07, Cullen Jennings (fluffy) <[email-masked]> wrote:

>> If anyone still thinks that SDP is just a blob not an API surface, take a look at the 'reference implementation' of browser to browser interop.

> Could you just summarize what the 100 lines do and which theses would be needed for browsers that implemented the drat standards? I'm trying to dig into what we need to fix.

rtcweb mailing list

[email-masked]