Subject: Re: [rtcweb] [MMUSIC] Is bundle just a port override?

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 9 May 2013 15:55:45 +0000

Mo, 

I think the key part of the grouping was it gave a way to say which m-line to use that still allowed that m-line to later be set to zero. I'm not saying the grouping adds much but keep in mind it is not really just the port you are selecting.  It's all the ICE transport stuff in the candidates so we would have to more than just a=port, you would also need the a=bundle-ice-candiaate and perhaps some DTLS info but I'm not sure. It seems something like this could work. not sure it would change too much. 

my 2 cents..

On Mar 18, 2013, at 9:19 PM, Mo Zanaty (mzanaty) <[email-masked]> wrote:

> Does bundle imply anything beyond a simple port override of the m-line port? If not, then why not just directly signal the port override in an attribute without any grouping semantics?
>  
> Offer to mux audio and video on the same port:
> m=audio 10000 RTP/AVP 0
> m=video 10002 RTP/AVP 31
> a=port 10000
> i=I really want 10000, but lied on the m-line for fear of confusing you. Confused yet?
>  
> Answer supports the port override attribute and agrees to mux audio and video:
> m=audio 40000 RTP/AVP 0
> m=video 40000 RTP/AVP 31
> a=port 40000
> …so audio and video ports are 10000<->40000.
>  
> Answer supports the port override attribute but doesn’t want to demux on his end:
> m=audio 40000 RTP/AVP 0
> m=video 40002 RTP/AVP 31
> a=port 40002
> …so audio ports are 10000<->40000 and video ports are 10000<->40002.
>  
> Answer doesn’t support the port override attribute, or doesn’t want either end to mux:
> m=audio 40000 RTP/AVP 0
> m=video 40002 RTP/AVP 31
> …so audio ports are 10000<->40000 and video ports are 10002<->40002.
>  
> Either end can re-offer without lies about ports on the m-line after confirming the peer is not confused by muxing, if they want to avoid confusing intermediaries.
>  
> Has this approach been tried yet? Dismissed?
>  
> Mo
>  
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 9 May 2013 15:56:04 +0000

On Mar 22, 2013, at 12:28 PM, Dale R. Worley <[email-masked]> wrote:

>> From: "Mo Zanaty (mzanaty)" <[email-masked]>
>> 
>> BTW, has anyone actually observed failures?
> 
> My memory is that Cullen Jennings knows of a significant installed
> base of SBCs that choke on SDP that contains duplicated port
> references.
> 
> Dale

Some of them are using the port as the think to uniquely key into the active data structures.

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 10 May 2013 10:55:12 -0600

> Some of them are using the port as the think to uniquely key into the active data structures. 

Sorry, apple auto correct got me. I mean "thing" not "think"