Subject: [rtcweb] H.264 versus VP8 - are we really going to spend 2 full hours rehashing this?

From: Harald Alvestrand <[email-masked]>
Date: Mon, 14 Oct 2013 16:10:55 +0200

I've read the H.264 Constrained Baseline proposal.

It contains no information that hasn't been presented to the list long 
ago; all but the performance evaluations were presented in Florida.

I've written the VP8 proposal.
It contains new information, but only in the form of pointing out that 
VP8 is more widely deployed, closer to being an ISO standard, and 
working better than when we discussed this in Florida. It is also being 
universally deployed in existing WebRTC implementations (Mozilla and 
Chrome).

We know that for most participants, the IPR issue is the only real 
issue. So far, I haven't seen any of the people who were saying "we want 
to ship products but can't possibly use H.264" saying that they have 
changed their minds.

Yet the chairs are proposing the following 2-hour agenda:

Frame discussions and process and agenda: 10 min (chairs)

VP8 presentation with clarify questions -  25 min (???)

H.264 presentation with clarify questions - 25 min (???)

Microphone discussions of pro/cons - 40 min (all)

Call the question - 10 min ( chairs )

Wrap up and next steps - 10 min (chairs)

Celebrate on our successful decision reach.

Don't we have ways in which we can make better use of 2 hours?

---

From: Mary Barnes <[email-masked]>
Date: Mon, 14 Oct 2013 09:22:50 -0500

I totally agree with the sentiment that the WG can make much better use of
the 2 hours.  We previously spent 2+ hours on this topic with no
conclusion.  Is the new information on VP8 enough to change anyone's
opinion?  Why not ask the questions that were proposed for this topic *now*
on the mailing list?

Regards,
Mary.

On Mon, Oct 14, 2013 at 9:10 AM, Harald Alvestrand <[email-masked]>wrote:

> It contains new information, but only in the form of pointing out that VP8
> is more widely deployed, closer to being an ISO standard, and working
> better than when we discussed this in Florida. It is also being universally
> deployed in existing WebRTC implementations (Mozilla and Chrome).
>
> We know that for most participants, the IPR issue is the only real issue.
> So far, I haven't seen any of the people who were saying "we want to ship
> products but can't possibly use H.264" saying that they have changed their
> minds.
>
> ______________________________**_________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/rtcweb<https://www.ietf.org/mailman/listinfo/rtcweb>
>

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 14 Oct 2013 07:34:36 -0700

+1. Allocating two hours is a colossal waste of time. 

> On Oct 14, 2013, at 7:22 AM, "Mary Barnes" <[email-masked]> wrote:
> 
> I totally agree with the sentiment that the WG can make much better use of the 2 hours.  We previously spent 2+ hours on this topic with no conclusion.  Is the new information on VP8 enough to change anyone's opinion?  Why not ask the questions that were proposed for this topic *now* on the mailing list? 
> 
> Regards,
> Mary. 
> 
> 
>> On Mon, Oct 14, 2013 at 9:10 AM, Harald Alvestrand <[email-masked]> wrote:
>> It contains no information that hasn't been presented to the list long ago; all but the performance evaluations were presented in Florida.
>> 
>> It contains new information, but only in the form of pointing out that VP8 is more widely deployed, closer to being an ISO standard, and working better than when we discussed this in Florida. It is also being universally deployed in existing WebRTC implementations (Mozilla and Chrome).
>> 
>> We know that for most participants, the IPR issue is the only real issue. So far, I haven't seen any of the people who were saying "we want to ship products but can't possibly use H.264" saying that they have changed their minds.
>> 
>> _______________________________________________
>> rtcweb mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: cowwoc <[email-masked]>
Date: Mon, 14 Oct 2013 13:56:25 -0400

Harald,

     What's the alternative? Whether the discussion happens on the 
mailing list or a call it sounds to me like you've got people with 
entrenched views. I'll take this opportunity to remind you of another 
option: mandate a codec whose IPR has expired and have clients negotiate 
up from there. This compromise displeases everyone equally, but it 
allows us to proceed without any further delay.

Gili

On 14/10/2013 10:10 AM, Harald Alvestrand wrote:
> working better than when we discussed this in Florida. It is also 
> being universally deployed in existing WebRTC implementations (Mozilla 
> and Chrome).
>
> issue. So far, I haven't seen any of the people who were saying "we 
> want to ship products but can't possibly use H.264" saying that they 
> have changed their minds.
>

---

From: Mary Barnes <[email-masked]>
Date: Mon, 14 Oct 2013 13:26:45 -0500

Gili,

The concern is around 2 hours on the agenda at the upcoming f2f meeting:
http://www.ietf.org/mail-archive/web/rtcweb/current/msg09037.html

We already spent around hours on this topic at a previous f2f IETF.  Here's
the multi-media recording for your enjoyment:
http://ietf86.conf.meetecho.com/index.php/Recorded_Sessions#RTCWEB_III

BTW, Meetecho is a great way for remote folks to follow the f2f IETF
meetings.

Regards,
Mary.

On Mon, Oct 14, 2013 at 12:56 PM, cowwoc <[email-masked]> wrote:

> Harald,
>
>     What's the alternative? Whether the discussion happens on the mailing
> list or a call it sounds to me like you've got people with entrenched
> views. I'll take this opportunity to remind you of another option: mandate
> a codec whose IPR has expired and have clients negotiate up from there.
> This compromise displeases everyone equally, but it allows us to proceed
> without any further delay.
>
> Gili
>
>
>> VP8 is more widely deployed, closer to being an ISO standard, and working

---

From: cowwoc <[email-masked]>
Date: Mon, 14 Oct 2013 15:25:24 -0400

Hi Mary,

     I understand. So you're saying that the WG believes that this topic 
has been discussed to death and therefore would like to call it to a 
vote without (or with a shorter) discussion, is that correct?

Gili

On 14/10/2013 2:26 PM, Mary Barnes wrote:
> We already spent around hours on this topic at a previous f2f IETF. 
>  Here's the multi-media recording for your enjoyment:
> On Mon, Oct 14, 2013 at 12:56 PM, cowwoc <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Harald,
>
>     entrenched views. I'll take this opportunity to remind you of
>     another option: mandate a codec whose IPR has expired and have
>     clients negotiate up from there. This compromise displeases
>     everyone equally, but it allows us to proceed without any further
>     delay.
>
>     Gili
>
>
>         It contains no information that hasn't been presented to the
>         list long ago; all but the performance evaluations were
>         presented in Florida.
>
>         It contains new information, but only in the form of pointing
>         out that VP8 is more widely deployed, closer to being an ISO
>         standard, and working better than when we discussed this in
>         Florida. It is also being universally deployed in existing
>         WebRTC implementations (Mozilla and Chrome).
>
>         We know that for most participants, the IPR issue is the only
>         real issue. So far, I haven't seen any of the people who were
>         saying "we want to ship products but can't possibly use H.264"
>         saying that they have changed their minds.
>
>         [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Mary Barnes <[email-masked]>
Date: Mon, 14 Oct 2013 16:31:49 -0500

Basically, yes.

On Mon, Oct 14, 2013 at 2:25 PM, cowwoc <[email-masked]> wrote:

> has been discussed to death and therefore would like to call it to a vote
> without (or with a shorter) discussion, is that correct?
>
> Gili
>
>
>>> issue. So far, I haven't seen any of the people who were saying "we want to
>>> ship products but can't possibly use H.264" saying that they have changed
>>> their minds.
>>>

---

From: Ted Hardie <[email-masked]>
Date: Mon, 14 Oct 2013 17:06:40 -0700

> without (or with a shorter) discussion, is that correct?
Please remember that we don't vote; we're trying to come to (at least
rough) consensus.  That's a harder process than voting, and it can take
more time.  A key part of it is ensuring that each of those with
substantive technical points to make is certain that they have been heard.
If the H.264 and VP8 proponents do not choose to use the full time for
their presentations or the working group participants the time for
questions, we will, of course, retrieve whatever time remains for other
discussions.  The more that substantive discussions happens now, on the
list, the more likely it is that we retrieve time.  If all the proponents
of each proposal and all the potential questioners are satisfied by the
discussion on the list, we can retrieve nearly all of it.

If the working group would like the chairs to propose other topics for any
remainder, I am sure we can do so; we'd also be happy for proposals from
the WG.

regards,

Ted Hardie