Subject: [rtcweb] Performance of rate-controlled H.264 Constrained High Profile

From: Bo Burman <[email-masked]>
Date: Thu, 24 Oct 2013 13:42:26 +0000

Hi all,

Our recent post on comparing H.264 Constrained Baseline Profile (CBP) and VP8 objective performance with the x264 rate-control patch applied showed that H.264 CBP and VP8 are comparable.

When using that same patch applied to Constrained High Profile (CHP) settings of x264, as used in draft-burman-rtcweb-h264-proposal<https://datatracker.ietf.org/doc/draft-burman-rtcweb-h264-proposal/>, we get the following results for rate-controlled CHP:

VP8 is anchor: H.264 CHP is 16% better
H.264 is anchor: H.264 CHP is 24% better

This latter result is fully consistent with the fixed-QP tests used in the above draft.

While we still propose CBP as MTI to get maximum reach, we recommend and expect most implementations to also support CHP, which can be seen to give a clear quality advantage irrespective if rate control is used or not. Regarding technical differences between CBP and CHP, see a summary in section 8 of the above draft. There is also no difference in licensing situation between CBP and CHP.

Regarding choice of anchor; in cases like this where two competing alternatives are compared and there is no obvious anchor, it is possible to instead use a geometric mean (http://en.wikipedia.org/wiki/Geometric_mean) that will not depend on any anchor but give a single consistent figure.

Geometric mean: H.264 CHP is 22% better

/Bo

---

From: Basil Mohamed Gohar <[email-masked]>
Date: Thu, 24 Oct 2013 09:56:15 -0400

On 10/24/2013 09:42 AM, Bo Burman wrote:
> Hi all,
> 
> Our recent post on comparing H.264 Constrained Baseline Profile (CBP)
> and VP8 objective performance with the x264 rate-control patch applied
> showed that H.264 CBP and VP8 are comparable.
> 
> When using that same patch applied to Constrained High Profile (CHP)
> settings of x264, as used in draft-burman-rtcweb-h264-proposal
> <https://datatracker.ietf.org/doc/draft-burman-rtcweb-h264-proposal/>,
> we get the following results for rate-controlled CHP:
> 
> While we still propose CBP as MTI to get maximum reach, we recommend and
> expect most implementations to also support CHP, which can be seen to
> give a clear quality advantage irrespective if rate control is used or
> not. Regarding technical differences between CBP and CHP, see a summary
> in section 8 of the above draft. There is also no difference in
> licensing situation between CBP and CHP.
> 
> Regarding choice of anchor; in cases like this where two competing
> alternatives are compared and there is no obvious anchor, it is possible
> to instead use a geometric mean
> (http://en.wikipedia.org/wiki/Geometric_mean) that will not depend on
> any anchor but give a single consistent figure.
> 

Bo,

Thanks for sharing the results of this comparison.

Correct me if I'm wrong, but I thought CBP was being used as a
comparison point to represent the H.264 option because the CBP was being
considered for offer under IPR terms that would be royalty free.

If this is the case, has the same offer or implication also been made
for CHP?  I may have missed it, but I don't recall that being the case.
 If it has not, then while these numbers are nice to have, they still
overlook the IPR issues completely.

-- 
Libre Video
http://librevideo.org

---

From: Bo Burman <[email-masked]>
Date: Thu, 24 Oct 2013 16:30:33 +0000

Hi Basil,

> Correct me if I'm wrong, but I thought CBP was being used as a comparison point to represent the H.264 option because
> the CBP was being considered for offer under IPR terms that would be royalty free.

That was definitely part of the _potential_ reason, but unfortunately seems very hard to achieve. It however still think H.264 CBP is a better choice than VP8 since I believe the IPR landscape is more known.

> If this is the case, has the same offer or implication also been made for CHP?  I may have missed it, but I don't recall that
> being the case.

No, that was never done, but if you choose to license CBP, that also includes CHP.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Basil Mohamed Gohar
> Sent: den 24 oktober 2013 15:56
> To: [email-masked]
> Subject: Re: [rtcweb] Performance of rate-controlled H.264 Constrained High Profile
> 
> > While we still propose CBP as MTI to get maximum reach, we recommend
> > and expect most implementations to also support CHP, which can be seen
> > to give a clear quality advantage irrespective if rate control is used
> > or not. Regarding technical differences between CBP and CHP, see a
> > summary in section 8 of the above draft. There is also no difference
> > in licensing situation between CBP and CHP.
> >
> > alternatives are compared and there is no obvious anchor, it is
> > possible to instead use a geometric mean
> Correct me if I'm wrong, but I thought CBP was being used as a comparison point to represent the H.264 option because
> the CBP was being considered for offer under IPR terms that would be royalty free.
> 
> If this is the case, has the same offer or implication also been made for CHP?  I may have missed it, but I don't recall that
> being the case.
>  If it has not, then while these numbers are nice to have, they still overlook the IPR issues completely.
> 
> --
> Libre Video
> http://librevideo.org
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Martin J. Dürst" <[email-masked]>
Date: Sun, 27 Oct 2013 10:28:01 +0900

> H.264 is anchor: H.264 CHP is 24% better

Why don't you guys switch over to something logarithmic (e.g. something 
like dB) so that you don't have to do this VP8 is anchor/H.264 is anchor 
thing?

Regards,   Martin.