Subject: [rtcweb] Chair request on video codec discussion

From: Ted Hardie <[email-masked]>
Date: Mon, 28 Oct 2013 14:08:12 -0700

Howdy,

While the proponents of H.264 and VP8 continue to discuss performance,
there appears to be general agreement that either codec could serve the
purpose set out our for our MTI:  to avoid negotiation failure that results
in the loss of basic functionality.  If there are technical issues which
would prevent  either from being used as the MTI that have not yet been
raised, please do so before the beginning of IETF88.

regards,

Ted, Cullen, Magnus

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Tue, 29 Oct 2013 18:12:17 +0000

One minor point from a developer perspective, that would certainly not be significant enough to impact MTI, is the availability of development, debugging and analysis tools. Things like wireshark dissectors, conversion/extraction tools like videosnarf, video bitstream analyzers like Elecard, etc. H.264 is universally supported. VP8 is supported in recent releases of a few analyzers like Interra (that are quite expensive however). A wireshark bug (9274)<https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9274> was filed a few weeks ago requesting VP8. I don’t mention this to fuel the pros/cons debate, or suggest it impacts MTI, but to bring visibility to an area where the VP8 team can potentially help developers by sharing any tools they may have with the community, or help develop them if missing.

Mo

On 10/28/13, 5:08 PM, Ted Hardie <[email-masked]<mailto:[email-masked]>> wrote:

Howdy,

While the proponents of H.264 and VP8 continue to discuss performance, there appears to be general agreement that either codec could serve the purpose set out our for our MTI:  to avoid negotiation failure that results in the loss of basic functionality.  If there are technical issues which would prevent  either from being used as the MTI that have not yet been raised, please do so before the beginning of IETF88.

regards,

Ted, Cullen, Magnus