Subject: [rtcweb] New SDP O/A required if selected ICE candidate does not match c= line?

From: Iñaki Baz Castillo <[email-masked]>
Date: Thu, 24 Oct 2013 02:45:28 +0200

Hi, RFC 5245 (ICE) says:

-----------------------------
  4.1.4.  Choosing Default Candidates

   A candidate is said to be default if it would be the target of media
   from a non-ICE peer; that target is called the DEFAULT DESTINATION.
   If the default candidates are not selected by the ICE algorithm when
   communicating with an ICE-aware peer, an updated offer/answer will be
   required after ICE processing completes in order to "fix up" the SDP
   so that the default destination for media matches the candidates
   selected by ICE.  If ICE happens to select the default candidates, no
   updated offer/answer is required.
------------------------------

Having to perform a second SDP O/A just to "fix the c= line" seems
terriblly annoying and unuseful IMHO. Said that, this is obviously
"violated" by WebRTC browsers, right?

Thanks a lot.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 24 Oct 2013 07:46:07 +0000

Hi,

If you use BUNDLE, you'll need a second SDP O/A to "fix the port" (assuming the first SDP O/A contains unique ports for each m- line). It doesn't have to be the same SDP O/A which "fixes the c=line" for ICE, but it can be.

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Iñaki Baz Castillo
Sent: 24. lokakuuta 2013 3:45
To: [email-masked]
Subject: [rtcweb] New SDP O/A required if selected ICE candidate does not match c= line?

Hi, RFC 5245 (ICE) says:

Having to perform a second SDP O/A just to "fix the c= line" seems terriblly annoying and unuseful IMHO. Said that, this is obviously "violated" by WebRTC browsers, right?

Thanks a lot.

--
Iñaki Baz Castillo
<[email-masked]>
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Stach, Thomas" <[email-masked]>
Date: Thu, 24 Oct 2013 10:09:02 +0000

Iñaki,

in the past some thoughts were already presented that the updated SDP offer/answer exchange is not necessary in all environments.
See e.g. https://tools.ietf.org/html/draft-rosenberg-mmusic-ice-nonsip-01#section-5.4.2 as cited below:

“ICE defines conditions on which an updated offer is required to be sent after ICE concludes - namely, if the candidates selected by ICE are not a match for the default candidates, an updated exchange is sent.
This function of ICE is primarily an artifact of the realities of SIP deployments. It is not at all needed for correctness of ICE operation. In the case of SIP, signaling intermediaries that are inspecting the offer/answer exchanges, but are not ICE aware, will be confused unless there is an updated exchange. This same consideration applies to using protocols. If the using protocol has deployments with intermediaries that inspect messages, and will be confused if the actual connections/media are established to something different than any defaults that were signaled, the updated exchange should be used. If not, it can be avoided.”

I think that in a pure WebRTC environment the second O/A can be omitted. 

Regards
Thomas 

> Sent: Donnerstag, 24. Oktober 2013 02:45
> To: [email-masked]

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Thu, 24 Oct 2013 12:56:08 +0200

> I think that in a pure WebRTC environment the second O/A can be omitted.

So, basically such a "SDP fix up" is 100% unnecesary for SIP endpoints
in the session, and just "useful" for intermediary servers to know
which media path is being used. IMHO RFC 5245 should NOT state that at
all.

Thanks a lot for the clarification.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 24 Oct 2013 14:28:55 +0000

On Oct 24, 2013, at 4:56 AM, Iñaki Baz Castillo <[email-masked]> wrote:

> IMHO RFC 5245 should NOT state that at
> all.

I will note that people are working on draft-ietf-mmusic-rfc5245bis-00