Subject: [rtcweb] Reflection of SRTP/SDES discussions at IETF 87?

From: Bernard Aboba <[email-masked]>
Date: Mon, 4 Nov 2013 15:14:10 -0800

At IETF 87 we had a discussion of SRTP/SDES.  In looking at the most recent version of several documents, I didn't see the consensus of that discussion reflected.  Was that because the consensus in the room wasn't verified on the list, or some other reason?  Or maybe I missed the text somewhere?  Here is what seemingly relates to this topic: 
 
http://tools.ietf.org/html/draft-ietf-rtcweb-security-arch-07 Section 5.5: 
 
   [OPEN ISSUE:  What should the settings be here?  MUST?]
   Implementations MAY support SDES for media traffic for backward
   compatibility purposes.
 
[BA] As I recall, the room consensus was MUST NOT with respect to SRTP/SDES, no? 
 
http://tools.ietf.org/html/draft-ietf-rtcweb-security
 
[BA] Nothing related to key management (which seems fine). 
 
http://tools.ietf.org/html/draft-ietf-rtcweb-rtp-usage
 
[BA]  The security and security-architecture documents are referenced normatively in Section 13 Security Considerations (which seems fine).

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 4 Nov 2013 15:35:12 -0800

I haven't updated the documents at all.

Yes, I am a bad person.

-Ekr

On Mon, Nov 4, 2013 at 3:14 PM, Bernard Aboba <[email-masked]>wrote:

> At IETF 87 we had a discussion of SRTP/SDES.  In looking at the most
> recent version of several documents, I didn't see the consensus of that
> discussion reflected.  Was that because the consensus in the room wasn't
> verified on the list, or some other reason?  Or maybe I missed the text
> somewhere?  Here is what seemingly relates to this topic:
>
> [BA]  The security and security-architecture documents are referenced
> normatively in Section 13 Security Considerations (which seems fine).
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 4 Nov 2013 16:38:49 -0800

Ekr said: 

"Yes, I am a bad person." [BA] I'll open a TRAC issue.  You can point to it if the Wednesday morning "Internet hardening" plenary crowd gets unruly :)

---

From: Tony Hansen <[email-masked]>
Date: Mon, 04 Nov 2013 19:57:30 -0500

On 11/4/13, 7:38 PM, Bernard Aboba wrote:
> Ekr said:
>
> "Yes, I am a bad person."
> [BA] I'll open a TRAC issue.  You can point to it if the Wednesday 
> morning "Internet hardening" plenary crowd gets unruly :)

EKR, do you have your Evil Bit set properly?

     Tony Hansen

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 04 Nov 2013 17:01:46 -0800

On 11/4/13 4:57 PM, Tony Hansen wrote:
>> [BA] I'll open a TRAC issue.  You can point to it if the
>> Wednesday morning "Internet hardening" plenary crowd gets unruly
>> :)
> 

He only said that he's bad. It remains to be determined whether he is
also evil. ;-)

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/