Subject: [rtcweb] No-Bundle in just one peer

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 11 Nov 2013 19:12:01 +0100

Hi,

In case peer A sends a SPD without Bundle support (so it needs to receive
incoming tracks in separate ports and send tracks from separate ports) does
it aslo mean that peer B must not use Bundle? Or could peer A use two local
ports (no Bundle) to send/receive tracks to/from a single port in peer B?

Thanks a lot.

--
Iñaki Baz Castillo
<[email-masked]>

---

From: Lorenzo Miniero <[email-masked]>
Date: Mon, 11 Nov 2013 19:17:12 +0100

Il giorno Mon, 11 Nov 2013 19:12:01 +0100
Iñaki Baz Castillo <[email-masked]> ha scritto:

> Hi,
> 
> In case peer A sends a SPD without Bundle support (so it needs to
> receive incoming tracks in separate ports and send tracks from
> separate ports) does it aslo mean that peer B must not use Bundle? Or
> could peer A use two local ports (no Bundle) to send/receive tracks
> to/from a single port in peer B?
> 
> Thanks a lot.
> 
> --
> Iñaki Baz Castillo
> <[email-masked]>

Hi Iñaki,

not sure what the spec currently mandates, but this works already in
existing implementations. Peer A just needs to do the ICE and DTLS
dance twice from its two ports towards the single port in B (twice or
more, in case you're not muxing RTCP either).

Lorenzo

---

From: Justin Uberti <[email-masked]>
Date: Mon, 11 Nov 2013 13:03:43 -0800

No, B cannot BUNDLE if A is not BUNDLEing. There are a number of corner
cases where things don't work right in the situation described above.

On Mon, Nov 11, 2013 at 10:17 AM, Lorenzo Miniero <[email-masked]>wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 12 Nov 2013 00:54:49 +0000

Hi,

Justin is correct.

At one point we made a decision, that either both endpoints do BUNDLE, or no endpoint does BUNDLE.

A, not supporting BUNDLE, may not like receiving an SDP Answer from B with a shared address assigned to multiple m- lines.

Regards,

Christer

Lähettäjä: [email-masked] [mailto:[email-masked]] Puolesta Justin Uberti
Lähetetty: 11. marraskuuta 2013 23:04
Vastaanottaja: Lorenzo Miniero
Kopio: [email-masked]
Aihe: Re: [rtcweb] No-Bundle in just one peer

No, B cannot BUNDLE if A is not BUNDLEing. There are a number of corner cases where things don't work right in the situation described above.

On Mon, Nov 11, 2013 at 10:17 AM, Lorenzo Miniero <[email-masked]<mailto:[email-masked]>> wrote:
Il giorno Mon, 11 Nov 2013 19:12:01 +0100
Iñaki Baz Castillo <[email-masked]<mailto:[email-masked]>> ha scritto:

> <[email-masked]<mailto:[email-masked]>>

Hi Iñaki,

Lorenzo
_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Tue, 12 Nov 2013 01:58:45 +0100

Clear. Thanks to all.

2013/11/12 Christer Holmberg <[email-masked]>:
> A, not supporting BUNDLE, may not like receiving an SDP Answer from B with a
> shared address assigned to multiple m- lines.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
>
>

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Lorenzo Miniero <[email-masked]>
Date: Wed, 13 Nov 2013 12:22:46 +0100

Il giorno Tue, 12 Nov 2013 01:58:45 +0100

> Clear. Thanks to all.

Thanks Justin and Christer for the clarification (I just did my bundle
catchup reading the draft and MMUSIC posts, mea culpa!) and sorry Iñaki
for the misinformation. ;-)

Lorenzo

> > A, not supporting BUNDLE, may not like receiving an SDP Answer from
> > B with a shared address assigned to multiple m- lines.
> >
> >
> >
> > Regards,
> >
> >
> >
> > Christer
> >
> >
> >
> >
> >
> > No, B cannot BUNDLE if A is not BUNDLEing. There are a number of
> > corner cases where things don't work right in the situation
> > described above.
> >
> >
> >
> > On Mon, Nov 11, 2013 at 10:17 AM, Lorenzo Miniero
> > <[email-masked]> wrote:
> >
> >> separate ports) does it aslo mean that peer B must not use Bundle?
> >> Or could peer A use two local ports (no Bundle) to send/receive
> >> tracks to/from a single port in peer B?
> >>
> >> Thanks a lot.
> >>
> >> --
> >> Iñaki Baz Castillo
> >> <[email-masked]>
> >
> > Hi Iñaki,
> >
> > dance twice from its two ports towards the single port in B (twice
> > or more, in case you're not muxing RTCP either).
> >
> > Lorenzo

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Wed, 13 Nov 2013 12:24:03 +0100

> for the misinformation. ;-)

Not at all! Thanks to you all.

-- 
Iñaki Baz Castillo
<[email-masked]>