Subject: Re: [rtcweb] opportunity cost (was MTI video codec, charter, RFC 3929)

From: Bernard Aboba <[email-masked]>
Date: Wed, 13 Nov 2013 15:06:06 -0800

Keith Drage said: 
 
"Agree
 I am at the point where I would prefer to spend the meeting cycles getting things we can agree on, rather than where we seem to be at the moment with an issue where there are two clear camps and no real sign of a compromise. Ultimately the market will decide (and some parts of it probably have already decided - which is probably the reason for no progress). Keith" [BA] Well said. With most of the RTCWEB WG drafts either having completed WGLC or being candidates for WGLC by the end of the year,  with some elbow grease it seems very possible to move the bulk of the documents to IETF last call within a few months at most.   Polishing the RTCWEB document set would yield multiple benefits.  Not only would it get us closer to the goal of standardizing the WebRTC protocol stack, but also might well turn up an issue or two we haven't thought enough about. Also, once we move the protocol stack further along, we'll have more cycles to spend on operational issues (like monitoring concerns discussed in XRBLOCK), which currently limit the ability to deploy WebRTC at very large scale.   Unfortunately, we've been spending so much time on the MTI video codec debate that less glamorous (but ultimately much more important) engineering work is being neglected.  This is all by way of seconding your point that there is a real opportunity cost to the never-ending, energy sapping MTI codec discussion.  Personally, I'd much rather redirect the work of the Internet Engineering Task Force RTCWEB WG away from amateur lawyering toward engineering where we actually have expertise and could potentially make a difference.

---

From: Göran Eriksson AP <[email-masked]>
Date: Thu, 14 Nov 2013 00:42:24 +0000

+1

14 nov 2013 kl. 00:06 skrev "Bernard Aboba" <[email-masked]<mailto:[email-masked]>>:

Keith Drage said:

"Agree

I am at the point where I would prefer to spend the meeting cycles getting things we can agree on, rather than where we seem to be at the moment with an issue where there are two clear camps and no real sign of a compromise.

Ultimately the market will decide (and some parts of it probably have already decided - which is probably the reason for no progress).

Keith"

[BA] Well said. With most of the RTCWEB WG drafts either having completed WGLC or being candidates for WGLC by the end of the year,  with some elbow grease it seems very possible to move the bulk of the documents to IETF last call within a few months at most.   Polishing the RTCWEB document set would yield multiple benefits.  Not only would it get us closer to the goal of standardizing the WebRTC protocol stack, but also might well turn up an issue or two we haven't thought enough about. Also, once we move the protocol stack further along, we'll have more cycles to spend on operational issues (like monitoring concerns discussed in XRBLOCK), which currently limit the ability to deploy WebRTC at very large scale.   Unfortunately, we've been spending so much time on the MTI video codec debate that less glamorous (but ultimately much more important) engineering work is being neglected.

This is all by way of seconding your point that there is a real opportunity cost to the never-ending, energy sapping MTI codec discussion.  Personally, I'd much rather redirect the work of the Internet Engineering Task Force RTCWEB WG away from amateur lawyering toward engineering where we actually have expertise and could potentially make a difference.
_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Erik Lagerway <[email-masked]>
Date: Wed, 13 Nov 2013 16:50:57 -0800

+1

*Erik Lagerway <http://ca.linkedin.com/in/lagerway> |
*Hookflash<http://hookflash.com/>* |
1 (855) Hookflash ext. 2 | Twitter
<http://twitter.com/elagerway> | WebRTC.is Blog <http://webrtc.is/> *

On Wed, Nov 13, 2013 at 4:42 PM, Göran Eriksson AP <
[email-masked]> wrote:

>  +1
>
> 14 nov 2013 kl. 00:06 skrev "Bernard Aboba" <[email-masked]>:
>
>   Keith Drage said:
>
> "Agree
>
> I am at the point where I would prefer to spend the meeting cycles getting
> things we can agree on, rather than where we seem to be at the moment with
> an issue where there are two clear camps and no real sign of a compromise.
>
> Ultimately the market will decide (and some parts of it probably have
> already decided - which is probably the reason for no progress).
>
> Keith"
>
> [BA] Well said. With most of the RTCWEB WG drafts either having completed
> WGLC or being candidates for WGLC by the end of the year,  with some elbow
> grease it seems very possible to move the bulk of the documents to IETF
> last call within a few months at most.   Polishing the RTCWEB document set
> would yield multiple benefits.  Not only would it get us closer to the goal
> of standardizing the WebRTC protocol stack, but also might well turn up an
> issue or two we haven't thought enough about. Also, once we move the
> protocol stack further along, we'll have more cycles to spend on
> operational issues (like monitoring concerns discussed in XRBLOCK), which
> currently limit the ability to deploy WebRTC at very large scale.
> Unfortunately, we've been spending so much time on the MTI video codec
> debate that less glamorous (but ultimately much more important) engineering
> work is being neglected.
>
> This is all by way of seconding your point that there is a real
> opportunity cost to the never-ending, energy sapping MTI codec discussion.
> Personally, I'd much rather redirect the work of the Internet Engineering
> Task Force RTCWEB WG away from amateur lawyering toward engineering where
> we actually have expertise and could potentially make a difference.
>
> [email-masked]
> [email-masked]

---

From: Chris Wendt <[email-masked]>
Date: Wed, 13 Nov 2013 21:19:30 -0500

+1

---

From: "Parthasarathi R" <[email-masked]>
Date: Sun, 17 Nov 2013 23:27:32 +0530

+1

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Erik Lagerway
Sent: Thursday, November 14, 2013 6:21 AM
To: Göran Eriksson AP
Cc: [email-masked]
Subject: Re: [rtcweb] opportunity cost (was MTI video codec, charter, RFC
3929)

+1  

 <http://ca.linkedin.com/in/lagerway> Erik Lagerway |
<http://hookflash.com/> Hookflash | 1 (855) Hookflash ext. 2 |
<http://twitter.com/elagerway> Twitter |  <http://webrtc.is/> WebRTC.is Blog

On Wed, Nov 13, 2013 at 4:42 PM, Göran Eriksson AP
<[email-masked]> wrote:

+1

Keith Drage said: 
 
"Agree

Keith"

[BA] Well said. With most of the RTCWEB WG drafts either having completed
WGLC or being candidates for WGLC by the end of the year,  with some elbow
grease it seems very possible to move the bulk of the documents to IETF last
call within a few months at most.   Polishing the RTCWEB document set would
yield multiple benefits.  Not only would it get us closer to the goal of
standardizing the WebRTC protocol stack, but also might well turn up an
issue or two we haven't thought enough about. Also, once we move the
protocol stack further along, we'll have more cycles to spend on operational
issues (like monitoring concerns discussed in XRBLOCK), which currently
limit the ability to deploy WebRTC at very large scale.   Unfortunately,
we've been spending so much time on the MTI video codec debate that less
glamorous (but ultimately much more important) engineering work is being
neglected. 

This is all by way of seconding your point that there is a real opportunity
cost to the never-ending, energy sapping MTI codec discussion.  Personally,
I'd much rather redirect the work of the Internet Engineering Task Force
RTCWEB WG away from amateur lawyering toward engineering where we actually
have expertise and could potentially make a difference.

---

From: Varun Singh <[email-masked]>
Date: Sun, 17 Nov 2013 23:43:45 +0200

+1, to focus on engineering and operational issues.

On Nov 14, 2013, at 1:06, Bernard Aboba <[email-masked]> wrote:

 Keith Drage said:

"Agree

Keith"

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 18 Nov 2013 05:46:56 +0100

> +1, to focus on engineering and operational issues.

Since firewall traversal was deemed to be a subject so specialized we
couldn't debate it on the main list, perhaps we could have an MTI-only
sublist?

I'll personally commit to reading every message on it, but I suspect
there are people on this mailing list who would like not to.

>
> On Nov 14, 2013, at 1:06, Bernard Aboba <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>> Keith Drage said:
>>  
>> "Agree
>>  
>> I am at the point where I would prefer to spend the meeting cycles
>> getting things we can agree on, rather than where we seem to be at
>> the moment with an issue where there are two clear camps and no real
>> sign of a compromise.
>>  
>> [BA] Well said. With most of the RTCWEB WG drafts either having
>> completed WGLC or being candidates for WGLC by the end of the year, 
>> with some elbow grease it seems very possible to move the bulk of the
>> documents to IETF last call within a few months at most.   Polishing
>> the RTCWEB document set would yield multiple benefits.  Not only
>> would it get us closer to the goal of standardizing the WebRTC
>> protocol stack, but also might well turn up an issue or two we
>> haven't thought enough about. Also, once we move the protocol stack
>> further along, we'll have more cycles to spend on operational issues
>> (like monitoring concerns discussed in XRBLOCK), which currently
>> limit the ability to deploy WebRTC at very large scale.  
>> Unfortunately, we've been spending so much time on the MTI video
>> codec debate that less glamorous (but ultimately much more important)
>> engineering work is being neglected.
>>  
>> opportunity cost to the never-ending, energy sapping MTI codec
>> discussion.  Personally, I'd much rather redirect the work of the
>> Internet Engineering Task Force RTCWEB WG away from amateur lawyering
>> toward engineering where we actually have expertise and could
>> potentially make a difference.
>> [email-masked] <mailto:[email-masked]>

-- 
Surveillance is pervasive. Go Dark.

---

From: "Chenxin (Xin)" <[email-masked]>
Date: Mon, 18 Nov 2013 06:32:57 +0000

+1, to focus on engineering and operational issues too.

I suggest to keep it on the main list now. The technical debate on the MTI video is enough. We need focus on how to handle this dilemma. I think that move the discussion to the sub-list will not be helpful, which should not need a long time technical discussion in this stage.

But I am fine if you think the sub-mailing list is used for the strategy. I am just afraid that  moving the discussion will delay the decision on MTI because losing focus and so on.

Best Regards,
     Xin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Harald Alvestrand
Sent: Monday, November 18, 2013 12:47 PM
To: [email-masked]
Subject: Re: [rtcweb] opportunity cost (was MTI video codec, charter, RFC 3929)

Since firewall traversal was deemed to be a subject so specialized we couldn't debate it on the main list, perhaps we could have an MTI-only sublist?

I'll personally commit to reading every message on it, but I suspect there are people on this mailing list who would like not to.

On Nov 14, 2013, at 1:06, Bernard Aboba <[email-masked]<mailto:[email-masked]>> wrote:
Keith Drage said:

"Agree

Keith"

rtcweb mailing list

--

---

From: Matt Fredrickson <[email-masked]>
Date: Mon, 18 Nov 2013 10:25:46 -0600

+1

Matthew Fredrickson

On Mon, Nov 18, 2013 at 12:32 AM, Chenxin (Xin)
<[email-masked]> wrote:
> I suggest to keep it on the main list now. The technical debate on the MTI
> video is enough. We need focus on how to handle this dilemma. I think that
> move the discussion to the sub-list will not be helpful, which should not
> need a long time technical discussion in this stage.
>
>
>
> But I am fine if you think the sub-mailing list is used for the strategy. I
> am just afraid that  moving the discussion will delay the decision on MTI
> because losing focus and so on.
>
>
>
>
>
> Best Regards,
>
>      Xin
>
>
>
> Harald Alvestrand
> I'll personally commit to reading every message on it, but I suspect there
> are people on this mailing list who would like not to.
>
>
>

---

From: Varun Singh <[email-masked]>
Date: Mon, 18 Nov 2013 18:27:28 -0800

> are people on this mailing list who would like not to.

if other codecs are being discussed (H.261/3, Theora), it may affect the
traffic model discussion in RMCAT , i.e., how much variability in
sending rates can be expected for a target rate and how quickly can the
codec respond to a new rate request.

If the expected behavior is very different from the discussions on
traffic models (in Vancouver), having those discussions helps us
understand the congestion control requirements better.

-- 
http://www.netlab.tkk.fi/~varun/