Subject: [rtcweb] PM-DIR review of draft-ietf-rtcweb-rtp-usage-10

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 18 Nov 2013 16:45:28 +0000

This is the PM-DIR review of draft-ietf-rtcweb-rtp-usage-10. I am the assigned PM-DIR reviewer for this I-D. 

This Internet-Draft defines the media transport aspects and provides the details of the RTP usage in WebRTC - specifically the requirements for which RTP features, profiles and extensions need to be supported in WebRTC. 

The I-D does not define performance metrics, so a 6390 review does not apply. 

The I-D includes a short section (section 8) dedicated to 'WebRTC Use of RTP: Performance Monitoring'. I am fine with the content of this section with two comments: 

1. 
>  It is not yet clear
   what extended metrics are appropriate for use in the WebRTC context,
   so implementations are not expected to generate any RTCP XR packets.

I believe that it would be more appropriate to replace ' implementations are not expected ' by ' implementations are not required '

2. 
>  A large number of additional performance metrics are supported by the
   RTCP Extended Reports (XR) framework [RFC3611].  

I think that mentioning 3611 only is limiting nowadays and that RFC 6792 should be mentioned as well.

Regards,

Dan

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 19 Nov 2013 11:54:54 +0100

Hi Dan,

Thanks for your review. I see no issue with changing the document as you
have requested.

Cheers

Magnus

On 2013-11-18 17:45, Romascanu, Dan (Dan) wrote:
> This Internet-Draft defines the media transport aspects and provides
> the details of the RTP usage in WebRTC - specifically the
> requirements for which RTP features, profiles and extensions need to
> be supported in WebRTC.
> 
> The I-D includes a short section (section 8) dedicated to 'WebRTC Use
> of RTP: Performance Monitoring'. I am fine with the content of this
> section with two comments:
> 
> 1.
>> It is not yet clear
> I believe that it would be more appropriate to replace '
> implementations are not expected ' by ' implementations are not
> required '
> 
> 2.
> _______________________________________________ rtcweb mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/rtcweb
> 
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------