Subject: Re: [rtcweb] API standardization on phones? (Re: Platforms that support H264)

From: Randell Jesup <[email-masked]>
Date: Sun, 03 Nov 2013 20:44:30 -0800

On 11/3/2013 12:34 PM, DRAGE, Keith (Keith) wrote:
> The only stuff I am aware of is done by
> http://www.khronos.org/
> But that is as far as my knowledge goes.

My understanding from someone at Skype who worked with OMX stuff was 
that it was horribly poorly compatible because most people never ran any 
of the test suites that Kronos charges for.  Take with a huge grain of 
salt as this is second-hand and wasn't the primary topic.

> It would certainly be desireable that there is an standardised API 
> that everyone uses to get access to embedded hardware codec support.

Always a good thing, if it's done well.

> Keith
>
>     ------------------------------------------------------------------------
>     *From:* [email-masked] [mailto:[email-masked]]
>     *On Behalf Of *Harald Alvestrand
>     *Sent:* 03 November 2013 18:10
>     *To:* [email-masked]
>     *Subject:* [rtcweb] API standardization on phones? (Re: Platforms
>     that support H264)
>
>     On 11/03/2013 06:52 PM, DRAGE, Keith (Keith) wrote:
>>     And this is where it would be useful to see some work done,
>>     although probably not by IETF.
>>     There a a few bits of API work out there, but nowhere do we see
>>     much push for adoption. As fae as I see there is no political
>>     reason why they should not be adopted, or even a fresh effort
>>     adopted to create some new ones. The only thing seems to be lack
>>     of impetus.
>
>     What's the industry state on standardization of APIs for phones?
>
>     Most of what I see seems to be platform specific, with some
>     exceptions (OpenGL / WebGL for graphics, OpenES for audio).
>
>     But it's not where I spend the most time looking; it would be good
>     to have someone who knows this space summarize 
>

-- 
Randell Jesup
[email-masked]

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Tue, 5 Nov 2013 09:52:06 +0000

Khronos OpenMAX IL is the de facto standard for how all chipset vendors expose their codecs to the OS/platform. The problem is the OS/platform does not usually expose those same codecs up to apps with the same API richness (or at all). There are unofficial/hacky ways to access this in Android via IOMX (NDK), or iOS via AV Foundation, as well as official ways in Android 4.1+ via MediaCodec (SDK). But they typically lack the richness of the underlying OMX IL from the chipset vendors, especially real-time and error resilience features.

In my experience with the dominant codec silicon vendors (QCOM, IMG, TI, etc.), their OMX IL implementations are quite robust but not fully interchangeable, i.e. the OS/platform (or app) must cope with different feature sets across the various vendor components.

Mo

On 11/3/13, 11:44 PM, Randell Jesup <[email-masked]<mailto:[email-masked]>> wrote:

http://www.khronos.org/

My understanding from someone at Skype who worked with OMX stuff was that it was horribly poorly compatible because most people never ran any of the test suites that Kronos charges for.  Take with a huge grain of salt as this is second-hand and wasn't the primary topic.

It would certainly be desireable that there is an standardised API that everyone uses to get access to embedded hardware codec support.

Keith

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Harald Alvestrand
Sent: 03 November 2013 18:10
To: [email-masked]<mailto:[email-masked]>
Subject: [rtcweb] API standardization on phones? (Re: Platforms that support H264)

On 11/03/2013 06:52 PM, DRAGE, Keith (Keith) wrote:
And this is where it would be useful to see some work done, although probably not by IETF.

There a a few bits of API work out there, but nowhere do we see much push for adoption. As fae as I see there is no political reason why they should not be adopted, or even a fresh effort adopted to create some new ones. The only thing seems to be lack of impetus.

Most of what I see seems to be platform specific, with some exceptions (OpenGL / WebGL for graphics, OpenES for audio).

But it's not where I spend the most time looking; it would be good to have someone who knows this space summarize

--
Randell Jesup
[email-masked]<mailto:[email-masked]>