Subject: [rtcweb] Apparently TLS is IPR-encumbered

From: cowwoc <[email-masked]>
Date: Tue, 26 Nov 2013 18:03:28 -0500

http://yro.slashdot.org/story/13/11/26/1927254/jury-finds-newegg-infringed-patent-owes-23-million

This is meant to be funny, but it just goes to show you the kind of 
stupid situations that software patents result in. I assume we don't use 
RC4 ciphers? :)

Gili

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 26 Nov 2013 23:14:57 +0000

> stupid situations that software patents result in. I assume we don't use

RC4 is in common use with TLS. For other reasons we're in
the process of working on BCPs for more desirable/modern
ciphersuites for (D)TLS. This WG could well select some
ciphersuites that you like better (or maybe you have, I've
not read the drafts recently, sorry).

S.

> 
> Gili
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
> 
>

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Nov 2013 15:22:59 -0800

On 26 November 2013 15:14, Stephen Farrell <[email-masked]> wrote:
> This WG could well select some
> ciphersuites that you like better

DTLS doesn't use RC4.  It's a little tricky dealing with a stream
cipher in datagram mode.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 26 Nov 2013 23:38:25 +0000

> DTLS doesn't use RC4.  It's a little tricky dealing with a stream

Sorry yes, I meant that even if rtcweb don't like the generic
BCP stuff that TLS (or UTA) does, for (D)TLS this wg can always
pick its own preferred ciphersuites.

S.

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Nov 2013 15:44:46 -0800

> pick its own preferred ciphersuites.

Definitely.  For instance, I'm currently considering the raising of
the bar for identity to SHA-256.  There's no point in building a new
thing on top of SHA-1.  First, I'll have to check whether that's at
all possible.

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 27 Nov 2013 04:40:52 +0000

If you are interested in this case and in high-powered, successful trolls,
I recommend this article:
http://arstechnica.com/tech-policy/2013/11/newegg-on-trial-mystery-company-
tqp-re-writes-the-history-of-encryption/  There are also a number of blog
posts in IP professional blogs, but those are full of jargon.

A few data points for those with no or only little time to read:
-Spangenberg is perhaps the most successful troll on the planet.
-the industry at large has paid many millions in royalties for this patent
already.  For example, MS paid $1M, and Amazon $0.5M
-the patent reportedly expired in mid 2012.  Which does not necessarily
mean that you cannot be sued for past infringement (that timeframe will
only be up around 2018).
Stephan