Subject: [rtcweb] "pranswer" be applied as an update to a previously sent "answer"?

From: "Lijing (Jessie)" <[email-masked]>
Date: Wed, 20 Nov 2013 11:22:23 +0000

draft-ietf-rtcweb-jsep-05 -----Section 4.1.3 says:

"pranswer" indicates that a description should be parsed as an
   answer, but not a final answer, and so should not result in the
   freeing of allocated resources.  It may result in the start of media
   transmission, if the answer does not specify an inactive media
   direction.  A description used as a "pranswer" may be applied as a
   response to an "offer", or an update to a previously sent "answer".

How can a pranswer be applied as an update to a previously sent answer?  I am not sure what's the corresponding scenario.
>From the state machine perspective, when answer is received, it enters the stable state. At this point, the state machine can not directly jump to local pranswer or remote pranswer state.

My two cents: May be it needs more description or correction here.

________________________________
Huawei Technologies Co., Ltd.
Bantian, Longgang District,Shenzhen 518129, P.R.China
http://www.huawei.com
Email: [email-masked]
________________________________

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 21 Nov 2013 13:19:47 +0100

On 11/20/2013 12:22 PM, Lijing (Jessie) wrote:
> How can a pranswer be applied as an update to a previously sent 
> answer?  I am not sure what's the corresponding scenario.
>
> From the state machine perspective, when answer is received, it enters 
> the stable state. At this point, the state machine can not directly 
> jump to local pranswer or remote pranswer state.
>

This makes sense, and is consistent with the state diagrams, if the last 
"answer" is changed to "pranswer".

Justin, is this an error in the draft?

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 21 Nov 2013 13:05:41 +0000

Hi,

I would assume that the text should say "update to a previously applied "pranswer".

Regards,

Christer

From: rtcweb [mailto:[email-masked]] On Behalf Of Harald Alvestrand
Sent: 21. marraskuuta 2013 14:20
To: [email-masked]
Subject: Re: [rtcweb] "pranswer" be applied as an update to a previously sent "answer"?

This makes sense, and is consistent with the state diagrams, if the last "answer" is changed to "pranswer".

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 21 Nov 2013 10:17:52 -0800

On Nov 21, 2013, at 5:05 AM, Christer Holmberg <[email-masked]> wrote:

> Hi,
>  
> I would assume that the text should say “update to a previously applied “pranswer”.
>  
> Regards,

+1 

> How can a pranswer be applied as an update to a previously sent answer?  I am not sure what’s the corresponding scenario.
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Justin Uberti <[email-masked]>
Date: Thu, 21 Nov 2013 12:26:25 -0800

Yes, it is an error. Someone else pointed it out to me right after I
submitted -05; will be fixed in the next rev.

On Thu, Nov 21, 2013 at 10:17 AM, Cullen Jennings <[email-masked]> wrote:

> > How can a pranswer be applied as an update to a previously sent answer?
>  I am not sure what’s the corresponding scenario.
> the stable state. At this point, the state machine can not directly jump to
> local pranswer or remote pranswer state.
> >