Subject: [rtcweb] Last day for any additional Video Codec Selection alternatives

From: Magnus Westerlund <[email-masked]>
Date: Wed, 27 Nov 2013 09:54:48 +0100

WG,

Today (27th November) is the last day to propose any additional
alternatives for the Video Codec Selection.

The current list of alternatives are the following:

 1. All entities MUST support H.264
 2. All entities MUST support VP8
 3. All entities MUST support both H.264 and VP8
 4. Browsers MUST support both H.264 and VP8, other entities MUST
    support at least one of H.264 and VP8
 5. All entities MUST support at least one of H.264 and VP8
 6. All entities MUST support H.261
 7. There is no MTI video codec
 8. 5+6, i.e. All entities MUST support H.261 and all entities MUST
    support at least one of H.264 and VP8
 9. All entities MUST support Theora.
10. All entities MUST implement at least two of {VP8, H.264 CBP, H.261}
11. All entities MUST implement at least two of {VP8, H.264 CBP, H.263}
12. All entities MUST support decoding using both H.264 and VP8, and
    MUST support encoding using at least one of H.264 or VP8

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 27 Nov 2013 10:15:13 +0100

WG,

I got a comment that it was a bit confusing that just 10 and 11
contained the Constrained Baseline Profile. To my understanding all
mentionings of H.264 reference the proposal in
https://datatracker.ietf.org/doc/draft-burman-rtcweb-h264-proposal/

and all VP8 are a reference to
https://datatracker.ietf.org/doc/draft-alvestrand-rtcweb-vp8/

This has been edited into the Wiki list:
http://trac.tools.ietf.org/wg/rtcweb/trac/wiki/WikiStart

That thus read:

 The following alternatives has been proposed:

 1. All entities MUST support H.264
 2. All entities MUST support VP8
 3. All entities MUST support both H.264 and VP8
 4. Browsers MUST support both H.264 and VP8, other entities MUST
    support at least one of H.264 and VP8
 5. All entities MUST support at least one of H.264 and VP8
 6. All entities MUST support H.261
 7. There is no MTI video codec
 8. 5+6, i.e. All entities MUST support H.261 and all entities MUST
    support at least one of H.264 and VP8
 9. All entities MUST support Theora
10. All entities MUST implement at least two of {VP8, H.264, H.261}
11. All entities MUST implement at least two of {VP8, H.264, H.263}
12. All entities MUST support decoding using both H.264 and VP8, and
    MUST support encoding using at least one of H.264 or VP8

H.264 is a reference to the proposal in ​
https://datatracker.ietf.org/doc/draft-burman-rtcweb-h264-proposal/

VP8 is a reference to the proposal in ​
https://datatracker.ietf.org/doc/draft-alvestrand-rtcweb-vp8/

Cheers

Magnus

On 2013-11-27 09:54, Magnus Westerlund wrote:
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
> 
> 

-- 

Magnus Westerlund

---

From: Emil Ivov <[email-masked]>
Date: Wed, 27 Nov 2013 12:41:12 +0100

Just to confirm, this is NOT the last day of discussion on whether a 
vote is the right way to do this at all, right?

That sounds like it would still be an open question for step two here:

http://www.ietf.org/mail-archive/web/rtcweb/current/msg09909.html

It's not explicitly stated though so a confirmation would be nice.

Emil

On 27.11.13, 09:54, Magnus Westerlund wrote:
> .

-- 
https://jitsi.org

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 27 Nov 2013 13:32:35 +0100

> vote is the right way to do this at all, right?

No, but tomorrow a week will have passed since we chairs sent out the
proposal and solicited feedback on the proposal.

> http://www.ietf.org/mail-archive/web/rtcweb/current/msg09909.html

As we stated in this message, after the week we chairs would update the
process proposal if we considered it necessary. I believe there are some
clarifications that needs to be done, including the voter eligibility.

After that the stated plan was to hold a consensus call in the WG to use
the proposed process.

Cheers

Magnus Westerlund

---

From: Gaelle Martin-Cocher <[email-masked]>
Date: Wed, 27 Nov 2013 16:28:57 +0000

Dear All,

Sorry for this late message, I was not available this past week.

It has been mentioned by a few of us that the risks on VP8 that some can't leave with, can be mitigated when VP8 becomes an ISO standard (via MPEG). 
VP8 has a chance to become an MPEG deliverable in January. I believe that could make a few of us more comfortable with supporting/mandating both H264 and VP8 and could change the consensus reaching process.

Can we give VP8 that chance before forcing a vote?

Thanks
Sincerely,
Gaëlle

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Magnus Westerlund
Sent: Wednesday, November 27, 2013 7:33 AM
To: Emil Ivov
Cc: [email-masked]
Subject: Re: [rtcweb] Last day for any additional Video Codec Selection alternatives

> vote is the right way to do this at all, right?

No, but tomorrow a week will have passed since we chairs sent out the proposal and solicited feedback on the proposal.

> http://www.ietf.org/mail-archive/web/rtcweb/current/msg09909.html

As we stated in this message, after the week we chairs would update the process proposal if we considered it necessary. I believe there are some clarifications that needs to be done, including the voter eligibility.

After that the stated plan was to hold a consensus call in the WG to use the proposed process.

Cheers

Magnus Westerlund

_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb
---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Gaelle Martin-Cocher <[email-masked]>
Date: Wed, 27 Nov 2013 19:38:44 +0000

If we proceed with the vote, I would like to see the following choice:
All entities must support H263.

Thanks
Gaëlle

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Gaelle Martin-Cocher
Sent: Wednesday, November 27, 2013 11:29 AM
To: Magnus Westerlund; Emil Ivov
Cc: [email-masked]
Subject: Re: [rtcweb] Last day for any additional Video Codec Selection alternatives

Dear All,

Thanks
Sincerely,
Gaëlle

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Magnus Westerlund
Sent: Wednesday, November 27, 2013 7:33 AM
To: Emil Ivov
Cc: [email-masked]
Subject: Re: [rtcweb] Last day for any additional Video Codec Selection alternatives

Cheers

Magnus Westerlund

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Nov 2013 11:49:08 -0800

> alternatives for the Video Codec Selection.

Just to cover all bases, I think that there is one important option missing:

X. The working group MUST make no MTI recommendation regarding video codecs.

Just to put it on the table at this level.  I suspect that many will
prefer this over their most hated alternatives.

---

From: Paul Giralt <[email-masked]>
Date: Wed, 27 Nov 2013 15:14:05 -0500

How is that different from Option 7? 

-Paul

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 27 Nov 2013 12:33:04 -0800

It appears different because not only would it not choose an MTI codec from among the present list of alternatives, but it also would take the MTI discussion off the table in the future as well. 
> From: [email-masked]
> Date: Wed, 27 Nov 2013 15:14:05 -0500
> To: [email-masked]
> CC: [email-masked]

---

From: cowwoc <[email-masked]>
Date: Wed, 27 Nov 2013 15:39:48 -0500

Option 7 already implies that to me. I'm in favor of leaving the list 
as-is or amending #7.

Gili

On 27/11/2013 3:33 PM, Bernard Aboba wrote:
> It appears different because not only would it not choose an MTI codec 
> from among the present list of alternatives, but it also would take 
> the MTI discussion off the table in the future as well.
>
> > From: [email-masked]

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Nov 2013 12:57:08 -0800

My bad.  Lost 7 in the middle of the list.

---

From: Frode Kileng <[email-masked]>
Date: Wed, 27 Nov 2013 21:58:15 +0100

Hi,

I guess this could wait, or is considered implicit by many, but I would 
propose that the following text is added to all options, i.e. similar to 
the text added to draft-ietf-rtcweb-audio-03:

     If other suitable video codecs are available to use, it is RECOMMENDED
     that they are also be included in the offer in order to maximize the
     possibility to establish the session without the need for video 
transcoding.

It may help comforting "the losers" and be useful in sourcing processes 
within big companies...

Best regards
Frode Kileng

---

From: Ted Hardie <[email-masked]>
Date: Wed, 27 Nov 2013 13:36:25 -0800

> All entities must support H263.
I've updated the wiki to include this as choice 13.  If you have a
reference that we could use that specifies version, annexes, or any other
additional detail, we can include a pointer.

Ted

> It has been mentioned by a few of us that the risks on VP8 that some can't
> leave with, can be mitigated when VP8 becomes an ISO standard (via MPEG).
> VP8 has a chance to become an MPEG deliverable in January. I believe that
> could make a few of us more comfortable with supporting/mandating both H264
> and VP8 and could change the consensus reaching process.
>
> This transmission (including any attachments) may contain confidential
> information, privileged material (including material protected by the
> solicitor-client or other applicable privileges), or constitute non-public
> information. Any use of this information by anyone other than the intended
> recipient is prohibited. If you have received this transmission in error,
> please immediately reply to the sender and delete this information from
> your system. Use, dissemination, distribution, or reproduction of this
> transmission by unintended recipients is not authorized and may be unlawful.
>
> This transmission (including any attachments) may contain confidential
> information, privileged material (including material protected by the
> solicitor-client or other applicable privileges), or constitute non-public
> information. Any use of this information by anyone other than the intended
> recipient is prohibited. If you have received this transmission in error,
> please immediately reply to the sender and delete this information from
> your system. Use, dissemination, distribution, or reproduction of this
> transmission by unintended recipients is not authorized and may be unlawful.
>

---

From: Silvia Pfeiffer <[email-masked]>
Date: Thu, 28 Nov 2013 08:39:14 +1100

Could we please include also:
All entities MUST implement at least two of {VP8, H.264 CBP, Theora}

Thanks,
Silvia.

On Thu, Nov 28, 2013 at 8:36 AM, Ted Hardie <[email-masked]> wrote:
> On Wed, Nov 27, 2013 at 11:38 AM, Gaelle Martin-Cocher
> <[email-masked]> wrote:
>>
> I've updated the wiki to include this as choice 13.  If you have a reference
> that we could use that specifies version, annexes, or any other additional
> detail, we can include a pointer.
>
> Ted
>
>>
>>
>> please immediately reply to the sender and delete this information from your
>> system. Use, dissemination, distribution, or reproduction of this
>> please immediately reply to the sender and delete this information from your
>> system. Use, dissemination, distribution, or reproduction of this

---

From: Jean-Marc Valin <[email-masked]>
Date: Wed, 27 Nov 2013 16:57:01 -0500

On 11/27/2013 04:39 PM, Silvia Pfeiffer wrote:
> Could we please include also: All entities MUST implement at least
> two of {VP8, H.264 CBP, Theora}

In practice, how does this differ from the option of having Theora as
the single MTI?

	Jean-Marc

> Thanks, Silvia.
>>> If we proceed with the vote, I would like to see the following
>>> choice: All entities must support H263.
>>> 
>>> Thanks Gaëlle
>>> 
>> 
>> I've updated the wiki to include this as choice 13.  If you have
>> a reference that we could use that specifies version, annexes, or
>> any other additional detail, we can include a pointer.
>> 
>> Ted
>> 
>>> 
>>> 
>>> -----Original Message----- From: rtcweb
>>> [mailto:[email-masked]] On Behalf Of Gaelle 
>>> Martin-Cocher Sent: Wednesday, November 27, 2013 11:29 AM To:
>>> Magnus Westerlund; Emil Ivov Cc: [email-masked] Subject: Re:
>>> [rtcweb] Last day for any additional Video Codec Selection 
>>> alternatives
>>> 
>>> Dear All,
>>> 
>>> It has been mentioned by a few of us that the risks on VP8 that
>>> some can't leave with, can be mitigated when VP8 becomes an ISO
>>> standard (via MPEG). VP8 has a chance to become an MPEG
>>> deliverable in January. I believe that could make a few of us
>>> more comfortable with supporting/mandating both H264 and VP8
>>> and could change the consensus reaching process.
>>> 
>>> Thanks Sincerely, Gaëlle
>>> -----Original Message----- From: rtcweb
>>> [mailto:[email-masked]] On Behalf Of Magnus 
>>> Westerlund Sent: Wednesday, November 27, 2013 7:33 AM To: Emil
>>> Ivov Cc: [email-masked] Subject: Re: [rtcweb] Last day for any
>>> additional Video Codec Selection alternatives
>>> 
>>>> Just to confirm, this is NOT the last day of discussion on
>>>> whether a vote is the right way to do this at all, right?
>>> 
>>> No, but tomorrow a week will have passed since we chairs sent
>>> out the proposal and solicited feedback on the proposal.
>>> 
>>>> 
>>> process proposal if we considered it necessary. I believe there
>>> are some clarifications that needs to be done, including the
>>> voter eligibility.
>>> 
>>> Färögatan 6                | Mobile +46 73 0949079 SE-164 80
>>> Stockholm, Sweden| mailto: [email-masked] 
>>> rtcweb mailing list [email-masked] 
>>> information, privileged material (including material protected
>>> by the solicitor-client or other applicable privileges), or
>>> constitute non-public information. Any use of this information
>>> by anyone other than the intended recipient is prohibited. If
>>> you have received this transmission in error, please
>>> immediately reply to the sender and delete this information
>>> from your system. Use, dissemination, distribution, or
>>> reproduction of this transmission by unintended recipients is
>>> not authorized and may be unlawful.
>>> 
>>> _______________________________________________ rtcweb mailing
>>> list [email-masked] 
>>> information, privileged material (including material protected
>>> by the solicitor-client or other applicable privileges), or
>>> constitute non-public information. Any use of this information
>>> by anyone other than the intended recipient is prohibited. If
>>> you have received this transmission in error, please
>>> immediately reply to the sender and delete this information
>>> from your system. Use, dissemination, distribution, or
>>> reproduction of this transmission by unintended recipients is
>>> not authorized and may be unlawful.
>>> 
>>> _______________________________________________ rtcweb mailing
>>> list [email-masked] 
>> _______________________________________________ rtcweb mailing
>> list [email-masked] 
> _______________________________________________ rtcweb mailing
> list [email-masked] https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Silvia Pfeiffer <[email-masked]>
Date: Thu, 28 Nov 2013 09:04:20 +1100

> In practice, how does this differ from the option of having Theora as

It gives people a choice between implementing VP8 or Theora in
addition to H.264 (or between Theora and H.264 in addition to VP8).

Silvia.

BTW: I think the spec ref for Theora is http://www.theora.org/doc/Theora.pdf

---

From: Ted Hardie <[email-masked]>
Date: Wed, 27 Nov 2013 14:07:41 -0800

> All entities MUST implement at least two of {VP8, H.264 CBP, Theora}
Added as item 14.

Ted

> reference
> your
> your

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Wed, 27 Nov 2013 23:31:25 +0100

>alternatives for the Video Codec Selection.

I would like to have available the following additional option:

  All entities MUST support decoding using Theora.

Thank you.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Silvia Pfeiffer <[email-masked]>
Date: Thu, 28 Nov 2013 09:33:11 +1100

>   All entities MUST support decoding using Theora.

So who encodes it? How is that different to option 9?

Silvia.

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Wed, 27 Nov 2013 23:39:51 +0100

>So who encodes it? How is that different to option 9?

There would be no mandatory-to-implement video codec for encoding in
"this" version of the specification should this option be selected.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: cowwoc <[email-masked]>
Date: Wed, 27 Nov 2013 17:56:55 -0500

> "this" version of the specification should this option be selected.

This sounds like a cross-cutting concern that should be extracted from 
voting options (otherwise we'll end up with endless permutations). I 
think we could replace "MUST support X" with "MUST decode X" for all 
options and obviously implementations MUST encode at least one of the 
formats being decoded. Do we really need to specify which formats get 
encoded?

Gili

---

From: Gaelle Martin-Cocher <[email-masked]>
Date: Thu, 28 Nov 2013 18:51:24 +0000

Thanks.

I would propose profile 0 level 70 defined in annex X of
http://www.itu.int/rec/T-REC-H.263/

Sincerely,
Gaëlle

From: Ted Hardie [mailto:[email-masked]]
Sent: Wednesday, November 27, 2013 4:36 PM
To: Gaelle Martin-Cocher
Cc: [email-masked]
Subject: Re: [rtcweb] Last day for any additional Video Codec Selection alternatives

On Wed, Nov 27, 2013 at 11:38 AM, Gaelle Martin-Cocher <[email-masked]<mailto:[email-masked]>> wrote:
If we proceed with the vote, I would like to see the following choice:
All entities must support H263.

Thanks
Gaëlle

I've updated the wiki to include this as choice 13.  If you have a reference that we could use that specifies version, annexes, or any other additional detail, we can include a pointer.

Ted

-----Original Message-----
From: rtcweb [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Gaelle Martin-Cocher
Sent: Wednesday, November 27, 2013 11:29 AM
To: Magnus Westerlund; Emil Ivov
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] Last day for any additional Video Codec Selection alternatives

Dear All,

Thanks
Sincerely,
Gaëlle

-----Original Message-----
From: rtcweb [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Magnus Westerlund
Sent: Wednesday, November 27, 2013 7:33 AM
To: Emil Ivov
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] Last day for any additional Video Codec Selection alternatives

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287<tel:%2B46%2010%207148287>
Färögatan 6                | Mobile +46 73 0949079<tel:%2B46%2073%200949079>
SE-164 80 Stockholm, Sweden| mailto: [email-masked]<mailto:[email-masked]>
----------------------------------------------------------------------

[email-masked]<mailto:[email-masked]>

[email-masked]<mailto:[email-masked]>

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb