Subject: Re: [rtcweb] RFC 6520 vs. draft-ietf-rtcweb-stun-consent-freshness-00

From: "Muthu Arul Mozhi Perumal (mperumal)" <[email-masked]>
Date: Tue, 3 Dec 2013 04:47:22 +0000

|-----Original Message-----
|From: Tirumaleswar Reddy (tireddy)
|Sent: Wednesday, November 27, 2013 6:32 PM
|To: Christer Holmberg; Martin Thomson
|Cc: [email-masked]; [email-masked]
|Subject: RE: [rtcweb] RFC 6520 vs. draft-ietf-rtcweb-stun-consent-freshness-00
|
|> -----Original Message-----
|> From: Christer Holmberg [mailto:[email-masked]]
|> Sent: Wednesday, November 27, 2013 1:32 PM
|> To: Tirumaleswar Reddy (tireddy); Martin Thomson
|> Cc: [email-masked]; [email-masked]
|> Subject: RE: [rtcweb] RFC 6520 vs. draft-ietf-rtcweb-stun-consent-freshness-00
|>
|> Hi,
|>
|> >>> [1] and [2] can be solved by mandating WebRTC endpoints to support
|> consent.
|> >>
|> >> I thought we were going to do that anyway - no matter what consent
|> >> mechanism we use.
|> >
|> > If DTLS based consent mechanism is picked then both peers must support DTLS
|> heartbeat and willing to exchange DTLS heartbeat request/response.
|>
|> How is that different from using ICE for consent? That also require support
|> from both peers, doesn't it ?
|
|Yes, ICE for consent also requires support from both peers.

No, there is one difference when the peer is not sending any traffic (e.g VoD):
For the STUN based mechanism, the peer is required to support only ICE-lite (or ICE) for the sender to verify consent freshness. With the DTLS based mechanism, the peer is required to support DTLS Heartbeat (RFC6520) and respond to HeartbeatRequest messages for the sender to verify consent freshness. That is asking more from legacy implementations.

Muthu

|
|-Tiru.
|
|>
|> Regards,
|>
|> Christer

---

From: Roman Shpount <[email-masked]>
Date: Tue, 3 Dec 2013 13:59:15 -0500

On Mon, Dec 2, 2013 at 11:47 PM, Muthu Arul Mozhi Perumal (mperumal) <
[email-masked]> wrote:

> For the STUN based mechanism, the peer is required to support only
> ICE-lite (or ICE) for the sender to verify consent freshness. With the DTLS
> based mechanism, the peer is required to support DTLS Heartbeat (RFC6520)
> and respond to HeartbeatRequest messages for the sender to verify consent
> freshness. That is asking more from legacy implementations.
>
>
For all practical purposes there are no legacy DTLS-SRTP implementations.
In most cases it is a new implementation for WebRTC anyway.
_____________
Roman Shpount