Subject: Re: [rtcweb] H.264 -- Decoder only specification

From: Roman Shpount <[email-masked]>
Date: Wed, 11 Dec 2013 15:13:58 -0500

Changing subject to keep this out of the straw poll

On Wed, Dec 11, 2013 at 2:44 PM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

>  I was of the understanding that the statement:
>
> "Encoder is not specified by the standard and there are no obligations
> for MPEG members to declare anything, so you are more then likely exposed
> to addition IPR risks when implementing a good encoder. "
>
> applied to pretty much every videocodec under the sum, and was not
> specific to H.264.
>
> The general method of specifying videocodecs is to specify the decoder
> only. I'd certainly thought seen a statement of that sort previously on the
> list; have I understood it wrong?
>
> Essentially if you do anything innovative that is not covered by the
> standard, you stand a chance of contravening IPR of someone who thought of
> it before you did and then patented it.
>
>
I am comparing it here with VP8 where Google provides the IPR rights to
everything used in their implementation, including both encoder and
decoder. Their reference encoder is good enough for production use and it
is in fact used with no or minimal modifications in real communication
applications. For H.264, if you need a production quality encoder, you need
to use an encoder implementation which is doing something non-trivial,
unspecified by the standard, and innovative, which is likely to have
additional IPR licensing requirements. The same applies to all the other
H.XXX video codecs, which do not include a usable encoder implementation as
a part of the standard.

_____________
Roman Shpount

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 11 Dec 2013 21:08:23 +0000

The only IPR declaration Google have made in IETF for VP8 appears to be against
draft-bankoski-vp8-bitstream-02
which appears to be the specification of the format and decoder only, not the encoder (and incidentally is 5 or 6 versions removed from the published RFC 6386 (individual submission)).

I am quite happy to be corrected on the above.

Would I also be right in assuming this is what has been submitted to ISO/IEC JTC1, and therefore in that group any IPR declarations will only be against the coding format and the decoder?

Your statement of the encoder being free appears to apply only against the Google implementation, and does not appear in any of the SDO material?

regards

Keith

________________________________
From: Roman Shpount [mailto:[email-masked]]
Sent: 11 December 2013 20:14
To: DRAGE, Keith (Keith)
Cc: Ted Hardie; [email-masked]; Cullen Jennings
Subject: Re: [rtcweb] H.264 -- Decoder only specification

On Wed, Dec 11, 2013 at 2:44 PM, DRAGE, Keith (Keith) <[email-masked]<mailto:[email-masked]>> wrote:
I was of the understanding that the statement:

"Encoder is not specified by the standard and there are no obligations for MPEG members to declare anything, so you are more then likely exposed to addition IPR risks when implementing a good encoder. "

applied to pretty much every videocodec under the sum, and was not specific to H.264.

The general method of specifying videocodecs is to specify the decoder only. I'd certainly thought seen a statement of that sort previously on the list; have I understood it wrong?

Essentially if you do anything innovative that is not covered by the standard, you stand a chance of contravening IPR of someone who thought of it before you did and then patented it.

I am comparing it here with VP8 where Google provides the IPR rights to everything used in their implementation, including both encoder and decoder. Their reference encoder is good enough for production use and it is in fact used with no or minimal modifications in real communication applications. For H.264, if you need a production quality encoder, you need to use an encoder implementation which is doing something non-trivial, unspecified by the standard, and innovative, which is likely to have additional IPR licensing requirements. The same applies to all the other H.XXX video codecs, which do not include a usable encoder implementation as a part of the standard.

_____________
Roman Shpount

---

From: Roman Shpount <[email-masked]>
Date: Wed, 11 Dec 2013 16:36:51 -0500

On Wed, Dec 11, 2013 at 4:08 PM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

>  The only IPR declaration Google have made in IETF for VP8 appears to be
> against draft-bankoski-vp8-bitstream-02
> which appears to be the specification of the format and decoder only, not
> the encoder (and incidentally is 5 or 6 versions removed from the published
> RFC 6386 (individual submission)).
>
> Would I also be right in assuming this is what has been submitted to
> ISO/IEC JTC1, and therefore in that group any IPR declarations will only be
> against the coding format and the decoder?
>
> Your statement of the encoder being free appears to apply only against the
> Google implementation, and does not appear in any of the SDO material?
>
>
>
I cannot speak on behalf of google regarding their submissions to various
standard groups. My statements were related to Google VP8 implementation
which is part of the WebM: http://www.webmproject.org/license/additional/
_____________
Roman Shpount

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 12 Dec 2013 08:13:30 +0100

On 12/11/2013 10:08 PM, DRAGE, Keith (Keith) wrote:
> which appears to be the specification of the format and decoder only,
> not the encoder (and incidentally is 5 or 6 versions removed from the
> published RFC 6386 (individual submission)).
>  

That IPR disclosure has been submitted in accordance with the IETF rules
for disclosure - obviously, since this is written and vetted by lawyers,
it says no more than it has to.

However, draft-alvestrand-rtcweb-vp8 does point to the declarations that
have been made outside of the IETF process, and those statements are
very explicit about covering the encoder.

In particular, for the CCL:

"*VP8 Patent Claims*" means, subject to the exclusion in the following
sentence, any and all patent claims that, at any time during the Term,
are licensable or sublicenseable by the Primary Licensors or Google or
its Affiliates and are necessarily infringed in connection with the
Exploitation of: (a) VP8 Video, a VP8 Codec or a combination of VP8
Codecs; or (b) the encoder source code contained in the VP8 Codec SDK
release designated as libvpx 0.9.7-p1.[....]

"*VP8 Codec*" means the portion or portions of any product that encodes,
transcodes, decodes or plays VP8 Video.

> ISO/IEC JTC1, and therefore in that group any IPR declarations will
> only be against the coding format and the decoder?

We do follow the procedures of the standards organizations we
participate in. The result of those procedures is likely to be exactly
as you state. Thus, if we want to declare something those organizations
don't ask for, we have to do it outside of those organizations' process.
>  
> Your statement of the encoder being free appears to apply only against
> the Google implementation, and does not appear in any of the SDO
> material?

See above.

>  
> regards
>  
> Keith
>  
>  
>  
>
>     ------------------------------------------------------------------------
>     *From:* Roman Shpount [mailto:[email-masked]]
>     *Sent:* 11 December 2013 20:14
>     *To:* DRAGE, Keith (Keith)
>     *Cc:* Ted Hardie; [email-masked]; Cullen Jennings
>     *Subject:* Re: [rtcweb] H.264 -- Decoder only specification
>
>     On Wed, Dec 11, 2013 at 2:44 PM, DRAGE, Keith (Keith)
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         "Encoder is not specified by the standard and there are no
>         obligations for MPEG members to declare anything, so you are
>         more then likely exposed to addition IPR risks when
>         implementing a good encoder. "
>          
>         The general method of specifying videocodecs is to specify the
>         decoder only. I'd certainly thought seen a statement of that
>         sort previously on the list; have I understood it wrong?
>          
>         Essentially if you do anything innovative that is not covered
>         by the standard, you stand a chance of contravening IPR of
>         someone who thought of it before you did and then patented it.
>
>
>     I am comparing it here with VP8 where Google provides the IPR
>     rights to everything used in their implementation, including both
>     encoder and decoder. Their reference encoder is good enough for
>     production use and it is in fact used with no or minimal
>     modifications in real communication applications. For H.264, if
>     you need a production quality encoder, you need to use an encoder
>     implementation which is doing something non-trivial, unspecified
>     by the standard, and innovative, which is likely to have
>     additional IPR licensing requirements. The same applies to all the
>     other H.XXX video codecs, which do not include a usable encoder
>     implementation as a part of the standard.
>
>     _____________
>     Roman Shpount
>      
>
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

-- 
Surveillance is pervasive. Go Dark.