Subject: [rtcweb] RTCWEB Data Channel Protocol: Label vs Protocol glare

From: Christer Holmberg <[email-masked]>
Date: Tue, 11 Feb 2014 17:50:38 +0000

Hi,

The draft says:

"Note: There is no attempt to resolve label glare; if both sides open
                a Channel labeled "x" at the same time, there will be two Channels
                labeled "x" - one on an even Stream pair, one on an odd pair."

I think the text shall be extended to also cover the Protocol, i.e. both ends can try to open a channel for protocol X at the same time.

Also, even if there is a label glare, it doesn't have to be for the same protocol. As far as I know, endpoints can choose whatever label value they want, and they don't even need to be for the same protcol (unless specific protocols define what label value(s) must be used for channels associated with that protocol).

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 11 Feb 2014 22:56:09 -0500

On 2/11/14 12:50 PM, Christer Holmberg wrote:
> Hi,
>
> The draft says:
>
> “Note: There is no attempt to resolve label glare; if both sides open
>
>                  labeled "x" - one on an even Stream pair, one on an odd
> pair.”
>
> I think the text shall be extended to also cover the Protocol, i.e. both
> ends can try to open a channel for protocol X at the same time.

And that should be fine.

Having two channels with the same protocol is analogous to having two 
audio rtp m-lines.

> Also, even if there is a label glare, it doesn’t have to be for the same
> protocol. As far as I know, endpoints can choose whatever label value
> they want, and they don’t even need to be for the same protcol (unless
> specific protocols define what label value(s) must be used for channels
> associated with that protocol).

IIUC the point is for applications to manage the label namespace as they 
wish.

	Thanks,
	Paul

> Regards,
>
> Christer
>
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 12 Feb 2014 10:32:56 +0000

Hi,

>> I think the text shall be extended to also cover the Protocol, i.e. 
>> both ends can try to open a channel for protocol X at the same time.
>
> And that should be fine.
>
> Having two channels with the same protocol is analogous to having two audio rtp m-lines.

...and sometimes that is what you want. But, in case you only want one channel for protocol X, the basic mechanism doesn't prevent a glare.

(Then, as has been discussed, one can do other things from preventing multiple channels for the same protocol to be created.)

>> Also, even if there is a label glare, it doesn't have to be for the 
>> same protocol. As far as I know, endpoints can choose whatever label 
>> value they want, and they don't even need to be for the same protcol 
>> (unless specific protocols define what label value(s) must be used for 
>> channels associated with that protocol).
>
> IIUC the point is for applications to manage the label namespace as they wish.

Assume that you are using application X, and I am using application Y. Both X and Y support protocol Z.

Now, unless protocol Z specifies what label value to use, X and Y may use different values. I don't know whether it really matters, but my point was that same label value doesn't by default mean same protocol :)

Regards,

Christer