Subject: [rtcweb] JSEP-06: max-bundle policy questions

From: Christer Holmberg <[email-masked]>
Date: Mon, 24 Feb 2014 16:54:41 +0000

Hi,

Section 4.1.1 says:

"o  "max-bundle": The application will BUNDLE all of its media streams
      on a single transport.  All streams other than the first will be
      marked as bundle-only.  This policy aims to minimize candidate
      gathering and maximize multiplexing, at the cost of less
      compatibility with legacy endpoints."

Q1:

I think it would be good to clarify that the application will BUNDLE all of its media streams *THAT THE APPLICATION IS ABLE TO DE-MULTIPLEX*.

Q2:

The text says that all streams other than the first will be marked as bundle-only. But, will the application have any clue which media type that first stream will be? Should we e.g. specify that it MUST be audio (if audio is enabled)?

Regards,

Christer

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Feb 2014 11:03:09 -0800

On 24 February 2014 08:54, Christer Holmberg
<[email-masked]> wrote:
> The text says that all streams other than the first will be marked as
> bundle-only. But, will the application have any clue which media type that
> first stream will be? Should we e.g. specify that it MUST be audio (if audio
> is enabled)?

I'd prefer not.  I'm OK with having a recommendation (or RECOMMENDED),
but not MUST.

If anything, the idea here is to select the media section that is
*most important*.  That's going to be application-specific.  Common
usages might have audio being the most important, but that's not a
universal principal.

MUST would also require a higher degree of specification.  Do you
prefer video over application?  Does it matter which application?
What if video is more important?

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 24 Feb 2014 19:24:41 +0000

Hi Martin,

I buy the argument that different applications may have different priorities regarding media type, so a "MUST audio" is not a good idea.

But, should the application then be able to indicate which media type (or, even which media source) shall be considered "first"? The browser probably has no clue?

Regards,

Christer

Sent from my Sony Ericsson Xperia arc S

Martin Thomson <[email-masked]> wrote:

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Feb 2014 11:30:08 -0800

> But, should the application then be able to indicate which media type (or, even which media source) shall be considered "first"? The browser probably has no clue?

I think that Justin has proposed a way to identify tracks that should
not be bundled.  I recall no objections to this [1].  I'd assume that
with only one track being marked that way, that track could be the one
that gets ports and the others not.

[1]... though I can't find anything in the API spec, and we did have
the discussion at an IETF meeting and nowhere else.  Maybe the W3C
don't know about it yet.

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 24 Feb 2014 20:01:46 +0000

Hi,

> I think that Justin has proposed a way to identify tracks that should not be bundled.  I recall no objections to this [1].  I'd assume that with only one track being marked that way, that track could be the one that gets ports and the others not.
>
>
> [1]... though I can't find anything in the API spec, and we did have the discussion at an IETF meeting and nowhere else.  Maybe the W3C don't know about it yet.

JSEP-06 defines different BUNDLE policies, but they are not on per track/m-line level.

Regards,

Christer