Subject: Re: [rtcweb] [tram] I-D Action: draft-thomson-tram-turn-bandwidth-00.txt

From: "Karl Stahl" <[email-masked]>
Date: Mon, 24 Feb 2014 23:22:20 +0100

Hi Pål,

You did not comment nor answer, in response to any of:

http://www.ietf.org/mail-archive/web/tram/current/msg00275.html 

http://www.ietf.org/mail-archive/web/tram/current/msg00273.html 

whether step D) can obsolete step C) (DISCUSS/MALICE) by allowing the
application/browser to transfer relevant real-time traffic information
(types and bandwidth) into every RTP package by using the already IETF
standardized RTP extension header RCF 5285, which could be used by any
current or future Internet (including OTT) network where WebRTC real-time
traffic may flow. It seems to have been standardized already 2008 to allow
such usage.

QoS related step C) draft-martinsen-tram-discuss can then be taken out of
TRAM, and step D) (that was never intended to be handled by TRAM anyway)
will be handled elsewhere.

I have repeated my suggestion to RTCWEB WG from the October discussions on
the relevant [rtcweb] [avtext] [mmusic] lists
http://www.ietf.org/mail-archive/web/rtcweb/current/msg09129.html to
introduce the QoS related step D) into draft-ietf-rtcweb-rtp-usage
suggesting usage of RFC 5285, where traffic information in RTP packets
simply would be filled by any browser under any OS.

Without step B), TRAM “Enforcing the real-time traffic through the
offered/discovered TURN servers”, the real-time traffic may happen through
the IP default gateways often congested by data traffic and QoS insensitive
streaming video and file sharing. Without specific QoS methods at those
points, the network raw bandwidth capacity may have to be 10-folded to
achieve sufficient QoE when WebRTC usage becomes popular. Methods like
DISCUSS addresses such things occurring when STUN instead TURN is used (by
allowing flows into such congestion points), but only provides direct
traffic info for outgoing (not incoming) real-time traffic and locally,
therefore are not even applicable to reservation type of networks like Cable
Networks and Mobile OTT. 

That would leave certain network types to investing in raw bandwidth
increase, instead of simply borrowing the bandwidth (from much larger data
traffic and QoS insensitive streaming video and file sharing at no adverse
effect) and making that borrowed no-cost bandwidth very valuable for the
carriers when delivering to their customers.

I know a few of you Cisco guys are among the ones that have been fighting
against the general “it is all about bandwidth” and “it will go away with
time”-attitude within IETF work, e.g. see
http://www.ietf.org/mail-archive/web/rtcweb/current/msg09031.html, but the
pointers given in the current QoS discussion within TRAM: 

(i) will *not allow* ISP’s to use already available and currently deployable
quality IP pipes for real-time traffic to also be used for WebRTC generated
real-time traffic.

(ii) will *not allow* some network types (e.g. Cable Networks and Mobile
OTT) to borrow bandwidth from data traffic and QoS insensitive streaming
video and file sharing. All networks will *also be inhibited* from the very
common and used method of simply providing an extra IP pipe (often provided
over the same wire but level-2 separated) dedicated for real-time usage

(*by resisting TRAM implementation of step B*)

Newer, fiber only type of networks, can still borrow bandwidth at no extra
cost, *by proprietary usage* of RFC 5285 by browsers. 

(iii) will leave most ISPs to *only use* raw bandwidth capacity increase
that may has to be 10-folded to reach sufficient QoE when WebRTC usage
becomes popular (if at all possible, since unmanaged IP pipes intermittently
are filled, whatever bandwidth is available).

Further explainations about QoS methods and their implementation were given
a few days ago in: 

http://www.ietf.org/mail-archive/web/tram/current/msg00274.html 

(i), (ii) and (iii) will *seriously delay* usage of telepresence capable and
quality demanding WebRTC (bandwidth being around 30 times higher over best
effort Internet, than telephony over quality managed networks) and will
*vastly increase cost* for ISPs to offer WebRTC with good QoE.

Below you are giving pointers saying “They are currently working on a
problem-statement draft and a use-case draft, any input to those would be
very helpful.” Those are unnecessary, risking leading to (i), (ii) and (iii)
above.

So are pointers such as: “RMCAT where congestion avoidance for RTP is being
developed”. TRAMs Milestone 3 is for the purpose of directing real-time
traffic where congestion control isn’t already in place. Using RFC 5285
available since 2008, to fill traffic information in RTP packets (step D))
is probably a necessity for most future “congestion control” discussed.

This chicken-and-egg circular also applies to RTCWEB direction of QoS issues
to: 

http://datatracker.ietf.org/doc/draft-dhesikan-tsvwg-rtcweb-qos 

focusing on DSCP-mapping without even mentioning RFC 5285 available since
2008, to fill traffic information in RTP packets where it  is a necessity
and will allow: 

(1) applications to directly convey QoS related real-time traffic info to
the network at points where RTP flow is directed to by TRAM Milstone 3, to
be used by *any network element implementing any suitable QoS methods for
the particular network* for 

(2) *all* WebRTC browsers *and* dedicated clients (not using WebRTC), under
*all* OSs, and *all* current and future IP networks 

(3) *without* having to be forced into application specific networks (PSTN,
IMS) instead of using the Internet (including OTT).

The only activity required, is to call for ISPs’ review whether the traffic
information transferred by RFC 5285 is sufficient for current and future
needs in their network as suggested in
http://www.ietf.org/mail-archive/web/rtcweb/current/msg09129.html

<snip>

…two parameters (e.g. two bytes each) are encoded into the RTP header
extension:

A) The maximum bandwidth requirement: Two bytes could contain everything
from some bps for real-time text to Gbps for future 3D supersize
telepresence… on a logarithmic scale.

B) The quality characteristics for the stream, with the highest bit set to
1, we could allocate a bit each for quality type e.g:

Best Effort, Audio, Video, Supplemental Video, Gaming, Data, Delay
Insensitive (e.g. video streaming), Minimum Delay, Reliable Delivery,
Prioritize X, Variation Y, that could be combined as required to describe
the stream.

And with highest bit set to 0, there could instead be a number for special
usage that does not fit the general description of the individual bits.

</snip>

Then this could be assigned numbers to have the RFC in place.

With TRAM milestone 3 also place, 

market forces will drive ISPs and browser makers to implement just that,
without even having it MUST-established.

“Who does not want a “WebRTC-Ready” Internet access?” and

“Who wants to use Chrome, if Firefox, Internet Explorer or Safari comes with
much better QoE?” and vice versa.

Please see further emails soon following this one, for details and history.

/Karl

Från: tram [mailto:[email-masked]] För Pal Martinsen (palmarti)
Skickat: den 21 februari 2014 10:37
Till: [email-masked]
Kopia: Karl Stahl; Oleg Moskalenko; Alan Johnston; Yoakum, John H (John)
Ämne: Re: [tram] I-D Action: draft-thomson-tram-turn-bandwidth-00.txt

Hi,

I agree the full QoS discussion should _not_ happen in TRAM. If you are
interested in helping out in that area I suggest you looking into the AEON
mailing list at: https://www.ietf.org/mailman/listinfo/aeon . They are
currently working on a problem-statement draft and a use-case draft, any
input to those would be very helpful.
(http://tools.ietf.org/html/draft-eckel-aeon-use-cases-01,
http://tools.ietf.org/html/draft-eckel-aeon-problem-statement-00).

That said, STUN have a few nice characteristics that makes it a perfect
candidate for transporting some of the QoS information.  IMHO that would be
extending the STUN spec and should be within the TRAM charter.  The main
goal of draft-martinsen-tram-discuss was to show how already existing QoS
mechanisms could be transported with STUN to provide more value, and to
start the discussion if TRAM is the appropriate place to have those on the
wire format discussions.

.-.

Pål-Erik

 

On 20 Feb 2014, at 19:55 pm, Yoakum, John H (John) <[email-masked]> wrote:

+1

I fully agree with the comments that QOS should be a low priority for the
initial focus of the TRAM efforts.  There are other groups doing QOS work
and frankly I engage in WebRTC multimedia interactions daily over the
Internet, enterprise VPNs, and various combinations and seldom suffer
egregious quality issues.  I am more concerned about carriers doing things
to regulate or degrade WebRTC flows than a failure of existing Internet
mechanisms to enable them.

Significant focus on QOS before we better enable TURN to be easily used in a
browser environment taking advantage or normal web characteristics (as
opposed to historic telephony constructs) would seem to be highly
distracting at this point.

Cheers,

John

AVAYA
1.919.425.8446

From: tram [mailto:[email-masked]] On Behalf Of Oleg Moskalenko
Sent: Thursday, February 20, 2014 12:43 PM
To: Alan Johnston
Cc: Karl Stahl; [email-masked]
Subject: Re: [tram] Fwd: I-D Action:
draft-thomson-tram-turn-bandwidth-00.txt

On Thu, Feb 20, 2014 at 6:26 AM, Alan Johnston <
<mailto:[email-masked]> [email-masked]> wrote:

Personally, I am not sure how much QoS is actually in scope for TRAM. Have
you been following RMCAT where congestion avoidance for RTP is being
developed?  I see some overlap in your goals and the goals of that work.

-

I'd concentrate on the TURN application-level functionality, for now, and
I'd leave QoS for the future discussions.

_______________________________________________
tram mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tram

---

From: "Karl Stahl" <[email-masked]>
Date: Tue, 25 Feb 2014 00:02:57 +0100

To the TRAM WG and RTCWEB WG and ADs:

It must be a clear objective of the TRAM WG that ISPs/NSPs are allowed and
encouraged to route quality demanding WebRTC media into their IP pipes that
are capable of transporting real-time traffic without quality issues, using
TURN servers. 

The subject from the TRAM mailing initiation spells out:

*Milestone 3: TURN server auto-discovery mechanism for enterprise and ISPs*

The TRAM WG must assure that TURN servers offered by ISPs/NSPs can be used
for the above purpose.

(The objective of the TRAM WG milestone 3 is *not only* to resolve
restrictive enterprise NAT/firewall traversal problem using TURN servers.)

I request that this is explicitly clarified in the TRAM charter.

The QoS discussions that has appeared in this TRAM WG, resulting from 

draft-martinsen-tram-discuss-00.txt

and 

has been confusing (to say the least), risking that the general QoS attitude
within IETF work “it is all about bandwidth” and “it will go away with
time”: 

video and file sharing. That all networks *will be inhibited* from the very

*while* newer, fiber only type of networks, still can borrow bandwidth at no
extra cost, *by proprietary usage* of RFC 5285 by browsers. 

(iii) will leave most ISPs to *only use* raw bandwidth capacity increase
that may have to be 10-folded to reach sufficient QoE when WebRTC usage
becomes popular (if at all possible, since unmanaged IP pipes intermittently
are filled, whatever bandwidth is available).

Further explanations about QoS methods and their implementation were given a
few days ago in: 

(i), (ii) and (iii) risk *seriously delaying* usage of telepresence capable
and quality demanding WebRTC (bandwidth being around 30 times higher over
best effort Internet, than telephony over quality managed networks) and will
*vastly increase cost* for ISPs to offer WebRTC with good QoE.

I am therefore advising that draft-martinsen-tram-discuss-00.txt and
draft-thomson-tram-turn-bandwidth-00.txt 

are withdrawn from TRAM. draft-martinsen-tram-discuss-00.txt can be
reintroduced after clarification in the draft, that it is not about QoS as
clarified by
http://www.ietf.org/mail-archive/web/tram/current/msg00276.html.

There are further details about this in the email
http://www.ietf.org/mail-archive/web/tram/current/msg00303.html also copied
below.

It is therein explained that my repeated suggestion to RTCWEB WG
http://www.ietf.org/mail-archive/web/rtcweb/current/msg11542.html from the
October discussions on the relevant [rtcweb] [avtext] [mmusic] lists
http://www.ietf.org/mail-archive/web/rtcweb/current/msg09129.html to
introduce the QoS related usage of RFC 5285 into draft-ietf-rtcweb-rtp-usage
in combinations with the Milestone 3 objectives of TRAM, immediately would
allow:

(1) *all* protocols using IETF RTP/SRTP and/or IETF TURN/STU/ICE (in
addition to WebRTC: e.g. SIP, Skype and Facetime, and most VoIP variants) to
quickly allow us to finally enjoy the high quality and connectivity
(NAT/firewall traversal) of real-time communication services now possible,
for  

(3) *without* having to be forced into application specific networks (PSTN,
IMS) instead of the Internet (including OTT).

The only activity required, is to call for ISPs’ review whether the traffic
information transferred by RFC 5285 is sufficient for the needs of their
networks.

WebRTC *can be* used for existing application specific IP networks (such as
IMS) for services existing on these networks, but with the introduction of
the TRAM objectives above and the proposed traffic information in every RTP
packet http://www.ietf.org/mail-archive/web/rtcweb/current/msg09129.html as
made possible by RFC 5285 available since 2008: 

(a) the same as well as other real-time services using IETF RTP traffic,
*can also (often much better) be* implemented over the Internet (including
OTT)

(b) also considering needs of QoS, media routing, control, quality
measurements, SLA implementation, usage, accounting, billing and SP-peering,

that so far has been attributed application specific networks, but in
practice and in reality have shown difficulties to implement (e.g. SP’s
peering of beyond POTS services, resulting in that the 50 year old, pre-AM
radio quality telephony service, still is the only truly global
communication service (and today often is used to initiate other better
proprietary communication services).

Application specific networks such as the IMS network have their own methods
of handling QoS, that not in anyway will be made less efficient by the
methods proposed here. Application specific networks *can use and will also
benefit* from the flow control and traffic requirement marking of RTP
streams proposed here.

WebRTC *will be* used over the Internet (including OTT) and *will probably
also be* used over the application specific IMS network for the services
existing there through a gateway function from the Internet. 

With RFC 5285 QoS usage and with TRAM milestone 3 in place (which I suggest
the WGs to expedite), 

The TRAM WG and RTCWEB WG chairs and ADs are advised to review whether IETF
standard work in these WGs by contributors having an interest in more than
one of current or emerging: ISPs, carrier equipment vendors or web browser
makers, may discriminate any with an interest only in one of these. The same
should apply to non-activity by WG contributors to remedy such
discrimination opened by allowed proprietary usage of RFCs such as RFC 5285.

One input for such review are responses directed to me in the September –
October discussion on the RTCWEB list and on the TRAM list from my entry
there February 8
http://www.ietf.org/mail-archive/web/tram/current/msg00132.html.

Please see just sent emails:

http://www.ietf.org/mail-archive/web/rtcweb/current/msg11542.html 

http://www.ietf.org/mail-archive/web/tram/current/msg00303.html 

and further emails soon following this one, for details and history.

/Karl  

Charter charter-ietf-tram-01
<https://datatracker.ietf.org/doc/charter-ietf-tram/>
https://datatracker.ietf.org/doc/charter-ietf-tram/ 

Från: Karl Stahl [mailto:[email-masked]] 
Skickat: den 24 februari 2014 23:22
Till: 'Pal Martinsen (palmarti)'; [email-masked]'; [email-masked]'
Kopia: 'Oleg Moskalenko'; 'Alan Johnston'; 'Yoakum, John H (John)'
Ämne: SV: [tram] [rtcweb] I-D Action:
draft-thomson-tram-turn-bandwidth-00.txt

Hi Pål,

Further explanations about QoS methods and their implementation were given a
few days ago in: 

<snip>

</snip>

/Karl

Från: Pal Martinsen (palmarti) [mailto:[email-masked]] 
Skickat: den 21 februari 2014 10:37
Till: [email-masked]
Kopia: Oleg Moskalenko; Alan Johnston; Karl Stahl; Yoakum, John H (John)
Ämne: Re: [tram] I-D Action: draft-thomson-tram-turn-bandwidth-00.txt

Hi,

.-.

Pål-Erik

On 20 Feb 2014, at 19:55 pm, Yoakum, John H (John) <
<mailto:[email-masked]> [email-masked]> wrote:

+1

 

Cheers,

John

AVAYA
1.919.425.8446

 

 

-

---

From: "Karl Stahl" <[email-masked]>
Date: Tue, 25 Feb 2014 01:20:30 +0100

Hi Alan,

I have in previous email
http://www.ietf.org/mail-archive/web/tram/current/msg00304.html suggested
that both DISCUSS and draft-thomson-tram-turn-bandwidth-00.txt is taken off
the TRAM WG, but I think is shall be reintroduced after you clarify as you
do in 

http://www.ietf.org/mail-archive/web/tram/current/msg00300.html :

Hi Karl, Thanks for your comments and feedback on the draft.

You are correct in saying that the BANDWIDTH extension is not about QoS.  It
is about fairness between users of a TURN server, and a TURN server being
able to indicate rate limiting policy to users. in the draft.

The “confusion” (to say least, see below) surrounding QoS within IETF has
lead me to protest and address the TRAM WG and RTCWEB WG and ADs with the
advise in http://www.ietf.org/mail-archive/web/tram/current/msg00304.html :

“The TRAM WG and RTCWEB WG chairs and ADs are advised to review whether IETF
standard work in these WGs by contributors having an interest in more than
one of current or emerging: ISPs, carrier equipment vendors or web browser
makers, may discriminate any with an interest only in one of these. The same
should apply to non-activity by WG contributors to remedy such
discrimination opened by allowed proprietary usage of RFCs such as RFC
5285.” 

This is because the introduction of the QoS related usage of RFC 5285 into
draft-ietf-rtcweb-rtp-usage in combinations with the Milestone 3 objectives
of TRAM, immediately would allow for:

While the “confusion” surrounding the QoS discussion in TRAM and RTCWEB
combined with the general QoS attitude within IETF “it is all about
bandwidth” and “it will go away with time” otherwise:

As Good doers, we should not allow this to happen.

/Karl

Från: Alan Johnston [mailto:[email-masked]] 
Skickat: den 21 februari 2014 18:59
Till: Pal Martinsen (palmarti)
Kopia: [email-masked]; Oleg Moskalenko; Karl Stahl; Yoakum, John H (John)
Ämne: Re: [tram] I-D Action: draft-thomson-tram-turn-bandwidth-00.txt

I guess the way I would expect this to progress is for QoS discussions to
happen in another working group.  Once that other working group came to
consensus on an approach, and if that approach required STUN or TURN
extensions, then we would discuss mechanisms and possible milestones in
TRAM.

- Alan -

On Fri, Feb 21, 2014 at 3:37 AM, Pal Martinsen (palmarti)
<[email-masked]> wrote:

Hi,

.-.

Pål-Erik

+1

 

Cheers,

John

AVAYA
1.919.425.8446

 

 

-

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Tue, 25 Feb 2014 12:48:06 +0000

On 24 Feb 2014, at 23:22 pm, Karl Stahl <[email-masked]<mailto:[email-masked]>> wrote:

Hi Pål,

Sorry about that. I did not notice any clear items to answer or comment on.

whether step D) can obsolete step C) (DISCUSS/MALICE) by allowing the application/browser to transfer relevant real-time traffic information (types and bandwidth) into every RTP package by using the already IETF standardized RTP extension header RCF 5285, which could be used by any current or future Internet (including OTT) network where WebRTC real-time traffic may flow. It seems to have been standardized already 2008 to allow such usage.

draft-martinsen-tram-discuss is intended to solve internal application stream prioritisation pr flow, i.e. it is more important for me to get the video stream across than my application stream at this moment in time. Its intention is to describe the 5-topple the STUN message was sent on.

Moving to a pr packet prioritisation is interesting as it can solve the bundle problem, and mark the relative importance of specific video frames (I-Frames for example). Since its pr packet the network element might not keep stream state so it might be easier that way. But the information needs to be in a fixed offset for quick network element processing. And we want to describe other streams than just RTP. That makes RTP header extensions unsuitable.

QoS related step C) draft-martinsen-tram-discuss can then be taken out of TRAM, and step D) (that was never intended to be handled by TRAM anyway) will be handled elsewhere.

I was hoping to argue that the draft is only new signalling of old concepts (DSCP and ECN). In the end it is the WG that decides if there is enough interest.

I have repeated my suggestion to RTCWEB WG from the October discussions on the relevant [rtcweb] [avtext] [mmusic] lists http://www.ietf.org/mail-archive/web/rtcweb/current/msg09129.html to introduce the QoS related step D) into draft-ietf-rtcweb-rtp-usage suggesting usage of RFC 5285, where traffic information in RTP packets simply would be filled by any browser under any OS.

Without step B), TRAM “Enforcing the real-time traffic through the offered/discovered TURN servers”, the real-time traffic may happen through the IP default gateways often congested by data traffic and QoS insensitive streaming video and file sharing. Without specific QoS methods at those points, the network raw bandwidth capacity may have to be 10-folded to achieve sufficient QoE when WebRTC usage becomes popular. Methods like DISCUSS addresses such things occurring when STUN instead TURN is used (by allowing flows into such congestion points), but only provides direct traffic info for outgoing (not incoming) real-time traffic and locally, therefore are not even applicable to reservation type of networks like Cable Networks and Mobile OTT.

If both clients supports draft-martinsen-tram-discuss you would get an bi-directional end to end description of the flow that works through NAT.
The information in the STUN packet can be used to remark DSCP bits to whatever values that is of best use for the network the packet is flowing though.

I dont see how TURN gives that ability. Once the channel is bound you only have a channel number in front of the UDP payload. And TURN is designed to carry alls sort of traffic. For this to work there must be some sort of only webRTC traffic is allowed through this TURN server. (And Ill bet bitorrent or others find a way to mimic webRTC to set up only a data channel..)

That would leave certain network types to investing in raw bandwidth increase, instead of simply borrowing the bandwidth (from much larger data traffic and QoS insensitive streaming video and file sharing at no adverse effect) and making that borrowed no-cost bandwidth very valuable for the carriers when delivering to their customers.
I know a few of you Cisco guys are among the ones that have been fighting against the general “it is all about bandwidth” and “it will go away with time”-attitude within IETF work, e.g. see http://www.ietf.org/mail-archive/web/rtcweb/current/msg09031.html, but the pointers given in the current QoS discussion within TRAM:

(i) will *not allow* ISP’s to use already available and currently deployable quality IP pipes for real-time traffic to also be used for WebRTC generated real-time traffic.

(ii) will *not allow* some network types (e.g. Cable Networks and Mobile OTT) to borrow bandwidth from data traffic and QoS insensitive streaming video and file sharing. All networks will *also be inhibited* from the very common and used method of simply providing an extra IP pipe (often provided over the same wire but level-2 separated) dedicated for real-time usage
(*by resisting TRAM implementation of step B*)
Newer, fiber only type of networks, can still borrow bandwidth at no extra cost, *by proprietary usage* of RFC 5285 by browsers.

(iii) will leave most ISPs to *only use* raw bandwidth capacity increase that may has to be 10-folded to reach sufficient QoE when WebRTC usage becomes popular (if at all possible, since unmanaged IP pipes intermittently are filled, whatever bandwidth is available).

Further explainations about QoS methods and their implementation were given a few days ago in:
http://www.ietf.org/mail-archive/web/tram/current/msg00274.html

(i), (ii) and (iii) will *seriously delay* usage of telepresence capable and quality demanding WebRTC (bandwidth being around 30 times higher over best effort Internet, than telephony over quality managed networks) and will *vastly increase cost* for ISPs to offer WebRTC with good QoE.

Below you are giving pointers saying “They are currently working on a problem-statement draft and a use-case draft, any input to those would be very helpful.” Those are unnecessary, risking leading to (i), (ii) and (iii) above.

We find them quite useful. It allows us to engage with potential users and see if there are real problems to solve. If the customer/users do not see a problem there is little incentive for us to invest in creating a solution that nobody wants. That said, it is always the danger of crating a to complicated solution that solves to many problems.

So are pointers such as: “RMCAT where congestion avoidance for RTP is being developed”. TRAMs Milestone 3 is for the purpose of directing real-time traffic where congestion control isn’t already in place. UsingRFC 5285 available since 2008, to fill traffic information in RTP packets (step D)) is probably a necessity for most future “congestion control” discussed.

There are some good example of RTP header extension usage. For example draft-avtext-berger-framemarking. But that information may very well be encrypted and unavailable to the network element.

.-.
Pål-Erik

This chicken-and-egg circular also applies to RTCWEB direction of QoS issues to:
http://datatracker.ietf.org/doc/draft-dhesikan-tsvwg-rtcweb-qos
focusing on DSCP-mapping without even mentioning RFC 5285 available since 2008, to fill traffic information in RTP packets where it  is a necessity and will allow:
(1) applications to directly convey QoS related real-time traffic info to the network at points where RTP flow is directed to by TRAM Milstone 3, to be used by *any network element implementing any suitable QoS methods for the particular network* for
(2) *all* WebRTC browsers *and* dedicated clients (not using WebRTC), under *all* OSs, and *all* current and future IP networks
(3) *without* having to be forced into application specific networks (PSTN, IMS) instead of using the Internet (including OTT).

The only activity required, is to call for ISPs’ review whether the traffic information transferred by RFC 5285 is sufficient for current and future needs in their network as suggested in http://www.ietf.org/mail-archive/web/rtcweb/current/msg09129.html
<snip>
…two parameters (e.g. two bytes each) are encoded into the RTP header extension:

A) The maximum bandwidth requirement: Two bytes could contain everything from some bps for real-time text to Gbps for future 3D supersize telepresence… on a logarithmic scale.

B) The quality characteristics for the stream, with the highest bit set to 1, we could allocate a bit each for quality type e.g:
Best Effort, Audio, Video, Supplemental Video, Gaming, Data, Delay Insensitive (e.g. video streaming), Minimum Delay, Reliable Delivery, Prioritize X, Variation Y, that could be combined as required to describe the stream.

And with highest bit set to 0, there could instead be a number for special usage that does not fit the general description of the individual bits.
</snip>

Then this could be assigned numbers to have the RFC in place.
With TRAM milestone 3 also place,
market forces will drive ISPs and browser makers to implement just that, without even having it MUST-established.
“Who does not want a “WebRTC-Ready” Internet access?” and
“Who wants to use Chrome, if Firefox, Internet Explorer or Safari comes with much better QoE?” and vice versa.
 l
Please see further emails soon following this one, for details and history.

/Karl

Till: [email-masked]<mailto:[email-masked]>

Hi,

I agree the full QoS discussion should _not_ happen in TRAM. If you are interested in helping out in that area I suggest you looking into the AEON mailing list at: https://www.ietf.org/mailman/listinfo/aeon . They are currently working on a problem-statement draft and a use-case draft, any input to those would be very helpful. (http://tools.ietf.org/html/draft-eckel-aeon-use-cases-01, http://tools.ietf.org/html/draft-eckel-aeon-problem-statement-00).

That said, STUN have a few nice characteristics that makes it a perfect candidate for transporting some of the QoS information.  IMHO that would be extending the STUN spec and should be within the TRAM charter.  The main goal of draft-martinsen-tram-discuss was to show how already existing QoS mechanisms could be transported with STUN to provide more value, and to start the discussion if TRAM is the appropriate place to have those on the wire format discussions.

.-.
Pål-Erik

On 20 Feb 2014, at 19:55 pm, Yoakum, John H (John) <[email-masked]<mailto:[email-masked]>> wrote:

+1
I fully agree with the comments that QOS should be a low priority for the initial focus of the TRAM efforts.  There are other groups doing QOS work and frankly I engage in WebRTC multimedia interactions daily over the Internet, enterprise VPNs, and various combinations and seldom suffer egregious quality issues.  I am more concerned about carriers doing things to regulate or degrade WebRTC flows than a failure of existing Internet mechanisms to enable them.

Significant focus on QOS before we better enable TURN to be easily used in a browser environment taking advantage or normal web characteristics (as opposed to historic telephony constructs) would seem to be highly distracting at this point.

Cheers,
John

AVAYA
1.919.425.8446

From: tram [mailto:[email-masked]] On Behalf Of Oleg Moskalenko
Sent: Thursday, February 20, 2014 12:43 PM
To: Alan Johnston
Cc: Karl Stahl; [email-masked]<mailto:[email-masked]>
Subject: Re: [tram] Fwd: I-D Action: draft-thomson-tram-turn-bandwidth-00.txt

On Thu, Feb 20, 2014 at 6:26 AM, Alan Johnston <[email-masked]<mailto:[email-masked]>> wrote:

Personally, I am not sure how much QoS is actually in scope for TRAM. Have you been following RMCAT where congestion avoidance for RTP is being developed?  I see some overlap in your goals and the goals of that work.
-

I'd concentrate on the TURN application-level functionality, for now, and I'd leave QoS for the future discussions.

_______________________________________________
tram mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tram

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 26 Feb 2014 01:05:38 +0000

On Feb 25, 2014, at 7:02 AM, Karl Stahl <[email-masked]> wrote:

> It must be a clear objective of the TRAM WG that ISPs/NSPs are allowed and encouraged to route quality demanding WebRTC media into their IP pipes that are capable of transporting real-time traffic without quality issues, using TURN servers.
>  

Reading the charter, the above is *not* at all a clear objective of the WG (note I am not the chair of this WG or the responsible AD). 

That said, I think you have pointed out this charter is abysmally vague - it does not say what the WG is not going to do. If I decided to do BGP for routing updates over TURN it would be within the scope of this charter. 

My advice to the responsible AD is recharter this WG before IETF 90 or close it. I would be glad to help write a charter that is not an infinite blank cheque.

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 26 Feb 2014 01:08:08 +0000

resend because the IETF mail lists said I had to many people in the to line

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 26 Feb 2014 01:08:09 +0000

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 26 Feb 2014 00:49:18 +0000

Karl, 

I am totally lost on this thread. Could you start a new tmead that summarize what the issues is, what seems to be the point of debate, and what your view is on what we should do. I think that would help make progress. 

Thank you, 

Cullen 

On Feb 25, 2014, at 8:20 AM, Karl Stahl <[email-masked]> wrote:

> Hi Alan,
>  
> I have in previous email http://www.ietf.org/mail-archive/web/tram/current/msg00304.html suggested that both DISCUSS and draft-thomson-tram-turn-bandwidth-00.txt is taken off the TRAM WG, but I think is shall be reintroduced after you clarify as you do in
> You are correct in saying that the BANDWIDTH extension is not about QoS.  It is about fairness between users of a TURN server, and a TURN server being able to indicate rate limiting policy to users. in the draft.
>  
> The “confusion” (to say least, see below) surrounding QoS within IETF has lead me to protest and address the TRAM WG and RTCWEB WG and ADs with the advise in http://www.ietf.org/mail-archive/web/tram/current/msg00304.html :
> “The TRAM WG and RTCWEB WG chairs and ADs are advised to review whether IETF standard work in these WGs by contributors having an interest in more than one of current or emerging: ISPs, carrier equipment vendors or web browser makers, may discriminate any with an interest only in one of these. The same should apply to non-activity by WG contributors to remedy such discrimination opened by allowed proprietary usage of RFCs such as RFC 5285.”
>  
> This is because the introduction of the QoS related usage of RFC 5285 into draft-ietf-rtcweb-rtp-usage in combinations with the Milestone 3 objectives of TRAM, immediately would allow for:
> (1) *all* protocols using IETF RTP/SRTP and/or IETF TURN/STU/ICE (in addition to WebRTC: e.g. SIP, Skype and Facetime, and most VoIP variants) to quickly allow us to finally enjoy the high quality and connectivity (NAT/firewall traversal) of real-time communication services now possible, for  
> (3) *without* having to be forced into application specific networks (PSTN, IMS) instead of the Internet (including OTT).
>  
> While the “confusion” surrounding the QoS discussion in TRAM and RTCWEB combined with thegeneral QoS attitude within IETF “it is all about bandwidth” and “it will go away with time” otherwise:
> (ii) will *not allow* some network types (e.g. Cable Networks and Mobile OTT) to borrow bandwidth from data traffic and QoS insensitive streaming video and file sharing. That all networks *will be inhibited* from the very common and used method of simply providing an extra IP pipe (often provided over the same wire but level-2 separated) dedicated for real-time usage
> *while* newer, fiber only type of networks, still can borrow bandwidth at no extra cost, *by proprietary usage* of RFC 5285 by browsers.
> (iii) will leave most ISPs to *only use* raw bandwidth capacity increase that may have to be 10-folded to reach sufficient QoE when WebRTC usage becomes popular (if at all possible, since unmanaged IP pipes intermittently are filled, whatever bandwidth is available).
>  
> I guess the way I would expect this to progress is for QoS discussions to happen in another working group.  Once that other working group came to consensus on an approach, and if that approach required STUN or TURN extensions, then we would discuss mechanisms and possible milestones in TRAM.
>  
> - Alan -
>  
> 
> On Fri, Feb 21, 2014 at 3:37 AM, Pal Martinsen (palmarti) <[email-masked]> wrote:
> Hi,
>  
> On Thu, Feb 20, 2014 at 6:26 AM, Alan Johnston <[email-masked]> wrote:
>  
>  
>  
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Barry Leiba <[email-masked]>
Date: Tue, 25 Feb 2014 17:12:20 -0800

> That said, I think you have pointed out this charter is abysmally
> vague - it does not say what the WG is not going to do. If I
> decided to do BGP for routing updates over TURN it would be
> within the scope of this charter.

Cullen, is it your opinion that a working group is always free to do
anything that's not explicitly forbidden in its charter?

I think that a working group is limited to doing what *is* in its
charter, and we sometimes explicitly forbid things for emphasis.

The TRAM charter says this:

   The work will include the addition of DTLS
   as an additional transport, authentication mechanisms, and
   extensions to TURN and STUN.

I don't think that would support, for example, BGP over TURN.

Barry

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 25 Feb 2014 20:52:39 -0600

So ... TRAM was chartered last Thursday ...

I'm gonna let Gonzalo (Yet Another Soon-to-be Former AD Serving as WG 
Chair) and Simon actually chair their working group for at least a full 
week before intruding further, but for now, let's assume that the 
working group wants to work on the milestones they signed up for last 
week, and see how badly that assumption blows up, rather than talk about 
rechartering every time someone proposes a topic that's out of scope.

I look forward to attending the first working group session next week, 
and to balloting on six TRAM drafts before IETF 92.

Thanks,

Spencer, as the responsible AD

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 26 Feb 2014 08:05:30 +0000

> I don't think that would support, for example, BGP over TURN.

BGP over TURN sounds like a turn extension to me. Now you might think that is a silly one and I would agree but I assure you Karl does not think the QoS extensions are silly extensions to TURN. 

So in your opinion are they in scope or out, I think that is the heart of the issue right now. I’m of the opinion they are in scope so I look forward to agenda time be allocated for them. 

Cullen

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 26 Feb 2014 08:26:13 +0000

On Feb 26, 2014, at 10:52 AM, Spencer Dawkins <[email-masked]> wrote:

> I'm gonna let Gonzalo (Yet Another Soon-to-be Former AD Serving as WG Chair) and Simon actually chair their working group for at least a full week before intruding further, but for now, let's assume that the working group wants to work on the milestones they signed up for last week, and see how badly that assumption blows up, rather than talk about rechartering every time someone proposes a topic that's out of scope.
> 
> I look forward to attending the first working group session next week, and to balloting on six TRAM drafts before IETF 92.
> 
> Thanks,
> 

Makes sense - I get the desire to let some work get done. 

I worry that every time someone says something is is not in scope of this WG, it is not going to feel like an open consensus decisions but is instead going to feel like a arbitrary fiat decisions by a chair or IESG made in a dark and smoky room - I hope I am wrong.

---

From: "Karl Stahl" <[email-masked]>
Date: Wed, 26 Feb 2014 16:47:50 +0100

(After having typed this up; I see today’s charter discussion etc. that I
haven’t read yet, but it will hopefully will be clearer by pointing at this
entry.)

Hi John, and 

Collin, Pål, Magnus, Charles,  Simon,

In my step A) B) and D) efforts in
http://www.ietf.org/mail-archive/web/tram/current/msg00275.html for the
“mission to bring quality to real-time traffic over our best effort Internet
is a huge mission, I am convinced it not a huge task – We just have to be a
bit clever here :). I only see these few standard steps required, before it
can happen!”

To accomplish these (1), (2), (3)-things for:

There are a lot of Mission Impossible, Pointers, Good arguments and other
things to consider in the mails from you guys that I have not (yet)
answered.

Allow me to come back to those under THIS THREAD/Subject after having
figured out how to do it in a structured way, with the aim of collecting the
summary in a new "Interfacing to QoS" thread, that only will relate to how
IP/IETF/WebRTC level 3-5 – *can interface* to the QoS-stuff (whether within
IETF, in the telephony world or elsewhere e.g. IEEE Ethernet, mainly
relating to lower level).

I think this is doable *without* ending up in any of the (i), (ii),
(iii)-things 

(?) and possible other Evil -things.

I refer to http://www.ietf.org/mail-archive/web/rtcweb/current/msg11548.html
for these “-things” and further.

John, Alan, Henry (Sinnreich), Henning, Richard, Cullen, Jörgen (Björkner),
Lars (Berggren) and other good friends since the early SIP age (before SIP
was “hijacked” into application specific network and proprietary usage and
nowadays rarely is used the IETF-way): 

I want to point out how “confusing” the QoS-issue has been and as hard as I
will the fight Mission Impossible attitude, I will also fight the “it is all
about bandwidth” and “it will go away with time” attitude…  (also in the
above http reference)

I agree with parts of what John says below but the remedy to achieve the
Good (1), (2), (3)-things instead of the Evil (i), (ii), (iii)-things, is
NOT to ignore QoS-things – It is the opposite! 

For you having more and relevant input – That has not been said, and that
you think I will not address anyway – in this "Interfacing to QoS" path,
please provide, but I will not be able to process much more than already
have been said – and I will use http back-pointers for what has already been
discussed in more detail.

If you want to point out QoS-stuff Requiring More Input-from/Feedback-to the
level 3 and above stuff IN ADDITION to what already has been discussed here
http://www.ietf.org/mail-archive/web/tram/current/msg00302.html  

Please also point out WHAT and WHY that can/or cannot be handled by the
methods proposed here and whether other existing methods can be used to
achieve the mission of "Interfacing to QoS" from IP = level 3 to lower
levels.

I will do some thinking about what LISTs different things shall be brought
to and then split the [TRAM] [WEBRTC] and advice regarding involving other
list will be considered. Such will probably show up and happen during this
mission.

Another thing from
http://www.ietf.org/mail-archive/web/tram/current/msg00275.html: What name 

Footnote **[Karl]* For similar reasons I have started to say things like
“the box containing the TURN server”. We should not change the TURN server
spec into including specific QoS methods to apply (like reservation,
changing DSCP bits or applying traffic shaping mechanism). What is happening
here is that we share the traffic information that the TURN server gets hold
of, with a QoS applying function (that will be different for different
networks) in “the same box”. With “the same box” I mean that we for now
don’t care about the interface/commands for sharing information between the
TURN server and the QoS applying function. There may be a future need to
specify/standardize this, but if we start doing that now and in TRAM, we
risk ending up in a 10-year process before having something in place (which
without a spec automatically will happen in vendor’s product development, by
putting the TURN server into already available “QoS applying function” boxes
(like firewalls or the mobile DPI/PCRF combination).
 
*What we need to consider and specify, is only what traffic info is required
(to be provided by the application/browser) for “QoS applying functions” in
different networks (including the very common reservation types) to do job
(i.e. giving us good QoE for real-time applications).*

And Henry, I will have to continue to use the S(BC)-word and the I(MS)-word,
since you did not succeed to “eradicate” them ;-)  Let’s hope we find a word
for the above box (quite undefined on the QoS-side – It is only the TURN
side and traffic info we are up to designing here) that does not need to be
“eradicated”. So no WebRTC-SBC I guess (hopefully it will not even be
WebRTC-specific), and ICE-SBC sounds crazy (since ICE was developed to
remove the need of SIP SBCs), the same applies to TURN-SBC (which implies
that this box hopefully is not even ICE-specific). TURN-QoS-Interface box is
relevant but long… 

/Karl

PS: To avoid being stopped by the “to many recipients” spam filter, the Guys
(including Mary) from 

http://www.ietf.org/mail-archive/web/rtcweb/current/msg11548.html 

and the ones mentioned in the email are copied separately.

Från: Yoakum, John H (John) [mailto:[email-masked]] 
Skickat: den 20 februari 2014 19:56
Till: Oleg Moskalenko; Alan Johnston
Kopia: Karl Stahl; [email-masked]
Ämne: RE: [tram] Fwd: I-D Action: draft-thomson-tram-turn-bandwidth-00.txt

+1

Cheers,

John

AVAYA
1.919.425.8446 

 

On Thu, Feb 20, 2014 at 6:26 AM, Alan Johnston <[email-masked]>
wrote:

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 26 Feb 2014 15:53:09 +0200

Hi Cullen,

I am keeping the cc: as is in order to close this thread but let's try
and avoid cross-posting in future discussions.

Thanks for your input. I agree that explicit charters are better than
implicit ones, especially around areas that can be controversial. Given
that we are not going to recharter the WG in the next few days, we are
going to focus the session in London on items that are *explicitly*
chartered.

After London, if we need to tighten the charter somehow, we will do that.

Cheers,

Gonzalo