Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-data-channel-07.txt - Comment on section 6 title

From: Christer Holmberg <[email-masked]>
Date: Tue, 11 Feb 2014 18:15:32 +0000

Hi,

Section 6 describes the characteristics of the data channel.

However, the section name is "The Usage of SCTP in the WebRTC Context".

I think we should rename that to something like "The Usage of SCTP for the WebRTC Data Channel".

Because, the definition of the channel is the same no matter in which context it is used :)

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 11 Feb 2014 23:03:53 -0500

I suggest that this just be called "Data Channel", not "WebRTC Data 
Channel". (Or pick some other neutral name - perhaps SCTP Data Channel.)

This won't be used solely for WebRTC. (It seems weird for two sip-based 
implementations of CLUE to be using a *WebRTC* Data Channel to talk to 
one another.)

(But it would still make sense for the JS API to have a WebRTC-specific 
name.)

	Thanks,
	Paul

On 2/11/14 1:15 PM, Christer Holmberg wrote:
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 12 Feb 2014 10:23:43 +0000

Hi,

> I suggest that this just be called "Data Channel", not "WebRTC Data Channel". (Or pick some other neutral name - perhaps SCTP Data Channel.)

Agree. A more generic name would be useful.

"Simple Data Channel"
"Simple SCTP Data Channel"
Etc...

> This won't be used solely for WebRTC. (It seems weird for two sip-based implementations of CLUE to be using a *WebRTC* Data Channel to talk to one another.)
>
> (But it would still make sense for the JS API to have a WebRTC-specific name.)

Agree.

Regards

Christer

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Wed, 12 Feb 2014 18:56:56 +0000

> "Simple SCTP Data Channel"

[Raju] How about "Application Data Channel"?

> (But it would still make sense for the JS API to have a WebRTC-specific name.)
+1

-raju