Subject: [rtcweb] Data channel: JavaScript usage of data channel without the Data Channel Protocol?

From: Christer Holmberg <[email-masked]>
Date: Thu, 6 Feb 2014 11:15:07 +0000

Hi,

As was indicated earlier, the usage of the Data Channel Protocol (DCP) is optional with the Data Channel.

However, if I understand the API correctly, only the DCP "open"/"ack" messages will trigger a JavaScript "open" event.

If so, how will my JS App be able to use the data channel if I do NOT use the Data Channel Protocol? Can I use it without the "open" event, and/or is there something else that will trigger it?

Regards,

Christer

---

From: Richard Ejzak <[email-masked]>
Date: Tue, 11 Feb 2014 14:05:06 -0600

Hi Christer,
I didn't see any other response to your question, but please excuse me if I
missed it.

My understanding of this case is that if DCEP is not used, the "open" event
is triggered once the browser finishes creating the protocol machinery for
the data channel being created.  This is the only mechanism available to
acknowledge to the JS app that the data channel has been set up since, as
you say, the browser will neither send nor receive an open/ack message.  I
don't see any other reasonable alternative to this without API changes.

There is a slight problem with this since the peer may not have established
the protocol machinery necessary to actually communicate on the created
data channel.  Some external mechanism is necessary to verify that both
peers have "opened" the same data channel before either party sends data.
 See my draft on SDP for external negotiation of data channels for a
description of one way to do this.

Richard

On Thu, Feb 6, 2014 at 5:15 AM, Christer Holmberg <
[email-masked]> wrote:

> However, if I understand the API correctly, only the DCP "open"/"ack"
> messages will trigger a JavaScript "open" event.
>
>
>
> If so, how will my JS App be able to use the data channel if I do NOT use
> the Data Channel Protocol? Can I use it without the "open" event, and/or is
> there something else that will trigger it?
>
>
>
> Regards,
>
>
>
> Christer
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 12 Feb 2014 10:28:12 +0000

Hi Richard,

Specific applications can decide who opens the data channel, when to start sending data, etc.

Regards,

Christer

From: Richard Ejzak [mailto:[email-masked]]
Sent: 11. helmikuuta 2014 22:05
To: Christer Holmberg
Cc: [email-masked]
Subject: Re: [rtcweb] Data channel: JavaScript usage of data channel without the Data Channel Protocol?

Hi Christer,
I didn't see any other response to your question, but please excuse me if I missed it.

My understanding of this case is that if DCEP is not used, the "open" event is triggered once the browser finishes creating the protocol machinery for the data channel being created.  This is the only mechanism available to acknowledge to the JS app that the data channel has been set up since, as you say, the browser will neither send nor receive an open/ack message.  I don't see any other reasonable alternative to this without API changes.

There is a slight problem with this since the peer may not have established the protocol machinery necessary to actually communicate on the created data channel.  Some external mechanism is necessary to verify that both peers have "opened" the same data channel before either party sends data.  See my draft on SDP for external negotiation of data channels for a description of one way to do this.

Richard

On Thu, Feb 6, 2014 at 5:15 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb