Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-jsep-06.txt - SDP sctpmap attribute usage

From: Christer Holmberg <[email-masked]>
Date: Fri, 14 Feb 2014 14:26:42 +0000

Hi,

Section 5.2.1 says:

	"Within the data m= section, the "a=mid", "a=ice-ufrag", "a=ice-
   	passwd", "a=ice-options", "a=candidate", "a=fingerprint", and
   	"a=setup" lines MUST be included as mentioned above, along with an
   	"a=sctpmap" line referencing the SCTP port number and specifying the
   	application protocol indicated in [I-D.ietf-rtcweb-data-protocol]."

The statement that the sctpmap attribute specifies the application protocol indicate in the DCP is not aligned with the sctp-sdp draft. The sctp-sdp draft specifies that the attribute specifies the application running on top of the SCTP association - which in this case is the WebRTC Data Channel. The protocol running on top of that data channel is then specified in the DCP.

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Sat, 15 Feb 2014 23:22:11 -0800

OK, I think the text may be confusing; I think we mean the same things. The
value that should be placed in the SDP is the protocol that identifies
"WebRTC Data Channel", not the protocol used in the specific data channel.

On Fri, Feb 14, 2014 at 6:26 AM, Christer Holmberg <
[email-masked]> wrote:

> The statement that the sctpmap attribute specifies the application
> protocol indicate in the DCP is not aligned with the sctp-sdp draft. The
> sctp-sdp draft specifies that the attribute specifies the application
> running on top of the SCTP association - which in this case is the WebRTC
> Data Channel. The protocol running on top of that data channel is then
> specified in the DCP.
>
> Regards,
>
> Christer
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>