Subject: Re: [rtcweb] ice-lite in WebRTC ???

From: Justin Uberti <[email-masked]>
Date: Thu, 6 Feb 2014 11:55:52 -0800

+rtcweb

WebRTC endpoints must implement full ICE. Legacy (non-WebRTC) endpoints can
use ICE Lite, but as mentioned in RFC5245, S 2.7, full ICE is preferred.

On Tue, Jan 21, 2014 at 10:50 AM, Rachel Dvori <[email-masked]>wrote:

> [email-masked]
>
>
>
>
>
> Dear Person,
>
>
>
> I have seen the below in the draft of:
> http://tools.ietf.org/html/draft-ietf-rtcweb-jsep-05
>
>
>
> Attributes other than the ones specified above MAY be included,
>
> except for the following attributes which are specifically
>
> incompatible with the requirements of [I-D.ietf-rtcweb-rtp-usage],
>
> and *MUST NOT* be included:
>
>
>
> o  "a=crypto"
>
> o  "a=key-mgmt"
>
> o  "*a=ice-lite*"
>
>
>
>
>
> But in draft of :
> http://tools.ietf.org/html/draft-ietf-rtcweb-rtp-usage-11
>
> There is no phrase that prevents a WebRTC user to be ice-lite
>
>
>
>
>
> Can you pls clarify:
>
> -          Where is it mentioned that ice-lite cannot be one of the
> participants of WebRTC
>
> -          What is the reason that no side can be ice-lite  (as if one
> side is full-ice, there is still STUN and connectivity checks etc.
>
>
>
> Thanks
>
> RD
>
>
>
> p.s. - what is the correct email address for this type of questions ?
>  (Thanks and sorry)
>
>
>

---

From: "Wilson Chen (weichen2)" <[email-masked]>
Date: Fri, 7 Feb 2014 01:56:43 +0000

In case of negotiating with server (may be a gateway), IMHO, the server would like not to do connectivity check, it is simpler and faster to work in ice-lite and passive mode.

Thanks,
Wilson Chen

From: rtcweb [mailto:[email-masked]] On Behalf Of Justin Uberti
Sent: 2014年2月7日 3:56
To: Rachel Dvori; [email-masked]
Subject: Re: [rtcweb] ice-lite in WebRTC ???

+rtcweb

WebRTC endpoints must implement full ICE. Legacy (non-WebRTC) endpoints can use ICE Lite, but as mentioned in RFC5245, S 2.7, full ICE is preferred.

On Tue, Jan 21, 2014 at 10:50 AM, Rachel Dvori <[email-masked]> wrote:
[email-masked]

Dear Person,
 
I have seen the below in the draft of:   http://tools.ietf.org/html/draft-ietf-rtcweb-jsep-05
 
Attributes other than the ones specified above MAY be included,
except for the following attributes which are specifically
incompatible with the requirements of [I-D.ietf-rtcweb-rtp-usage],
and MUST NOT be included:
 
o  "a=crypto"
o  "a=key-mgmt"
o  "a=ice-lite"

But in draft of :  http://tools.ietf.org/html/draft-ietf-rtcweb-rtp-usage-11  
There is no phrase that prevents a WebRTC user to be ice-lite

Can you pls clarify:
-          Where is it mentioned that ice-lite cannot be one of the participants of WebRTC
-          What is the reason that no side can be ice-lite  (as if one side is full-ice, there is still STUN and connectivity checks etc.
 
Thanks
RD
 
p.s. - what is the correct email address for this type of questions ?  (Thanks and sorry)

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 07 Feb 2014 02:59:15 +0100

> In case of negotiating with server (may be a gateway), IMHO, the server would like not to do connectivity check, it is simpler and faster to work in ice-lite and passive mode.

The server doesn't have to claim WebRTC conformance, it just has to
claim to interoperate with WebRTC endpoints.

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

-- 
Surveillance is pervasive. Go Dark.

---

From: "Parthasarathi R" <[email-masked]>
Date: Fri, 7 Feb 2014 21:56:20 +0530

<snip> > The server doesn't have to claim WebRTC conformance, it just has to
> claim to interoperate with WebRTC endpoints. </snip>

The above assumption leads to lot of confusion in WebRTC Server implementation which starts from RTCWeb requirement itself. IMO, it is better to provide the minimum IETF standard guidelines for WebRTC servers like ice-lite/ICE, BUNDLE required or not, ICE-TCP/TURN. 

> -----Original Message-----
> From: rtcweb [mailto:[email-masked]] On Behalf Of Harald
> Alvestrand
> Sent: Friday, February 07, 2014 7:29 AM
> To: [email-masked]
> > In case of negotiating with server (may be a gateway), IMHO, the
> server would like not to do connectivity check, it is simpler and
> faster to work in ice-lite and passive mode.
> 
> > WebRTC endpoints must implement full ICE. Legacy (non-WebRTC)
> endpoints can use ICE Lite, but as mentioned in RFC5245, S 2.7, full
> ICE is preferred.
> >
> > -          What is the reason that no side can be ice-lite  (as if
> one side is full-ice, there is still STUN and connectivity checks etc.
> >
> > Thanks
> > RD
> >

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 07 Feb 2014 19:04:06 +0100

> The above assumption leads to lot of confusion in WebRTC Server implementation which starts from RTCWeb requirement itself. IMO, it is better to provide the minimum IETF standard guidelines for Web…

It seems to me like a good document to write, but should probably be
done after we finish the requirements for WebRTC endpoints.

Unless someone wishes to start one, of course.

---

From: "Parthasarathi R" <[email-masked]>
Date: Sat, 8 Feb 2014 15:37:03 +0530

Hi Harald & all,

I agree with Harald that WebRTC Endpoints requirements has to be frozen before starting WebRTC Server/Gateway guidelines documents. I guess that draft-ietf-rtcweb-use-cases-and-requirements document open items will be closed during IETF-89 based on the current open items.

I'll write the strawman proposal after IETF-89 to start the discussion. I'm interested in hearing anybody else interested in contributing for the same.

Thanks
Partha

> From: Harald Alvestrand [mailto:[email-masked]]
> Sent: Friday, February 07, 2014 11:34 PM
> To: Parthasarathi R; [email-masked]
> > The above assumption leads to lot of confusion in WebRTC Server
> implementation which starts from RTCWeb requirement itself. IMO, it is
> better to provide the minimum IETF standard guidelines for WebRTC
> servers like ice-lite/ICE, BUNDLE required or not, ICE-TCP/TURN.
>

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Sat, 08 Feb 2014 12:23:40 +0100

Hi Partha,

I have quite some real life experience on webrtc server side 
implementation, so count on me.

Best regards
Sergio