Subject: [rtcweb] Notes from Data discussion today

From: Cullen Jennings <[email-masked]>
Date: Tue, 4 Mar 2014 11:32:50 +0000

Data Presentation

Issue #1 

- Will say MUST use NDATA and ignore intermediate states till we have that
- Will keep the signaling of receiver seize limits

Issue #2
- add general statement on congestion control and specific for TCP windows based congestion control 

Issue #3
- say nothing about this in our specification and leave it to the SCTP specifications
- will propose the path max retrain = association max retrans in TSVWG
- no text involving this in rtcweb specs 

Issue #4 
- will remove negation and discussion of this. It is a point for the WG developing  SCTP.
- Ted to send text on how to craft such a statement 

Issue #5 
- part of the issue here is there is a protocol on top of SCTP 
- change to text say “reset channel”

Issue #6
-  will use the the "IANA registry for WebSocket Subprotocol names "

Issue #7 
- skipped due to time 

Issue #8
- The transports documents should make the DCEP  be MTI 
- The data channel draft will not require implementation of DCEP

Issue #9 
- this is an example of something you can do with tool set we provide and may or may not be a bad idea 
- do nothing for now and be sad later

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 04 Mar 2014 15:44:59 +0000

> - change to text say “reset channel”

I understand what an SCTP stream reset is.

I can guess what "reset channel" means, but AFAIK it isn't defined anywhere.

I guess it may mean sending an Outgoing SSN Reset Request, or an 
Incoming SSN Reset Request, or both.

(If there was a notion of a Data Channel Protocol, then it could have a 
channel reset request, that mapped to the appropriate corresponding SCTP 
actions.)

	Thanks,
	Paul

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 4 Mar 2014 15:50:21 +0000

> I can guess what "reset channel" means, but AFAIK it isn't defined anywhere.
More precise language: Close the channel. This is described in
http://tools.ietf.org/html/draft-ietf-rtcweb-data-channel-07#section-6.7

Best regards
Michael
> 
> I guess it may mean sending an Outgoing SSN Reset Request, or an Incoming SSN Reset Request, or both.
> 
> (If there was a notion of a Data Channel Protocol, then it could have a channel reset request, that mapped to the appropriate corresponding SCTP actions.)
> 
> 	Thanks,
> 	Paul
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 04 Mar 2014 15:56:05 +0000

> - The data channel draft will not require implementation of DCEP

It isn't hugely important to me which document the MTI is in.
(I do care for clarity, but not as far as substance.)

What *is* important to me is what the definition of "webrtc-datachannel" 
is, in the registry defined by draft-ietf-mmusic-sctp-sdp-06. (I can't 
find anything that does the definition.)

If it says DCEP is MTI then I'm ok. If it doesn't then I think there is 
a problem.

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 04 Mar 2014 16:17:38 +0000

> http://tools.ietf.org/html/draft-ietf-rtcweb-data-channel-07#section-6.7

OK. Close enough I guess. (Close - Reset)

	Sorry,
	Paul