Subject: Re: [rtcweb] JSEP-06: max-bundle policy questions

From: Justin Uberti <[email-masked]>
Date: Sun, 2 Mar 2014 13:45:43 -0800

On Mon, Feb 24, 2014 at 12:01 PM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> >> But, should the application then be able to indicate which media type
> (or, even which media source) shall be considered "first"? The browser
> probably has no clue?
> >
> > I think that Justin has proposed a way to identify tracks that should
> not be bundled.  I recall no objections to this [1].  I'd assume that with
> only one track being marked that way, that track could be the one that gets
> ports and the others not.
> >
> >
> > [1]... though I can't find anything in the API spec, and we did have the
> discussion at an IETF meeting and nowhere else.  Maybe the W3C don't know
> about it yet.
>
> JSEP-06 defines different BUNDLE policies, but they are not on per
> track/m-line level.

We had a discussion in Seattle (IIRC) that the "first" track could be the
first one provided to AddTrack, and I think that is simplest. (This of
course requires the AddTrack proposal to go through.)

---

From: Justin Uberti <[email-masked]>
Date: Sun, 2 Mar 2014 13:46:49 -0800

On Mon, Feb 24, 2014 at 8:54 AM, Christer Holmberg <
[email-masked]> wrote:

>  Hi,
>
>
>
> Section 4.1.1 says:
>
>
>
> “o  "max-bundle": *The application will BUNDLE all of its media streams*
>
> *      on a single transport.*  All streams other than the first will be
>
>       marked as bundle-only.  This policy aims to minimize candidate
>
>       gathering and maximize multiplexing, at the cost of less
>
>       compatibility with legacy endpoints.”
>
>
>
> *Q1:*
>
>
>
> I think it would be good to clarify that the application will BUNDLE all
> of its media streams **THAT THE APPLICATION IS ABLE TO DE-MULTIPLEX**.
>

I don't follow what you are saying here. How would a WebRTC application end
up with streams it could not demultiplex?

>
>
> *Q2:*
>
>
>
> The text says that all streams other than the first will be marked as
> bundle-only. But, will the application have any clue which media type that
> first stream will be? Should we e.g. specify that it MUST be audio (if
> audio is enabled)?
>
>
>
> Regards,
>
>
>
> Christer
>

---

From: Martin Thomson <[email-masked]>
Date: Sun, 2 Mar 2014 22:51:35 -0800

> course requires the AddTrack proposal to go through.)

That's true.  But then you have to decide which is first :)  We could
assume that the order follows what is in every example ever, but
that's still an assumption.

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 3 Mar 2014 10:34:24 +0000

Hi,
Section 4.1.1 says:
“o  "max-bundle": The application will BUNDLE all of its media streams
      on a single transport.  All streams other than the first will be
      marked as bundle-only.  This policy aims to minimize candidate
      gathering and maximize multiplexing, at the cost of less
      compatibility with legacy endpoints.”
Q1:
I think it would be good to clarify that the application will BUNDLE all of its media streams *THAT THE APPLICATION IS ABLE TO DE-MULTIPLEX*.

I don't follow what you are saying here. How would a WebRTC application end up with streams it could not demultiplex?

Maybe someone is implementing some new media type, for which the bundling hasn’t been specified.

Regards,

Christer