Subject: Re: [rtcweb] JSEP-06: How to create the second offer where only the port numbers are changed?

From: Justin Uberti <[email-masked]>
Date: Sun, 2 Mar 2014 13:49:00 -0800

On Mon, Feb 24, 2014 at 9:07 AM, Christer Holmberg <
[email-masked]> wrote:

>  Hi,
>
>
>
> As specified in BUNDLE, before the remote peer has indicated support of
> BUNDLE, all m- lines (including those within to a bundle group) must have
> unique port numbers.
>
>
>
> Then, when the remote peer has indicated support of BUNDLE, a second offer
> (called the BAS offer) needs to be sent, in which the same port number is
> assigned to all m- lines within a bundle group.
>
>
>
> My question is: how do I create the BAS offer? I don’t want to change
> anything – I just want to get an SDP with the BUNDLE port assigned to all
> m- lines. Is there a flag in createOffer() for that?
>
>
>
The implementation knows that any offers that are created after the BUNDLE
answer should have the same port numbers. So, the app could push the
createOffer button once it receives the answer if it wanted to ensure this
happened immediately. Otherwise, there will be an onnegotiationneeded event
once ICE completes, and the offer sent at that time will have the updated
ports.

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 3 Mar 2014 10:30:59 +0000

Hi,
As specified in BUNDLE, before the remote peer has indicated support of BUNDLE, all m- lines (including those within to a bundle group) must have unique port numbers.
Then, when the remote peer has indicated support of BUNDLE, a second offer (called the BAS offer) needs to be sent, in which the same port number is assigned to all m- lines within a bundle group.
My question is: how do I create the BAS offer? I don’t want to change anything – I just want to get an SDP with the BUNDLE port assigned to all m- lines. Is there a flag in createOffer() for that?
The implementation knows that any offers that are created after the BUNDLE answer should have the same port numbers. So, the app could push the createOffer button once it receives the answer if it wanted to ensure this happened immediately. Otherwise, there will be an onnegotiationneeded event once ICE completes, and the offer sent at that time will have the updated ports.

When I call createOffer(), can I be ensure that only the port values will change?

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Mon, 3 Mar 2014 05:31:03 -0800

On Mon, Mar 3, 2014 at 2:30 AM, Christer Holmberg <
[email-masked]> wrote:

>  The implementation knows that any offers that are created after the
> BUNDLE answer should have the same port numbers. So, the app could push the
> When I call createOffer(), can I be ensure that *only* the port values
> will change?
>
>
>

No. Why would this be necessary?

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 3 Mar 2014 13:48:27 +0000

Hi,

Because the only thing I want to do is to send a new offer, with the same port number in each m- line. I don’t want anything else to change.

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Mon, 3 Mar 2014 06:12:43 -0800

But why is it a problem if other things change (e.g. a=remote-candidates is
set)?

On Mon, Mar 3, 2014 at 5:48 AM, Christer Holmberg <
[email-masked]> wrote:

>  Hi,
>
>      As specified in BUNDLE, before the remote peer has indicated support
> of BUNDLE, all m- lines (including those within to a bundle group) must
> have unique port numbers.
>
> Because the only thing I want to do is to send a new offer, with the same
> port number in each m- line. I don’t want anything else to change.
>
>
>
> Regards,
>
>
>
> Christer
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 3 Mar 2014 14:35:31 +0000

Fair enough, maybe some things can change. And, BUNDLE does not forbid changing values, but it does say that the offerer should be careful when doing so.

Section 6.4.3:

“The Offerer MAY modify any SDP parameter in a BAS Offer.

   NOTE: It is important that the BAS Offer gets accepted by the
   Answerer, so the Offerer needs to consider the necessity to modify
   SDP parameters that could get the Answerer to reject the BAS Offer.
   Removing "m=" lines, or reducing the number of codecs, in the BAS
   Offer used for the is considered to have a low risk of being
   rejected.”

So, I guess what should be avoided is adding of new m- lines, new codecs, or anything which may trigger the answer to reject the offer.

Regards,

Christer

From: Justin Uberti [mailto:[email-masked]]
Sent: 03 March 2014 16:13
To: Christer Holmberg
Cc: [email-masked]
Subject: Re: JSEP-06: How to create the second offer where only the port numbers are changed?

But why is it a problem if other things change (e.g. a=remote-candidates is set)?

On Mon, Mar 3, 2014 at 5:48 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Mon, 3 Mar 2014 06:39:02 -0800

Agreed.

On Mon, Mar 3, 2014 at 6:35 AM, Christer Holmberg <
[email-masked]> wrote:

>  Fair enough, maybe some things can change. And, BUNDLE does not forbid
> changing values, but it does say that the offerer should be careful when
> doing so.
>
>
>
> Section 6.4.3:
>
>
>
> So, I guess what should be avoided is adding of new m- lines, new codecs,
> or anything which may trigger the answer to reject the offer.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
> *From:* Justin Uberti [mailto:[email-masked]]
> *Sent:* 03 March 2014 16:13
> *To:* Christer Holmberg
> *Cc:* [email-masked]
> *Subject:* Re: JSEP-06: How to create the second offer where only the
> port numbers are changed?
>
>
>