Subject: Re: [rtcweb] draft-ietf-rtcweb-security-arch-09: DTLS 1.2 only?

From: Andrei Popov <[email-masked]>
Date: Mon, 5 May 2014 22:38:22 +0000

Just to confirm: does everyone think it's a good idea to require the use of DTLS 1.2?

Cheers,

Andrei

From: rtcweb [mailto:[email-masked]] On Behalf Of Andrei Popov
Sent: Wednesday, April 16, 2014 3:32 PM
To: [email-masked]
Subject: [rtcweb] draft-ietf-rtcweb-security-arch-09: DTLS 1.2 only?

draft-ietf-rtcweb-security-arch-09. says:

" [[OPEN ISSUE:  Are these the right cipher suites?]]  All
   implementations MUST implement the following two cipher suites:
   TLS_DHE_RSA_WITH_AES_128_GCM_SHA256 and
   TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 ..."

These are (D)TLS 1.2 cipher suites; I think this requirement would exclude DTLS 1.0 implementations. For easier/broader adoption, would it make sense to allow DTLS 1.0?

Cheers,

Andrei

---

From: Martin Thomson <[email-masked]>
Date: Mon, 5 May 2014 16:47:22 -0700

On 5 May 2014 15:38, Andrei Popov <[email-masked]> wrote:
> Just to confirm: does everyone think it’s a good idea to require the use of
> DTLS 1.2?

I'll note that Firefox currently doesn't comply with this requirement.
 We currently only negotiate DTLS 1.0 (i.e., datagram TLS 1.1).  We
should be conformant with this shortly.  (Assuming of course that this
doesn't change.)

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 5 May 2014 20:03:24 -0700

At the moment, the choice of GCM seems to be generating more heat than DTLS 1.2 :(

> On May 5, 2014, at 3:38 PM, Andrei Popov <[email-masked]> wrote:
> 
> Just to confirm: does everyone think it’s a good idea to require the use of DTLS 1.2?
>  
> Cheers,
>  
> Andrei
>  
> “ [[OPEN ISSUE:  Are these the right cipher suites?]]  All
>    TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 …”
>  
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb