Subject: [rtcweb] Agenda for RTCWeb Interim May 19-20, 2014

From: Cullen Jennings <[email-masked]>
Date: Thu, 8 May 2014 09:32:25 -0600

Below is a the current agenda for the upcoming RTCWEB Interim (essentially, we have the morning sessions for the three days May 19, May 20, May 21 2014).  If you have not filled in your participation in the doodle poll, please do so at: http://doodle.com/qewq4xvszbc6d4sn. That helps us plan space and food as well as have badges ready.

Thanks

Ted, Sean, Cullen

Interim Meeting RTCWEB May 2014
http://doodle.com/qewq4xvszbc6d4sn

Day 1

Admin Trivia (15m) - Chairs

RTP + Media  (75m) Magnus Westerlund and Harald Alvestrand 
draft-ietf-rtcweb-rtp-usage-13
draft-ietf-rtcweb-audio-05
draft-ietf-rtcweb-transports-03

JSEP (2.5h) Eric Rescorla
draft-ietf-rtcweb-jsep-06

Day 2

Data Channel (4h) Randell Jesup
draft-ietf-rtcweb-data-channel-08
draft-ietf-rtcweb-data-protocol-04

Day 3

Security ( 2h ) Eric Rescorla
draft-ietf-rtcweb-security-06
draft-ietf-rtcweb-security-arch-09

ALPN ( 15m ) Martin Thomson 
draft-thomson-rtcweb-alpn-00

Consent Freshness ( 30m) Martin Thomson

draft-ietf-rtcweb-stun-consent-freshness-02

Matters arising from webrtc meetings ( remaining time)

---

From: Mary Barnes <[email-masked]>
Date: Thu, 8 May 2014 11:02:10 -0500

Is there remote participation information available?  I could not find
anything in my email archives nor on the mailing list.

Thanks,
Mary.

On Thu, May 8, 2014 at 10:32 AM, Cullen Jennings <[email-masked]> wrote:

>
> Below is a the current agenda for the upcoming RTCWEB Interim
> (essentially, we have the morning sessions for the three days May 19, May
> 20, May 21 2014).  If you have not filled in your participation in the
> doodle poll, please do so at: http://doodle.com/qewq4xvszbc6d4sn. That
> helps us plan space and food as well as have badges ready.
>
> Thanks
>
> Ted, Sean, Cullen
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Ted Hardie <[email-masked]>
Date: Thu, 8 May 2014 09:41:31 -0700

On Thu, May 8, 2014 at 9:02 AM, Mary Barnes <[email-masked]>wrote:

> ​Hi Mary,

Thanks for raising the question; the answer may depend slightly on how many
people are attending remotely.

Anyone who is currently planning to attend remotely, can you let the chairs
know?

thanks,

Ted

---

From: Mary Barnes <[email-masked]>
Date: Thu, 8 May 2014 11:43:10 -0500

I will obviously be attending remotely.  But, your question leads me to
another question as to whether the meeting is being recorded for people
that aren't able to be on the call for 3 days solid?

Thanks,
Mary.

On Thu, May 8, 2014 at 11:41 AM, Ted Hardie <[email-masked]> wrote:

> Thanks for raising the question; the answer may depend slightly on how
> many people are attending remotely.
>
> Anyone who is currently planning to attend remotely, can you let the
> chairs know?
>
> thanks,
>
> Ted
>
>
>
>
>>

---

From: Erik Lagerway <[email-masked]>
Date: Thu, 8 May 2014 09:44:53 -0700

+1 to remote participation.

*Erik Lagerway <http://ca.linkedin.com/in/lagerway> |
*Hookflash<http://hookflash.com/>* |
1 (855) Hookflash ext. 2 | Twitter
<http://twitter.com/elagerway> | WebRTC.is Blog <http://webrtc.is/> *

---

From: Simon Pietro Romano <[email-masked]>
Date: Thu, 8 May 2014 18:46:03 +0200

+1

Simon

On 08/mag/2014, at 18:44, Erik Lagerway <[email-masked]> wrote:

> Erik Lagerway | Hookflash | 1 (855) Hookflash ext. 2 | Twitter | WebRTC.is Blog 
> 
> 
> On Thu, May 8, 2014 at 9:43 AM, Mary Barnes <[email-masked]> wrote:
> I will obviously be attending remotely.  But, your question leads me to another question as to whether the meeting is being recorded for people that aren't able to be on the call for 3 days solid?
> 
> Thanks,
> Mary.
> 
> 
> 
> On Thu, May 8, 2014 at 9:02 AM, Mary Barnes <[email-masked]> wrote:
> Is there remote participation information available?  I could not find anything in my email archives nor on the mailing list.
> 
> Thanks,
> Mary.
> 
> ​Hi Mary,
> 
> Thanks for raising the question; the answer may depend slightly on how many people are attending remotely.  
> 
> Anyone who is currently planning to attend remotely, can you let the chairs know?
> 
> thanks,
> 
> Ted
> 
> 
>  
> 

                     					       _\\|//_
                           				      ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked]

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
  ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 8 May 2014 16:47:37 +0000

+1

Dan

From: rtcweb [mailto:[email-masked]] On Behalf Of Simon Pietro Romano
Sent: Thursday, May 08, 2014 7:46 PM
To: Erik Lagerway
Cc: [email-masked]
Subject: Re: [rtcweb] Agenda for RTCWeb Interim May 19-20, 2014

+1

Simon

On 08/mag/2014, at 18:44, Erik Lagerway <[email-masked]<mailto:[email-masked]>> wrote:

Erik Lagerway<http://ca.linkedin.com/in/lagerway> | Hookflash<http://hookflash.com/> | 1 (855) Hookflash ext. 2 | Twitter<http://twitter.com/elagerway> | WebRTC.is Blog<http://webrtc.is/>

On Thu, May 8, 2014 at 9:43 AM, Mary Barnes <[email-masked]<mailto:[email-masked]>> wrote:
I will obviously be attending remotely.  But, your question leads me to another question as to whether the meeting is being recorded for people that aren't able to be on the call for 3 days solid?

Thanks,
Mary.

On Thu, May 8, 2014 at 11:41 AM, Ted Hardie <[email-masked]<mailto:[email-masked]>> wrote:
On Thu, May 8, 2014 at 9:02 AM, Mary Barnes <[email-masked]<mailto:[email-masked]>> wrote:
Is there remote participation information available?  I could not find anything in my email archives nor on the mailing list.

Thanks,
Mary.

​Hi Mary,

thanks,

Ted

On Thu, May 8, 2014 at 10:32 AM, Cullen Jennings <[email-masked]<mailto:[email-masked]>> wrote:

Thanks

Ted, Sean, Cullen

Day 1

Day 2

Day 3

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

                                                                             _\\|//_
                                                                            ( O-O )
                                           e-mail: [email-masked]<mailto:[email-masked]>

---

From: Emil Ivov <[email-masked]>
Date: Thu, 8 May 2014 18:54:15 +0200

+1. I don't know if I'd be able to actually do that so +1 one to
Mary's questions about recording as well.

Emil

On Thu, May 8, 2014 at 6:46 PM, Simon Pietro Romano <[email-masked]> wrote:
>> another question as to whether the meeting is being recorded for people that
>> aren't able to be on the call for 3 days solid?
>>
>> Thanks,
>> Mary.
>>
>>
>>
>>> Hi Mary,
>>>>> doodle poll, please do so at: http://doodle.com/qewq4xvszbc6d4sn. That helps
>>>>> us plan space and food as well as have badges ready.
>>>>>
>>>>> Thanks
>>>>>
>>>>> Ted, Sean, Cullen
>>>>>
>>>>>

-- 
https://jitsi.org

---

From: Salvatore Loreto <[email-masked]>
Date: Thu, 8 May 2014 17:00:38 +0000

+1

On May 8, 2014, at 7:47 PM, "Romascanu, Dan (Dan)" <[email-masked]<mailto:[email-masked]>> wrote:

+1

Dan

From: rtcweb [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Simon Pietro Romano
Sent: Thursday, May 08, 2014 7:46 PM
To: Erik Lagerway
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] Agenda for RTCWeb Interim May 19-20, 2014

+1

Simon

Thanks,
Mary.

Thanks,
Mary.

​Hi Mary,

thanks,

Ted

Below is a the current agenda for the upcoming RTCWEB Interim (essentially, we have the morning sessions for the three days May 19, May 20, May 21 2014).  If you have not filled in your participation in the doodle poll, please do so at:http://doodle.com/qewq4xvszbc6d4sn. That helps us plan space and food as well as have badges ready.

Thanks

Ted, Sean, Cullen

Day 1

Day 2

Day 3

                                                                             _\\|//_
                                                                            ( O-O )

---

From: Salvatore Loreto <[email-masked]>
Date: Thu, 8 May 2014 17:00:46 +0000

+1

+1

Dan

+1

Simon

Thanks,
Mary.

Thanks,
Mary.

​Hi Mary,

thanks,

Ted

Thanks

Ted, Sean, Cullen

Day 1

Day 2

Day 3

                                                                             _\\|//_
                                                                            ( O-O )

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 8 May 2014 11:50:00 -0600

As long as the room supports it, I imagine we will have a live stream from either WebEX or Hangouts - not sure which yet.  For remote feedback back to the room there will be the usual xmpp for RTCWeb and IRC for WebRTC. I don’t know what the situation is in the room for mic’s etc but we will have remote access as best we can.

---

From: Mary Barnes <[email-masked]>
Date: Thu, 8 May 2014 14:13:52 -0500

Honestly, I find this extremely disappointing. In the end, if your audio
isn't good, then the meeting is not accessible to the community (myself
included) that might not happen the $s to travel for the meeting.  When we
had CLUE WG interim meetings, we worked very hard to ensure we had quality
audio for the recording and any remote participants.  My understanding is
that this the usual expectation for official IETF WG meetings.

Regards,
Mary.

On Thu, May 8, 2014 at 12:50 PM, Cullen Jennings <[email-masked]> wrote:

>
> As long as the room supports it, I imagine we will have a live stream from
> either WebEX or Hangouts - not sure which yet.  For remote feedback back to
> the room there will be the usual xmpp for RTCWeb and IRC for WebRTC. I
> don’t know what the situation is in the room for mic’s etc but we will have
> remote access as best we can.
>
>

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 8 May 2014 17:07:07 -0700

On May 8, 2014, at 12:13 PM, Mary Barnes <[email-masked]> wrote:
> 
> Honestly, I find this extremely disappointing. In the end, if your audio isn't good, then the meeting is not accessible to the community (myself included) that might not happen the $s to travel for the meeting.

[BA] I have heard rumors that there is an audio codec that can provide excellent audio quality across a range of bandwidths so that remote participants can hear and even speak.  Supposedly this technology was named after a cartoon penguin (
http://en.m.wikipedia.org/wiki/Opus_the_Penguin).

Also there is a rumour that there are browsers supporting camera devices, so that remote participants can see and even show their own faces (using a technology known to the ancient Greeks as 'get users of Medea', see: 
http://en.m.wikipedia.org/wiki/Medea).

Lastly there are rumours relating to support for screen sharing, and even whispers that the shadowy group known as "the tools team" has put a server online supporting all of this. No doubt this group is related to the cast of the 'Home Improvement' TV show (http://en.m.wikipedia.org/wiki/Home_Improvement_(TV_series)).

Of course, these are mere rumours that no respectable person would give any credence to, and therefore an august body such as this one must cast them aside lest it risk being distracted from its mission.

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 8 May 2014 21:10:10 -0600

Mary, I really did not meet to create a storm on this. 

I’m glad to do whatever we can but as you know, when we have a room with 50 people in it, the problems is microphones, speakers, and echo cancelation. I don’t know what we will have in the way of mics, a floor setup that lets people move to mics, or ECan that can deal with a room both that large. 

I have attended two IETF remotely and the experience was pretty awful on both and that was in a dedicated location set up in advance with an AV support team. I think everyone that has ever remote attended an IETF meeting has seen that being remote, even when set up in the best of all possible ways, is much worse than being there.  If you’ve got any preference on what you want us to use - I’m sure we can get whatever of the major systems you want and 800 numbers and such on webex. I’m sure we can have webex or hangouts if that is the preference. But I can’t promise that remote people will hear everything and I can more or less promises that I have never seen a set up where lots of remote people speaking worked out well. 

On May 8, 2014, at 1:13 PM, Mary Barnes <[email-masked]> wrote:

> Honestly, I find this extremely disappointing. In the end, if your audio isn't good, then the meeting is not accessible to the community (myself included) that might not happen the $s to travel for the meeting.  When we had CLUE WG interim meetings, we worked very hard to ensure we had quality audio for the recording and any remote participants.  My understanding is that this the usual expectation for official IETF WG meetings. 
> 
> Regards,
> Mary.
> 
>

---

From: "Roni Even" <[email-masked]>
Date: Fri, 9 May 2014 11:15:36 +0300

I plan to attend remotely but based on the time difference will be also happy if recording will be avialble

Roni Even

From: rtcweb [mailto:[email-masked]] On Behalf Of Ted Hardie
Sent: 08 May, 2014 7:42 PM
To: Mary Barnes
Cc: [email-masked]
Subject: Re: [rtcweb] Agenda for RTCWeb Interim May 19-20, 2014

Thanks,

Mary.

​Hi Mary,

thanks,

Ted

Thanks

Ted, Sean, Cullen

Day 1

Day 2

Day 3

---

From: Mary Barnes <[email-masked]>
Date: Fri, 9 May 2014 10:03:06 -0500

It certainly would have been nice to know when the meeting was being
organized that there were no plans for remote participation nor recording.
That might have impacted people's decisions to not travel to the meeting.
 At this stage, it's way too late to book travel - airfare is $1000-1300 RT
from DFW to DCA.

I fully understand the logistical issues and it is a hassle to go to
meeting locations early and spend 1/2-1 day setting up a room with A/V guys
to ensure that you can get a reasonable experience for remote participants.
 I personally think it's manageable for chairs if you can get an extra
microphone and ensure people speak into the microphone.  I would imagine
it's not possible to have a meeting with 50 people without a microphone in
the room.

So, I guess, I may have gained 3 extra days in my schedule and I would hope
in this situation that there are meticulous notes with regards to consensus
points, issue resolution, action items, etc.  And, of course, there should
be an understanding that while consensus may have been obtained in the
meeting room, it's not reasonable to expect that no one else has input on
the topic.

Thanks,
Mary.

On Thu, May 8, 2014 at 10:10 PM, Cullen Jennings <[email-masked]> wrote:

> I’m glad to do whatever we can but as you know, when we have a room with
> 50 people in it, the problems is microphones, speakers, and echo
> cancelation. I don’t know what we will have in the way of mics, a floor
> setup that lets people move to mics, or ECan that can deal with a room both
> that large.
>
> I have attended two IETF remotely and the experience was pretty awful on
> both and that was in a dedicated location set up in advance with an AV
> support team. I think everyone that has ever remote attended an IETF
> meeting has seen that being remote, even when set up in the best of all
> possible ways, is much worse than being there.  If you’ve got any
> preference on what you want us to use - I’m sure we can get whatever of the
> major systems you want and 800 numbers and such on webex. I’m sure we can
> have webex or hangouts if that is the preference. But I can’t promise that
> remote people will hear everything and I can more or less promises that I
> have never seen a set up where lots of remote people speaking worked out
> well.
>
>
> > As long as the room supports it, I imagine we will have a live stream
> from either WebEX or Hangouts - not sure which yet.  For remote feedback
> back to the room there will be the usual xmpp for RTCWeb and IRC for
> WebRTC. I don’t know what the situation is in the room for mic’s etc but we
> will have remote access as best we can.
> >
> >

---

From: Ted Hardie <[email-masked]>
Date: Fri, 9 May 2014 08:25:40 -0700

​Hi Mary,

We will have some remote participation mechanism, but we're still trying to
work out which one will best serve.   Since none of the hosts are actually
local to the venue, that's non trivial.  ​But at this point you can assume
it is one of Hangouts, the Jitsi trial service, or Webex.  If you have a
setup that can handle each of those, then you should be fine.

​Recording is a bit different, but I will continue to talk to the venue
folks about that.

Ted​

> So, I guess, I may have gained 3 extra days in my schedule and I would
> hope in this situation that there are meticulous notes with regards to
> consensus points, issue resolution, action items, etc.  And, of course,
> there should be an understanding that while consensus may have been
> obtained in the meeting room, it's not reasonable to expect that no one
> else has input on the topic.
>
> Thanks,
> Mary.
>
>
>> > Honestly, I find this extremely disappointing. In the end, if your
>> audio isn't good, then the meeting is not accessible to the community
>> (myself included) that might not happen the $s to travel for the meeting.
>>  When we had CLUE WG interim meetings, we worked very hard to ensure we had
>> quality audio for the recording and any remote participants.  My
>> understanding is that this the usual expectation for official IETF WG
>> meetings.
>> >
>> > Regards,
>> > Mary.
>> >
>> >
>> > > Is there remote participation information available?  I could not
>> find anything in my email archives nor on the mailing list.
>> > >
>> > > Thanks,
>> > > Mary.
>> > >
>> > >

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 9 May 2014 12:38:37 -0600

On May 9, 2014, at 9:03 AM, Mary Barnes <[email-masked]> wrote:

> It certainly would have been nice to know when the meeting was being organized that there were no plans for remote participation nor recording. 

Mary that is really warping what I said out of context.  We will do the best that we can - and like most IETF interim meetings, including the CLUE ones, that will almost certainly be less than ideal.

---

From: Mary Barnes <[email-masked]>
Date: Fri, 9 May 2014 13:40:07 -0500

Well, the answer to my question initially was that the remote participation
was going to depend upon who would be attending, so it wasn't clear to me
there was any original intent to support remote participation.  I've
chatted with Ted and I'm satisfied that you guys will do the best you can
based upon the location where you are meeting.

Thanks,
Mary.

On Fri, May 9, 2014 at 1:38 PM, Cullen Jennings <[email-masked]> wrote:

> Mary that is really warping what I said out of context.  We will do the
> best that we can - and like most IETF interim meetings, including the CLUE
> ones, that will almost certainly be less than ideal.
>
>

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 9 May 2014 12:45:07 -0600

ok, glad to see it is sorted out and sorry if we caused confusion. I think Teds mail was saying “how” not “if” we would do remote was depended on number of people. We always done our best to make remote work. 

On May 9, 2014, at 12:40 PM, Mary Barnes <[email-masked]> wrote:

> Well, the answer to my question initially was that the remote participation was going to depend upon who would be attending, so it wasn't clear to me there was any original intent to support remote participation.  I've chatted with Ted and I'm satisfied that you guys will do the best you can based upon the location where you are meeting.
> 
> Thanks,
> Mary. 
> 
>

---

From: Christian Groves <[email-masked]>
Date: Mon, 12 May 2014 12:11:22 +1000

Likewise.

Christian

On 9/05/2014 6:15 PM, Roni Even wrote:
> *From:*rtcweb [mailto:[email-masked]] *On Behalf Of *Ted Hardie
> *Sent:* 08 May, 2014 7:42 PM
> *To:* Mary Barnes
> *Cc:* [email-masked]
> *Subject:* Re: [rtcweb] Agenda for RTCWeb Interim May 19-20, 2014
>
> On Thu, May 8, 2014 at 9:02 AM, Mary Barnes 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     (essentially, we have the morning sessions for the three days May
>     19, May 20, May 21 2014). If you have not filled in your
>     participation in the doodle poll, please do so at:
>     http://doodle.com/qewq4xvszbc6d4sn. That helps us plan space and
>     food as well as have badges ready.
>
>     Thanks
>
>     Ted, Sean, Cullen
>
>
>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 12 May 2014 10:45:42 +0000

+1

Dan

> -----Original Message-----
> From: rtcweb [mailto:[email-masked]] On Behalf Of Christian
> Groves
> Sent: Monday, May 12, 2014 5:11 AM
> To: [email-masked]

---

From: "Karl Stahl" <[email-masked]>
Date: Mon, 12 May 2014 13:49:13 +0200

The same for me. /Karl

-----Ursprungligt meddelande-----
Från: rtcweb [mailto:[email-masked]] För Christian Groves
Skickat: den 12 maj 2014 04:11
Till: [email-masked]
Ämne: Re: [rtcweb] Agenda for RTCWeb Interim May 19-20, 2014

Likewise.

Christian

---

From: Martin Thomson <[email-masked]>
Date: Sun, 18 May 2014 19:47:54 -0700

It took me ages to work this out, but the starting time is 08:30 EDT.
The only place any times are mentioned is the Doodle signup page.

---

From: Sean Turner <[email-masked]>
Date: Sun, 18 May 2014 23:01:54 -0400

To confirm that’s when we’re on tap to start: 830 EDT.

spt