Subject: Re: [rtcweb] ICE-Lite, Was: I-D Action: draft-ietf-rtcweb-stun-consent-freshness-02.txt

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Sat, 17 May 2014 21:08:44 +0000

A browser running full ICE needs to be able to connect with a device doing ICE lite - that is in our requirements but to HTA point, it’s not obvious to me that changes what the browser needs to implement to make this work other than implement ICE. Is there something I am missing?

On Apr 12, 2014, at 7:55 AM, Harald Alvestrand <[email-masked]> wrote:

> On 04/12/2014 11:57 AM, Karl Stahl wrote:
>> To avoid confusion…
>>  
>> Gateways are not mentioned in draft-ietf-rtcweb-transports-03
>>  
>> Under 3.5.  Middle box related functions
>> It too simply says:
>> ICE [RFC5245] MUST be supported.  The implementation MUST be a full
>>    ICE implementation, not ICE-Lite.
>>  
>> It needs to be said that gateways, i.e. devices having a media port on a public IP address – never behind a NAT/firewall – SHOULD implement ICE-Lite. (which browsers implementing full ICE correctly are compatible with – and has to be – which we all have the same understanding of, I believe)
> 
> I think we've been over this ground before.
> 
> At the moment, the RTCWEB protocol suite documentation deals with requirements for browsers, not requirements for gateways.
> 
> If someone wishes to start a requirements-for-gateways documents, I think they should be free to do that - but I hope we can finish this document set before that.
> 
> 
>>  
>>  
>> /Karl
>>  
>>  
>> Från: rtcweb [mailto:[email-masked]] För Christer Holmberg
>> Skickat: den 12 april 2014 10:26
>> Till: Harald Alvestrand; Martin Thomson; Ram Mohan R (rmohanr)
>> Kopia: [email-masked]
>> Ämne: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-stun-consent-freshness-02.txt
>>  
>> Hi,
>>  
>> It’s not about running a browser on ice-lite – it is about a browser being prepared to run with a remote endpoint that is running ice-lite (e.g. a gateway). Certain browser implementations have had some problems with that, afaik…
>>  
>> Regards,
>>  
>> Christer
>>  
>> From: Harald Alvestrand [mailto:[email-masked]] 
>> Sent: 12 April 2014 08:59
>> To: Christer Holmberg; Martin Thomson; Ram Mohan R (rmohanr)
>> Cc: [email-masked]
>> Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-stun-consent-freshness-02.txt
>>  
>> Seems we have another reason why running a browser on ice-lite is a bad idea. Good that we do not allow that.
>> 
>> On 11. april 2014 22:37:55 CEST, Christer Holmberg <[email-masked]> wrote:
>> Hi,
>>  With ICE-lite mode since the ICE-lite endpoint does not typically 
>>  generate any binding requests, it may not generate STUN consent as well.
>> 
>> 
>> Wat?
>> 
>> Consent is generated by responding to connectivity checks.  An ICE-lite endpoint has to do that.
>> 
>> 
>> Sure, but I guess what is meant is that the ICE-lite endpoint does not generate STUN consent REQUESTS.
>> 
>> Regards,
>> 
>> Christer
>> 
>> 
>> rtcweb mailing list
>> 
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
>> 
>> -- 
>> Sent from my Android device with K-9 Mail. Please excuse my brevity.
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Karl Stahl" <[email-masked]>
Date: Sat, 17 May 2014 23:40:10 +0200

-----Ursprungligt meddelande-----
Från: Cullen Jennings (fluffy) [mailto:[email-masked]] 
Skickat: den 17 maj 2014 23:09
Till: [email-masked]
Kopia: Karl Stahl; Christer Holmberg; Harald Tveit Alvestrand; Martin
Thomson; Ram Mohan R (rmohanr)
Ämne: Re: [rtcweb] ICE-Lite, Was: I-D Action:
draft-ietf-rtcweb-stun-consent-freshness-02.txt

A browser running full ICE needs to be able to connect with a device doing
ICE lite - that is in our requirements but to HTA point, it’s not obvious to
me that changes what the browser needs to implement to make this work other
than implement ICE. Is there something I am missing?

--- No, don't think so. I saw a clarifying text had been added to the draft
which could cause confusion.
/Karl

On Apr 12, 2014, at 7:55 AM, Harald Alvestrand <[email-masked]> wrote:

>> Under 3.5.  Middle box related functions It too simply says:
>> It needs to be said that gateways, i.e. devices having a media port 
>> on a public IP address – never behind a NAT/firewall – SHOULD 
>> implement ICE-Lite. (which browsers implementing full ICE correctly 
>> are compatible with – and has to be – which we all have the same 
>> understanding of, I believe)
> 
> At the moment, the RTCWEB protocol suite documentation deals with
requirements for browsers, not requirements for gateways.
> 
> If someone wishes to start a requirements-for-gateways documents, I think
they should be free to do that - but I hope we can finish this document set
before that.
>> Ämne: Re: [rtcweb] I-D Action: 
>> draft-ietf-rtcweb-stun-consent-freshness-02.txt
>>  
>> Hi,
>>  
>> It’s not about running a browser on ice-lite – it is about a browser 
>> being prepared to run with a remote endpoint that is running ice-lite 
>> (e.g. a gateway). Certain browser implementations have had some 
>> problems with that, afaik…
>>  
>> Regards,
>>  
>> Christer
>>  
>> Subject: Re: [rtcweb] I-D Action: 
>> draft-ietf-rtcweb-stun-consent-freshness-02.txt
>>