Subject: Re: [rtcweb] Pictures of congestion control on the Internet - which is more realistic?

From: Tim Panton <[email-masked]>
Date: Thu, 1 May 2014 12:08:41 +0100

On 30 Apr 2014, at 22:21, Cullen Jennings (fluffy) <[email-masked]> wrote:

> 
> On Apr 23, 2014, at 9:02 AM, Roman Shpount <[email-masked]> wrote:
> 
>> I would say that some video end points have congestion back off.  Almost all audio end points have none. Based on this, most UDP endpoints do not deal well with congestion.
> 
> Well … I sort of agree with you and Wenger and sort of don’t. They have an upper layer congestion control. Basically when the congestion gets bad, the humans on both ends hang up the call and go call each other on their cell phones. 

That's probably true right now, especially in the SIP world largely because it is linked to and modelled on  the fixed bandwidth expectations of ISDN.
In selecting Opus we have mandated an audio codec that explicitly supports dynamic bandwidth changes and is sufficiently tolerant
of dropped packets to allow congestion control to function without the user necessarily hearing the few dropped packets.
Lets not give up on this.

It is also worth noting that cell phones can do this already, selecting the AMR mode according to the link capacity -  so there is a proof-by-example :-)

Tim.

Tim Panton - Web/VoIP consultant and implementor
www.westhawk.co.uk

---

From: Roman Shpount <[email-masked]>
Date: Thu, 1 May 2014 14:04:02 -0400

> Lets not give up on this.

Nobody argues we should give up on this, but using an adaptive rate audio
codec does not remove the need for QOS.

>
> It is also worth noting that cell phones can do this already, selecting
> the AMR mode according to the link capacity -  so there is a
> proof-by-example :-)
>
>
On cell phone networks voice traffic is treated differently then data so,
in fact, there is QOS in place on the cell data link.

The whole argument is if application level rate adaptation is enough or QOS
support is needed. I would say rate adaptation helps, but QOS is still
needed.
_____________
Roman Shpount

---

From: Michael Welzl <[email-masked]>
Date: Thu, 1 May 2014 20:33:34 +0200

Sent from my iPhone

> On 1. mai 2014, at 20:04, Roman Shpount <[email-masked]> wrote:
> 
> Nobody argues we should give up on this, but using an adaptive rate audio codec does not remove the need for QOS.
>  
>> 
> On cell phone networks voice traffic is treated differently then data so, in fact, there is QOS in place on the cell data link.
> 
> The whole argument is if application level rate adaptation is enough or QOS support is needed. I would say rate adaptation helps, but QOS is still needed.

app level can only operate on traffic coming from one host; it can't make my high-pri flow more important than *your* low-pri flow...

> _____________
> Roman Shpount
>  
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 02 May 2014 19:45:12 +0200

On 05/01/2014 08:04 PM, Roman Shpount wrote:
> On Thu, May 1, 2014 at 7:08 AM, Tim Panton <[email-masked]
> <mailto:[email-masked]>> wrote:
>
> Nobody argues we should give up on this, but using an adaptive rate
> audio codec does not remove the need for QOS.
>  
>
>
>     It is also worth noting that cell phones can do this already,
>     selecting the AMR mode according to the link capacity -  so there
>     is a proof-by-example :-)
>
>
> On cell phone networks voice traffic is treated differently then data
> so, in fact, there is QOS in place on the cell data link.
>
> The whole argument is if application level rate adaptation is enough
> or QOS support is needed. I would say rate adaptation helps, but QOS
> is still needed.

I'd put it the other way round - QoS helps (when it works), but rate
adaptation is still needed.

We might actually agree on what we need to do :-)

-- 
Surveillance is pervasive. Go Dark.

---

From: Roman Shpount <[email-masked]>
Date: Fri, 2 May 2014 13:48:59 -0400

> We might actually agree on what we need to do :-)

I am sure we agree :) We need both QOS and rate adaptation to get the best
possible communication connection quality.
_____________
Roman Shpount