Subject: [rtcweb] (no subject)

From: Eric Rescorla <[email-masked]>
Date: Sun, 11 May 2014 21:52:34 -0700

https://github.com/rtcweb-wg/jsep/issues/19

JSEP S 5.2.1 reads:

   Attributes that are common between all m= sections MAY be moved to
   session-level, if explicitly defined to be valid at session-level.

We should probably encourage this. I propose we make this a SHOULD
rather than a MAY.

-Ekr

---

From: Suhas Nandakumar <[email-masked]>
Date: Sun, 11 May 2014 22:41:28 -0700

+1. Agree to make it SHOULD.

On Sun, May 11, 2014 at 9:52 PM, Eric Rescorla <[email-masked]> wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 12 May 2014 06:48:01 +0000

Hi,

The attribute VALUE needs to be common between all m= sections in order to put the attribute to be put on the session level.

But, do we need to say anything? Isn’t this basic SDP?

Regards,

Christer

From: rtcweb [mailto:[email-masked]] On Behalf Of Suhas Nandakumar
Sent: 12. toukokuuta 2014 8:41
To: Eric Rescorla
Cc: [email-masked]
Subject: Re: [rtcweb] (no subject)

On Sun, May 11, 2014 at 9:52 PM, Eric Rescorla <[email-masked]<mailto:[email-masked]>> wrote:
https://github.com/rtcweb-wg/jsep/issues/19

JSEP S 5.2.1 reads:

-Ekr

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 17 May 2014 13:27:37 -0500

as a purely pragmatic issue, some device seem to have SDP bugs that cause them to ignore some attributes at the session level. I don’t really care what we do on this as mostly I think theses devices should fix their bugs but when people talk abut SDP interop issues, this is occasionally an issue that comes up. 

So I agree we need to have a SHOULD on saying where things go that could be at either a session level or a m= level. Session level makes more sense from a standards point of view but m= level might have slightly better interoperability. 

I don’t care which we choose - perhaps some of the people that considerers themselves and experts on why SDP has interop problems could chime in on how important this is.

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 18 May 2014 10:00:15 +0000

Hi,

I don't think we need to say anything. Because, if I receive session-level attributes on the wire, I should not have to move them around in my JS app before passing the SDP to JSEP. And vice verse.

Also keep in mind that the session vs media does not only affect SDP attributes - you have the same issue for the c= line.

Regards,

Christer

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Cullen Jennings
Sent: 17 May 2014 21:28
To: Eric Rescorla
Cc: [email-masked]
Subject: Re: [rtcweb] (no subject)

as a purely pragmatic issue, some device seem to have SDP bugs that cause them to ignore some attributes at the session level. I don't really care what we do on this as mostly I think theses devices should fix their bugs but when people talk abut SDP interop issues, this is occasionally an issue that comes up. 

I don't care which we choose - perhaps some of the people that considerers themselves and experts on why SDP has interop problems could chime in on how important this is.

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 18 May 2014 06:22:47 -0700

On Sun, May 18, 2014 at 3:00 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> I don't think we need to say anything. Because, if I receive session-level
> attributes on the wire, I should not have to move them around in my JS app
> before passing the SDP to JSEP. And vice verse.

This section is instructions to the browser author.

-Ekr

 Also keep in mind that the session vs media does not only affect SDP
> attributes - you have the same issue for the c= line.
>
> Regards,
>
> Christer
>
> as a purely pragmatic issue, some device seem to have SDP bugs that cause
> them to ignore some attributes at the session level. I don't really care
> what we do on this as mostly I think theses devices should fix their bugs
> but when people talk abut SDP interop issues, this is occasionally an issue
> that comes up.
>
> So I agree we need to have a SHOULD on saying where things go that could
> be at either a session level or a m= level. Session level makes more sense
> from a standards point of view but m= level might have slightly better
> interoperability.
>
> I don't care which we choose - perhaps some of the people that considerers
> themselves and experts on why SDP has interop problems could chime in on
> how important this is.
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 18 May 2014 14:15:01 +0000

Hi,

Correct. My mistake.

Then, assuming we want to say something, is there a reason why we can’t use MUST (whatever MUST of course needs to be decided :)? It will life easier for JS apps that, for whatever reason, need to process the SDP generated for the browser.

Regards,

Christer

-Ekr

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Sun, 18 May 2014 21:02:37 -0700

I think there is a readability benefit to have all the stuff spelled out at
media-level. I don't see what we gain by moving things to session level;
the byte savings are not significant enough to be worth optimizing for.

However, if there is a clear interoperability advantage for one or the
other, let's just SHOULD that.

On Sun, May 18, 2014 at 7:15 AM, Christer Holmberg <
[email-masked]> wrote:

> Then, assuming we want to say something, is there a reason why we can’t
> use MUST (whatever MUST of course needs to be decided :)? It will life
> easier for JS apps that, for whatever reason, need to process the SDP
> generated for the browser.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
>
>
> -Ekr
>
>
>
>
>
>   as a purely pragmatic issue, some device seem to have SDP bugs that
> cause them to ignore some attributes at the session level. I don't really
> care what we do on this as mostly I think theses devices should fix their
> bugs but when people talk abut SDP interop issues, this is occasionally an
> issue that comes up.
>