Subject: [rtcweb] Dates for rtcweb drafts

From: Cullen Jennings <[email-masked]>
Date: Thu, 9 Oct 2014 13:08:04 -0600

Once again, the chairs are updating dates for documents. I'm forming a list of when we hope to have an RFC for various drafts. In many ways the relative ordering of when these drafts is probably more accurate than the actually dates. The straw man for dates is

I-D.ietf-rtcweb-alpn  2015 Feb 

I-D.ietf-rtcweb-audio 2015 May

I-D.ietf-rtcweb-constraints-registry 2015 Jan 

I-D.ietf-rtcweb-data-channel  2014 Dec

I-D.ietf-rtcweb-data-protocol 2014 Dec

I-D.ietf-rtcweb-jsep  2015 May 

I-D.ietf-rtcweb-overview 2015 May 

I-D.ietf-rtcweb-rtp-usage 2015 Jan

I-D.ietf-rtcweb-security-arch 2015 Dec 

I-D.ietf-rtcweb-security 2015 Dec 

I-D.ietf-rtcweb-stun-consent-freshness 2015 Feb

I-D.ietf-rtcweb-transports 2015 Jan

I-D.ietf-rtcweb-video 2015 May

If you are an author or involved with these drafts or just have a strong opinion on what the date to be an RFC will be and want to use a different date than the ones above, let me know.

Thanks, Cullen

If you are interested, I have a document where I track the dates of most the normative dependencies for WebRTC at 

https://tools.ietf.org/html/draft-jennings-rtcweb-deps

---

From: Martin Thomson <[email-masked]>
Date: Thu, 9 Oct 2014 13:00:55 -0700

> I-D.ietf-rtcweb-jsep  2015 May

https://www.youtube.com/watch?v=dik_wnOE4dk&index=2&t=33s&list=WL

This is a really large document and a good proportion of it hasn't
been reviewed or discussed.

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 9 Oct 2014 13:18:44 -0700

On Thu, Oct 9, 2014 at 1:00 PM, Martin Thomson <[email-masked]>
wrote:

> been reviewed or discussed

... or written.

-Ekr

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Martin Thomson <[email-masked]>
Date: Thu, 9 Oct 2014 13:22:59 -0700

>> been reviewed or discussed

I don't know, it looks like you've been making good progress.  You
might be half-way.

The "Parsing an Offer", "Parsing an Answer", "Applying a Local
Description" and "Applying a Remote Description" sections might be
empty now, but they aren't that hard.

---

From: Colin Perkins <[email-masked]>
Date: Fri, 10 Oct 2014 11:47:40 +0100

> Once again, the chairs are updating dates for documents. I'm forming a list of when we hope to have an RFC for various drafts. In many ways the relative ordering of when these drafts is probably mo…
…
> I-D.ietf-rtcweb-rtp-usage 2015 Jan

The only open issue with this draft is FEC support. Varun recently submitted draft-singh-payload-rtp-1d2d-parity-scheme-00 as a possible FEC scheme for WebRTC. Feedback from the working group on whether that draft is suitable to be referenced from the rtp-usage draft would be helpful.

-- 
Colin Perkins
https://csperkins.org/

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 10 Oct 2014 12:52:44 +0200

I'd like the chairs to indicate whether or not they are going to 
entertain -gateways for WG draft status too.

> I-D.ietf-rtcweb-security 2015 Dec
I assume "2014 Dec" is the intended target date here?

---

From: Martin Thomson <[email-masked]>
Date: Fri, 10 Oct 2014 09:35:27 -0700

On 10 October 2014 03:52, Harald Alvestrand <[email-masked]> wrote:
> I'd like the chairs to indicate whether or not they are going to entertain
> -gateways for WG draft status too.

Maybe you should instead ask the working group.

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 10 Oct 2014 18:58:51 +0200

> Maybe you should instead ask the working group.

That's the question I think it's the WG chairs' job to ask.

-- 
Surveillance is pervasive. Go Dark.

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 10 Oct 2014 17:13:10 +0000

While you try to figure out who should ask the question, I'll give MY answer: I think the draft should be adopted as a WG item :)

Regards,

Christer

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 10 Oct 2014 10:38:46 -0700

+1.

> On Oct 10, 2014, at 10:13, Christer Holmberg <[email-masked]> wrote:
>

---

From: "Rauschenbach, Uwe (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 14 Oct 2014 17:38:53 +0000

+1

> From: rtcweb [mailto:[email-masked]] On Behalf Of ext Bernard
> Aboba
> Sent: Friday, October 10, 2014 7:39 PM
> To: Christer Holmberg
> Cc: [email-masked]
> > While you try to figure out who should ask the question, I'll give MY
> answer: I think the draft should be adopted as a WG item :)
> >
> > Regards,
> >
> > Christer
> >