Subject: [rtcweb] Agenda for the upcoming meeting

From: Ted Hardie <[email-masked]>
Date: Thu, 16 Oct 2014 10:10:50 -0700

During this morning chairs call, we discussed the agenda for the upcoming
meeting.  The two big items are JSEP and the video codec discussion, and
our current thought is to have the JSEP discussion on Monday and the video
codec discussion on Thursday.  There are a number of items we may need to
discuss; if there are particular issues you feel we need to cover, please
send a message to the list with the topic and the amount of time you feel
you need.

thanks,

Ted, Cullen, Sean

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 16 Oct 2014 17:21:23 +0000

Hi,

Another issue that must be solved is the Data Channel stream id issue that is currently being discussed.

Hopefully it can be solved on the list before the meeting, but just in case it can’t…

We have a dependency on that issue also in CLUE.

Regards,

Christer

From: rtcweb [mailto:[email-masked]] On Behalf Of Ted Hardie
Sent: 16 October 2014 20:11
To: [email-masked]; Sean Turner; Cullen Jennings
Subject: [rtcweb] Agenda for the upcoming meeting

During this morning chairs call, we discussed the agenda for the upcoming meeting.  The two big items are JSEP and the video codec discussion, and our current thought is to have the JSEP discussion on Monday and the video codec discussion on Thursday.  There are a number of items we may need to discuss; if there are particular issues you feel we need to cover, please send a message to the list with the topic and the amount of time you feel you need.

thanks,

Ted, Cullen, Sean

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 17 Oct 2014 15:25:41 +0200

On 10/16/2014 07:10 PM, Ted Hardie wrote:
> During this morning chairs call, we discussed the agenda for the 
> upcoming meeting.  The two big items are JSEP and the video codec 
> discussion, and our current thought is to have the JSEP discussion on 
> Monday and the video codec discussion on Thursday.  There are a number 
> of items we may need to discuss; if there are particular issues you 
> feel we need to cover, please send a message to the list with the 
> topic and the amount of time you feel you need.

We have not had face to face discussion on 
draft-alvestrand-rtcweb-gateways (and not much discussion on the mailing 
list either).

I'd like to have a review of that document on the agenda.

Note: In my opinion, the chairs can choose to decide on whether the 
group should adopt the draft before, during or after the meeting, with 
or without calling for consensus of the WG.

I would like to have the chairs say what they intend to do about this 
document.

>
> thanks,
>
> Ted, Cullen, Sean
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Justin Uberti <[email-masked]>
Date: Fri, 17 Oct 2014 15:49:02 -0700

I would like to discuss enterprise WebRTC proxies, a previously unaddressed
requirement which now has a proposal in
https://tools.ietf.org/html/draft-schwartz-rtcweb-return-03

On Fri, Oct 17, 2014 at 6:25 AM, Harald Alvestrand <[email-masked]>
wrote:

> Monday and the video codec discussion on Thursday.  There are a number of
> items we may need to discuss; if there are particular issues you feel we
> need to cover, please send a message to the list with the topic and the
> amount of time you feel you need.
>
>
> Note: In my opinion, the chairs can choose to decide on whether the group
> should adopt the draft before, during or after the meeting, with or without
> calling for consensus of the WG.
>
> rtcweb mailing [email-masked]://www.ietf.org/mailman/listinfo/rtcweb
>
>
>

---

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Sun, 19 Oct 2014 15:38:26 -0600

On 10/16/14, 11:10 AM, Ted Hardie wrote:
> Monday and the video codec discussion on Thursday.

As far as I can see, the temper of the list has been that it would be 
premature and a waste of energy to discuss the video codec topic at IETF 
91. Do the chairs see things differently?

Peter

-- 
Peter Saint-Andre
https://andyet.com/

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Mon, 20 Oct 2014 18:55:36 +0000

So lets be clear here. Every time we checked, there has been consensus that we need an MTI codec. So right now this work is sort of blocked on that and we would like to get what people are calling webrtc 1.0 out before the end of 2015.  I think that a pragmatic look at this would result there is at least some reasonable odds it might take more than one or two meetings to resolve this if we end up in an alternative consensus process. 

You said on the list you felt "the state of video codec development needs to evolve" before this discussions. I did not know what you what you see needs to happen in this evolution and how long should we wait before on this. I was wondering if you meant we should wait for the IETF to standardize a video codec (like the netvc BOF is proposing) but I really had no idea what you meant 

Do you think there would be a better time to discuss this?

Cullen

So far much of conversation has been folks in the Microsoft camp - keep in mind some of that group has said in the past they would be 

On Oct 19, 2014, at 3:38 PM, Peter Saint-Andre - &yet <[email-masked]> wrote:

> As far as I can see, the temper of the list has been that it would be premature and a waste of energy to discuss the video codec topic at IETF 91. Do the chairs see things differently?
> 
> Peter
> 
> -- 
> Peter Saint-Andre
> https://andyet.com/
>

---

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Mon, 20 Oct 2014 13:28:20 -0600

On 10/20/14, 12:55 PM, Cullen Jennings (fluffy) wrote:
>
> So lets be clear here. Every time we checked, there has been
> consensus that we need an MTI codec. So right now this work is sort
> of blocked on that and we would like to get what people are calling
> webrtc 1.0 out before the end of 2015.  I think that a pragmatic look
> at this would result there is at least some reasonable odds it might
> take more than one or two meetings to resolve this if we end up in an
> alternative consensus process.

Given the parameters being assumed, you're probably right that several 
IETF meeting cycles will likely be needed.

> You said on the list you felt "the state of video codec development
> needs to evolve" before this discussions. I did not know what you
> what you see needs to happen in this evolution and how long should we
> wait before on this. I was wondering if you meant we should wait for
> the IETF to standardize a video codec (like the netvc BOF is
> proposing) but I really had no idea what you meant

IMHO, if that working group had been formed after the video codec BoF 
two years ago, we might be further along toward a real solution.

> Do you think there would be a better time to discuss this?

When we can make a decision on a technical basis, not a political basis. 
The current situation involves "camps", as you say, and I just don't 
think that's a good foundation from which to make decisions.

As things stand today, the most likely outcome appears to be "two MTIs" 
(which we've done in draft-ietf-rtcweb-audio so I suppose it's not the 
end of the world).

Peter

-- 
Peter Saint-Andre
https://andyet.com/

---

From: Emil Ivov <[email-masked]>
Date: Mon, 20 Oct 2014 21:41:42 +0200

On 20 Oct 2014 8:55 PM, "Cullen Jennings (fluffy)" <[email-masked]> wrote:
> So lets be clear here.

Good idea!

> Every time we checked, there has been consensus that we need an MTI codec.
> So right now this work is sort of blocked on that

So clearly, what work is blocked on that exactly?

> and we would like to get what people are calling webrtc 1.0 out before the end of 2015.

I would love for that to happen as well. There are a bunch of pieces
still being worked on but I can't find any that depend on the MTI
debate happening. (Except for trickle ICE of course! The delay there
is totally not the fault of the authors and entirely caused by the
lack of an MTI video codec ;) ).

>  I think that a pragmatic look at this would result there is at least some reasonable odds it might take more than one or two meetings to resolve this if we end up in an alternative consensus process.

It's probably worth distinguishing between finishing the technical and
the administrative aspects of our work. I am sure that the latter
would be much less dramatic.

> Do you think there would be a better time to discuss this?

Well, for starters, it might be good to have some form of consensus
already appearing plausible on the mailing list! Right now it seems we
can't even agree to talk about it.

> So far much of conversation has been folks in the Microsoft camp - keep in mind some of that group has said in the past they would be

Hm ... I personally saw strong thread participation from Cisco
employees ... but that might be because we attended different counting
schools! ;)

Emil

--
https://jitsi.org

---

From: Silvia Pfeiffer <[email-masked]>
Date: Tue, 21 Oct 2014 08:56:49 +1100

On 21 Oct 2014 05:55, "Cullen Jennings (fluffy)" <[email-masked]> wrote:
>
>
> So lets be clear here. Every time we checked, there has been consensus
that we need an MTI codec. So right now this work is sort of blocked on
that and we would like to get what people are calling webrtc 1.0 out before
the end of 2015.  I think that a pragmatic look at this would result there
is at least some reasonable odds it might take more than one or two
meetings to resolve this if we end up in an alternative consensus process.
>
> You said on the list you felt "the state of video codec development needs
to evolve" before this discussions. I did not know what you what you see
needs to happen in this evolution and how long should we wait before on
this. I was wondering if you meant we should wait for the IETF to
standardize a video codec (like the netvc BOF is proposing) but I really
had no idea what you meant
> So far much of conversation has been folks in the Microsoft camp - keep
in mind some of that group has said in the past they would be

What's the Microsoft camp? This far I can see a VP8/9 camp and a H.264/5
camp and both camps have their reasons for making the respective choice. I
think at this stage it's a religious discussion and not one likely to be
resolved until a completely new and clearly superior codec in all discussed
dimensions comes along. Is there really a point to spend more time
discussing now?

(BTW: I won't be at the meeting, so feel free to waste your time. Just
saying...)

Regards,
Silvia.

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 21 Oct 2014 14:32:23 +0000

> So clearly, what work is blocked on that exactly?

The only thing that seems to be blocked is the MTI Codec decision and here I think we need to accept that no decision is better than a wrong decision or a decision that divides the community. 

Therefore I suggest we continue to ignore the issue and move on.

Andy

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 22 Oct 2014 10:28:00 +0000

Yes please let’s spend some time discussing https://tools.ietf.org/html/draft-schwartz-rtcweb-return-03.

Regards
Andy

From: rtcweb [mailto:[email-masked]] On Behalf Of Justin Uberti
Sent: 17 October 2014 23:49
To: Harald Alvestrand
Cc: [email-masked]
Subject: Re: [rtcweb] Agenda for the upcoming meeting

I would like to discuss enterprise WebRTC proxies, a previously unaddressed requirement which now has a proposal in
https://tools.ietf.org/html/draft-schwartz-rtcweb-return-03

On Fri, Oct 17, 2014 at 6:25 AM, Harald Alvestrand <[email-masked]<mailto:[email-masked]>> wrote:
On 10/16/2014 07:10 PM, Ted Hardie wrote:
During this morning chairs call, we discussed the agenda for the upcoming meeting.  The two big items are JSEP and the video codec discussion, and our current thought is to have the JSEP discussion on Monday and the video codec discussion on Thursday.  There are a number of items we may need to discuss; if there are particular issues you feel we need to cover, please send a message to the list with the topic and the amount of time you feel you need.

We have not had face to face discussion on draft-alvestrand-rtcweb-gateways (and not much discussion on the mailing list either).

Note: In my opinion, the chairs can choose to decide on whether the group should adopt the draft before, during or after the meeting, with or without calling for consensus of the WG.

I would like to have the chairs say what they intend to do about this document.

thanks,

Ted, Cullen, Sean

rtcweb mailing list

[email-masked]<mailto:[email-masked]>

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb