Subject: Re: [rtcweb] draft-ietf-rtcweb-transports

From: Harald Alvestrand <[email-masked]>
Date: Wed, 22 Oct 2014 16:52:42 +0200

On 08/25/2014 07:36 AM, Justin Uberti wrote:
> Yes, 4571 must be used for ICE connectivity checks, when using ICE-TCP.
>
> However, TURN/TCP has its own framing for STUN messages.
>
> I would simplify your sentence to:
>
>    If ICE-TCP connections are used, framing according to [RFC4571] MUST
>    be used for all packets, unless the content has its own framing
> mechanism.

Checking the list for long-delayed updates....

Checking back: The change from TCP to ICE-TCP is good (this excludes
TURN-TCP from this paragraph), but the exchange leaves me uncertain
about the status of STUN packets on ICE-TCP connections.

Do they happen at all? If they happen, should they be RFC 4571
encapsulated, or not?

>
>
> On Fri, Aug 22, 2014 at 8:38 AM, Iñaki Baz Castillo <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     draft-ietf-rtcweb-transports-06 says:
>
>        If TCP connections are used, RTP framing according to [RFC4571]
>     MUST
>        be used, both for the RTP packets and for the DTLS packets used to
>        carry data channels.
>
>
>     Not just RTP and DTLS, but also for STUN packets must be framed with
>     RFC4571. And I do not understand why "DTLS packets used to carry data
>     channels". In fact all the DTLS packets (also the ones for the
>     handshake) must be framed as per RFC 4571.
>
>
>     So I suggest to improve the above text as follows:
>
>        If TCP connections are used, RTP framing according to [RFC4571]
>     MUST
>        be used for the STUN packets, SRTP packets, SRTCP packets and DTLS
>        packets.
>
>
>
>
>
>
>     --
>     Iñaki Baz Castillo
>     <[email-masked] <mailto:[email-masked]>>
>
>     _______________________________________________
>     rtcweb mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/rtcweb
>
>
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

-- 
Surveillance is pervasive. Go Dark.

---

From: Justin Uberti <[email-masked]>
Date: Wed, 22 Oct 2014 13:36:05 -0700

yes, they need to happen. Framing is 4571. See
http://tools.ietf.org/html/rfc6544#section-7.1.

On Wed, Oct 22, 2014 at 7:52 AM, Harald Alvestrand <[email-masked]>
wrote:

> TURN-TCP from this paragraph), but the exchange leaves me uncertain about
> the status of STUN packets on ICE-TCP connections.
>
> On Fri, Aug 22, 2014 at 8:38 AM, Iñaki Baz Castillo <[email-masked]> wrote:
>
>> Hi,
>>
>>    If TCP connections are used, RTP framing according to [RFC4571] MUST
>>    If TCP connections are used, RTP framing according to [RFC4571] MUST
>> <[email-masked]>
> rtcweb mailing [email-masked]://www.ietf.org/mailman/listinfo/rtcweb
>
>
>
> --