Subject: [rtcweb] Gateways

From: Martin Thomson <[email-masked]>
Date: Mon, 10 Nov 2014 19:26:56 -0800

I'm not sure that this is the comment Ted was looking for here.

I don't think that we need this document, as Keith observes, a short
note in -overview suffices:

A gateway is a webrtc endpoint or webrtc-compatible endpoint that
forwards stuff (media or data) to other endpoints.  This is useful.

---

From: Lorenzo Miniero <[email-masked]>
Date: Tue, 11 Nov 2014 04:38:12 +0100

On Mon, 10 Nov 2014 19:26:56 -0800

> forwards stuff (media or data) to other endpoints.  This is useful.

Having worked on one I think we need more than that, so I'd support such
a document. There are several things that can go wrong (see the stuff
we're discussing in STRAW, for instance) so gateways are indeed
special IMHO.

I can help/contribute text if deemed useful.

Lorenzo

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Rauschenbach, Uwe (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 11 Nov 2014 04:10:33 +0000

Hi Martin,

In Toronto, we have discussed that we need a home for statements regarding relaxing of requirements for gateways, such as support for ICE lite. The -gateways draft provides this home; I would be OK with another home as long as the necessary text can be provided. 

On the value of this, I think we should remind developers somewhere in our documentation that WebRTC browsers / "non-browsers" should be aware that they may meet end points that have a restricted feature set and that they need to be able to interwork with them.

The statement you propose below is too short to capture the specific requirements relaxations for WebRTC gateways. 

Kind regards,
Uwe 

> -----Original Message-----
> From: rtcweb [mailto:[email-masked]] On Behalf Of ext Martin
> Thomson
> Sent: Monday, November 10, 2014 5:27 PM
> To: [email-masked]
> Subject: [rtcweb] Gateways
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 11 Nov 2014 05:26:44 +0000

That is not what I was suggesting.

I still believe that the gateways draft should be integrated into the overview, but independent of that it does need to quantify in some what what a webrtc gateway should conform to.

So I believe that there should be a structure similar to that given in sections 4 through 9 of the overview document. The statements made there will obviously not be quite so mandating as those for the endpoints, but for example it should be perfectly reasonable to state that for example:

"If the WebRTC gateway terminates RTP, then the WebRTC gateway MUST implement draft-ietf-rtcweb-rtp-usage."

I would like it to focus on thet parts of the protocol suite that the gateway is likely to terminate.

Regards

Keith

> From: rtcweb [mailto:[email-masked]] On Behalf Of 
> Martin Thomson
> Sent: 11 November 2014 03:27
> To: [email-masked]
> I don't think that we need this document, as Keith observes, 
> a short note in -overview suffices:
> 
> A gateway is a webrtc endpoint or webrtc-compatible endpoint 
> that forwards stuff (media or data) to other endpoints.  This 
> is useful.
>

---

From: Martin Thomson <[email-masked]>
Date: Mon, 10 Nov 2014 21:28:57 -0800

> That is not what I was suggesting.

I didn't mean to suggest that.  I agreed with the integration
suggestion you provided, but added my own:

There is no value to *WebRTC* in having a thorough and robust
description of the things that are outside of WebRTC other than to
note that they exist and might interface in a somewhat rough fashion
with WebRTC.

---

From: Victor Pascual Avila <[email-masked]>
Date: Tue, 11 Nov 2014 09:49:20 +0100

> we're discussing in STRAW, for instance) so gateways are indeed

Agree.

Some examples:

https://tools.ietf.org/html/draft-ietf-straw-b2bua-stun-00

https://tools.ietf.org/html/draft-ietf-straw-b2bua-rtcp-02

https://tools.ietf.org/html/draft-ram-straw-b2bua-dtls-srtp-00

-Victor