Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-overview-12.txt

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 6 Nov 2014 20:00:25 +0000

A few comments:

General: I believe the overview document should include the gateway document, rather than being a separate document.

2.4: Definition of WebRTC device: This refers to protocols, but does not say what the scope of those protocols are. Does it include only the protocols listed in this document, other protocols that could be used in conjunction with webrtc, or what.

5: My understanding is that one of the security documents is a requirements document, which leads to the other document containing the security specification. Therefore the reference to the first should be at most informative, and the normative reference only to the second. I sought clarification on this at the last meeting, and that was the understanding I received. 

I believe it would be useful to have an offline discussion in Honolulu to spend some time reviewing the overview and gateway documents. Would there be an hour somewhere to slot this in. It would at least be useful to know what direction you think should be taking on the on-list discussion of some of the terms.

Regards

Keith

> -----Original Message-----
> From: rtcweb [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: 13 October 2014 10:51
> To: [email-masked]
> Cc: [email-masked]
> Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-overview-12.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
>  This draft is a work item of the Real-Time Communication in 
> WEB-browsers Working Group of the IETF.
> 
>         Title           : Overview: Real Time Protocols for 
> Browser-based Applications
>         Author          : Harald T. Alvestrand
> 	Filename        : draft-ietf-rtcweb-overview-12.txt
> 	Pages           : 22
> 	Date            : 2014-10-13
> 
> Abstract:
>    This document gives an overview and context of a protocol suite
>    intended for use with real-time applications that can be 
> deployed in
>    browsers - "real time communication on the Web".
> 
>    It intends to serve as a starting and coordination point 
> to make sure
>    all the parts that are needed to achieve this goal are 
> findable, and
>    that the parts that belong in the Internet protocol suite are fully
>    specified and on the right publication track.
> 
>    This document is an Applicability Statement - it does not itself
>    specify any protocol, but specifies which other 
> specifications WebRTC
>    compliant implementations are supposed to follow.
> 
>    This document is a work item of the RTCWEB working group.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-rtcweb-overview/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-rtcweb-overview-12
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-rtcweb-overview-12
> 
> 
> Please note that it may take a couple of minutes from the 
> time of submission until the htmlized version and diff are 
> available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 06 Nov 2014 12:22:09 -0800

> A few comments:

How nice to discuss something other than codecs - thank you!
> General: I believe the overview document should include the gateway document, rather than being a separate document.

I disagree (kind of obvious from the fact that I created the gateway
document).
I regard gateways as one "edge" of the WebRTC universe; putting them
into the overview document makes them much more "front and center".

I think there are special concerns with gateways that need discussion
(although not much has made it into -gateways yet - there's been very
little feedback), and having them in a separate document will make them
easier to address.

> 2.4: Definition of WebRTC device: This refers to protocols, but does not say what the scope of those protocols are. Does it include only the protocols listed in this document, other protocols that…

The protocols required by this document and its normative references.
Any protocol "could be used in conjunction with WebRTC", so that would
include the "whole world".

> 5: My understanding is that one of the security documents is a requirements document, which leads to the other document containing the security specification. Therefore the reference to the first s…

Good point. Unless someone argues the contrary, I'll move the reference
to "-security" to the informative section.

> I believe it would be useful to have an offline discussion in Honolulu to spend some time reviewing the overview and gateway documents. Would there be an hour somewhere to slot this in. It would at…

"offline" = "at meeting"?
Gateways is on the agenda, I believe.

-- 
Surveillance is pervasive. Go Dark.

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 06 Nov 2014 18:46:10 -0800

> to "-security" to the informative section.
Followup:

I reviewed -security and -security-arch briefly.
There is a lot of normative language in -security (MUST), but all the
examples that I was able to follow were matched by more specific
normative language in -security-arch. (The exception I could find is the
requirement for masking on TCP, which seems to have beeen overtaken by
events - we don't have any way to generate any content that needs
masking, so it's hard to see that it needs to be normative for that reason.)

Editors of -security*: Is the intent that one should be able to refer to
only -security-arch normatively?

           Harald