Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-overview-13.txt

From: [email-masked]
Date: Fri, 28 Nov 2014 05:19:03 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Real-Time Communication in WEB-browsers Working Group of the IETF.

        Title           : Overview: Real Time Protocols for Browser-based Applications
        Author          : Harald T. Alvestrand
	Filename        : draft-ietf-rtcweb-overview-13.txt
	Pages           : 22
	Date            : 2014-11-28

Abstract:
   This document gives an overview and context of a protocol suite
   intended for use with real-time applications that can be deployed in
   browsers - "real time communication on the Web".

   It intends to serve as a starting and coordination point to make sure
   all the parts that are needed to achieve this goal are findable, and
   that the parts that belong in the Internet protocol suite are fully
   specified and on the right publication track.

   This document is an Applicability Statement - it does not itself
   specify any protocol, but specifies which other specifications WebRTC
   compliant implementations are supposed to follow.

   This document is a work item of the RTCWEB working group.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtcweb-overview/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-rtcweb-overview-13

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-rtcweb-overview-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Sun, 30 Nov 2014 19:44:01 +0000

>A WebRTC browser (also called a WebRTC User Agent or WebRTC UA) is      >something that conforms to both the protocol specification and the
>Javascript API defined above.

Thanks for adding updates to the terminology, which now captures most
of it.
I have a comment on the above text in 2.2.

This seem to focus more on WebRTC **browser**. But, there are hybrid
environments, such as Apache Cordova, which are not browsers but can
conform to protocol specification and Javascript API just like a 
browser (as most of the times they share same source code as a browser). Android KitKat provided WebView component, that supports WebRTC APIs+Javascript, is one example which is close to native than hybrid environment. To include these use cases, I suggest changing the above text to:

"A WebRTC User Agent or WebRTC UA is something that conforms to both the protocol specification and the Javascript API defined above. WebRTC browser is one such WebRTC UA. However, other non-browser implementations may conform to WebRTC UA as well."

BR
Raju

> -----Original Message-----
> From: rtcweb [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Friday, November 28, 2014 7:19 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-overview-13.txt
> 
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 1 Dec 2014 00:13:58 +0000

Hi,

My understanding from Honolulu was that we were NOT going to talk about "WebRTC User Agents" - we were going to talk about "WebRTC browsers" and "WebRTC non-browsers".

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Makaraju, Maridi Raju (Raju)<mailto:[email-masked]>
Sent: ‎30/‎11/‎2014 21:44
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-overview-13.txt

BR
Raju