Subject: [rtcweb] WebRTC endpoint non-browser

From: Gaelle Martin-Cocher <[email-masked]>
Date: Mon, 8 Dec 2014 16:03:32 +0000

All,

Is it possible to know who is going to develop services that belongs to the WebRTC  endpoint non-browser category?
I think it would really help if we can identify that.
Thanks,

Gaëlle

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Mon, 08 Dec 2014 17:10:24 +0100

Native or custom applications, audio gateways, mcus, transcoders, SBCs...

Best regards
Sergio

On 08/12/2014 17:03, Gaelle Martin-Cocher wrote:
>
> All,
>
> Is it possible to know who is going to develop services that belongs 
> to the WebRTC  endpoint non-browser category?
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Gaelle Martin-Cocher <[email-masked]>
Date: Mon, 8 Dec 2014 16:24:08 +0000

You are listing webrtc-compatible endpoints, not webrtc "non browser" endpoints.
I am not asking of generic types of services but who actually belong to the non browser endpoint category.

Thanks
Gaëlle

From: rtcweb [mailto:[email-masked]] On Behalf Of Sergio Garcia Murillo
Sent: Monday, December 08, 2014 11:10 AM
To: [email-masked]
Subject: Re: [rtcweb] WebRTC endpoint non-browser

Best regards
Sergio

Gaëlle

rtcweb mailing list

[email-masked]<mailto:[email-masked]>

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 8 Dec 2014 18:23:15 +0100

2014-12-08 17:24 GMT+01:00 Gaelle Martin-Cocher <[email-masked]>:
> You are listing webrtc-compatible endpoints, not webrtc “non browser”
> endpoints.
>

If you build a mobile native app with WebRTC capabilities (using a
WebRTC library or your own one) then that is a "non browser" WebRTC
endpoint.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Gaelle Martin-Cocher <[email-masked]>
Date: Mon, 8 Dec 2014 17:24:25 +0000

Are you building such app?

-----Original Message-----
From: Iñaki Baz Castillo [mailto:[email-masked]] 
Sent: Monday, December 08, 2014 12:23 PM
To: Gaelle Martin-Cocher
Cc: Sergio Garcia Murillo; [email-masked]
Subject: Re: [rtcweb] WebRTC endpoint non-browser

> to the non browser endpoint category.

If you build a mobile native app with WebRTC capabilities (using a WebRTC library or your own one) then that is a "non browser" WebRTC endpoint.

--
Iñaki Baz Castillo
<[email-masked]>

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 8 Dec 2014 18:25:38 +0100

> Are you building such app?

Does it matter?

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Lorenzo Miniero <[email-masked]>
Date: Mon, 08 Dec 2014 18:25:44 +0100

Many of us are,

L.

-- 
Inviato dal mio dispositivo Android con K-9 Mail. Perdonate la brevità.

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Mon, 08 Dec 2014 20:47:24 +0100

They may be webrtc endpoints, or compatible-endpoints depending if they 
implement full webrtc-rtc stuff our just a minimum subset.

Being specific, any mobile application not using a browser will be a 
webrtc endpoint. So I bet every single webrtc service will implement 
their own app, hence their own webrtc endpoint.

Best regards
Sergio

On 08/12/2014 17:24, Gaelle Martin-Cocher wrote:
> *From:*rtcweb [mailto:[email-masked]] *On Behalf Of *Sergio 
> Garcia Murillo
> *Sent:* Monday, December 08, 2014 11:10 AM
> *To:* [email-masked]
> *Subject:* Re: [rtcweb] WebRTC endpoint non-browser
>
>     Is it possible to know who is going to develop services that
>     belongs to the WebRTC  endpoint non-browser category?
>
>     [email-masked]  <mailto:[email-masked]>
>

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Mon, 08 Dec 2014 20:48:36 +0100

The question, is who cares?

My  application will do whatever is needed for my service, implement 
one, two, three or none video codecs according to my business 
requirements. I don't really care (so won't my users) if you call it 
webrtc endpoint, webrtc-compatible endpoint or webrtc-non-compatible 
endpoint.

So, from my point of view, we are just discussing about definitions of 
entities so we all speak same languages, any attempt to push a MTI codec 
is wishful thinking at best.

Talking about reality, from my experience, most of the apps will be 
google's libwebrtc based, so they will implement whatever is provided in 
there. VP8 for sure, and h264 if supported by mobile and used by libwebrtc.

On a side note, with current state of specs, a Microsoft based ORTC 
implementation on IE will be a webrtc endpoint.

Best regards
Sergio
On 08/12/2014 19:00, Gaelle Martin-Cocher wrote:
>
> Do you have any concrete examples?
>
> Does this mobile app, needs to interact with another mobile app? 
> Again, I am looking for concrete example.
>
> I bet that every single webrtc service will be a webrtc compatible 
> endpoint.
>
> I would like to have a confirmation that this is not the case and that 
> those apps that you are mentioning will interact with other apps and 
> implement both codecs.
>
> Best,
>
> Gaëlle
>
> *From:*Sergio Garcia Murillo [mailto:[email-masked]]
> *Sent:* Monday, December 08, 2014 12:10 PM
> *To:* Gaelle Martin-Cocher
> *Subject:* RE: [rtcweb] WebRTC endpoint non-browser
>
> They may be webrtc endpoints, or compatible-endpoints depending if 
> they implement full webrtc-rtc stuff our just a minimum subset.
>
> El 08/12/2014 17:24, "Gaelle Martin-Cocher" 
> <[email-masked] <mailto:[email-masked]>> 
> escribió:
>
> *From:*rtcweb [mailto:[email-masked] 
> <mailto:[email-masked]>] *On Behalf Of *Sergio Garcia Murillo
> *To:* [email-masked] <mailto:[email-masked]>

---

From: Dave Taht <[email-masked]>
Date: Mon, 8 Dec 2014 11:53:15 -0800

I would like emacs support.

I am not actually joking...

I typically work in emacs with an erc window open and it would be nice
to see who I am working with inside of emacs, rather than a browser.
Have no idea how to do this....

/me goes to look at resiprocate....

On Mon, Dec 8, 2014 at 11:48 AM, Sergio Garcia Murillo
<[email-masked]> wrote:
> My  application will do whatever is needed for my service, implement one,
> two, three or none video codecs according to my business requirements. I
> don't really care (so won't my users) if you call it webrtc endpoint,
> webrtc-compatible endpoint or webrtc-non-compatible endpoint.
>
> entities so we all speak same languages, any attempt to push a MTI codec is
> wishful thinking at best.
>
> Talking about reality, from my experience, most of the apps will be google's
> libwebrtc based, so they will implement whatever is provided in there. VP8
> for sure, and h264 if supported by mobile and used by libwebrtc.
>
> Does this mobile app, needs to interact with another mobile app? Again, I am
> looking for concrete example.
>
> I bet that every single webrtc service will be a webrtc compatible endpoint.
>
> I would like to have a confirmation that this is not the case and that those
> apps that you are mentioning will interact with other apps and implement
> both codecs.
>
>
>
> Best,
>
> Gaëlle
>
>
>
>
>
> From: Sergio Garcia Murillo [mailto:[email-masked]]
> Sent: Monday, December 08, 2014 12:10 PM
> To: Gaelle Martin-Cocher
> Subject: RE: [rtcweb] WebRTC endpoint non-browser
>
>
>
> Being specific, any mobile application not using a browser will be a webrtc
> endpoint. So I bet every single webrtc service will implement their own app,
> hence their own webrtc endpoint.
>
> Best regards
> Sergio
>
> El 08/12/2014 17:24, "Gaelle Martin-Cocher" <[email-masked]>
> escribió:
>

-- 
Dave Täht

thttp://www.bufferbloat.net/projects/bloat/wiki/Upcoming_Talks

---

From: Tim Panton <[email-masked]>
Date: Mon, 8 Dec 2014 20:09:52 +0000

> On 8 Dec 2014, at 17:24, Gaelle Martin-Cocher <[email-masked]> wrote:
> 

Yes.
I am currently working on the android version of one. see https://yopet.us for a rough idea.

I need native capabilites to manage notifications and wake/sleep interactions so it can't be just
a browser app (as shown in the old video)