Subject: [rtcweb] BUNDLE: How to process bundled m- lines when no address fulfills the criteria for being selected as the offerer BUNDLE address?

From: Christer Holmberg <[email-masked]>
Date: Wed, 17 Dec 2014 13:15:00 +0000

Hi,

We currently have the following text in BUNDLE, when the answerer selects the offerer BUNDLE address:

                "If one or more of the criteria are not fulfilled, the answerer MUST select the next
                identification-tag in the identification-tag list, and perform the same criteria
                check for the "m=" line associated with that identification-tag. If there are no
                more identification-tags in the identification-tag list, the answerer MUST NOT
                create the BUNDLE group."

Now, as the text says, if there is no bundled "m=" line address in the offer which fulfills the criteria for being selected as the offerer BUNDLE address, the answer MUST NOT create the offerer BUNDLE group. So far so good.

However, I think it would be good to have some text on what the answerer DOES with the "m=" lines (in case the answerer doesn't reject the whole offer, that is).

So, I suggested to append the following text to the paragraph:

"Unless the answerer rejects the whole offer, the answerer  MUST apply the answerer
procedures for moving an "m=" line out of a BUNDLE group to each  bundled "m=" line
in the offer when creating the answer."

This basically means that, if the "m=" line had a shared address, or a bundle-only attribute, it will be rejected. If the "m=" line had a unique address, the answerer will assign a unique address in the answer.

Comments?

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 17 Dec 2014 14:28:39 +0000

Sorry - wrong list. Please discard and continue with your codec discussion :)

Regards,

Christet

Sent from my Windows Phone
________________________________
From: Christer Holmberg<mailto:[email-masked]>
Sent: ‎17/‎12/‎2014 15:15
To: [email-masked]<mailto:[email-masked]>
Subject: [rtcweb] BUNDLE: How to process bundled m- lines when no address fulfills the criteria for being selected as the offerer BUNDLE address?

Hi,

                “If one or more of the criteria are not fulfilled, the answerer MUST select the next
                identification-tag in the identification-tag list, and perform the same criteria
                check for the "m=" line associated with that identification-tag. If there are no
                more identification-tags in the identification-tag list, the answerer MUST NOT
                create the BUNDLE group.”

Now, as the text says, if there is no bundled “m=” line address in the offer which fulfills the criteria for being selected as the offerer BUNDLE address, the answer MUST NOT create the offerer BUNDLE group. So far so good.

However, I think it would be good to have some text on what the answerer DOES with the “m=” lines (in case the answerer doesn’t reject the whole offer, that is).

“Unless the answerer rejects the whole offer, the answerer  MUST apply the answerer
procedures for moving an "m=" line out of a BUNDLE group to each  bundled "m=" line
in the offer when creating the answer.”

This basically means that, if the “m=” line had a shared address, or a bundle-only attribute, it will be rejected. If the “m=” line had a unique address, the answerer will assign a unique address in the answer.

Comments?

Regards,

Christer