Subject: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

From: Peter Thatcher <[email-masked]>
Date: Wed, 21 Jan 2015 14:18:56 -0800

​W​
e're
​working on implementing draft-ietf-mmusic-sctp-sdp-12 and going through
the process of making the change while not breaking things and we'd like to
not have to do this a second time. Before making this change, I'd like to
be doubly clear that I got the right value for data channel m-lines:
​​

"UDP/DTLS/SCTP"
​ (or "TCP/DTLS/SCTP")

​Is that for sure the right value?​
​

---

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 21 Jan 2015 17:31:19 -0800

They look right to me ..would let Christer confirm though

Cheers
Suhas

---

From: Justin Uberti <[email-masked]>
Date: Wed, 21 Jan 2015 21:36:44 -0800

The open question was whether this should be UDP/DTLS/SCTP, or UDP/TLS/SCTP
(DTLS implicit) to match the existing UDP/TLS/RTP/SAVPF values defined in
5763.

Upside of TLS: consistent with precedent
Upside of DTLS: less confusing

On Wed, Jan 21, 2015 at 5:31 PM, Suhas Nandakumar <[email-masked]>
wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 22 Jan 2015 06:48:47 +0000

Hi,

My understanding of the outcome of the discussions was that we were going to use “DTLS”.

But, personally I could live with both, so if my understanding is wrong I’m happy to change the draft :)

Note, however, that IF we change to “TLS”, then I guess we also need to discuss the “SCTP/DTLS” value, and whether it should be “SCTP/TLS” instead.

Regards,

Christer

From: rtcweb [mailto:[email-masked]] On Behalf Of Justin Uberti
Sent: 22 January 2015 07:37
To: Suhas Nandakumar
Cc: <[email-masked]>
Subject: Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

The open question was whether this should be UDP/DTLS/SCTP, or UDP/TLS/SCTP (DTLS implicit) to match the existing UDP/TLS/RTP/SAVPF values defined in 5763.

On Wed, Jan 21, 2015 at 5:31 PM, Suhas Nandakumar <[email-masked]<mailto:[email-masked]>> wrote:
They look right to me ..would let Christer confirm though

Cheers
Suhas

On Wednesday, January 21, 2015, Peter Thatcher <[email-masked]<mailto:[email-masked]>> wrote:
​W​
e're
​working on implementing draft-ietf-mmusic-sctp-sdp-12 and going through the process of making the change while not breaking things and we'd like to not have to do this a second time. Before making this change, I'd like to be doubly clear that I got the right value for data channel m-lines:
​​

"UDP/DTLS/SCTP"
​ (or "TCP/DTLS/SCTP")

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Thu, 22 Jan 2015 08:23:42 +0000

Despite the fact of cloase alignment between protocols DTLS and TLS, both are still different protocols (e.g. capabilities concerning assured or non-assured L4 transport, protocol versioning, …).

Thus, my preference would be to use to correct name, i.e., “DTLS” and not any indirect indication such as TLS based.
Also because of the protocol stack segment “TCP/DTLS/SCTP” (“the indirect approach would be what? “TCP/TLS/SCTP”?” which leads to ambiguities … due to native “TCP/TLS/…” layering and RTCWEB required “TCP/DTLS/… “ layering).

Regards,
Albrecht

From: rtcweb [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Donnerstag, 22. Januar 2015 07:49
To: Justin Uberti; Suhas Nandakumar
Cc: <[email-masked]>
Subject: Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

Hi,

Regards,

Christer

From: rtcweb [mailto:[email-masked]] On Behalf Of Justin Uberti
Sent: 22 January 2015 07:37
To: Suhas Nandakumar
Cc: <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

Cheers
Suhas

"UDP/DTLS/SCTP"
​ (or "TCP/DTLS/SCTP")

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 22 Jan 2015 11:08:42 +0000

So, you support using “DTLS”? :)

From: Schwarz, Albrecht (Albrecht) [mailto:[email-masked]]
Sent: 22 January 2015 10:24
To: Christer Holmberg; Justin Uberti; Suhas Nandakumar
Cc: <[email-masked]>
Subject: RE: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

Regards,
Albrecht

Hi,

Regards,

Christer

Cheers
Suhas

"UDP/DTLS/SCTP"
​ (or "TCP/DTLS/SCTP")

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Thu, 22 Jan 2015 12:01:06 +0000

From protocol stacks layering point of view, isn’t the following more accurately represent them?
For TCP ICE based data channel transport: TCP/RFC4571/DTLS/SCTP
For UDP ICE based data channel transport: UDP/DTLS/SCTP

Per my understanding, independent of underlying transport (UDP; or “TCP over RFC4471” framing mimicking datagram transport) the DTLS protocol is same.

BR
Raju

From: rtcweb [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Thursday, January 22, 2015 5:09 AM
To: Schwarz, Albrecht (Albrecht); Justin Uberti; Suhas Nandakumar
Cc: <[email-masked]>
Subject: Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

Regards,
Albrecht

Hi,

Regards,

Christer

Cheers
Suhas

"UDP/DTLS/SCTP"
​ (or "TCP/DTLS/SCTP")

---

From: Justin Uberti <[email-masked]>
Date: Thu, 22 Jan 2015 14:45:20 -0800

The protocol is the same. We are just deciding what the identifying string
should be.

Given the amount of confusion in this space, I think it makes sense to be
as explicit as possible, and use DTLS instead of TLS for the name.

On Thu, Jan 22, 2015 at 4:01 AM, Makaraju, Maridi Raju (Raju) <
[email-masked]> wrote:

> Per my understanding, independent of underlying transport (UDP; or “TCP
> over RFC4471” framing mimicking datagram transport) the DTLS protocol is
> same.
>
>
>
> BR
>
> Raju
>
>
>
>
>
>
>
> *From:* rtcweb [mailto:[email-masked]] *On Behalf Of *Christer
> Holmberg
> *Sent:* Thursday, January 22, 2015 5:09 AM
> *To:* Schwarz, Albrecht (Albrecht); Justin Uberti; Suhas Nandakumar
>
> *Cc:* <[email-masked]>
> *Subject:* Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel
> m-lines, right?
>
>
>
> *From:* Schwarz, Albrecht (Albrecht) [
> mailto:[email-masked]
> <[email-masked]>]
> *Sent:* 22 January 2015 10:24
> *To:* Christer Holmberg; Justin Uberti; Suhas Nandakumar
> *Cc:* <[email-masked]>
> *Subject:* RE: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel
> m-lines, right?
>
>
>
> Despite the fact of cloase alignment between protocols DTLS and TLS, both
> are still different protocols (e.g. capabilities concerning assured or
> non-assured L4 transport, protocol versioning, …).
>
>
>
> Thus, my preference would be to use to correct name, i.e., “DTLS” and not
> any indirect indication such as TLS based.
>
> Also because of the protocol stack segment “TCP/DTLS/SCTP” (“the indirect
> approach would be what? “TCP/TLS/SCTP”?” which leads to ambiguities … due
> to native “TCP/TLS/…” layering and RTCWEB required “TCP/DTLS/… “ layering).
>
>
>
> Regards,
>
> Albrecht
>
>
>
>
>
>
>
> *From:* rtcweb [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Christer Holmberg
> *Sent:* Donnerstag, 22. Januar 2015 07:49
> *To:* Justin Uberti; Suhas Nandakumar
> *Cc:* <[email-masked]>
> *Subject:* Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel
> m-lines, right?
>
>
>
> Hi,
>
>
>
> Note, however, that IF we change to “TLS”, then I guess we also need to
> discuss the “SCTP/DTLS” value, and whether it should be “SCTP/TLS” instead.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
>
>
>
>
> *From:* rtcweb [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Justin Uberti
> *Sent:* 22 January 2015 07:37
> *To:* Suhas Nandakumar
> *Cc:* <[email-masked]>
> *Subject:* Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel
> m-lines, right?
>
>
>
> The open question was whether this should be UDP/DTLS/SCTP, or
> UDP/TLS/SCTP (DTLS implicit) to match the existing UDP/TLS/RTP/SAVPF values
> defined in 5763.
>
>
>

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Thu, 22 Jan 2015 23:35:31 +0000

I was also suggesting the following identifying string to make it unambiguous up to L4 protocol.
I don’t hear any objections to it explicitly. Or did I misinterpret the response?
For TCP ICE based data channel transport: TCP/RFC4571/DTLS/SCTP
For UDP ICE based data channel transport: UDP/DTLS/SCTP

BR
Raju

From: Justin Uberti [mailto:[email-masked]]
Sent: Thursday, January 22, 2015 4:45 PM
To: Makaraju, Maridi Raju (Raju)
Cc: Christer Holmberg; Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]>
Subject: Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

The protocol is the same. We are just deciding what the identifying string should be.

Given the amount of confusion in this space, I think it makes sense to be as explicit as possible, and use DTLS instead of TLS for the name.

On Thu, Jan 22, 2015 at 4:01 AM, Makaraju, Maridi Raju (Raju) <[email-masked]<mailto:[email-masked]>> wrote:
From protocol stacks layering point of view, isn’t the following more accurately represent them?
For TCP ICE based data channel transport: TCP/RFC4571/DTLS/SCTP
For UDP ICE based data channel transport: UDP/DTLS/SCTP

BR
Raju

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 22 Jan 2015 15:59:17 -0800

This seems fine to me.

On Thu, Jan 22, 2015 at 2:45 PM, Justin Uberti <[email-masked]> wrote:

>> *From:* rtcweb [mailto:[email-masked] <[email-masked]>]
>> *On Behalf Of *Christer Holmberg
>> *From:* rtcweb [mailto:[email-masked] <[email-masked]>]
>> *On Behalf Of *Justin Uberti

---

From: Justin Uberti <[email-masked]>
Date: Thu, 22 Jan 2015 19:57:03 -0800

No, I don't think including RFC4571 is reasonable. That ship has already
sailed.

On Thu, Jan 22, 2015 at 3:35 PM, Makaraju, Maridi Raju (Raju) <
[email-masked]> wrote:

> *From:* Justin Uberti [mailto:[email-masked]]
> *Sent:* Thursday, January 22, 2015 4:45 PM
> *To:* Makaraju, Maridi Raju (Raju)
> *Cc:* Christer Holmberg; Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <
> [email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 23 Jan 2015 07:22:13 +0000

Hi,

I agree that we should not use RFC numbers in proto values.

Also keep in mind that UDP/DTLS/SCTP does not mean “ICE based”. ICE is optional for UDP/DTLS/SCTP (that fact that we mandate ICE for RTCWEB is a separate issue).

Regards,

Christer

Sent: 23. tammikuuta 2015 5:57

No, I don't think including RFC4571 is reasonable. That ship has already sailed.

On Thu, Jan 22, 2015 at 3:35 PM, Makaraju, Maridi Raju (Raju) <[email-masked]<mailto:[email-masked]>> wrote:

BR
Raju

From: Justin Uberti [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, January 22, 2015 4:45 PM
To: Makaraju, Maridi Raju (Raju)
Cc: Christer Holmberg; Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

BR
Raju

---

From: "Makaraju, Maridi Raju (Raju)" <[email-masked]>
Date: Sat, 24 Jan 2015 13:35:28 +0000

I am ok to use UDP/DTLS/SCTP and TCP/DTLS/SCTP.
I agree that use of RFC #s is not the best option.
However, I find some unease in the discussions about “TCP/DTLS” part, which seems to suggest why not use “TCP/TLS”?  We understand that it can’t be called that way because of the RFC 4571 “shim layer” in between DTLS and TCP layers. Unfortunately, unlike TPKT, RFC 4571 did not give a name to the protocol, which would have been easy to use than the RFC directly.

BR
Raju
From: Christer Holmberg [mailto:[email-masked]]
Sent: Friday, January 23, 2015 1:22 AM
To: Justin Uberti; Makaraju, Maridi Raju (Raju)
Cc: Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]>
Subject: RE: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

Hi,

Regards,

Christer

BR
Raju

BR
Raju

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 27 Jan 2015 12:18:32 +0000

Hi,

Related to this, when I read the data channel draft, it explicitly talks about UDP. TCP is not even mentioned.

So, does that mean that TCP/DTLS/SCTP is not “officially” a part of the data channel spec?

Regards,

Christer

From: Makaraju, Maridi Raju (Raju) [mailto:[email-masked]]
Sent: 24. tammikuuta 2015 15:35
To: Christer Holmberg; Justin Uberti
Cc: Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]>
Subject: RE: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

BR
Raju
Cc: Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]<mailto:[email-masked]>>

Hi,

Regards,

Christer

BR
Raju

BR
Raju

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 27 Jan 2015 08:38:35 -0800

Well, if you are doing ICE-TCP, I would expect you to run DataChannels over
that. ISTM that that suggests that the marker should be TCP/DTLS/SCTP.

-Ekr

On Tue, Jan 27, 2015 at 4:18 AM, Christer Holmberg <
[email-masked]> wrote:

> *From:* Makaraju, Maridi Raju (Raju) [mailto:
> [email-masked]]
> *Sent:* 24. tammikuuta 2015 15:35
> *To:* Christer Holmberg; Justin Uberti
> *Cc:* Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]>
> However, I find some unease in the discussions about “TCP/DTLS” part,
> which seems to suggest why not use “TCP/TLS”?  We understand that it can’t
> be called that way because of the RFC 4571 “shim layer” in between DTLS and
> TCP layers. Unfortunately, unlike TPKT, RFC 4571 did not give a name to the
> protocol, which would have been easy to use than the RFC directly.
>
>
>
> BR
>
> Raju
>
> *From:* Christer Holmberg [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* Friday, January 23, 2015 1:22 AM
> *To:* Justin Uberti; Makaraju, Maridi Raju (Raju)
> *Cc:* Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]>
> Also keep in mind that UDP/DTLS/SCTP does not mean “ICE based”. ICE is
> optional for UDP/DTLS/SCTP (that fact that we mandate ICE for RTCWEB is a
> separate issue).
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
> *From:* Justin Uberti [mailto:[email-masked] <[email-masked]>]
> *Sent:* 23. tammikuuta 2015 5:57

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 27 Jan 2015 17:44:32 +0000

Hi,

>Well, if you are doing ICE-TCP, I would expect you to run >DataChannels over that. ISTM that that suggests that the marker >should be TCP/DTLS/SCTP.

I am not arguing against that. I just wonder why the data channel draft doesn’t say anything about TCP, while explicitly talking about UDP.

Regards,

Christer

On Tue, Jan 27, 2015 at 4:18 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

From: Makaraju, Maridi Raju (Raju) [mailto:[email-masked]<mailto:[email-masked]>]

BR
Raju

Hi,

Regards,

Christer

BR
Raju

BR
Raju

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 27 Jan 2015 19:15:55 +0100

> On 27 Jan 2015, at 18:44, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>  
That is correct. However,
http://tools.ietf.org/html/draft-ietf-tsvwg-sctp-dtls-encaps-09
says in the Abstract:
   Using the
   encapsulation method described in this document, SCTP is unaware of
   the protocols being used below DTLS;
So it is clear that you can use other protocols like ICE/TCP. However, this
is not explicitly discussed and using TCP has the known drawback of running
a CC (in SCTP) over a CC (in TCP).

I guess the reason why TCP is not mentioned explicitly is that noone brought
the issue up. It was always meant that you run over ICE no matter what ICE is running over...

Best regards
Michael
>  
> Regards,
>  
> Christer
>  
>  
>  
> On Tue, Jan 27, 2015 at 4:18 AM, Christer Holmberg <[email-masked]> wrote:
> Hi,
>  
> On Thu, Jan 22, 2015 at 3:35 PM, Makaraju, Maridi Raju (Raju) <[email-masked]> wrote:
> On Thu, Jan 22, 2015 at 4:01 AM, Makaraju, Maridi Raju (Raju) <[email-masked]> wrote: