Subject: Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?

From: Christian Groves <[email-masked]>
Date: Wed, 04 Feb 2015 21:40:16 +1100

Is it too late to add some explicit text indicating TCP rather than 
having to reply on another draft? It's easily missed by people reading 
the draft and given the real estate given in the data channel draft its 
possible to come to another conclusion.

Christian

On 28/01/2015 5:15 AM, Michael Tuexen wrote:
>> On 27 Jan 2015, at 18:44, Christer Holmberg <[email-masked]> wrote:
>>
>> Hi,
>>   
>>> Well, if you are doing ICE-TCP, I would expect you to run >DataChannels over that. ISTM that that suggests that the marker >should be TCP/DTLS/SCTP.
>>   
>> I am not arguing against that. I just wonder why the data channel draft doesn’t say anything about TCP, while explicitly talking about UDP.
> That is correct. However,
> http://tools.ietf.org/html/draft-ietf-tsvwg-sctp-dtls-encaps-09
> says in the Abstract:
>     Using the
>     encapsulation method described in this document, SCTP is unaware of
>     the protocols being used below DTLS;
> So it is clear that you can use other protocols like ICE/TCP. However, this
> is not explicitly discussed and using TCP has the known drawback of running
> a CC (in SCTP) over a CC (in TCP).
>
> I guess the reason why TCP is not mentioned explicitly is that noone brought
> the issue up. It was always meant that you run over ICE no matter what ICE is running over...
>
> Best regards
> Michael
>>   
>> Regards,
>>   
>> Christer
>>   
>>   
>>   
>> On Tue, Jan 27, 2015 at 4:18 AM, Christer Holmberg <[email-masked]> wrote:
>> Hi,
>>   
>> Related to this, when I read the data channel draft, it explicitly talks about UDP. TCP is not even mentioned.
>>   
>> So, does that mean that TCP/DTLS/SCTP is not “officially” a part of the data channel spec?
>>   
>> Regards,
>>   
>> Christer
>>   
>> From: Makaraju, Maridi Raju (Raju) [mailto:[email-masked]]
>> Sent: 24. tammikuuta 2015 15:35
>> To: Christer Holmberg; Justin Uberti
>> Cc: Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]>
>> Subject: RE: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?
>>   
>> I am ok to use UDP/DTLS/SCTP and TCP/DTLS/SCTP.
>> I agree that use of RFC #s is not the best option.
>> However, I find some unease in the discussions about “TCP/DTLS” part, which seems to suggest why not use “TCP/TLS”?  We understand that it can’t be called that way because of the RFC 4571 “shim layer” in between DTLS and TCP layers. Unfortunately, unlike TPKT, RFC 4571 did not give a name to the protocol, which would have been easy to use than the RFC directly.
>>   
>> BR
>> Raju
>> From: Christer Holmberg [mailto:[email-masked]]
>> Sent: Friday, January 23, 2015 1:22 AM
>> To: Justin Uberti; Makaraju, Maridi Raju (Raju)
>> Cc: Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]>
>> Subject: RE: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?
>>   
>> Hi,
>>   
>> I agree that we should not use RFC numbers in proto values.
>>   
>> Also keep in mind that UDP/DTLS/SCTP does not mean “ICE based”. ICE is optional for UDP/DTLS/SCTP (that fact that we mandate ICE for RTCWEB is a separate issue).
>>   
>> Regards,
>>   
>> Christer
>>   
>> From: Justin Uberti [mailto:[email-masked]]
>> Sent: 23. tammikuuta 2015 5:57
>> To: Makaraju, Maridi Raju (Raju)
>> Cc: Christer Holmberg; Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]>
>> Subject: Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?
>>   
>> No, I don't think including RFC4571 is reasonable. That ship has already sailed.
>>   
>> On Thu, Jan 22, 2015 at 3:35 PM, Makaraju, Maridi Raju (Raju) <[email-masked]> wrote:
>> I was also suggesting the following identifying string to make it unambiguous up to L4 protocol.
>> I don’t hear any objections to it explicitly. Or did I misinterpret the response?
>> For TCP ICE based data channel transport: TCP/RFC4571/DTLS/SCTP
>> For UDP ICE based data channel transport: UDP/DTLS/SCTP
>>   
>> BR
>> Raju
>>   
>> From: Justin Uberti [mailto:[email-masked]]
>> Sent: Thursday, January 22, 2015 4:45 PM
>> To: Makaraju, Maridi Raju (Raju)
>> Cc: Christer Holmberg; Schwarz, Albrecht (Albrecht); Suhas Nandakumar; <[email-masked]>
>> Subject: Re: [rtcweb] It's "UDP/DTLS/SCTP" for the data channel m-lines, right?
>>   
>> The protocol is the same. We are just deciding what the identifying string should be.
>>   
>> Given the amount of confusion in this space, I think it makes sense to be as explicit as possible, and use DTLS instead of TLS for the name.
>>   
>> On Thu, Jan 22, 2015 at 4:01 AM, Makaraju, Maridi Raju (Raju) <[email-masked]> wrote:
>>  From protocol stacks layering point of view, isn’t the following more accurately represent them?
>> For TCP ICE based data channel transport: TCP/RFC4571/DTLS/SCTP
>> For UDP ICE based data channel transport: UDP/DTLS/SCTP
>>   
>> Per my understanding, independent of underlying transport (UDP; or “TCP over RFC4471” framing mimicking datagram transport) the DTLS protocol is same.
>>   
>> BR
>> Raju
>>   
>>   
>>
>> _______________________________________________
>> rtcweb mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
>>
>>   
>> _______________________________________________
>> rtcweb mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 4 Feb 2015 12:07:24 +0100

> On 04 Feb 2015, at 11:40, Christian Groves <[email-masked]> wrote:
> 
> Is it too late to add some explicit text indicating TCP rather than having to reply on another draft? It's easily missed by people reading the draft and given the real estate given in the data channel draft its possible to come to another conclusion.
The document is in the RFC Editor queue... I would think that it is clear that ICE can run over several
protocols, not only UDP. So it might have been better not show nothing below ICE. But it think ICE/UDP
will be the stack used in a lot of cases.

We could still try to make sure the stack is clear in
https://tools.ietf.org/html/draft-ietf-rtcweb-transports-07

That has the advantage that it also deals with the media channels.

Best regards
Michael

---

From: Christian Groves <[email-masked]>
Date: Thu, 05 Feb 2015 11:02:16 +1100

Hello Michael,

Yes I think UDP will be the common case and I agree ICE can run over 
several protocols however Figure 1 (and associated 
text)/[http://tools.ietf.org/html/draft-ietf-rtcweb-data-channel-13] 
only shows ICE/UDP. The draft really gives the impression that whilst 
ICE is used, ICE/UDP is the variant the draft has chosen.

Could we ask the RFC editor to insert something in the introduction like 
"Note: This document focusses on SCTP over DTLS over ICE/UDP. However 
SCTP over DTLS over ICE/TCP is also supported."?

I think it's much better to try to get something in the data channel 
draft than updating the transports draft. Although it still wouldn't 
hurt to add something there either.

Regards, Christian

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 5 Feb 2015 01:29:46 +0100

> On 05 Feb 2015, at 01:02, Christian Groves <[email-masked]> wrote:
> 
> Hello Michael,
> 
> Yes I think UDP will be the common case and I agree ICE can run over several protocols however Figure 1 (and associated text)/[http://tools.ietf.org/html/draft-ietf-rtcweb-data-channel-13] only shows ICE/UDP. The draft really gives the impression that whilst ICE is used, ICE/UDP is the variant the draft has chosen.
> 
> Could we ask the RFC editor to insert something in the introduction like "Note: This document focusses on SCTP over DTLS over ICE/UDP. However SCTP over DTLS over ICE/TCP is also supported."?
I don't know. I don't think this is appropriate for an AUTH48 comment. But the WG chairs might now
the process better...

Best regards
Michael
> 
> I think it's much better to try to get something in the data channel draft than updating the transports draft. Although it still wouldn't hurt to add something there either.
> 
> Regards, Christian
>

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 05 Feb 2015 12:39:55 +0100

> That has the advantage that it also deals with the media channels.

Completely BTW: The -transports draft is now on github:

[email-masked]:alvestrand/webrtc-specs.git

Feel free to send me a pull request if you have specific language
suggestions.

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 05 Feb 2015 12:46:47 +0100

> [email-masked]:alvestrand/webrtc-specs.git

Self-correcting: The master master is at this URL:

[email-masked]:rtcweb-wg/rtcweb-transport.git

There is no issue tracker, and I can't enable one - seems the site
admins have to do that.

> Feel free to send me a pull request if you have specific language

This still applies.

---

From: Ted Hardie <[email-masked]>
Date: Thu, 5 Feb 2015 12:05:29 -0800

> There is no issue tracker, and I can't enable one - seems the site

​I believe the issue tracker should be working now.

regards,

Ted​