Subject: [rtcweb] Question about draft-ietf-rtcweb-stun-consent-freshness-11

From: Bernard Aboba <[email-masked]>
Date: Sat, 14 Feb 2015 14:18:58 -0800

>From Section 4.1:

   Initial consent to send traffic is obtained using ICE.  Consent
   expires after 30 seconds.  That is, if a valid STUN binding response
   corresponding to any STUN request sent in the last 30 seconds has not
   been received from the remote peer's transport address, the endpoint
   MUST cease transmission on that 5-tuple.  STUN consent responses
   received after consent expiry do not re-establish consent, and may be
   discarded or cause an ICMP error.

[BA] Let us say that peer A sends STUN requests to peer B.  Request 1

does not receive a response within 30 seconds, but Request 2 (sent 5
seconds later) does receive a response.  Does that mean that peer A
considers consent revoked 30 seconds after sending Request 1, even
though it has since gotten a response?

This does not make sense to me.

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 14 Feb 2015 22:46:03 +0000

Hi Bernard,

I had the same comment some time ago.

But, note that the text now says "response to *any* STUN request", meaning that as long as you receive a response to at least one STUN request that was sent in the last 30 seconds you are ok, and consent will not expire.

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Bernard Aboba<mailto:[email-masked]>
Sent: ‎15/‎02/‎2015 00:19
To: [email-masked]<mailto:[email-masked]>
Subject: [rtcweb] Question about draft-ietf-rtcweb-stun-consent-freshness-11

does not receive a response within 30 seconds, but Request 2 (sent 5 seconds later) does receive a response.  Does that mean that peer A considers consent revoked 30 seconds after sending Request 1, even though it has since gotten a response?