Subject: [rtcweb] Data Channel Closure: Is sctp-reset mandatory?

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Feb 2015 15:28:51 +0000

Hi,

When I am about to close the data channel, if I also want to tear down the SCTP-over-DTLS association, do I first need to send sctp-reset (in order to close my data channel(s)), before sending SHUTDOWN? Or, can I simply send SHUTDOWN?

Regards,

Christer

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 3 Feb 2015 18:28:43 +0100

> On 03 Feb 2015, at 16:28, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>  
You can simply shutdown. See the last paragraph in
https://tools.ietf.org/html/draft-ietf-rtcweb-data-channel-13#section-6.2
Best regards
Michael
>  
> Regards,
>  
> Christer
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Feb 2015 17:35:02 +0000

Thanks!

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Tue, 3 Feb 2015 18:36:17 +0000

Michael,

thanks for answering the case of the termination of the SCTP association in outgoing direction.
What about the incoming direction?
How should I react in case of an incoming SCTP RE-CONFIG chunk (with a SCTP stream reset)?
a) may I immediately send a SCTP SHUTDOWN chunk?
or
b) firstly replying the RE-CONFIG procedure and subsequently initiating the SCTP association shutdwon with a SCTP SHUTDOWN chunk?

The distinction between incoming and outgoing direction isn't made in https://tools.ietf.org/html/draft-ietf-rtcweb-data-channel-13#section-6.2 in my understanding.

Thanks,
Albrecht

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Dienstag, 3. Februar 2015 18:35
To: Michael Tuexen
Cc: [email-masked]
Subject: Re: [rtcweb] Data Channel Closure: Is sctp-reset mandatory?

Thanks!

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 3 Feb 2015 21:15:24 +0100

> On 03 Feb 2015, at 19:36, Schwarz, Albrecht (Albrecht) <[email-masked]> wrote:
> 
> Michael,
> 
No it isn't. If you want to turn down the association, but can do that at any time. This
is at least my understanding when I put the text into the document.

Best regards
Michael