Subject: [rtcweb] Usage of b= at session level - JSEP

From: "Roni Even" <[email-masked]>
Date: Wed, 25 Mar 2015 21:33:13 +0200

Hi,

About using AS at session level. Making it an error may cause
interoperability problems with other systems.

Note that 3GPP TS22114
(http://www.etsi.org/deliver/etsi_ts/126100_126199/126114/12.08.00_60/ts_126
114v120800p.pdf ) in section A.6 uses AS at the session level and not CT for
total bandwidth

The IMTC SIP parity WG took the same approach in the SIP Video Profile Best
Practices

Roni Even

---

From: Martin Thomson <[email-masked]>
Date: Wed, 25 Mar 2015 14:53:01 -0500

> interoperability problems with other systems.

Would it be a major problem in that situation if the b=AS were ignored?

I think that we could also require that b=CT be ignored on the media level
too.  If it turns out that it has significant usage, that is.

---

From: "Roni Even" <[email-masked]>
Date: Fri, 27 Mar 2015 15:12:13 +0300

About using AS at session level. Making it an error may cause interoperability problems with other systems.

[Roni Even] b=AS at session level can be ignored (as any SDP attribute) but the problem will be with what it will do to the total bandwidth used. The session level limits the total for all media levels in the session, while when you sum the b= values in the media levels they can be higher than the b= at the session level.

I think that we could also require that b=CT be ignored on the media level too.  If it turns out that it has significant usage, that is.

[Roni Even] I am not aware of usage of CT, as you can see from the documents I had in my email (3GPP and IMTC SIP parity) they use AS and TIAS