Subject: [rtcweb] WG call for adoption: draft-alvestrand-rtcweb-gateways

From: Sean Turner <[email-masked]>
Date: Thu, 16 Apr 2015 14:15:28 -0400

All,

There’s been some interest expressed in having http://datatracker.ietf.org/doc/draft-alvestrand-rtcweb-gateways/ adopted as an RTCWeb WG item.  Please respond to say whether you support adoption of this work as a working group work item and whether you will participate in the discussion.   If you are opposed to this draft becoming a WG document, please say so (and say why).  Please have your response in by 20150423 23:59 UTC.

Thanks in advance!

spt

---

From: Harald Alvestrand <[email-masked]>
Date: Sat, 18 Apr 2015 07:46:58 +0200

> There’s been some interest expressed in having http://datatracker.ietf.org/doc/draft-alvestrand-rtcweb-gateways/ adopted as an RTCWeb WG item.  Please respond to say whether you support adoption of…
Naturally, I support adoption.

Question: Is this a repeat of the exercise on which Cullen reported
consensus for adoption in December 2014, or is this a side effect of
starting fomal tracking of adoption status?

-- 
Surveillance is pervasive. Go Dark.

---

From: "Rauschenbach, Uwe (Nokia - DE/Munich)" <[email-masked]>
Date: Sun, 19 Apr 2015 18:51:34 +0000

+1 for adoption.

The same question that Harald raised came to my mind - there was another adoption call end of last year with a lot of support (https://www.ietf.org/mail-archive/web/rtcweb/current/msg14050.html).

Kind regards,
Uwe

________________________________________
Von: rtcweb [[email-masked]]&quot; im Auftrag von &quot;ext Harald Alvestrand [[email-masked]]
Gesendet: Samstag, 18. April 2015 07:46
An: Sean Turner; [email-masked]
Cc: [email-masked]
Betreff: Re: [rtcweb] WG call for adoption: draft-alvestrand-rtcweb-gateways

_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Gaelle Martin-Cocher <[email-masked]>
Date: Wed, 22 Apr 2015 15:36:37 +0000

Dear all,

I do have some concerns with this proposal.
>From https://www.ietf.org/mail-archive/web/rtcweb/current/msg13885.html
I was under impression that the gateway would be an informational draft and there was no desire to specify conformance requirements.

The current text describes high level functions that can be expected from a gateway but does not define clearly what would be required to conform to. 
If the intend of the draft is to specify conformance requirements (first sentence of the abstract) there could be more requirements to relax and the current requirements would need to be define more clearly. 
Is it the intend?

If it is, here are some examples:
While the WebRTC Gateway is described in the abstract (but not only, see section 1) as "a class of
   WebRTC-compatible endpoints called "WebRTC gateways" ", section 2 states that WebRTC gateway are "expected to conform to the requirements for WebRTC non-browsers in [I-D.ietf-rtcweb-overview], with the exceptions defined in this section"

Wouldn't it be clearer to just define the WebRTC gateway from the WebRTC non-browser rather than from an unspecified WebRTC-compatible endpoint? 
It might provide a better understanding of what the gateway should be conforming to.

Requirements in 2, either:
- are clear: e.g. the gateway MUST support DTLS-SRTP 
- describe what the gateway MAY NOT support....see second to last paragraph 
- or leave some ambiguity: The gateway does not have to do X (e.g. full ICE); so it may do Y (e.g. ICE-Lite). 
Playing devil's advocate: can there be a gateway doing yet something else? 
What would it conform to?  

Shouldn't the requirement be reworded to state what the gateway MAY or SHALL do/support.... and conform to?

Section 1.1 and 1.2 seems unclear if meant to belong to a conformance requirements draft.

It is unclear to me if the purpose of the draft is to define conformance requirements for WebRTC gateway, or is to focus on relaxing some requirements for gateways as per section 2, or is an informational description of what can be expected from a WebRTC 'compatible' gateway.

Sincerely,
Gaëlle

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Rauschenbach, Uwe (Nokia - DE/Munich)
Sent: Sunday, April 19, 2015 2:52 PM
To: ext Harald Alvestrand; Sean Turner; [email-masked]
Cc: [email-masked]
Subject: Re: [rtcweb] WG call for adoption: draft-alvestrand-rtcweb-gateways

+1 for adoption.

Kind regards,
Uwe

On 04/16/2015 08:15 PM, Sean Turner wrote:
> All,
>
> There's been some interest expressed in having http://datatracker.ietf.org/doc/draft-alvestrand-rtcweb-gateways/ adopted as an RTCWeb WG item.  Please respond to say whether you support adoption of this work as a working group work item and whether you will participate in the discussion.   If you are opposed to this draft becoming a WG document, please say so (and say why).  Please have your response in by 20150423 23:59 UTC.
>
> Thanks in advance!
>
> spt

Question: Is this a repeat of the exercise on which Cullen reported consensus for adoption in December 2014, or is this a side effect of starting fomal tracking of adoption status?

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 22 Apr 2015 18:19:43 +0200

> If the intend of the draft is to specify conformance requirements (first sentence of the abstract) there could be more requirements to relax and the current requirements would need to be define mor…

I have not updated the intro - I think feedback was reasonably clear
that an informational document was wanted, we want to give advice, but
not to dictate what implementations do.

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 29 Apr 2015 15:27:09 +0000

So to be clear my understanding is that the draft status will be changed to "Informational" and the abstract will be changed to remove the statement about specifying "conformance requirements".  Is that correct?

The draft is therefore not intended to specify conformance requirements but will provide implementation guidance.

Regards
Andy

> From: rtcweb [mailto:[email-masked]] On Behalf Of Harald
> Alvestrand
> Sent: 22 April 2015 17:20
> To: Gaelle Martin-Cocher; Rauschenbach, Uwe (Nokia - DE/Munich); Sean
> Turner; [email-masked]
> > I was under impression that the gateway would be an informational
> draft and there was no desire to specify conformance requirements.
> >
> > The current text describes high level functions that can be expected
> from a gateway but does not define clearly what would be required to
> conform to.
> > If the intend of the draft is to specify conformance requirements
> (first sentence of the abstract) there could be more requirements to
> relax and the current requirements would need to be define more
> clearly.
> > Is it the intend?
> 
> >    WebRTC-compatible endpoints called "WebRTC gateways" ", section 2
> states that WebRTC gateway are "expected to conform to the requirements
> for WebRTC non-browsers in [I-D.ietf-rtcweb-overview], with the
> exceptions defined in this section"
> >
> > Wouldn't it be clearer to just define the WebRTC gateway from the
> WebRTC non-browser rather than from an unspecified WebRTC-compatible
> endpoint?
> > - or leave some ambiguity: The gateway does not have to do X (e.g.
> full ICE); so it may do Y (e.g. ICE-Lite).
> > It is unclear to me if the purpose of the draft is to define
> conformance requirements for WebRTC gateway, or is to focus on relaxing
> some requirements for gateways as per section 2, or is an informational
> description of what can be expected from a WebRTC 'compatible' gateway.
> >
> >
> > Sincerely,
> > Gaëlle
> >
> >
> >
> > The same question that Harald raised came to my mind - there was
> another adoption call end of last year with a lot of support
> (https://www.ietf.org/mail-archive/web/rtcweb/current/msg14050.html).
> >
> > Kind regards,
> > Uwe
> >
> >> There's been some interest expressed in having
> http://datatracker.ietf.org/doc/draft-alvestrand-rtcweb-gateways/
> adopted as an RTCWeb WG item.  Please respond to say whether you
> support adoption of this work as a working group work item and whether
> you will participate in the discussion.   If you are opposed to this
> draft becoming a WG document, please say so (and say why).  Please have
> your response in by 20150423 23:59 UTC.
> >>
> >> Thanks in advance!
> >>
> >> spt

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 29 Apr 2015 20:50:48 +0200

> The draft is therefore not intended to specify conformance requirements but will provide implementation guidance.

Yes, that's my plan.

---

From: Victor Pascual Avila <[email-masked]>
Date: Wed, 29 Apr 2015 21:02:09 +0200

>> The draft is therefore not intended to specify conformance requirements but will provide implementation guidance.

Fine with me.

-Victor

-- 
Victor Pascual Ávila

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 30 Apr 2015 08:10:33 +0000

I do support adoption of the draft as an informational draft.

Andy

> From: Harald Alvestrand [mailto:[email-masked]]
> Sent: 29 April 2015 19:51
> To: Hutton, Andrew; Gaelle Martin-Cocher; Rauschenbach, Uwe (Nokia -
> DE/Munich); Sean Turner; [email-masked]
> > So to be clear my understanding is that the draft status will be
> changed to "Informational" and the abstract will be changed to remove
> the statement about specifying "conformance requirements".  Is that
> correct?
> >
> > The draft is therefore not intended to specify conformance
> requirements but will provide implementation guidance.
> >
> 
> Yes, that's my plan.
> 
> 
> > Regards
> > Andy
> >
> >
> >
> >>> While the WebRTC Gateway is described in the abstract (but not
> only,
> >> see section 1) as "a class of
> >>> It might provide a better understanding of what the gateway should
> be
> >> conforming to.
> >>>
> >>> Playing devil's advocate: can there be a gateway doing yet
> something
> >> else?
> >>> Section 1.1 and 1.2 seems unclear if meant to belong to a
> conformance
> >> requirements draft.
> >>>
> >>>
> >>> Subject: Re: [rtcweb] WG call for adoption: draft-alvestrand-
> rtcweb-
> >> gateways
> >>>
> >>> +1 for adoption.
> >>>
> >> (https://www.ietf.org/mail-
> archive/web/rtcweb/current/msg14050.html).
> >>>
> >>> Kind regards,
> >>> Uwe
> >>>
> >>> Von: rtcweb [[email-masked]]&quot; im Auftrag von
> &quot;ext
> >> Harald Alvestrand [[email-masked]]
> >>> Betreff: Re: [rtcweb] WG call for adoption: draft-alvestrand-
> rtcweb-
> >> gateways
> >>>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 30 Apr 2015 08:30:27 +0000

Section 2 contains the following text:

"Since a gateway is expected to be deployed where it can be reached with a static IP address (as seen from the client), a WebRTC gateway does not need to support full ICE; it therefore MAY implement ICE-Lite only".

It might be a minor comment but I think it is wrong to say that a gateway "is expected to be deployed where it can be reached with a static IP address" and this gives the wrong impression.

A gateway might be deployed in such a way but I would not say it is expected to be deployed that way.

So I suggest the following text.

"A WebRTC gateway which is deployed where it can be reached with a static IP address (as seen from the client), does not need to support full ICE; it therefore MAY implement ICE-Lite only".

Regards
Andy

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 30 Apr 2015 13:17:53 +0000

I remain to be convinced that this should be entirely informational.

I suspect a mixture of conditional conformable requirements and informational material may be what we end up with.

For example, if the gateway terminates the datachannel, then the gateway MUST support the requirements of the datachannel document. If the gateway performs trascoding, or other interference with the RTP stream, then the gateway MUST support the requirements of rtp-usage document.

>From an external referencing perspective, it does not matter whether it is informational or standards track, but the important point to me is that the document can and will contain normative requirements where appropriate.

Keith

> From: rtcweb [mailto:[email-masked]] On Behalf Of 
> Hutton, Andrew
> Sent: 30 April 2015 09:11
> To: Harald Alvestrand; Gaelle Martin-Cocher; Rauschenbach, 
> Uwe (Nokia - DE/Munich); Sean Turner; [email-masked]
> > Subject: Re: [rtcweb] WG call for adoption: 
> draft-alvestrand-rtcweb- 
> > gateways
> > 
> > >> Subject: Re: [rtcweb] WG call for adoption: 
> > >> draft-alvestrand-rtcweb- gateways
> > >>
> > >> from a gateway but does not define clearly what would be 
> required 
> > >> to conform to.
> > >> (first sentence of the abstract) there could be more 
> requirements 
> > >> to relax and the current requirements would need to be 
> define more 
> > >> clearly.
> > >>> Is it the intend?
> > >>
> > >> I have not updated the intro - I think feedback was reasonably 
> > >> clear that an informational document was wanted, we want to give 
> > >> advice,
> > but
> > >>>    WebRTC-compatible endpoints called "WebRTC gateways" 
> ", section
> > 2
> > >> WebRTC non-browser rather than from an unspecified 
> > >> WebRTC-compatible endpoint?
> > >>> - describe what the gateway MAY NOT support....see 
> second to last
> > >> paragraph
> > >>> Shouldn't the requirement be reworded to state what the gateway 
> > >>> MAY
> > >> or SHALL do/support.... and conform to?
> > >>>
> > >> draft becoming a WG document, please say so (and say 
> why).  Please
> > have
> > >> consensus for adoption in December 2014, or is this a 
> side effect 
> > >> of starting fomal tracking of adoption status?
> > >>>
> > >>> --

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 30 Apr 2015 13:17:55 +0000

I support this draft, but I was also under the impression that adoption had already been agreed.

Therefore this call seems to be yet another excuse for delaying work on this document.

Keith

> From: rtcweb [mailto:[email-masked]] On Behalf Of Sean Turner
> Sent: 16 April 2015 19:15
> To: [email-masked]
> Subject: [rtcweb] WG call for adoption: 
> draft-alvestrand-rtcweb-gateways
> 
> All,
> 
> http://datatracker.ietf.org/doc/draft-alvestrand-rtcweb-gatewa
> ys/ adopted as an RTCWeb WG item.  Please respond to say 
> whether you support adoption of this work as a working group 
> work item and whether you will participate in the discussion. 
>   If you are opposed to this draft becoming a WG document, 
> please say so (and say why).  Please have your response in by 
> 20150423 23:59 UTC.
> 
> Thanks in advance!
> 
> spt

---

From: "Rauschenbach, Uwe (Nokia - DE/Munich)" <[email-masked]>
Date: Thu, 30 Apr 2015 15:16:50 +0000

I agree. 
This draft contains informative parts and requirements to gateway implementations - and it needs to be able to express these in normative language.

Kind regards,
Uwe 

-----Original Message-----
From: ext DRAGE, Keith (Keith) [mailto:[email-masked]] 
Sent: Thursday, April 30, 2015 3:18 PM
To: Hutton, Andrew; Harald Alvestrand; Gaelle Martin-Cocher; Rauschenbach, Uwe (Nokia - DE/Munich); Sean Turner; [email-masked]
Cc: [email-masked]
Subject: RE: [rtcweb] WG call for adoption: draft-alvestrand-rtcweb-gateways

Keith

> > >> Rauschenbach, Uwe (Nokia - DE/Munich)

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 30 Apr 2015 15:35:34 +0000

I won't lose any sleep over the classification of the draft but the definition of a WebRTC Gateway is that it is a WebRTC Compatible Device (as stated in draft-ietf-rtcweb-overview) which by definition is not constrained by the RTCWEB spec's.

I can wait and see what normative text makes it in to the document so far what I see are obvious statements that if not followed the WebRTC part of the gateway just would not work.

Andy

> From: Rauschenbach, Uwe (Nokia - DE/Munich)
> [mailto:[email-masked]]
> Sent: 30 April 2015 16:17
> To: ext DRAGE, Keith (Keith); Hutton, Andrew; Harald Alvestrand; Gaelle
> Martin-Cocher; Sean Turner; [email-masked]
> This draft contains informative parts and requirements to gateway
> implementations - and it needs to be able to express these in normative
> language.
> 
> Kind regards,
> Uwe
> 
> To: Hutton, Andrew; Harald Alvestrand; Gaelle Martin-Cocher;
> Rauschenbach, Uwe (Nokia - DE/Munich); Sean Turner; [email-masked]
> I suspect a mixture of conditional conformable requirements and
> informational material may be what we end up with.
> 
> For example, if the gateway terminates the datachannel, then the
> gateway MUST support the requirements of the datachannel document. If
> the gateway performs trascoding, or other interference with the RTP
> stream, then the gateway MUST support the requirements of rtp-usage
> document.
> 
> From an external referencing perspective, it does not matter whether it
> is informational or standards track, but the important point to me is
> that the document can and will contain normative requirements where
> appropriate.
> 
> Keith
>