Subject: [rtcweb] nombis and ICE restart [was: Comment on consent-freshness-14]

From: Christer Holmberg <[email-masked]>
Date: Fri, 19 Jun 2015 16:15:36 +0000

(Changed the subject, because ICE restart with nombis is not related to consent-freshness)

Hi,

>> In recent moons people have been talking about never finalizing ICE, instead you will keep collecting candidates throughout the session, and 
>> switch between them if one is "better" than that other. You may drop some candidates, and you may maintain others (even though you are 
>> currently not sending any data on them)
>
> [BA] A specific proposal is here:
> https://tools.ietf.org/html/draft-uberti-mmusic-nombis

Correct, I forgot to include the link.

>> That brings up a question, though: if you never finalize ICE, will you ever be able to do an ICE restart?
>
> ICE can always be restarted, whether media is currently flowing or not.

Sure, but my question was more general whether you can do ICE restart if you use nombis.

When reading the nombis draft, it does say that you can perform an ICE restart. But, is there any reason for doing it, as you can simply continue collecting new candidates (and drop the ones you don't want to use anymore, I assume) using "normal nombis behaviour"?

Regards,

Christer

---

From: Harald Alvestrand <[email-masked]>
Date: Sat, 20 Jun 2015 12:49:36 +0200

> When reading the nombis draft, it does say that you can perform an ICE restart. But, is there any reason for doing it, as you can simply continue collecting new candidates (and drop the ones you do…

If you believe the ICE credentials at the other end have been lost or 
compromised, or if you've lost your own ICE credentials (relevant in the 
rehydration case, if rehydration is possible to do), an ICE restart is a 
Good Thing.

With nombis, losing the connection should not be a reason to do an ICE 
restart.

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 20 Jun 2015 11:40:09 +0000

Hi Harald,

>>>> In recent moons people have been talking about never finalizing ICE, 
>>>> instead you will keep collecting candidates throughout the session, 
>>>> and switch between them if one is "better" than that other. You may 
>>>> drop some candidates, and you may maintain others (even though you 
>>>> are currently not sending any data on them)
>> When reading the nombis draft, it does say that you can perform an ICE restart. But, is there any reason for doing it, as you can simply continue >> collecting new candidates (and drop the ones you don't want to use anymore, I assume) using "normal nombis behaviour"?
>
> If you believe the ICE credentials at the other end have been lost or compromised, or if you've lost your own ICE credentials (relevant in the 
> rehydration case, if rehydration is possible to do), an ICE restart is a Good Thing.
>
> With nombis, losing the connection should not be a reason to do an ICE restart.

I think it would be good to capture what you just said in the nombis draft, e.g. in an "ICE Restart Considerations"/"To ICE Restart or not to ICE restart" section.

Regards,

Christer

---

From: Harald Alvestrand <[email-masked]>
Date: Sat, 20 Jun 2015 17:14:39 +0200

> I think it would be good to capture what you just said in the nombis draft, e.g. in an "ICE Restart Considerations"/"To ICE Restart or not to ICE restart" section.

Filed as https://github.com/juberti/draughts/issues/19 (the repo is 
still a private one).