Subject: Re: [rtcweb] OPS-Dir review of draft-ietf-rtcweb-stun-consent-freshness-13

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 1 Jun 2015 09:13:13 +0000

> -----Original Message-----
> From: rtcweb [mailto:[email-masked]] On Behalf Of Ram Mohan R
> (rmohanr)
> Sent: Monday, June 01, 2015 11:31 AM
> To: Christer Holmberg; Bernard Aboba; Harald Alvestrand
> Cc: [email-masked]
> Subject: Re: [rtcweb] OPS-Dir review of draft-ietf-rtcweb-stun-consent-
> freshness-13
> 
> WFM. I am fine with keeping APIs out of scope for consent document. It will
> be better to have all APIs in one document and have reference to that where
> ever applicable.

NEW:

8.  API Recommendations

   The W3C specification [W3C-WEBRTC] may provide an API hook that
   generates an event when consent has expired for a given 5-tuple,
   meaning that transmission of data has ceased.  This could indicate
   what application data is affected, such as media or data channels.
   The mechanism of how applications are made aware of consent
   expiration is outside the scope of the document.

-Tiru

> 
> Regards,
> Ram
> 
> -----Original Message-----
> From: Christer Holmberg <[email-masked]>
> Date: Sunday, 31 May 2015 7:08 pm
> To: Bernard Aboba <[email-masked]>, Harald Alvestrand
> <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Subject: Re: [rtcweb] OPS-Dir review of
> draft-ietf-rtcweb-stun-consent-freshness-13
> 
> >Hi,
> >
> >>> I'd prefer to limit the number of documents that try to design APIs.
> >>>
> >>> Can we do something more generic, like "Applications that use the
> >>> RTWEB transport will need to be notified when transmission ceases
> >>> due to expiry of consent. The design of APIs to carry these
> >>> notifications  is out of scope for this document."?
> >>
> >> [BA] Agree with Harald. Loss of STUN consent on a 5-tuple is quite
> >>different from tripping  a circuit breaker. Let's not design the APIs
> >>in this document.
> >
> >I agree on the not-designing-the-API part.
> >
> >Regarding Harald's suggested text, it's fine - but I don't think it
> >belongs in this document. Shouldn't it be in the RTCWEB overview and/or
> >security document instead?
> >
> >The consent freshness draft could then state that the
> >mechanism/requirements how applications are made aware of consent
> >expiration is outside the scope of the document.
> >
> >Regards,
> >
> >Christer
> >
> >
> >
> >
> >
> >_______________________________________________
> >rtcweb mailing list
> >[email-masked]
> >https://www.ietf.org/mailman/listinfo/rtcweb
> >
> >_______________________________________________
> >rtcweb mailing list
> >[email-masked]
> >https://www.ietf.org/mailman/listinfo/rtcweb
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 1 Jun 2015 09:16:38 +0000

Hi,

Why do we need to talk about W3C specifications at all? Couldn't we simply remove section 8?

The out-of-the-scope text I suggested earlier could be put e.g. in the Introduction, or in an Applicability section.

Regards,

Christer

-----Original Message-----
From: Tirumaleswar Reddy (tireddy) [mailto:[email-masked]] 
Sent: 1. kesäkuuta 2015 12:13
To: Ram Mohan R (rmohanr); Christer Holmberg; Bernard Aboba; Harald Alvestrand
Cc: [email-masked]
Subject: RE: [rtcweb] OPS-Dir review of draft-ietf-rtcweb-stun-consent-freshness-13

> WFM. I am fine with keeping APIs out of scope for consent document. It 
> will be better to have all APIs in one document and have reference to 
> that where ever applicable.

NEW:

8.  API Recommendations

-Tiru

> >>different from tripping  a circuit breaker. Let's not design the 
> >>APIs in this document.
> >
> >belongs in this document. Shouldn't it be in the RTCWEB overview 
> >and/or security document instead?
> >

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 1 Jun 2015 09:21:22 +0000

> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Monday, June 01, 2015 2:47 PM
> To: Tirumaleswar Reddy (tireddy); Ram Mohan R (rmohanr); Bernard Aboba;
> Harald Alvestrand
> Cc: [email-masked]

It can be removed, discussion about W3C was there from day one of the draft.

> 
> The out-of-the-scope text I suggested earlier could be put e.g. in the
> Introduction, or in an Applicability section.

Works for me.

-Tiru