Subject: [rtcweb] RTCPWEB: Support of only mux, or both mux and non-mux?

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Nov 2015 06:01:12 +0000

Hi,

Today, in RTCWEB, we decided that support of NON-RTP/RTCP mux is going to be optional - also for non-BUNDLE.

One of my comments was how we in SDP are going to signal whether an endpoint supports ONLY RTCP/RTP-mux, or BOTH mux and non-mux.

One idea was to only include ICE components for RTP if only mux is supported, but it was commented that it doesn't work with trickle.

Another idea would be to always include the SDP rtcp attribute in the offer and:

-          If the endpoint supports ONLY mux, the rtcp attribute value would have the same port value as the m- line port

-          If the endpoint supports BOTH mux and non-mux, the rtcp attribute would have the RTCP port (even if it's RTP+1)

(The SDP rtcp-mux attribute would obviously always be present in the offer)

Regards,

Christer

---

From: Martin Thomson <[email-masked]>
Date: Wed, 4 Nov 2015 10:11:13 +0900

On 3 November 2015 at 15:01, Christer Holmberg
<[email-masked]> wrote:
> -          If the endpoint supports ONLY mux, the rtcp attribute value would
> have the same port value as the m- line port
>
> -          If the endpoint supports BOTH mux and non-mux, the rtcp attribute
> would have the RTCP port (even if it’s RTP+1)

That seems fine to me.

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 4 Nov 2015 06:54:13 +0000

Hi,

>> would have the RTCP port (even if it’s RTP+1)

The question is how we document it. We can of course add text to JSEP, but I think it should apply to SDP in general. BUNDLE is not the correct place either, since it is not BUNDLE specific.

I guess I could put together a short draft, and then we go from there.

Regards,

Christer