Subject: [rtcweb] FW: New Version Notification for draft-holmberg-mmusic-mux-exclusive-00.txt

From: Christer Holmberg <[email-masked]>
Date: Thu, 5 Nov 2015 06:59:39 +0000

New draft, replacing the previous one, this time with "exclusive" spelled correctly.

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 05 November 2015 08:50
To: Christer Holmberg <[email-masked]>
Subject: New Version Notification for draft-holmberg-mmusic-mux-exclusive-00.txt

A new version of I-D, draft-holmberg-mmusic-mux-exclusive-00.txt
has been successfully submitted by Christer Holmberg and posted to the IETF repository.

Name:		draft-holmberg-mmusic-mux-exclusive
Revision:	00
Title:		Indicating Exclusive Support of RTP/RTCP Multiplexing using SDP
Document date:	2015-11-04
Group:		Individual Submission
Pages:		5
URL:            https://www.ietf.org/internet-drafts/draft-holmberg-mmusic-mux-exclusive-00.txt
Status:         https://datatracker.ietf.org/doc/draft-holmberg-mmusic-mux-exclusive/
Htmlized:       https://tools.ietf.org/html/draft-holmberg-mmusic-mux-exclusive-00

Abstract:
   This document defines how an endpoint can indicate exclusive support
   of RTP/RTCP multiplexing using the Session Description Protocol
   (SDP).

   The document updates RFC 5761, by defining how the SDP 'rtcp'
   attribute is used, together with the SDP 'rtcp-mux' attribute, to
   indicate exclusive support of RTP/RTCP multiplexing.

   Editor's note: 'exclusive' is probably not the best terminology, so
   feel free to suggest something more appropriate.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Taylor Brandstetter <[email-masked]>
Date: Wed, 18 Nov 2015 12:57:17 -0800

If I understand correctly, this proposes that if the endpoint exclusively
uses RTP/RTCP muxing, it must make the RTP and RTCP port numbers identical.

However, with trickle ICE, if no candidates have been gathered yet, the RTP
and RTCP port numbers will both be 9. So this creates an ambiguity; in this
situation, it will be impossible to tell whether or not the endpoint
exclusively uses RTCP muxing.

Would it be possible to indicate exclusive support of RTCP muxing by
setting the RTCP port value to 0? This would be pretty similar to assigning
a 0 port value to an m-line when using "bundle-only".

On Wed, Nov 4, 2015 at 10:59 PM, Christer Holmberg <
[email-masked]> wrote:

> Subject: New Version Notification for
> draft-holmberg-mmusic-mux-exclusive-00.txt
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-holmberg-mmusic-mux-exclusive-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-holmberg-mmusic-mux-exclusive/
> Htmlized:
> https://tools.ietf.org/html/draft-holmberg-mmusic-mux-exclusive-00
>
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>