Subject: [rtcweb] confirming consensus to change draft-ietf-rtcweb-rtp-usage

From: Sean Turner <[email-masked]>
Date: Mon, 14 Dec 2015 09:24:19 -0500

In August there was a thread "Do we have consensus on not requiring rtcp-non-mux” that resulted in proposed changes to draft-ietf-rtcweb-rtp-usage, see https://www.ietf.org/proceedings/94/slides/slides-94-rtcweb-4.pdf. This email is to confirm the consensus we had in the room at IETF 94 to make the following change in s4.5 of draft-ietf-rtcweb-rtp-usage:

Intro (for context):

Such RTP and RTCP multiplexing MUST be negotiated in the
signalling channel before it is used. If SDP is used  for
signalling, this negotiation MUST use the attributes defined in
RFC5761.

OLD:

implementations are also REQUIRED to support RTP and
RTCP sent on separate transport-layer flows.

NEW:

Implementations MAY support RTP and RTCP sent on
separate transport-layer flows. They MAY also refuse to
do so, in which case any negotiation that results in
multiplexing not being negotiated is treated as a failure.

If do not agree with this change please post a reply to this message with a reason why by December 18th.

Because draft-ietf-rtcweb-rtp-usage is in the RFC editor’s queue, to incorporate this change our AD is going to need to pull it back from the RFC-editor’s queue and re-run the IETF LC but that’s only going to happen once we confirm the room’s consensus.

the chairs,
c/s/t

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 14 Dec 2015 14:36:13 +0000

Hi,

I don't disagree with the change.

However, if you do the change, then the following statement ("Intro") in the draft is not correct:

   "If SDP is used for signalling, this negotiation MUST use the attributes defined in [RFC5761]."

Because, RFC 5761 requires support of fallback to non-mux, and it also requires ICE RTCP candidates when RTCP is used.

I have suggested a mechanism (draft-holmberg-mmusic-mux-exclusive) on how to negotiate/indicate support when fallback to non-mux is NOT supported.

Regards,

Christer

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Sean Turner
Sent: 14. joulukuuta 2015 16:24
To: [email-masked]
Subject: [rtcweb] confirming consensus to change draft-ietf-rtcweb-rtp-usage

Intro (for context):

Such RTP and RTCP multiplexing MUST be negotiated in the signalling channel before it is used. If SDP is used  for signalling, this negotiation MUST use the attributes defined in RFC5761.

OLD:

implementations are also REQUIRED to support RTP and RTCP sent on separate transport-layer flows.

NEW:

Implementations MAY support RTP and RTCP sent on separate transport-layer flows. They MAY also refuse to do so, in which case any negotiation that results in multiplexing not being negotiated is treated as a failure.

the chairs,
c/s/t
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 14 Dec 2015 17:35:40 -0500

I second Christer's suggestion. Only citing RFC 5761 and not draft-holmberg-mmusic-mux-exclusive will have nasty side effects like having to gather both RTP and RTCP ICE candidates in an Offer even if the Offerer exclusively supports mux. We need the cleaner solution that his draft provides.

> On Dec 14, 2015, at 9:36 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>

---

From: Colin Perkins <[email-masked]>
Date: Mon, 14 Dec 2015 22:49:32 +0000

Can you suggest explicit text changes?

Colin

> On 14 Dec 2015, at 22:35, Bernard Aboba <[email-masked]> wrote:
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 15 Dec 2015 04:38:53 +0000

Hi,

I'll think of some text, but we'd need to reference draft-mux-exclusive for the case when fallback to non-mux is not supported.

Regards,

Christer

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Colin Perkins<mailto:[email-masked]>
Sent: ‎15/‎12/‎2015 00:49
To: Bernard Aboba<mailto:[email-masked]>
Cc: Christer Holmberg<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] confirming consensus to change draft-ietf-rtcweb-rtp-usage

Colin

--
Colin Perkins
https://csperkins.org/

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 15 Dec 2015 10:22:18 +0000

Text proposal(<new></new>)

Regards,

Christer

---------------------------------

4.5.  RTP and RTCP Multiplexing

   Historically, RTP and RTCP have been run on separate transport layer
   flows (e.g., two UDP ports for each RTP session, one port for RTP and
   one port for RTCP).  With the increased use of Network Address/Port
   Translation (NAT/NAPT) this has become problematic, since maintaining
   multiple NAT bindings can be costly.  It also complicates firewall
   administration, since multiple ports need to be opened to allow RTP
   traffic.  To reduce these costs and session set-up times,
   implementations are REQUIRED to support multiplexing RTP data packets
   and RTCP control packets on a single transport-layer flow [RFC5761].
   Such RTP and RTCP multiplexing MUST be negotiated in the signalling
   channel before it is used.  If SDP is used for signalling, this
   negotiation MUST use the attributes defined in [RFC5761].
   <new>If an implementation does not  support RTP and RTCP sent on
   separate transport-layer flows, it MUST indicate that using the mechanism
   defined in [reference-to-draft-mux-exclusive]</new>. For
   backwards compatibility, implementations MAY support RTP and RTCP
   sent on separate transport-layer flows. They MAY also refuse to do so, in
   which case any negotiation that results in multiplexing not being negotiated
   is treated as a failure.

   Note that the use of RTP and RTCP multiplexed onto a single
   transport-layer flow ensures that there is occasional traffic sent on
   that port, even if there is no active media traffic.  This can be
   useful to keep NAT bindings alive [RFC6263].

---------------------------------

From: rtcweb [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 15. joulukuuta 2015 6:39
To: Colin Perkins; Bernard Aboba
Cc: [email-masked]
Subject: Re: [rtcweb] confirming consensus to change draft-ietf-rtcweb-rtp-usage

Hi,

Regards,

Christer

Regards,

Christer

Colin

> On 14 Dec 2015, at 22:35, Bernard Aboba <[email-masked]<mailto:[email-masked]>> wrote:
>
>> On Dec 14, 2015, at 9:36 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> Hi,
>>
>> To: [email-masked]<mailto:[email-masked]>
>> [email-masked]<mailto:[email-masked]>
>> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

--
Colin Perkins
https://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Thu, 17 Dec 2015 09:53:33 +0000

That text is fine with me - any other views?
Colin

> On 15 Dec 2015, at 10:22, Christer Holmberg <[email-masked]> wrote:
> 
> From: rtcweb [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Christer Holmberg
> Cc: [email-masked] <mailto:[email-masked]>
> From: Colin Perkins <mailto:[email-masked]>
> To: Bernard Aboba <mailto:[email-masked]>
> Cc: Christer Holmberg <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> > On 14 Dec 2015, at 22:35, Bernard Aboba <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> >> On Dec 14, 2015, at 9:36 AM, Christer Holmberg <[email-masked] <mailto:[email-masked]>> wrote:
> >> 
> >> Hi,
> >> 
> >> From: rtcweb [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Sean Turner
> >> To: [email-masked] <mailto:[email-masked]>
> >> In August there was a thread "Do we have consensus on not requiring rtcp-non-mux” that resulted in proposed changes to draft-ietf-rtcweb-rtp-usage, seehttps://www.ietf.org/proceedings/94/slides/slides-94-rtcweb-4.pdf <https://www.ietf.org/proceedings/94/slides/slides-94-rtcweb-4.pdf>. This email is to confirm the consensus we had in the room at IETF 94 to make the following change in s4.5 of draft-ietf-rtcweb-rtp-usage:
> >> 
> >> Intro (for context):
> >> 
> >> [email-masked] <mailto:[email-masked]>
> >> https://www.ietf.org/mailman/listinfo/rtcweb <https://www.ietf.org/mailman/listinfo/rtcweb>
> >> [email-masked] <mailto:[email-masked]>
> >> https://www.ietf.org/mailman/listinfo/rtcweb <https://www.ietf.org/mailman/listinfo/rtcweb>
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/rtcweb <https://www.ietf.org/mailman/listinfo/rtcweb>
> 
> 
> 
> -- 
> Colin Perkins
> https://csperkins.org/ <https://csperkins.org/>

-- 
Colin Perkins
https://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Thu, 17 Dec 2015 10:00:45 +0000

To confirm, this would give the following change to the rtp-usage draft:

--- draft-ietf-rtcweb-rtp-usage.xml	(revision 1071)
+++ draft-ietf-rtcweb-rtp-usage.xml	(working copy)
@@ -10,7 +10,7 @@
 <?rfc inline="yes"?>
 <?rfc compact="yes"?>
 <?rfc subcompact="no"?>
-<rfc category="std" docName="draft-ietf-rtcweb-rtp-usage-25" ipr="trust200902">
+<rfc category="std" docName="draft-ietf-rtcweb-rtp-usage-26" ipr="trust200902">
   <front>
     <title abbrev="RTP for WebRTC">Web Real-Time Communication (WebRTC): Media
     Transport and Use of RTP</title>
@@ -71,7 +71,7 @@
       </address>
     </author>
 
-    <date day="12" month="June" year="2015" />
+    <date day="21" month="December" year="2015" />
 
     <workgroup>RTCWEB Working Group</workgroup>
 
@@ -483,9 +483,13 @@
         target="RFC5761"></xref>. Such RTP and RTCP multiplexing MUST be
         negotiated in the signalling channel before it is used. If SDP is used
         for signalling, this negotiation MUST use the attributes defined in
-        <xref target="RFC5761"></xref>. For backwards compatibility,
-        implementations are also REQUIRED to support RTP and RTCP sent on
-        separate transport-layer flows.</t>
+        <xref target="RFC5761"></xref>.  Implementations MAY support RTP and
+        RTCP sent on separate transport-layer flows. They MAY also refuse to
+        do so, in which case any negotiation that results in multiplexing not
+        being negotiated is treated as a failure. If an implementation does 
+        not support RTP and RTCP sent on separate transport-layer flows, it 
+        MUST indicate that using the mechanism defined in 
+        <xref target="I-D.holmberg-mmusic-mux-exclusive"/>.</t>
 
         <t>Note that the use of RTP and RTCP multiplexed onto a single
         transport-layer flow ensures that there is occasional traffic sent on
@@ -2037,6 +2041,8 @@
 
       <?rfc include='reference.I-D.ietf-avtcore-rtp-topologies-update'?>
 
+      <?rfc include='reference.I-D.holmberg-mmusic-mux-exclusive'?>
+
       <?rfc include='reference.W3C.WD-webrtc-20130910'?>
 
       <?rfc include='reference.W3C.WD-mediacapture-streams-20130903'?>

> On 17 Dec 2015, at 09:53, Colin Perkins <[email-masked]> wrote:
> 
>> On 15 Dec 2015, at 10:22, Christer Holmberg <[email-masked] <mailto:[email-masked]>> wrote:
>> 

-- 
Colin Perkins
https://csperkins.org/

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 17 Dec 2015 13:17:15 +0000

I think if the word “failure” is used, you need to quantify what it means. For example, even with these words, I assume the session does not (and is not intended to) fail, and the SDP negotiation as a whole does not fail. Not even sure the entire media line negotiation fails.

Keith

From: rtcweb [mailto:[email-masked]] On Behalf Of Colin Perkins
Sent: 17 December 2015 10:01
To: Christer Holmberg
Cc: [email-masked]
Subject: Re: [rtcweb] confirming consensus to change draft-ietf-rtcweb-rtp-usage

@@ -483,9 +483,13 @@

On 17 Dec 2015, at 09:53, Colin Perkins <[email-masked]<mailto:[email-masked]>> wrote:

On 15 Dec 2015, at 10:22, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Regards,

Christer

Cc: [email-masked]<mailto:[email-masked]>

Hi,

Regards,

Christer

Regards,

Christer

Colin

>> In August there was a thread "Do we have consensus on not requiring rtcp-non-mux” that resulted in proposed changes to draft-ietf-rtcweb-rtp-usage, seehttps://www.ietf.org/proceedings/94/slides/slides-94-rtcweb-4.pdf. This email is to confirm the consensus we had in the room at IETF 94 to make the following change in s4.5 of draft-ietf-rtcweb-rtp-usage:
>>
>> Intro (for context):
>>

--
Colin Perkins
https://csperkins.org/

--
Colin Perkins
https://csperkins.org/

--
Colin Perkins
https://csperkins.org/