Subject: [rtcweb] draft-ietf-rtcweb-transports-11 -- Section-3.4 Middle box related functions

From: Victor Pascual Avila <[email-masked]>
Date: Tue, 9 Feb 2016 10:02:00 +0100

Hi,

end-to-end TCP is supported but not very useful due to HoLB. Typical
use is just TCP to a TURN server or gateway, then UDP.

Can we assume real-time media over a TCP-based access works fine?

Thanks,
-Victor

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 14 Feb 2016 16:23:53 -0700

> On Feb 9, 2016, at 2:02 AM, Victor Pascual Avila <[email-masked]> wrote:
> 

No - in many real world circumstances it will be really messed up and only work intermittently. But the main idea of ICE is try a range of things and choose the best thing that works.

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 18 Feb 2016 15:26:53 +0100

We can assume it works better than no connection. If both are allowed by firewalls, UDP will work better in ~all cases.

Den 15. februar 2016 00:23:53 CET, skrev Cullen Jennings <[email-masked]>:
>No - in many real world circumstances it will be really messed up and
>only work intermittently. But the main idea of ICE is try a range of
>things and choose the best thing that works. 
>
>
>_______________________________________________
>rtcweb mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/rtcweb

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.