Subject: Re: [rtcweb] JSEP: multiple fingerprints for a certificate

From: Harald Alvestrand <[email-masked]>
Date: Wed, 14 Sep 2016 20:31:21 +0200

Den 25. aug. 2016 17:04, skrev Cullen Jennings:
> 
> The JSEP authors have typically tried to have JSEP ref everything that implementers need to know just to make it easier for them to find it. I will add a ref to draft-ietf-mmusic-4572-update to JSEP.  Given it is an "update" it technical is a dependency either way. 

Speaking in terms of standards theory (and not referencing the
particular issue):

If a conformant implementation of X can be made based on only the
information in 4572, it is OK to reference 4572 in the specification for
X. Any clarifications in -bis drafts can be considered "advice for the
implementor", it doesn't change validity.

If a conformant implementation has to do something that is illegal
according to 4572, but legal according to 4572-bis, the spec *has* to
reference 4572-bis normatively. A reference to 4572 in addition is not
needed. Note that this blocks publication until 4572-bis is published.

Note that this applies to optional features too; if an optional feature
can't be implemented without reading 4572-bis, it's a normative dependency.

Back to discussing the subject line..

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 14 Sep 2016 18:50:17 +0000

Hi,

Just a minor correction: there is no 4572-bis. draft-4572-update updates/clarifies parts of RFC 4572.

4572-update does not fix anything that is "illegal" in RFC 4572. However, 4572-update is also a little more than "advice for the implementer".

So, I definitely think we should normatively reference 4572-update in JSEP. RTCWEB is what triggered 4572-update to begin with...

Regards,

Christer

-----Original Message-----
From: Harald Alvestrand [mailto:[email-masked]] 
Sent: 14 September 2016 21:31
To: Cullen Jennings <[email-masked]>; Christer Holmberg <[email-masked]>
Cc: RTCWeb IETF <[email-masked]>
Subject: Re: [rtcweb] JSEP: multiple fingerprints for a certificate

> The JSEP authors have typically tried to have JSEP ref everything that implementers need to know just to make it easier for them to find it. I will add a ref to draft-ietf-mmusic-4572-update to JSE…

Speaking in terms of standards theory (and not referencing the particular issue):

If a conformant implementation of X can be made based on only the information in 4572, it is OK to reference 4572 in the specification for X. Any clarifications in -bis drafts can be considered "advice for the implementor", it doesn't change validity.

If a conformant implementation has to do something that is illegal according to 4572, but legal according to 4572-bis, the spec *has* to reference 4572-bis normatively. A reference to 4572 in addition is not needed. Note that this blocks publication until 4572-bis is published.

Note that this applies to optional features too; if an optional feature can't be implemented without reading 4572-bis, it's a normative dependency.