Subject: [rtcweb] JSEP Section 4.2.3: setDirection()

From: Bernard Aboba <[email-masked]>
Date: Wed, 9 Nov 2016 17:22:28 -0800

Section 4.2.3:

   The setDirection method sets the direction of a transceiver, which
   affects the direction attribute of the associated m= section on
   future calls to createOffer and createAnswer.

[BA] "sets the direction of a transceiver" is a bit confusing because

setDirection() doesn't immediately change whether an RtpSender can

send or an RtpReceiver can receive.  Since setDirection does

immediately change the value of the transceiver.direction

attribute you might say "sets the transceiver.direction attribute" instead.

Also, an application may want to determine the current

direction (e.g. whether an RtpSender can send or an RtpReceiver

can receive) as opposed to the pending direction (provided

by transceiver.direction).  Taylor agreed to create a WebRTC 1.0

PR to add the concept of current direction (e.g. by adding

a currentDirection attribute).  It would therefore be useful to add some text

to Section 4.2.3 explaining the distinction.  For example:

"Note that while setDirection sets the transceiver.direction

attribute immediately, this pending direction does not immediately

affect whether an RtpSender will send or RtpReceiver will receive.

After calls to setLocal/setRemoteDescription, the direction currently

in effect is represented by transceiver.currentDirection (the attribute

Taylor will be defining)."

---

From: Taylor Brandstetter <[email-masked]>
Date: Wed, 9 Nov 2016 22:28:36 -0800

If we add a negotiatedDirection attribute, should we add something in JSEP
about it? It deals with SDP, so that seems logical.

On Wed, Nov 9, 2016 at 5:22 PM, Bernard Aboba <[email-masked]>
wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 9 Nov 2016 23:30:08 -0800

Yes, we should add something in JSEP since it is related to SDP.