Subject: [rtcweb] Datachannel Hackathon at IETF 101 ?

From: T H Panton <[email-masked]>
Date: Wed, 24 Jan 2018 11:28:03 +0000

There has been talk over on the w3c list about the scarcity and unsuitability of free-standing WebRTC datachannel implementations.

I wonder if this is a suitable target for the IETF 101 hackathon? 

The challenge would be to throw up one or 2 free standing datachannel implementations based on existing open
source with APIs that might suit authors of networked games or SFUs.

Comments? Thoughts?

T.

---

From: Richard Barnes <[email-masked]>
Date: Wed, 24 Jan 2018 10:23:54 -0500

Seems worthwhile to me, if you can find some people to do it.

On Wed, Jan 24, 2018 at 6:28 AM, T H Panton <[email-masked]> wrote:

> There has been talk over on the w3c list about the scarcity and
> unsuitability of free-standing WebRTC datachannel implementations.
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Wed, 24 Jan 2018 16:28:46 +0100

I will not be attending this IETF meeting physically, but I would be 
interested in collaborating (either helping to implement the datachannel 
libraries or integrating them on my media server for testing)

Best regards
Sergio

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 25 Jan 2018 18:46:39 +0100

> On 24. Jan 2018, at 12:28, T H Panton <[email-masked]> wrote:
> 
We are participating and could use the Firefox WebRTC implementation. We would be able to
debug SCTP issues and possibly some issues in the WebRTC implementation of Firefox.

Best regards
Michael
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 25 Jan 2018 18:14:41 +0000

Hi,

If the purpose is to test different data channel stacks (in addition to just establishing the SCTP-over-DTLS association), I assume there needs to be some applications that use the data channels?

It would be nice to have webpage where people could add links to their applications using data channels, so that people can then click :)

Regards,

Christer

-----Original Message-----
From: dispatch [mailto:[email-masked]] On Behalf Of Michael Tuexen
Sent: 25 January 2018 19:47
To: T H Panton <[email-masked]>
Cc: Felix Weinrank <[email-masked]>; [email-masked]; RTCWeb IETF <[email-masked]>
Subject: Re: [dispatch] [rtcweb] Datachannel Hackathon at IETF 101 ?

> The challenge would be to throw up one or 2 free standing datachannel 
> implementations based on existing open source with APIs that might suit authors of networked games or SFUs.
> 
> Comments? Thoughts?
We are participating and could use the Firefox WebRTC implementation. We would be able to debug SCTP issues and possibly some issues in the WebRTC implementation of Firefox.

Best regards
Michael

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 25 Jan 2018 21:27:05 +0100

> On 25. Jan 2018, at 19:14, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
> 
Some examples can be found at:
https://github.com/nplab/WebRTC-Data-Channel-Playground

Best regards
Michael

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 25 Jan 2018 21:22:22 +0000

Thanks!

It would also be interesting to see some cool killer apps (other than file transfers) using data channels :)

Regards,

Christer

-----Original Message-----
From: Michael Tuexen [mailto:[email-masked]] 
Sent: 25 January 2018 22:27
To: Christer Holmberg <[email-masked]>
Cc: T H Panton <[email-masked]>; Felix Weinrank <[email-masked]>; [email-masked]; RTCWeb IETF <[email-masked]>
Subject: Re: [dispatch] [rtcweb] Datachannel Hackathon at IETF 101 ?

> It would be nice to have webpage where people could add links to their 
> applications using data channels, so that people can then click :)

Best regards
Michael

---

From: Nils Ohlmeier <[email-masked]>
Date: Thu, 25 Jan 2018 14:29:26 -0800

Hi Christer,

While I totally agree that it would be awesome to find killer apps for data channels I don’t think an IETF Hackathon is a) the place to find new killer aps and b) creating something at an IETF Hackathon requires an app idea to exist already.

It was my understanding	that Mr. Panton was proposing to solve the chicken and egg problem of people complaining that creating data channel apps (outside of browsers) is too complicated by hacking together an easily integratabtle data channel lib. I would totally be up to participate in that.

Once we have such a lib we and other then can start playing around and maybe until the next IETF we will have “some cool killer apps”.

Best
  Nils Ohlmeier

> On Jan 25, 2018, at 13:22, Christer Holmberg <[email-masked]> wrote:
> 
> Thanks!
>

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 30 Jan 2018 14:59:22 +0100

Speaking of features that have received little love from deployment ....
would anyone be interested in hacking on the identity API?

It seems to have received little love from implementors so far, but
there's been strong pushback against removing it too. We need either it
or something like it to satisfy the security requirements we set out to
satisfy.

Harald

-- 
Surveillance is pervasive. Go Dark.

---

From: Nils Ohlmeier <[email-masked]>
Date: Tue, 30 Jan 2018 15:37:06 -0800

Yes I would love to test it against the Firefox Identity implementation.

Were you thinking about adding it to JS code of an open source bridge/SFU, or standing up an identity service, or both?

Best
  Nils

> On Jan 30, 2018, at 05:59, Harald Alvestrand <[email-masked]> wrote:
>

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 31 Jan 2018 08:50:15 +0100

> Were you thinking about adding it to JS code of an open source bridge/SFU, or standing up an identity service, or both?

Whatever can be shown to work. The point would be to show by
demonstration that it's (relatively) easy to provide and use identity
service and that Firefox browsers can use it with different backends /
services.

(I don't see any chance to get identity into Chrome by London - if we
can build a convincing story in London, the next IETF might be more
hopeful.)

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jan 2018 19:03:37 +1100

(-dispatch)

I'll be at the hackathon and am willing to assist.  I have an identity
provider, but it is garbage.  It would be nice to see something a
little more fully thought out.

On Wed, Jan 31, 2018 at 6:50 PM, Harald Alvestrand <[email-masked]> wrote:
> Were you thinking about adding it to JS code of an open source bridge/SFU,
> or standing up an identity service, or both?
>
>
> Whatever can be shown to work. The point would be to show by demonstration
> that it's (relatively) easy to provide and use identity service and that
> Firefox browsers can use it with different backends / services.
>
> (I don't see any chance to get identity into Chrome by London - if we can
> build a convincing story in London, the next IETF might be more hopeful.)
>
>
>
> Best
>   Nils
>
> implementations based on existing open

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Wed, 31 Jan 2018 09:31:25 +0100

I would be also happy to collaborate and implement it server side.

Best regards
Sergio

---

From: Alexandre GOUAILLARD <[email-masked]>
Date: Wed, 31 Jan 2018 08:34:15 -0800

depending on which day this happens, I would join.

On Thu, Jan 25, 2018 at 2:29 PM, Nils Ohlmeier <[email-masked]>
wrote:

> Hi Christer,
>
> While I totally agree that it would be awesome to find killer apps for
> data channels I don’t think an IETF Hackathon is a) the place to find new
> killer aps and b) creating something at an IETF Hackathon requires an app
> idea to exist already.
>
> It was my understanding that Mr. Panton was proposing to solve the chicken
> and egg problem of people complaining that creating data channel apps
> (outside of browsers) is too complicated by hacking together an easily
> integratabtle data channel lib. I would totally be up to participate in
> that.
>
> Once we have such a lib we and other then can start playing around and
> maybe until the next IETF we will have “some cool killer apps”.
>
> Best
>   Nils Ohlmeier
>
> > Cc: T H Panton <[email-masked]>; Felix Weinrank <
> [email-masked]>; [email-masked]; RTCWeb IETF <[email-masked]>
> >> If the purpose is to test different data channel stacks (in addition to
> just establishing the SCTP-over-DTLS association), I assume there needs to
> be some applications that use the data channels?
> >>
> >> We are participating and could use the Firefox WebRTC implementation.
> We would be able to debug SCTP issues and possibly some issues in the
> WebRTC implementation of Firefox.
> >>
> >> Best regards
> >> Michael
> >>>
> >>> T.
> >>>

-- 
Alex. Gouaillard, PhD, PhD, MBA
------------------------------------------------------------------------------------
President - CoSMo Software Consulting, Singapore
------------------------------------------------------------------------------------
sg.linkedin.com/agouaillard

   -

---

From: Alexandre GOUAILLARD <[email-masked]>
Date: Wed, 31 Jan 2018 08:36:34 -0800

I might have a use case with block chain, and bandwidth to hack something
there in march.
if I understand correctly, you need *one* implementation of the concept to
play well with the webrtc spec, correct?

   -

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 31 Jan 2018 16:49:05 +0000

Hi,

I agree that the main purpose of the hackathon is not to make apps.

But, what prevents people from showing their apps, and discuss data channel related problems that they may have ran into? Also, having a "show case" may trigger wider interest :)

For example, when I did a file transfer app some time a few years ago, I noted that the data channel kept going down. On the Mozilla(?) developer site I figured out that one had to include application level pauses between sending fragments from preventing that to happen. Don't know if that is still an issue, but just to give an example.

Regards,

Christer

-----Original Message-----
From: Nils Ohlmeier [mailto:[email-masked]] 
Sent: 26 January 2018 00:29
To: Christer Holmberg <[email-masked]>
Cc: Michael Tuexen <[email-masked]>; Felix Weinrank <[email-masked]>; [email-masked]; RTCWeb IETF <[email-masked]>
Subject: Re: [rtcweb] [dispatch] Datachannel Hackathon at IETF 101 ?

Hi Christer,

Best
  Nils Ohlmeier

> Cc: T H Panton <[email-masked]>; Felix Weinrank 
> <[email-masked]>; [email-masked]; RTCWeb IETF 
> <[email-masked]>
>> It would be nice to have webpage where people could add links to 
>> their applications using data channels, so that people can then click 
>> :)
>>> The challenge would be to throw up one or 2 free standing 
>>> datachannel implementations based on existing open source with APIs that might suit authors of networked games or SFUs.
>>> 
>>> Comments? Thoughts?