Subject: [rtcweb] JSEP: remote-candidate attribute

From: Christer Holmberg <[email-masked]>
Date: Tue, 6 Mar 2018 14:11:00 +0000

Hi,

The following has probably been discussed at some point, but I could not find it in the mail archive, and it is not described in JSEP.

My understanding is that JSEP does not use the remote-candidate attribute (it must parse it if received, but it doesn’t process it).

What was the reason for that?

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Sat, 31 Mar 2018 22:43:58 +0000

JSEP doesn't use the remote-candidates attribute because it isn't
necessary; because JSEP assumes that the selected pair will be handled
entirely within the ICE process (i.e., through USE-CANDIDATE and/or
PRIORITY), the answerer doesn't need to wait for its checks to complete
before sending an answer.

On Tue, Mar 6, 2018 at 6:11 AM Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> The following has probably been discussed at some point, but I could not
> find it in the mail archive, and it is not described in JSEP.
>
> My understanding is that JSEP does not use the remote-candidate attribute
> (it must parse it if received, but it doesn’t process it).
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>