Subject: Re: [rtcweb] WGLC for draft-ietf-rtcweb-sdp - Christer's review

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 1 Aug 2018 06:33:32 -0700

Hello Christer

Thanks for the review.Please see inline.

cheers
Suhas

On Sat, Jul 28, 2018 at 4:56 AM Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> Here are my comments:
>
> Q1: Regarding the ICE attributes (non-trickle), I think the draft shall
> reference draft-ietf-mmusic-ice-sip-sdp
>

[Suhas] Since JSEP refers to RFC5245, this draft decided to follow the same
as well.

> Q2: I think the examples shall include the 'ice2' ice-options value
> (defined in RFC 8445), to indicate that aggressive nomination is not
> supported.
>
> [Suhas] SDP examples are based on JSEP requirements for constructing SDP.
The latest version of  JSEP doesn't seem to support "ice2". It would be
nice to keep both the drafts in sync as for the rules of the SDP
construction. I am curious to hear what is the WG take on this though

> Yes, this again brings up the what-ICE-version-to-reference-question. All
> the other ICE related drafts in the examples reference (directly or
> indirectly) RFC 8445.
>
> Regards,
>
> Christer
>
> -----Original Message-----
> From: rtcweb [mailto:[email-masked]] On Behalf Of Sean Turner
> Sent: 26 July 2018 21:10
> To: RTCWeb IETF <[email-masked]>
> Subject: [rtcweb] WGLC for draft-ietf-rtcweb-sdp
>
> All,
>
> This is the working group last call for the "Annotated Example SDP for
> WebRTC" draft available at
> https://datatracker.ietf.org/doc/draft-ietf-rtcweb-sdp/.  Please review
> the document and send your comments to the list by 2359 UTC on 17 August
> 2018.
>
> Thanks - spt
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 1 Aug 2018 20:26:33 +0000

Hi,

>> Q1: Regarding the ICE attributes (non-trickle), I think the draft shall reference draft-ietf-mmusic-ice-sip-sdp
>
> [Suhas] Since JSEP refers to RFC5245, this draft decided to follow the same as well.
 
JSEP also implicitly references RFC 8445 (ICEbis).

I have suggested to change the JSEP reference.

>> Q2: I think the examples shall include the 'ice2' ice-options value (defined in RFC 8445), to 
>> indicate that aggressive nomination is not supported.
> [Suhas] SDP examples are based on JSEP requirements for constructing SDP. The latest version of  JSEP 
> doesn't seem to support "ice2". It would be nice to keep both the drafts in sync as for the rules of the SDP 

Due to the implicit reference to RFC 8445 I don't think there is a sync even within JSEP.
 
Regards,

Christer

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Sean Turner
Sent: 26 July 2018 21:10
To: RTCWeb IETF <[email-masked]>
Subject: [rtcweb] WGLC for draft-ietf-rtcweb-sdp

All,

This is the working group last call for the "Annotated Example SDP for WebRTC" draft available at https://datatracker.ietf.org/doc/draft-ietf-rtcweb-sdp/.  Please review the document and send your comments to the list by 2359 UTC on 17 August 2018.

Thanks - spt

---

From: Sean Turner <[email-masked]>
Date: Thu, 2 Aug 2018 15:06:21 -0400

> On Jul 28, 2018, at 07:55, Christer Holmberg <[email-masked]> wrote:
> 
> Yes, this again brings up the what-ICE-version-to-reference-question. All the other ICE related drafts in the examples reference (directly or indirectly) RFC 8445.

We (Ted, Cullen, and Sean) consulted with our AD and confirmed that the plan outlined when trying to address this issue in the rtcweb-overview draft is still the plan [0].  tl;dr: figure this out when cluster 238 gets untangled in the RFC editor’s queue.

spt

[0] https://mailarchive.ietf.org/arch/msg/rtcweb/GWdXRIO68FZwVtzzqugnELKeaY8

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 2 Aug 2018 21:25:31 +0000

Hi,

>> Yes, this again brings up the what-ICE-version-to-reference-question. All the other ICE 
>> related drafts in the examples reference (directly or indirectly) RFC 8445.
>
> We (Ted, Cullen, and Sean) consulted with our AD and confirmed that the plan outlined 
> when trying to address this issue in the rtcweb-overview draft is still the plan [0].  tl;dr: 
> figure this out when cluster 238 gets untangled in the RFC editor’s queue.

Correct. Just wanted to point out that this draft might be affected too.

Regards,

Christer