Subject: [rtcweb] RID syntax inconsistencies

From: Bernard Aboba <[email-masked]>
Date: Tue, 15 Jan 2019 08:03:50 -0800

An issue has been raised about inconsistencies in the RID syntax between
draft-ietf-mmusic-rid and draft-ietf-avtext-rid .

According to https://tools.ietf.org/html/draft-ietf-mmusic-rid-15 , we have:

rid-id = 1*(alpha-numeric / "-" / "_")

According to: https://tools.ietf.org/html/draft-ietf-avtext-rid-09#section-3
 :

As with all SDES items, RtpStreamId and RepairedRtpStreamId are
limited to a total of 255 octets in length. RtpStreamId and
RepairedStreamId are constrained to contain only alphanumeric
characters. For avoidance of doubt, the only allowed byte values for
these IDs are decimal 48 through 57, 65 through 90, and 97 through
122.

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 15 Jan 2019 16:25:52 +0000

Hi,

So the main point is the missing ”-” and ”_” i.e. dec 45 and 95 in ASCII. 

Are any of these characters used by actual implementations? 

If not isn’t the easiest to restrict the MMUSIC RID to the set AVTEXT RID defines? 

I guess we should also address the limitation of 255 characters, i.e. change syntax in MMUSIC-RID to:

rid-id = 1*255(alpha-numeric)

Cheers

Magnus Westerlund

From: rtcweb <[email-masked]> On Behalf Of Bernard Aboba
Sent: den 15 januari 2019 17:04
To: RTCWeb IETF <[email-masked]>
Subject: [rtcweb] RID syntax inconsistencies

An issue has been raised about inconsistencies in the RID syntax between draft-ietf-mmusic-rid and draft-ietf-avtext-rid . 

According to  <https://tools.ietf.org/html/draft-ietf-mmusic-rid-15> https://tools.ietf.org/html/draft-ietf-mmusic-rid-15 , we have:

According to:  <https://tools.ietf.org/html/draft-ietf-avtext-rid-09#section-3> https://tools.ietf.org/html/draft-ietf-avtext-rid-09#section-3 :

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Tue, 15 Jan 2019 18:54:01 +0100

> Are any of these characters used by actual implementations?

This is funny because I'm working on this right now and, somehow, I
wish to create RID values as follows:

  "rid1.0"
  "rid1.1"
  "rid1.2"

I may use "-" instead of ".", of course, but somehow I'd like to be
able to write a "separator" char.

-- 
Iñaki Baz Castillo
<[email-masked]>