Subject: Re: [rtcweb] [rtcweb-wg/jsep] JSEP says that subsequent offers need to specify the ICE protocol (#854)

From: Adam Roach <[email-masked]>
Date: Mon, 28 Jan 2019 13:39:06 -0600

Taking it back to the RTCWEB mailing list.

This seems like a better formulation than the text that I put together, 
and it is a similarly minimal change that has no impact on any current 
WebRTC implementations (at least, that I know of).

Justin -- if you're willing to craft text that captures this, you'll 
probably do a better job of doing it in a style that matches the rest of 
JSEP than I can.

/a

On 1/28/19 1:33 PM, Roman Shpount wrote:
> My proposal was to use TCP/DTLS/blah whenever the default candidate is a
> TCP candidate and *ICE nomination is complete*. If TCP candidate become
> default candidate after ICE nomination is complete, both end points should
> support TCP/DTLS based protocol. In all other cases, candidates are
> either still being collected or UDP candidate should be present and 
> used as
> default.
>
> In the initial offer, when ICE nomination is in progress, when ICE restart
> is initiated, end points must still use UDP based proto, since we do not
> want them to send TCP based offer if remote does not support it or change
> the proto during the ICE negotiation.
>
> Regards,
> _____________
> Roman Shpount
>
>
> On Sat, Jan 26, 2019 at 8:29 PM Justin Uberti <[email-masked]>
> wrote:
>
> > Path in #862 <https://github.com/rtcweb-wg/jsep/pull/862> seems to be to
> > use TCP/DTLS/blah whenever the default candidate is a TCP candidate. As
> > discussed in #394 <https://github.com/rtcweb-wg/jsep/issues/394>, this
> > will break endpoints that don't understand the TCP/DTLS/RTP/SAVPF proto
> > name, but at this point such endpoints should be rare.
> >
> > —
> > You are receiving this because you commented.
> > Reply to this email directly, view it on GitHub
> > 
> <https://github.com/rtcweb-wg/jsep/issues/854#issuecomment-457880866>, 
> or mute
> > the thread
> > 
> <https://github.com/notifications/unsubscribe-auth/AEh5ShA-_F70HMwECsHCaHt_kHcJPxBhks5vHQD6gaJpZM4X5Svw>
> > .
> >
>
> —
> You are receiving this because you are subscribed to this thread.
> Reply to this email directly, view it on GitHub 
> <https://github.com/rtcweb-wg/jsep/issues/854#issuecomment-458269864>, 
> or mute the thread 
> <https://github.com/notifications/unsubscribe-auth/AC1khFiKZS_Wmwvu7FfZ2NMgA-hzsf9lks5vH1CNgaJpZM4X5Svw>.
>

---

From: Justin Uberti <[email-masked]>
Date: Mon, 28 Jan 2019 11:50:22 -0800

OK, will take a shot today or tomorrow.

On Mon, Jan 28, 2019 at 11:39 AM Adam Roach <[email-masked]> wrote:

> either still being collected or UDP candidate should be present and used as
> default.
>
> <[email-masked]>
> wrote:
>
> > Path in #862 <https://github.com/rtcweb-wg/jsep/pull/862>
> <https://github.com/rtcweb-wg/jsep/pull/862> seems to be to
> > discussed in #394 <https://github.com/rtcweb-wg/jsep/issues/394>
> <https://github.com/rtcweb-wg/jsep/issues/394>, this
> > <https://github.com/rtcweb-wg/jsep/issues/854#issuecomment-457880866>
> <https://github.com/rtcweb-wg/jsep/issues/854#issuecomment-457880866>, or
> mute
> > the thread
> >
> <https://github.com/rtcweb-wg/jsep/issues/854#issuecomment-458269864>, or mute
> the thread
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>