Subject: [rtcweb] Results of call for consensus on ICE transport parameter issue

From: Ted Hardie <[email-masked]>
Date: Fri, 15 Feb 2019 14:56:15 -0800

The chairs believe that there was rough consensus among those responding to
make the change in:

https://github.com/rtcweb-wg/jsep/pull/863

Given the state of the document, it will be the Area Director's call as to
how much of the post-working group approval process must be re-done.
Authors, please wait on his direction before publishing a new version with
this merged.

Regards,
Ted and Sean

---

From: Justin Uberti <[email-masked]>
Date: Fri, 15 Feb 2019 17:56:57 -0800

I have updated this PR to incorporate minor feedback that was received
during the consensus call. Those who had feedback, please take another look
and comment on the PR if you are satisfied.

On Fri, Feb 15, 2019 at 2:56 PM Ted Hardie <[email-masked]> wrote:

> The chairs believe that there was rough consensus among those responding
> to make the change in:
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 19 Feb 2019 20:04:40 +0000

Looks good.

Regards,

Christer

From: rtcweb <[email-masked]> on behalf of Justin Uberti <juberti=[email-masked]>
Date: Saturday, 16 February 2019 at 3.57
To: Ted Hardie <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [rtcweb] Results of call for consensus on ICE transport parameter issue

I have updated this PR to incorporate minor feedback that was received during the consensus call. Those who had feedback, please take another look and comment on the PR if you are satisfied.

On Fri, Feb 15, 2019 at 2:56 PM Ted Hardie <[email-masked]<mailto:[email-masked]>> wrote:
The chairs believe that there was rough consensus among those responding to make the change in:

Given the state of the document, it will be the Area Director's call as to how much of the post-working group approval process must be re-done.  Authors, please wait on his direction before publishing a new version with this merged.

Regards,
Ted and Sean
_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Roman Shpount <[email-masked]>
Date: Tue, 19 Feb 2019 16:18:55 -0500

Hi Justin,

I did provide editorial feedback to the change on github:

1. This document refers to SDP protocol as profile. If you look at the
referenced documents that define "profiles" in JSEP, they all refer to them
as protocols. Also, in case of SRTP, profile is actually something
different and refers to SRTP key parameters.

2. Default candidate does not have profile (or protocol), it has transport,
port, and (connection-)address. So each "m=" and "c=" MUST be filled in
with port, protocol, and address to match port, transport, and address of
the default candidate for the m= section, as described in ice-sip-sdp.

Regards,
_____________
Roman Shpount

On Tue, Feb 19, 2019 at 3:05 PM Christer Holmberg <
[email-masked]> wrote:

> Looks good.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
> *From: *rtcweb <[email-masked]> on behalf of Justin Uberti
> <juberti=[email-masked]>
> *Date: *Saturday, 16 February 2019 at 3.57
> *To: *Ted Hardie <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [rtcweb] Results of call for consensus on ICE transport
> parameter issue
>
>
>

---

From: Justin Uberti <[email-masked]>
Date: Fri, 22 Feb 2019 17:46:23 -0800

Roman, thanks for raising this. I looked into this a bit and it's kind of
ambiguous; https://tools.ietf.org/html/rfc7850 uses "profile", "proto", and
"protocol" (although "protocol" is used most frequently).

JSEP actually uses both profile and protocol to refer to the transport,
depending on the section; if we make a change here, we should hit all
usages, which probably means that it is outside of the scope of this
particular issue.

On Tue, Feb 19, 2019 at 1:19 PM Roman Shpount <[email-masked]> wrote:

> 2. Default candidate does not have profile (or protocol), it has
> transport, port, and (connection-)address. So each "m=" and "c=" MUST be
> filled in with port, protocol, and address to match port, transport, and
> address of the default candidate for the m= section, as described in
> ice-sip-sdp.
>
> Regards,
> _____________
> Roman Shpount
>
>
>> <juberti=[email-masked] <[email-masked]>>
>> Given the state of the document, it will be the Area Director's call as
>> to how much of the post-working group approval process must be re-done.

---

From: Justin Uberti <[email-masked]>
Date: Sun, 24 Feb 2019 20:09:47 -0800

Found a way to address this with minor changes to the existing PR.

On Fri, Feb 22, 2019 at 5:46 PM Justin Uberti <[email-masked]> wrote:

> ambiguous; https://tools.ietf.org/html/rfc7850 uses "profile", "proto",
> and "protocol" (although "protocol" is used most frequently).
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 25 Feb 2019 07:58:47 +0000

Hi,

In 4566bis, <proto> defines a transport protocol.

In case of RTP, the text refers to RTP/AVP as an “RTP profile”, but it is still a transport protocol.

Regards,

Christer

From: Justin Uberti <[email-masked]>
Date: Monday, 25 February 2019 at 6.10
To: Roman Shpount <[email-masked]>
Cc: Ted Hardie <[email-masked]>, "[email-masked]" <[email-masked]>, Christer Holmberg <[email-masked]>
Subject: Re: [rtcweb] Results of call for consensus on ICE transport parameter issue

On Fri, Feb 22, 2019 at 5:46 PM Justin Uberti <[email-masked]<mailto:[email-masked]>> wrote:
Roman, thanks for raising this. I looked into this a bit and it's kind of ambiguous; https://tools.ietf.org/html/rfc7850 uses "profile", "proto", and "protocol" (although "protocol" is used most frequently).

JSEP actually uses both profile and protocol to refer to the transport, depending on the section; if we make a change here, we should hit all usages, which probably means that it is outside of the scope of this particular issue.

On Tue, Feb 19, 2019 at 1:19 PM Roman Shpount <[email-masked]<mailto:[email-masked]>> wrote:
Hi Justin,

1. This document refers to SDP protocol as profile. If you look at the referenced documents that define "profiles" in JSEP, they all refer to them as protocols. Also, in case of SRTP, profile is actually something different and refers to SRTP key parameters.

2. Default candidate does not have profile (or protocol), it has transport, port, and (connection-)address. So each "m=" and "c=" MUST be filled in with port, protocol, and address to match port, transport, and address of the default candidate for the m= section, as described in ice-sip-sdp.

Regards,
_____________
Roman Shpount

On Tue, Feb 19, 2019 at 3:05 PM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Looks good.

Regards,

Christer

From: rtcweb <[email-masked]<mailto:[email-masked]>> on behalf of Justin Uberti <juberti=[email-masked]<mailto:[email-masked]>>
Date: Saturday, 16 February 2019 at 3.57
To: Ted Hardie <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rtcweb] Results of call for consensus on ICE transport parameter issue

Regards,
Ted and Sean

---

From: Justin Uberti <[email-masked]>
Date: Mon, 25 Feb 2019 09:53:45 -0800

Sure, but I think it makes sense to use the same terminology (i.e.,
"profile") as is used in other RTP-related documents.

On Sun, Feb 24, 2019 at 11:58 PM Christer Holmberg <
[email-masked]> wrote:

> *From: *Justin Uberti <[email-masked]>
> *Date: *Monday, 25 February 2019 at 6.10
> *To: *Roman Shpount <[email-masked]>
> *Cc: *Ted Hardie <[email-masked]>, "[email-masked]" <[email-masked]>,
> Christer Holmberg <[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 25 Feb 2019 19:43:26 +0000

Hi,

I am not sure what other document you refer to, but it really depends on what the text is talking about: the semantics of the <proto> field, which is a transport protocol, or whatever is used as a transport protocol (e.g., an RTP profile).

Having said that, I am aware that documents unfortunately don’t use consistent terminology, so I wouldn’t be surprised if the 4566bis terminology isn’t used everywhere (also, there have been discussions about the 4566bis terminology itself…).

My personal preference would be to be aligned with 4566bis, but as long as we are consistent within JSEP I can live with it.

Regards,

Christer

From: Justin Uberti <[email-masked]>
Date: Monday, 25 February 2019 at 19.54
To: Christer Holmberg <[email-masked]>
Cc: Roman Shpount <[email-masked]>, Ted Hardie <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [rtcweb] Results of call for consensus on ICE transport parameter issue

Sure, but I think it makes sense to use the same terminology (i.e., "profile") as is used in other RTP-related documents.

On Sun, Feb 24, 2019 at 11:58 PM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

From: Justin Uberti <[email-masked]<mailto:[email-masked]>>
Date: Monday, 25 February 2019 at 6.10
To: Roman Shpount <[email-masked]<mailto:[email-masked]>>
Cc: Ted Hardie <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rtcweb] Results of call for consensus on ICE transport parameter issue

Regards,
_____________
Roman Shpount

Regards,

Christer

Regards,
Ted and Sean

---

From: Justin Uberti <[email-masked]>
Date: Mon, 25 Feb 2019 11:55:52 -0800

I believe the current PR makes JSEP internally consistent.

On Mon, Feb 25, 2019 at 11:43 AM Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
>
>
> I am not sure what other document you refer to, but it really depends on
> what the text is talking about: the semantics of the <proto> field, which
> is a transport protocol, or whatever is used as a transport protocol (e.g.,
> an RTP profile).
>
>
>
> Having said that, I am aware that documents unfortunately don’t use
> consistent terminology, so I wouldn’t be surprised if the 4566bis
> terminology isn’t used everywhere (also, there have been discussions about
> the 4566bis terminology itself…).
>
>
>
> My personal preference would be to be aligned with 4566bis, but as long as
> we are consistent within JSEP I can live with it.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
>
>
> *Date: *Monday, 25 February 2019 at 19.54
> *To: *Christer Holmberg <[email-masked]>
> *Cc: *Roman Shpount <[email-masked]>, Ted Hardie <[email-masked]>,
> "[email-masked]" <[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 25 Feb 2019 20:03:58 +0000

Hi,

>I believe the current PR makes JSEP internally consistent.

Ok, I wasn’t sure that is what you meant when you said that you “found a way to address this” 😊

Regards,

Christer

On Mon, Feb 25, 2019 at 11:43 AM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

From: Justin Uberti <[email-masked]<mailto:[email-masked]>>
Date: Monday, 25 February 2019 at 19.54
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Cc: Roman Shpount <[email-masked]<mailto:[email-masked]>>, Ted Hardie <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rtcweb] Results of call for consensus on ICE transport parameter issue

Regards,

Christer

Regards,
_____________
Roman Shpount

Regards,

Christer

Regards,
Ted and Sean