Subject: Re: [rtcweb] Is rtcweb the right place for draft-ietf-rtcweb-mdns-ice-candidates?

From: Roman Shpount <[email-masked]>
Date: Wed, 14 Aug 2019 17:21:16 -0400

Hi All,

Since RTCWEB is closed, I am going to ask once again: Should we
move draft-ietf-rtcweb-mdns-ice-candidates to mmusic?

I know people are unhappy with mmusic draft development speed, but if
enough people participate, we should be able to complete mdns draft quickly
and potentially develop an additional draft which will clarify generic FQDN
candidate processing procedures.

Thank You,
_____________
Roman Shpount

On Sun, Jul 7, 2019 at 3:47 AM Harald Alvestrand <[email-masked]>
wrote:

> On 7/6/19 10:15 PM, Roman Shpount wrote:
>
>
> Given mmusic's traditional processing speed, I am not sure there's any
>> point in formally moving the document at this point.
>>
>
> It is especially slow when none of the people interested in the specific
> feature (FQDN in ICE candidates) participate in the discussion. So far this
> looks like this feature is going to be shipped regardless of what anybody
> thinks about it and without even attempting to discuss it in the group
> which is responsible for this functionality.
>
> My favorite examples are -msid (initial version May 2012, IESG evaluation
> June 2016); -sdp-simulcast (initial version April 2015, IESG evaluation May
> 2018); -bundle-negotiation (initial version October 2011, IESG evaluation
> February 2018).
>
> Each of these has its own history, but when a group is capable of
> discussing a draft for seven years before it is IESG-ready, I question the
> effectieness of moving drafts into that group.
>
>
> Best Regards,
> _____________
> Roman Shpount
>
>
>
> --
> Surveillance is pervasive. Go Dark.
>
>

---

From: Justin Uberti <[email-masked]>
Date: Wed, 14 Aug 2019 15:18:06 -0700

My understanding is that draft-ietf-rtcweb-mdns-ice-candidates is going to
be AD sponsored.

On Wed, Aug 14, 2019 at 2:21 PM Roman Shpount <[email-masked]> wrote:

>> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Adam Roach <[email-masked]>
Date: Wed, 14 Aug 2019 17:40:37 -0500

Justin is correct regarding the current plan.

/a

On 8/14/19 5:18 PM, Justin Uberti wrote:
> My understanding is that draft-ietf-rtcweb-mdns-ice-candidates is 
> going to be AD sponsored.
>
> On Wed, Aug 14, 2019 at 2:21 PM Roman Shpount <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi All,
>
>     I know people are unhappy with mmusic draft development speed, but
>     if enough people participate, we should be able to complete mdns
>     draft quickly and potentially develop an additional draft which
>     will clarify generic FQDN candidate processing procedures.
>
>     Thank You,
>     _____________
>     Roman Shpount
>
>
>     On Sun, Jul 7, 2019 at 3:47 AM Harald Alvestrand
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>>         It is especially slow when none of the people interested in
>>         the specific feature (FQDN in ICE candidates) participate in
>>         the discussion. So far this looks like this feature is going
>>         to be shipped regardless of what anybody thinks about it and
>>         without even attempting to discuss it in the group which is
>>         responsible for this functionality.
>
>         My favorite examples are -msid (initial version May 2012, IESG
>         evaluation June 2016); -sdp-simulcast (initial version April
>         2015, IESG evaluation May 2018); -bundle-negotiation (initial
>         version October 2011, IESG evaluation February 2018).
>
>         Each of these has its own history, but when a group is capable
>         of discussing a draft for seven years before it is IESG-ready,
>         I question the effectieness of moving drafts into that group.
>
>
>>         Best Regards,
>>         _____________
>>         Roman Shpount
>
>
>         -- 
>     [email-masked] <mailto:[email-masked]>

---

From: Roman Shpount <[email-masked]>
Date: Wed, 14 Aug 2019 18:45:57 -0400

Just want to remind everyone that a new draft will need to be written to
update ice-sip-sdp to enable sending FQDN in ICE candidates before
mdns-ice-candidate can be released. I would assume it would need to happen
in mmusic.

Also, mdns-ice-candidate is not really rtcweb specific. IP address privacy
concerns addressed this draft apply to any peer-to-peer communication
protocol that uses ICE.
_____________
Roman Shpount

On Wed, Aug 14, 2019 at 6:40 PM Adam Roach <[email-masked]> wrote:

>>> evaluation June 2016); -sdp-simulcast (initial version April 2015, IESG
>>> evaluation May 2018); -bundle-negotiation (initial version October 2011,
>>> IESG evaluation February 2018).
>>>
> rtcweb mailing [email-masked]://www.ietf.org/mailman/listinfo/rtcweb
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 15 Aug 2019 05:34:42 +0000

Hi,

I agree with Roman, and I think the MMUSIC would be the best place since it most likely will have to update another MMUSIC spec. Also, there were quite a bit of discussions regarding FQDN support in MMUSIC while we were working on draft-ice-sip-sdp, so in my opinion a proper WG is the best place to work on the draft.

Regards,

Christer

Lähettäjä: rtcweb <[email-masked]> Puolesta Roman Shpount
Lähetetty: torstai 15. elokuuta 2019 1.46
Vastaanottaja: Adam Roach <[email-masked]>
Kopio: RTCWeb IETF <[email-masked]>; Justin Uberti <juberti=[email-masked]>
Aihe: Re: [rtcweb] Is rtcweb the right place for draft-ietf-rtcweb-mdns-ice-candidates?

Just want to remind everyone that a new draft will need to be written to update ice-sip-sdp to enable sending FQDN in ICE candidates before mdns-ice-candidate can be released. I would assume it would need to happen in mmusic.

Also, mdns-ice-candidate is not really rtcweb specific. IP address privacy concerns addressed this draft apply to any peer-to-peer communication protocol that uses ICE.
_____________
Roman Shpount

On Wed, Aug 14, 2019 at 6:40 PM Adam Roach <[email-masked]<mailto:[email-masked]>> wrote:
Justin is correct regarding the current plan.

/a

On 8/14/19 5:18 PM, Justin Uberti wrote:
My understanding is that draft-ietf-rtcweb-mdns-ice-candidates is going to be AD sponsored.

On Wed, Aug 14, 2019 at 2:21 PM Roman Shpount <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

Since RTCWEB is closed, I am going to ask once again: Should we move draft-ietf-rtcweb-mdns-ice-candidates to mmusic?

I know people are unhappy with mmusic draft development speed, but if enough people participate, we should be able to complete mdns draft quickly and potentially develop an additional draft which will clarify generic FQDN candidate processing procedures.

Thank You,
_____________
Roman Shpount

On Sun, Jul 7, 2019 at 3:47 AM Harald Alvestrand <[email-masked]<mailto:[email-masked]>> wrote:
On 7/6/19 10:15 PM, Roman Shpount wrote:

It is especially slow when none of the people interested in the specific feature (FQDN in ICE candidates) participate in the discussion. So far this looks like this feature is going to be shipped regardless of what anybody thinks about it and without even attempting to discuss it in the group which is responsible for this functionality.

My favorite examples are -msid (initial version May 2012, IESG evaluation June 2016); -sdp-simulcast (initial version April 2015, IESG evaluation May 2018); -bundle-negotiation (initial version October 2011, IESG evaluation February 2018).

Each of these has its own history, but when a group is capable of discussing a draft for seven years before it is IESG-ready, I question the effectieness of moving drafts into that group.

Best Regards,
_____________
Roman Shpount

--

Surveillance is pervasive. Go Dark.
_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

rtcweb mailing list

[email-masked]<mailto:[email-masked]>