Subject: Re: New Draft- BFD Express Path

From: Steve Baillargeon <[email-masked]>
Date: Wed, 20 Apr 2011 15:49:19 -0400

I am sorry for being very late to this discussion.
I am not sure what is the status of the BFD express path draft.

It looks some of the ideas from the BFD express path draft are being introduced/complimented in a new OSPF draft called OSPF TE express path by the same author and more.

The OSPF TE express path does not make any references to the mechanism for measuring the network performance across a link.  Does the author assume it is the mechanism proposed in the BFD express path draft?

I hope not.
In general, I agree that IPPM is a much better fit for monitoring network performance.
TWAMP for instance can monitor/estimate all aspects of an IP link or path performance including forward, reverse and round-trip metrics.

Regards
Steve B

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
To: Mach Chen <mach at huawei.com>
Subject: Re: New Draft- BFD Express Path
From: Vishwas Manral <vishwas.ietf at gmail.com>
Date: Wed, 24 Nov 2010 10:18:33 -0800
Cc: rtg-bfd at ietf.org
--------------------------------------------------------------------------------

Hi Mach,

I agree to the charters of IPPM and MPLS-TP, however looking at the
draft I see they are passing a lot more details than just originator
and receiver timestamps.

My comment was that it could be looked at in greater detail.

Thanks,
Vishwas

---

From: Vishwas Manral <[email-masked]>
Date: Wed, 20 Apr 2011 13:22:58 -0700

Hi Steve,

We have come across a few hurdles in the measurements of loss and delay and
their usage in the Express forwarding. A lot of the variance in delays can
happen due to congestion in devices. We are trying to model and see how
things can be done.

You should hear some proposal on this soon.

Thanks,
Vishwas
On Wed, Apr 20, 2011 at 12:49 PM, Steve Baillargeon <
[email-masked]> wrote:

> It looks some of the ideas from the BFD express path draft are being
> introduced/complimented in a new OSPF draft called OSPF TE express path by
> the same author and more.
>
> The OSPF TE express path does not make any references to the mechanism for
> measuring the network performance across a link.  Does the author assume it
> is the mechanism proposed in the BFD express path draft?
>
> I hope not.
> TWAMP for instance can monitor/estimate all aspects of an IP link or path
> performance including forward, reverse and round-trip metrics.
>
> Regards
> Steve B
>
>
>
> *To: Mach Chen <mach at huawei.com> *
> *Subject: Re: New Draft- BFD Express Path *
> *From: Vishwas Manral <vishwas.ietf at gmail.com> *
> *Date: Wed, 24 Nov 2010 10:18:33 -0800 *
> *Cc: rtg-bfd at ietf.org *
> *
> *
> *Hi Mach,*
> *I agree to the charters of IPPM and MPLS-TP, however looking at the*
> *draft I see they are passing a lot more details than just originator*
> *and receiver timestamps.*
>
> *My comment was that it could be looked at in greater detail.*
>
> *Thanks,*
> *Vishwas*
>
>
>
>
>
>

---

From: Steve Baillargeon <[email-masked]>
Date: Thu, 21 Apr 2011 07:41:31 -0400

Hi Vishwas
Most or all of these delay measurement issues and challenges have been resolved in IPPM.

I think active measurement is somehow required to measure the one-way delays across a link and TWAMP is best equipped for it.

For instance, the implementer may decide to run the BFD session and the TWAMP session using different DSCP codepoints.
This separation is desirable. Furthermore, TWAMP allows multiple test sessions to run concurrently between two peers using different DSCP codepoints.
This performance data can be used to measure the average link delay for instance.

-Steve

________________________________
From: Vishwas Manral [mailto:[email-masked]]
Sent: April-20-11 4:23 PM
To: Steve Baillargeon
Cc: [email-masked]
Subject: Re: New Draft- BFD Express Path

Hi Steve,

We have come across a few hurdles in the measurements of loss and delay and their usage in the Express forwarding. A lot of the variance in delays can happen due to congestion in devices. We are trying to model and see how things can be done.

Thanks,
Vishwas
On Wed, Apr 20, 2011 at 12:49 PM, Steve Baillargeon <[email-masked]<mailto:[email-masked]>> wrote:
I am sorry for being very late to this discussion.
I am not sure what is the status of the BFD express path draft.

I hope not.

Regards
Steve B

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
To: Mach Chen <mach at huawei.com<http://huawei.com/>>
Subject: Re: New Draft- BFD Express Path
From: Vishwas Manral <vishwas.ietf at gmail.com<http://gmail.com/>>
Date: Wed, 24 Nov 2010 10:18:33 -0800
Cc: rtg-bfd at ietf.org<http://ietf.org/>
--------------------------------------------------------------------------------

Hi Mach,

Thanks,
Vishwas

---

From: Thomas Nadeau <[email-masked]>
Date: Thu, 21 Apr 2011 08:07:12 -0400

Steve, this is a good point. I raised the possibility of using BFD for this purpose when it was just on the drawing board several years ago, but the idea was nixed by Dave^2 in order to keep the protocol simple. To my knowledge,  this design decision still stands.

	--Tom

> On Wed, Apr 20, 2011 at 12:49 PM, Steve Baillargeon <[email-masked]> wrote:

---

From: Vishwas Manral <[email-masked]>
Date: Thu, 21 Apr 2011 09:34:50 -0700

Hi Steve,

The work is mainly targeted at the finance industry networks. We are talking
about microsecond granularity and we want to take into consideration link
and node delays seperately. I do not think IPPM is anywhere close to
measuring device delays.

If it has been done, can you please point me to how you would model delay on
a device? The actual packet format to use for measurement sis a considerably
smaller thing.

Thanks,
Vishwas
On Thu, Apr 21, 2011 at 4:41 AM, Steve Baillargeon <
[email-masked]> wrote:

> I think active measurement is somehow required to measure the one-way
> delays across a link and TWAMP is best equipped for it.
>
> For instance, the implementer may decide to run the BFD session and the
> TWAMP session using different DSCP codepoints.
> This separation is desirable. Furthermore, TWAMP allows multiple test
> sessions to run concurrently between two peers using different DSCP
> codepoints.
>  ------------------------------
> *From:* Vishwas Manral [mailto:[email-masked]]
> *Sent:* April-20-11 4:23 PM
> *To:* Steve Baillargeon
> *Cc:* [email-masked]
>
> *Subject:* Re: New Draft- BFD Express Path
>
>   Hi Steve,
>