Subject: Fwd: I-D Action: draft-mmm-bfd-on-lags-06.txt

From: Marc Binderberger <[email-masked]>
Date: Fri, 12 Oct 2012 13:10:25 +0200

Hello BFD experts,

the authors of draft-mmm-bfd-on-lags have taken your input plus our internal discussions to create a new version -06 of the draft.

Well, see yourself :-)

Best regards,
Marc

Begin forwarded message:

> From: [email-masked]
> Date: October 12, 2012 10:41:17 GMT+02:00
> To: [email-masked]
> Subject: I-D Action: draft-mmm-bfd-on-lags-06.txt
> Reply-To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces
> 	Author(s)       : Manav Bhatia
>                          Mach(Guoyi) Chen
>                          Sami Boutros
>                          Marc Binderberger
>                          Jeffrey Haas
> 	Filename        : draft-mmm-bfd-on-lags-06.txt
> 	Pages           : 11
> 	Date            : 2012-10-12
> 
> Abstract:
>   This document proposes a mechanism to run BFD on Link Aggregation
>   Group (LAG) interfaces.  It does so by running an independent
>   Asynchronous mode BFD session on every LAG member link.
> 
>   This mechanism allows the verification of member link continuity,
>   either in combination with, or in absence of, LACP.  It provides a
>   shorter detection time than what LACP offers.  The continuity check
>   can also cover elements of layer 3 bidirectional forwarding.
> 
>   This mechanism utilizes a well-known UDP port distinct from that of
>   single-hop BFD over IP.  This new UDP port removes the ambiguity of
>   BFD over LAG packets from BFD over single-hop IP.
> 
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-mmm-bfd-on-lags
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-mmm-bfd-on-lags-06
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-mmm-bfd-on-lags-06
> 
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 12 Oct 2012 11:25:04 -0400

Working group,

> the authors of draft-mmm-bfd-on-lags have taken your input plus our internal discussions to create a new version -06 of the draft.

The current document reflects the consensus to date on the feature.  Since
we have multiple vendors working on code related to this specification,
we're expecting minor tweaks to accommodate implementations as we gain
experience with the specification.  Our hope, however, is that the structure
of the feature is generally stable.

The authors and editors of the draft would greatly appreciate your feedback
on the current text.

Things of note:
- We are hoping our re-charter for the working group will be complete by the
  Atlanta IETF and will include this item.
- We have proceeded with requesting code points for the well known MAC
  address and the UDP port.
- The major place where the specification seems to still need attention is
  clarifying behavior in the presence of VLANs when the VLAN terminates in a
  VRF.

As noted before, BFD will *not* be meeting at the upcoming IETF.  However,
it is my intention to publish status slides for the WG as part of the
meeting materials.

-- Jeff