Subject: Fwd: New Version Notification for draft-mirsky-mpls-bfd-bootstrap-clarify-00.txt

From: Greg Mirsky <[email-masked]>
Date: Wed, 18 Oct 2017 05:50:46 -0700

Dear All,
this new document proposes clarification of two questions brought up in
course of recent discussion of RFC 5884:

   - use of Return mode values in bootstrapping BFD session echo request;
   - inclusion of BFD Discriminator TLV in echo response to the
   bootstrapping echo request.

Your comments, questions are always welcome and greatly appreciated.

Regards,
Greg

---------- Forwarded message ----------
From: <[email-masked]>
Date: Wed, Oct 18, 2017 at 5:46 AM
Subject: New Version Notification for
draft-mirsky-mpls-bfd-bootstrap-clarify-00.txt
To: Gregory Mirsky <[email-masked]>, Yanhua Zhao <
[email-masked]>

A new version of I-D, draft-mirsky-mpls-bfd-bootstrap-clarify-00.txt
has been successfully submitted by Greg Mirsky and posted to the
IETF repository.

Name:           draft-mirsky-mpls-bfd-bootstrap-clarify
Revision:       00
Title:          Clarifying Use of LSP Ping to Bootstrap BFD over MPLS LSP
Document date:  2017-10-18
Group:          Individual Submission
Pages:          4
URL:            https://www.ietf.org/internet-drafts/draft-mirsky-mpls-bfd-
bootstrap-clarify-00.txt
Status:         https://datatracker.ietf.org/doc/draft-mirsky-mpls-bfd-
bootstrap-clarify/
Htmlized:       https://tools.ietf.org/html/draft-mirsky-mpls-bfd-
bootstrap-clarify-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-mirsky-mpls-
bfd-bootstrap-clarify-00

Abstract:
   This document, if approved, updates RFC 5884 by clarifying procedures
   for using MPLS LSP ping to bootstrap Bidirectional Forwarding
   Detection (BFD) over MPLS Label Switch Path.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 20 Oct 2017 12:54:23 +0000

Greg,

This document seems to say “use “Do not Reply” reply mode, and even if you reply do not use the BFD Disc TLV, because it is not used.

Wouldn’t it be simpler to say “follow RFC 8029, and the ingress does not care about the BFD Disc TLV in the reply”? This would not suddenly make uncompliant existing implementations, potentially.

Also I wonder if this should be bfd-mpls instead of mpls-bfd, given where RFC 5884 was advanced.

Thanks,

—
Carlos Pignataro, [email-masked]<mailto:[email-masked]>

“Sometimes I use big words that I do not fully understand, to make myself sound more photosynthesis."

On Oct 18, 2017, at 8:50 AM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Dear All,
this new document proposes clarification of two questions brought up in course of recent discussion of RFC 5884:

  *   use of Return mode values in bootstrapping BFD session echo request;
  *   inclusion of BFD Discriminator TLV in echo response to the bootstrapping echo request.

Regards,
Greg

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Wed, Oct 18, 2017 at 5:46 AM
Subject: New Version Notification for draft-mirsky-mpls-bfd-bootstrap-clarify-00.txt
To: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, Yanhua Zhao <[email-masked]<mailto:[email-masked]>>

Name:           draft-mirsky-mpls-bfd-bootstrap-clarify
Revision:       00
Title:          Clarifying Use of LSP Ping to Bootstrap BFD over MPLS LSP
Document date:  2017-10-18
Group:          Individual Submission
Pages:          4
URL:            https://www.ietf.org/internet-drafts/draft-mirsky-mpls-bfd-bootstrap-clarify-00.txt
Status:         https://datatracker.ietf.org/doc/draft-mirsky-mpls-bfd-bootstrap-clarify/
Htmlized:       https://tools.ietf.org/html/draft-mirsky-mpls-bfd-bootstrap-clarify-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-mirsky-mpls-bfd-bootstrap-clarify-00

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

The IETF Secretariat

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 20 Oct 2017 08:18:46 -0700

Hi Carlos,
thank you for taking interest in the proposal, much appreciated. Please
find my notes in-line and tagged GIM>>.

Regards,
Greg

On Fri, Oct 20, 2017 at 5:54 AM, Carlos Pignataro (cpignata) <
[email-masked]> wrote:

> Greg,
>
> This document seems to say “use “Do not Reply” reply mode, and even if you
> reply do not use the BFD Disc TLV, because it is not used.
>
GIM>> To be precise it says "SHOULD use "Do not Reply" thus preserving
compliance of implementations that do otherwise.

>
> Wouldn’t it be simpler to say “follow RFC 8029, and the ingress does not
> care about the BFD Disc TLV in the reply”? This would not suddenly make
> uncompliant existing implementations, potentially.
>
GIM>> I agree that normative language on handling echo reply is bit
restrictive. My goal is to have good discussion and see what others think.

> Also I wonder if this should be bfd-mpls instead of mpls-bfd, given where
GIM>> Probably it should be the way you've suggested. Hope it is not a big
problem for individual draft.

>
> Thanks,
>
> —
> Carlos Pignataro, [email-masked]
>
> *“Sometimes I use big words that I do not fully understand, to make myself
> sound more photosynthesis."*
>
> On Oct 18, 2017, at 8:50 AM, Greg Mirsky <[email-masked]> wrote:
>
> Dear All,
> URL:            https://www.ietf.org/internet-
> drafts/draft-mirsky-mpls-bfd-bootstrap-clarify-00.txt
> Status:         https://datatracker.ietf.org/
> doc/draft-mirsky-mpls-bfd-bootstrap-clarify/
> Htmlized:       https://tools.ietf.org/html/d
> raft-mirsky-mpls-bfd-bootstrap-clarify-00
> Htmlized:       https://datatracker.ietf.org/
> doc/html/draft-mirsky-mpls-bfd-bootstrap-clarify-00
>
>
> Abstract:
> [email-masked]