Subject: WGLC for BFD Multipoint documents (last round)

From: Jeffrey Haas <[email-masked]>
Date: Wed, 13 Dec 2017 12:24:43 -0500

Working Group,

In an attempt to give our AD a holiday gift, we're at the point where we may
now work to conclude WGLC on the BFD multipoint documents.  We did one pass
of last call June-July of this year, and held off approval pending review
from ALU who has an implementation of the base spec.  ALU has since
responded that they're fine with the contents.

To provide the working group one last opportunity to review the documents,
we're running a final last call and will send off the changes to our AD
afterward.

The prior WGLC thread is here:
https://mailarchive.ietf.org/arch/msg/rtg-bfd/yDOFOpd9BIIKtLniDGdqPioSt_w/?qid=2d0831389d19508c66f9a387096250e6

The documents are here:
https://datatracker.ietf.org/doc/draft-ietf-bfd-multipoint/
https://datatracker.ietf.org/doc/draft-ietf-bfd-multipoint-active-tail/

The intent is to conclude this WGLC at end of year.

-- Jeff

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 13 Dec 2017 12:26:41 -0500

On Wed, Dec 13, 2017 at 12:24:43PM -0500, Jeffrey Haas wrote:
> now work to conclude WGLC on the BFD multipoint documents.

It is also worth noting that Greg Mirsky will be taking over as the editor
on these documents.  Santosh has graciously handed over this task since his
day job no longer provides him sufficient time for this work.

Please let's extend Santosh and Greg our thanks for this work.

-- Jeff

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 14 Dec 2017 20:11:51 -0600

Dear All,
attached please find diff and the new draft-ietf-bfd-multipoint-12 version.
Appreciate your review of the changes applied to address comments received
earlier.
Your comments, questions always welcome and greatly appreciated.

Regards,
Greg

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 15 Dec 2017 15:30:40 -0600

Dear All,
attached please find diffs and the updated version of the
draft-ietf-bfd-multipoint-active-tail. All changes are editorial. Please
review changes and share your comments.

Regards,
Greg

On Wed, Dec 13, 2017 at 11:24 AM, Jeffrey Haas <[email-masked]> wrote:

> https://mailarchive.ietf.org/arch/msg/rtg-bfd/
> yDOFOpd9BIIKtLniDGdqPioSt_w/?qid=2d0831389d19508c66f9a387096250e6
>
> The documents are here:

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Sat, 16 Dec 2017 04:01:48 +0000

Dear Greg,

It appears these comments are not addressed:
https://www.ietf.org/mail-archive/web/rtg-bfd/current/msg03475.html

Best,

Sent from my iPad

On Dec 15, 2017, at 11:05 AM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Dear All,
attached please find diff and the new draft-ietf-bfd-multipoint-12 version. Appreciate your review of the changes applied to address comments received earlier.
Your comments, questions always welcome and greatly appreciated.

Regards,
Greg

On Wed, Dec 13, 2017 at 11:26 AM, Jeffrey Haas <[email-masked]<mailto:[email-masked]>> wrote:

-- Jeff

<draft-ietf-bfd-multipoint-12.txt>
<Diff_ draft-ietf-bfd-multipoint-11.txt - draft-ietf-bfd-multipoint-12.txt.html>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Sat, 16 Dec 2017 04:02:59 +0000

Hi, Greg,

It seems the comments regarding bfd.SessionType are not addressed:
https://www.ietf.org/mail-archive/web/rtg-bfd/current/msg03475.html

Thanks,

Sent from my iPad

On Dec 15, 2017, at 5:15 PM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Dear All,
attached please find diffs and the updated version of the draft-ietf-bfd-multipoint-active-tail. All changes are editorial. Please review changes and share your comments.

Regards,
Greg

On Wed, Dec 13, 2017 at 11:24 AM, Jeffrey Haas <[email-masked]<mailto:[email-masked]>> wrote:
Working Group,

The documents are here:

-- Jeff

<draft-ietf-bfd-multipoint-active-tail-06.txt>
<Diff_ draft-ietf-bfd-multipoint-active-tail-05.txt - draft-ietf-bfd-multipoint-active-tail-06.txt.html>

---

From: Greg Mirsky <[email-masked]>
Date: Sat, 16 Dec 2017 15:31:43 -0600

Hi Carlos,
thank you very much for pointing this out. Sorry I've missed it. I agree
that it requires resolution but I think that the resolution is different
from what you've proposed in your original comment. The names of the new
variable in RFC 7880 and
draft-ietf-bfd-multipoint/draft-ietf-bfd-multipoint-active-tails are
identical but, I believe, semantics are different:

   - RFC 7880 uses bfd.SessionType to reflect S-BFD role the node performs
   in S-BFD session
   - draft-ietf-bfd-multipoint-* are using bfd.SessionType to reflect
   topology of the BFD session, i.e. whether it is p2p or p2mp

S-BFD currently specified for p2p but I don't see a reason why S-BFD cannot
be applied to p2mp cases. So, for a BFD node that supports both RFC 7880
and draft-ietf-bfd-multipoint values of variables may be SBFDInitiator and
PointToPoint. And, at some time, there will be interest to define behavior
of the SBFDInitiator/MultipointHead and SBFDReflector/MultipointTail
combinations.

Thus I see this issue as name conflict that can be resolved by changing the
name in draft-ietf-bfd-multipoint-* to something other than
bfd.SessionType. Perhaps we can change the name to bfd.SessionTopology.

Greatly appreciate comments, suggestions. Let's make holiday presents to
our AD!

Regards,
Greg

On Fri, Dec 15, 2017 at 10:02 PM, Carlos Pignataro (cpignata) <
[email-masked]> wrote:

> On Dec 15, 2017, at 5:15 PM, Greg Mirsky <[email-masked]> wrote:
>
> Dear All,
>> https://mailarchive.ietf.org/arch/msg/rtg-bfd/yDOFOpd9BIIKtL
>> niDGdqPioSt_w/?qid=2d0831389d19508c66f9a387096250e6
>>
>> The documents are here:
> <Diff_ draft-ietf-bfd-multipoint-active-tail-05.txt -
> draft-ietf-bfd-multipoint-active-tail-06.txt.html>
>
>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 19 Dec 2017 02:20:11 +0000

Hi, Greg,

Thank you for the thoughtful, detailed reply.

Please find a corresponding follow-up:

You say that bfd.SessionType in RFC 7880 is used “to reflect S-BFD role the node performs in S-BFD session”, but that is incorrect. When you read the RFC, it says:
   o  bfd.SessionType: This is a new state variable that describes
      the type of a particular session.  Allowable values for S-BFD
      sessions are:

You say that bfd.SessionType in draft-ietf-bfd-multipoint-* is used to “reflect topology of the BFD session, i.e. whether it is p2p or p2mp”. However, that is incorrect. When you read the document it says:
      bfd.SessionType
         The type of this session.
And "point-to-point" and "point-to-multipoint" do not denote “topology”.

Consequently, in either case, both cases refer to the Type of session.

RFC 7880 defines values “allowable for S-BFD”, and draft-ietf-bfd-multipoint-, since it defines a new type of BFD session, needs to defined values allowable for BFD (i.e., PointToPoint, MultipointHead, and MultipointTail).

If at some point someone wants to define S-BFD p2mp, it can be done with the same variable.

Adding a new state variable for this results in unnecessary complexity.

—
Carlos Pignataro, [email-masked]<mailto:[email-masked]>

“Sometimes I use big words that I do not fully understand, to make myself sound more photosynthesis."

On Dec 16, 2017, at 4:31 PM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Hi Carlos,
thank you very much for pointing this out. Sorry I've missed it. I agree that it requires resolution but I think that the resolution is different from what you've proposed in your original comment. The names of the new variable in RFC 7880 and draft-ietf-bfd-multipoint/draft-ietf-bfd-multipoint-active-tails are identical but, I believe, semantics are different:

  *   RFC 7880 uses bfd.SessionType to reflect S-BFD role the node performs in S-BFD session
  *   draft-ietf-bfd-multipoint-* are using bfd.SessionType to reflect topology of the BFD session, i.e. whether it is p2p or p2mp

S-BFD currently specified for p2p but I don't see a reason why S-BFD cannot be applied to p2mp cases. So, for a BFD node that supports both RFC 7880 and draft-ietf-bfd-multipoint values of variables may be SBFDInitiator and PointToPoint. And, at some time, there will be interest to define behavior of the SBFDInitiator/MultipointHead and SBFDReflector/MultipointTail combinations.

Thus I see this issue as name conflict that can be resolved by changing the name in draft-ietf-bfd-multipoint-* to something other than bfd.SessionType. Perhaps we can change the name to bfd.SessionTopology.

Greatly appreciate comments, suggestions. Let's make holiday presents to our AD!

Regards,
Greg

On Fri, Dec 15, 2017 at 10:02 PM, Carlos Pignataro (cpignata) <[email-masked]<mailto:[email-masked]>> wrote:
Hi, Greg,

Thanks,

Sent from my iPad

Dear All,

Regards,
Greg

The documents are here:

-- Jeff

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 19 Dec 2017 11:05:37 -0500

[Speaking as an individual contributor.]

> Thus I see this issue as name conflict that can be resolved by changing the name in draft-ietf-bfd-multipoint-* to something other than bfd.SessionType. Perhaps we can change the name to bfd.Sessio…

I concur with Carlos.  This really isn't a topology, simply a session type.
(And one that is core to even the original BFD spec, albeit simply a bit
that wasn't well defined!)

I also agree that the solution to permitting S-BFD with multipoint is to
simply have a value that expresses that combination.  At this point, S-BFD
with multipoint is undefined.

At this point it is also worth noting that the session type has no
centralized location covering their enumerations.  This leads to two
interesting observations:
- We could have an IANA registry for such things.  However, I'm not sure
  this is really need.  But this also means:
- Here's another case why some pieces of the BFD yang module likely shoudl
  be IANA maintained.  In this case, the bfd-path-type identity as the
  relevant example.

-- Jeff

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 19 Dec 2017 14:17:02 -0800

Hi Carlos and Jeff,
thank you for responding so expediently. I think we've reached the rough
consensus. Attached are the diffs for both BFD documents and the updated
copies. Please let me know if the changes being made have addressed all the
comments received during the WGLC. I'll then upload new versions.

Regards,
Greg

On Tue, Dec 19, 2017 at 8:05 AM, Jeffrey Haas <[email-masked]> wrote:

> > S-BFD currently specified for p2p but I don't see a reason why S-BFD
> cannot be applied to p2mp cases. So, for a BFD node that supports both RFC
> 7880 and draft-ietf-bfd-multipoint values of variables may be SBFDInitiator
> and PointToPoint. And, at some time, there will be interest to define
> behavior of the SBFDInitiator/MultipointHead and
> SBFDReflector/MultipointTail combinations.
> >
> > Thus I see this issue as name conflict that can be resolved by changing
> the name in draft-ietf-bfd-multipoint-* to something other than

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 20 Dec 2017 12:13:22 -0500

Greg,

> comments received during the WGLC. I'll then upload new versions.

I believe this covers all points I've seen on the mailing list to date.

Please push the updates.

We'll have further discussion about the need for a registry in conjunction
with the Yang module implications discussion.

-- Jeff

> On Tue, Dec 19, 2017 at 8:05 AM, Jeffrey Haas <[email-masked]> wrote:
[...]