Subject: [Technical Errata Reported] RFC7880 (5211)

From: RFC Errata System <[email-masked]>
Date: Sat, 16 Dec 2017 12:27:55 -0800 (PST)

The following errata report has been submitted for RFC7880,
"Seamless Bidirectional Forwarding Detection (S-BFD)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5211

--------------------------------------
Type: Technical
Reported by: Greg Mirsky <[email-masked]>

Section: 6.1

Original Text
-------------
   o  bfd.SessionType: This is a new state variable that describes
      the type of a particular session.  Allowable values for S-BFD
      sessions are:

      *  SBFDInitiator - an S-BFD session on a network node that
         performs a continuity test to a target entity by sending S-BFD
         packets.

      *  SBFDReflector - an S-BFD session on a network node that listens
         for incoming S-BFD Control packets to local entities and
         generates response S-BFD Control packets.

   The bfd.SessionType variable MUST be initialized to the appropriate
   type when an S-BFD session is created.

Corrected Text
--------------
   o  bfd.SessionType: This is a new state variable that describes
      the type of a particular session.  Allowable values for S-BFD
      sessions are:

      *  SBFDNone - indicates that the BFD session is not of S-BFD type.

      *  SBFDInitiator - an S-BFD session on a network node that
         performs a continuity test to a target entity by sending S-BFD
         packets.

      *  SBFDReflector - an S-BFD session on a network node that listens
         for incoming S-BFD Control packets to local entities and
         generates response S-BFD Control packets.

   The bfd.SessionType variable MUST be set to SBFDNone when a BFD
   session other than S-BFD. The bfd.SessionType variable MUST be 
   initialized to the appropriate type when an S-BFD session is created.

Notes
-----
The original text leaves value of the new variable bfd.SessionType unspecified if the type of BFD session is other than S-BFD.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7880 (draft-ietf-bfd-seamless-base-11)
--------------------------------------
Title               : Seamless Bidirectional Forwarding Detection (S-BFD)
Publication Date    : July 2016
Author(s)           : C. Pignataro, D. Ward, N. Akiya, M. Bhatia, S. Pallagatti
Category            : PROPOSED STANDARD
Source              : Bidirectional Forwarding Detection
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 19 Dec 2017 02:28:12 +0000

As a co-author of RFC 7880, I disagree with the report below, and recommend Rejecting this Erratum.

S-BFD uses the BFD state variables, and “bfd.SessionType” is applicable with finer granularity than “Not S-BFD”.

Some details at. https://mailarchive.ietf.org/arch/msg/rtg-bfd/HxHT6Nxhpxot4baDag7cW6gm_ZQ

Further:

The proposed value of “SBFDNone” is covered at https://tools.ietf.org/html/draft-ietf-bfd-multipoint-11#section-4.4.1 with the values of either “PointToPoint” (classing, p2p, BFD), “MultipointHead”, and “MultipointTail” (plus “MultipointClient”)

Including a new state variable and new values for the bfd.SessionType adds unnecessary complexity.

—
Carlos Pignataro, [email-masked]<mailto:[email-masked]>

“Sometimes I use big words that I do not fully understand, to make myself sound more photosynthesis."

On Dec 16, 2017, at 3:27 PM, RFC Errata System <[email-masked]<mailto:[email-masked]>> wrote:

--------------------------------------
Type: Technical
Reported by: Greg Mirsky <[email-masked]<mailto:[email-masked]>>

Section: 6.1

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 19 Dec 2017 20:29:06 -0800

Hi Carlos, et.al,
I agree that for a BFD node that in addition to RFC 7880 supports
draft-ietf-bfd-multipoint bfd.SessionType will not be left unset when the
BFD session is other than of S-BFD type (PointToPoint, MultipointHead or
Multipoint Tail). But if the BFD node only supports base BFD [RFC5880] and
S-BFD [RFC7880] specifications bfd.SessionType is unspecified if the
session type is neither SBFDInitiator, nor SBFDReflector. Making resolution
of this issue to be dependent on support of BFD for Multipoint Networks
doesn't seem as prudent approach. I'm open to suggestions of the better
name for the new value of bfd.SessionType, other than SBFDNone.

Regards,
Greg

On Mon, Dec 18, 2017 at 6:28 PM, Carlos Pignataro (cpignata) <
[email-masked]> wrote:

> The proposed value of “SBFDNone” is covered at https://tools.ietf.org/
> html/draft-ietf-bfd-multipoint-11#section-4.4.1 with the values of either
> “PointToPoint” (classing, p2p, BFD), “MultipointHead”, and “MultipointTail”
> (plus “MultipointClient”)
>
> Carlos Pignataro, [email-masked]
>
> *“Sometimes I use big words that I do not fully understand, to make myself
> sound more photosynthesis."*
>
> On Dec 16, 2017, at 3:27 PM, RFC Errata System <[email-masked]>
> wrote:
>
> The original text leaves value of the new variable bfd.SessionType
> unspecified if the type of BFD session is other than S-BFD.
>
> Instructions:
> -------------

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 20 Dec 2017 04:39:49 +0000

Hi, Greg,

The bfd.SessionType is really a core state variable to the original BFD spec — just implicitly defined. This is made explicit by the “PointToPoint” value from draft-ietf-bfd-multipoint-11, but that does not mean that RFC 7880 and RFC 5880 need to be revised to add this.

Using SBFDNone (or something like it) is harmful, because that covers a set of multiple values (PointToPoint and MultipoitntHead are both SBFDNone).

Net-net, I still do not believe, on technical grounds, that there’s any change needed to RFC 7880 or RFC 5880.

The one change to consider is to have draft-ietf-bfd-multipoint-11 update RFC 5880 by saying that no value means PointToPoint.

Thanks,

—

On Dec 19, 2017, at 11:29 PM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Hi Carlos, et.al<http://et.al/>,
I agree that for a BFD node that in addition to RFC 7880 supports draft-ietf-bfd-multipoint bfd.SessionType will not be left unset when the BFD session is other than of S-BFD type (PointToPoint, MultipointHead or Multipoint Tail). But if the BFD node only supports base BFD [RFC5880] and S-BFD [RFC7880] specifications bfd.SessionType is unspecified if the session type is neither SBFDInitiator, nor SBFDReflector. Making resolution of this issue to be dependent on support of BFD for Multipoint Networks doesn't seem as prudent approach. I'm open to suggestions of the better name for the new value of bfd.SessionType, other than SBFDNone.

Regards,
Greg

On Mon, Dec 18, 2017 at 6:28 PM, Carlos Pignataro (cpignata) <[email-masked]<mailto:[email-masked]>> wrote:
As a co-author of RFC 7880, I disagree with the report below, and recommend Rejecting this Erratum.

Further:

—

Section: 6.1

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------